Jump to content
blueline

Margin Report v2.10

Recommended Posts

Hi guys, notice my problem with the shopping cart was due to the fact that I install Master Product with Margin Reports. That may be the cause why the shopping cart is empty or not showing the correct items at times. Anyone manage to get these 2 MODs working together? Mind sharing your experience and what needs to be done?

Share this post


Link to post
Share on other sites

Hi guys,

 

This is a great contributions. I installed it and everything works great. However, I have one problem is that it does not seem to take the coupon discount or gift voucher out before showing the profit margin.

 

Anyone here know how to solve this? I would like to know my actual profit after all the discount or gift certificate the customers redeemed.

 

Thanks

Share this post


Link to post
Share on other sites

Can any one post this mod with overwrite & run files & the pdf in plain text. I have too many mods installed and would take much too long to edit not to mention troubleshooting.

 

Thanks


I'm not a coder just a splicer.

Share this post


Link to post
Share on other sites

Why the hell are the instructions in PDF!! Its awful and certainly not the best way to copy the code.

 

I have my admin heavily modded and the margin report clashes with mods like ultrapics from maxi dvd.

 

Has anyone installed the margin report with these mods installed? I tried last time and the whole thing ruined my store, i had to roll back and reinstall a few mods again.

 

any advice appreciated.

Edited by jcgrant

Share this post


Link to post
Share on other sites

Nice Mod!! Thanks!!

 

 

Just one thing, is there anyway to change when I edit or add products the cost price from ex tax to inc tax??

 

Thanks

Share this post


Link to post
Share on other sites

Thanks for the great Contribution. I just installed it and it appears there are a couple of errors. The major thing is that the "products_cost" field in the "orders_products" never gets entered. They are all zeros.

 

Also I get different results when using, today - yesterday - annual, etc. Sometimes certain orders show up, and other times they don't. Like, they may show up for yesterday, but not for this year!

 

Anyone else run into this?

 

-Aaron

Share this post


Link to post
Share on other sites
Hi guys,

 

This is a great contributions. I installed it and everything works great.  However, I have one problem is that it does not seem to take the coupon discount or gift voucher out before showing the profit margin.

 

Anyone here know how to solve this? I would like to know my actual profit after all the discount or gift certificate the customers redeemed.

 

Thanks

 

I have the same problem. Any fix?

Share this post


Link to post
Share on other sites

did anyone manage to get hold of the installation doc in non PDF format?

 

Its going to take forever if I have to hand type each replacement!!!

 

TIA

Sadie

Share this post


Link to post
Share on other sites

Here is my problem, in the orders screen the order id 1178 is a total of Total: $187.65 and they were three products purchased like this

 

3 x Product 1

3 x Product 2

3 x Product 3

 

But when I do my margin report it shows me this:

1178 3 $58.10

 

And thats not right so therefore my Sales Amount is off, how do I fix this and is anybody else having the same problem?

Share this post


Link to post
Share on other sites

I just installed this contribution but there seems to be some bugs inside.

 

Now I cant copy my product...It says some errors on COST FIELD. I have to type all over again for a similar product...previously I just copy and change a couple of things... :(

 

Anybody out there still using this contribution? I find it a great contribution but need someone to follow it up...I am too poor to do this myself at php coding... :(


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites
This thing died eh?

 

it is sad if nobody is following up with this great contribution...

 

I just found out that the profit calculation is not correct. If my customer order the same product with 5 units quantity, the report still show one unit and the profit generated is only for one unit... :(

 

Anybody care to follow up? Me no good in programming... :(


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites

I figured tonight would be the night I install this, got it in with no issues and i have a ton of mods, so I was surprised.

But, the COST amount is not appearing in the chart I select (monthly in this case), I made sure the cost was inputted on my product info page, but does not appear in my records of the chart for margin report....exported to excel and still no cost showing.

Any takers?

Share this post


Link to post
Share on other sites

A couple of keys to this mod.

 

I have it running OK.

 

The issue with the cost not working is related to some missing code for when the order is saved into the order table, need to ensure the cost field is in the orders table (as described a lot earlier in this thread).

For those having issues with quantities, you need to find the mod in this thread which updates the reports to do some quantity calculations.

 

This is a great contribution which should be able to be a standard feature of OSC.

 

Vaughnn

Share this post


Link to post
Share on other sites
A couple of keys to this mod.

 

I have it running OK.

 

The issue with the cost not working is related to some missing code for when the order is saved into the order table, need to ensure the cost field is in the orders table (as described a lot earlier in this thread).

For those having issues with quantities, you need to find the mod in this thread which updates the reports to do some quantity calculations.

 

This is a great contribution which should be able to be a standard feature of OSC.

 

Vaughnn

 

So what code do I need to enter to make it work?

Share this post


Link to post
Share on other sites

I love this mod, but I have little problem with the time difference between my local time and server time. Does anyone has a fix for this? When I run a report, I would like to query base on my local time. Right now it shows all the records based on server time.

 

Any quick fix?

Share this post


Link to post
Share on other sites
I love this mod, but I have little problem with the time difference between my local time and server time. Does anyone has a fix for this? When I run a report, I would like to query base on my local time. Right now it shows all the records based on server time.

 

Any quick fix?

 

my understanding is no quick fix for this... :(


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites

I have managed to make the gross profit shows correctly with different quantity purchase. Read back the previous discussion posts on this. Missing product_costs in two files.

 

However, I still cant copy product. It says:

 

1054 - Unknown column 'product_cost' in 'field list'

 

select products_quantity, products_model, products_image, products_image_med, products_image_lrg, products_image_sm_1, products_image_xl_1, products_image_sm_2, products_image_xl_2, products_image_sm_3, products_image_xl_3, products_image_sm_4, products_image_xl_4, products_image_sm_5, products_image_xl_5, products_image_sm_6, products_image_xl_6, products_price, product_cost, products_date_available, products_weight, products_tax_class_id, manufacturers_id from products where products_id = '81'

 

[TEP STOP]

 

I have already run the SQL with mod to products and order...

 

:(


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites
That's because in the sql you should have products_cost not product_cost!!!

 

Thanks! Corrected that one.

 

Now still got this error... :(

1136 - Column count doesn't match value count at row 1

 

insert into products (products_quantity, products_model, products_image, products_image_med, products_image_lrg, products_image_sm_1, products_image_xl_1, products_image_sm_2, products_image_xl_2, products_image_sm_3, products_image_xl_3, products_image_sm_4, products_image_xl_4, products_image_sm_5, products_image_xl_5, products_image_sm_6, products_image_xl_6, products_price, products_cost, products_date_added, products_date_available, products_weight, products_status, products_tax_class_id, manufacturers_id) values ('10', '', 'mhc204w_l.jpg', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '115.0000', now(), '', '0.00', '0', '0', '8')

 

[TEP STOP]

 

I have the Ultra Pics + html contributions installed. I tested it in my test site, and before installing the margin report, I can still copy. After installing margin report, error above comes out... :(


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites

This mod is in PDF!!??? I'm going insane. Have to transfer to notepad and do line by f****** LINE!

 

WHAT?! :blink:

 

Destined to crash many sites. Thanks to a great contribution and a REALLY STUPID execution thereof. :angry:


Hip Hop Jewelry | Bling Bling | Iced Out

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×