Jump to content
Sign in to follow this  
joeyjgarcia

Attribute Sets Contribution

Recommended Posts

The logic is as follows:

 

- create your option

- create your attributes set(s)

 

create your product

THEN

edit your product

 

Currently you cannot add sets to a product that does not yet exist. You must create it then edit to add the sets. This is true with Attributes Sets Plus as well.

 

regards

Chris

 

Hi,Chris

 

Thank you for your help! The logic that you said is right , but I can add sets when I creat a new product in Attributes Sets 4.0 , I think the 4.0 is more convenience then 5.5 in this function, Can you tell me the pivotal difference between 4.0 and 5.5 .

 

Thanks

Best regards

Caleb

Share this post


Link to post
Share on other sites

My problem is that the attributes are sorting backwards. I put them from 1-20 in the order I want, but in the order form, they sort from 20-1. Am I missing something?


Tara Lang

Share this post


Link to post
Share on other sites

Ok, so I removed Attribute Sets, installed the Plus version, and now there is NO sorting whatsoever to my attribute sets.


Tara Lang

Share this post


Link to post
Share on other sites

Two great contibutions I use are the Attribute sets and Mass Move. The only problem is mass move will move or copy the products really well but unfortunatly it will not move the attribute sets, has anyone fixed this problem. I know this might not be the correct thread but I cannot find a mass move thread in the forum

 

cheers

Brian

Share this post


Link to post
Share on other sites
Ok, so I removed Attribute Sets, installed the Plus version, and now there is NO sorting whatsoever to my attribute sets.

 

Hi - just spotted this - if you are using attributes sets plus this is the wrong thread - but to answer your issue just check you have correctly installed the scripts - it does worK!

 

chris

 

 

Two great contibutions I use are the Attribute sets and Mass Move. The only problem is mass move will move or copy the products really well but unfortunatly it will not move the attribute sets, has anyone fixed this problem. I know this might not be the correct thread but I cannot find a mass move thread in the forum

 

cheers

Brian

 

 

I am not familiar with Mass Move but if it moves between categories I do not see why it should affect the attributes sets - Speaking specifically for Attributes Sets Plus, once allocated to a product the product attributes are standard osC - its only the sets storage that is custom whcih is in its own custom tables, so it has no impact on your other contribution.

 

regards

Chris.

Share this post


Link to post
Share on other sites

when i go to look at a product, i get this error:

 

1146 - Table 'photogra_osCommerce.TABLE_PRODUCTS_ATTRIBUTES_SETS_TO_PRODUCTS' doesn't exist

 

SELECT pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix , pase.sort_order FROM products_attributes pa, TABLE_PRODUCTS_ATTRIBUTES_SETS_TO_PRODUCTS pas2pa, TABLE_PRODUCTS_ATTRIBUTES_SETS pas, TABLE_PRODUCTS_ATTRIBUTES_SETS_ELEMENTS pase, products_options_values pov WHERE pa.products_id = '28' AND pa.options_id = '1' AND pas2pa.products_id = pa.products_id AND pas.products_attributes_sets_id = pas2pa.products_attributes_sets_id AND pas.products_options_id = pa.options_id AND pase.products_attributes_sets_id = pas.products_attributes_sets_id AND pase.options_values_id = pa.options_values_id AND pov.products_options_values_id = pa.options_values_id AND pov.language_id = '1' ORDER BY pase.sort_order, pa.options_values_id

 

 

 

however, there is a table called "products_attributes_sets_to_products" in the database called "photogra_osCommerce"... and that table has col's called " products_attributes_sets_to_products", "products_attributes_sets_id" and "products_id"

 

any ideas why this is happening?

Share this post


Link to post
Share on other sites
when i go to look at a product, i get this error:

 

1146 - Table 'photogra_osCommerce.TABLE_PRODUCTS_ATTRIBUTES_SETS_TO_PRODUCTS' doesn't exist

 

any ideas why this is happening?

 

Because you are missing a statement like :

 

define('TABLE_PRODUCTS_ATTRIBUTES_SETS_TO_PRODUCTS', 'products_attributes_sets_to_products');

 

for the file:

 

catalog/includes/database_tables.php

 

Check your install instructions (or better yet install Attributes Sets Plus that supercedes this contribution).

Edited by toasty

Share this post


Link to post
Share on other sites

toasty: i checked and redid both database_table.php files with no success.

 

edit: oh, i didnt even realize it but i am using Linkmatics_AttributeSetsPlus_v1

Share this post


Link to post
Share on other sites

Hi,

 

Thanks this Attribute Sets works great. I do have a question that has probably been asked atleast a dozen times, my search skills seem to be lacking, as I was unable to find the answer.

 

Several of the products in my store have up to 6 different options. (Thanks to this contribution, were very simple to add to the store) Is there any way to set the order the options appear? Say I have a style and and a size. I want the style option to appear on the product page before the size, can this be done? I used attribute sets 5.5 with the bug fix. I did not try the plus contrib as this works well the way it is. I would like to be able to set the order though.

 

Thanks

:)

Share this post


Link to post
Share on other sites

I hope somebody can point me in the right direction.

 

In one of my stores under development, I have products that have different size options and different prices. In this instance it is candles of different sizes. Small candle is one price, medium is a little more, etc. We show a table of prices on the product page.

 

My client doesn't like that the attributes drop down menu shows the Option Value Price. Is there a way to hide it in the drop down but still calculate the correct price?

 

Thanks for any hints.

 

Janet

Share this post


Link to post
Share on other sites

I am receiving the following error when I press save to add a set to a product:

 

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '0,'+',1)' at line 1

 

insert into products_attributes (products_id, options_id, options_values_id, options_values_price, price_prefix, sort_order) values (77,17,,0,'+',1)

 

Any ideas? Much appreciated. This looks like it's going to be very very helpful and save countless hours!

 

Thanks!

Dale

Share this post


Link to post
Share on other sites

Hi,

 

Can someone tell me what are the changes needed if any, to make this contribution work on a shop installed in the root folder? I had attribute sets plus installed on my shop and after I moved it to root the contrib stoped working, so before I attempt to install this one I would like to know if it will work.

 

Thanks

Share this post


Link to post
Share on other sites

Disregard my question above, it works fine. When testing, I forgot to create new attributes and was trying to use the default ones to create sets.

Share this post


Link to post
Share on other sites

Hey, I noticed that you only use English - I wanted to do the same - how do I delete the other 2 default languages? Please help.

 

THanks!

Share this post


Link to post
Share on other sites

Hi,

could someone please help me with the following problem? I am getting this error:

 

Attribute Sets changes were saved.1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

 

select products_attributes_sets_id from products_attributes_sets_to_products where products_id =

 

[TEP STOP]

 

after editing an existing attribute-set. Is there a fix somewhere, which i might overseen? Another Problem: is it possible with AS (not AS PLUS, because i need multi-language) to do a correct sorting? (like in A->B->C and not C->B->A)

 

Greets,

Sandra

Share this post


Link to post
Share on other sites
Hi,

could someone please help me with the following problem? I am getting this error:

 

Attribute Sets changes were saved.1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

 

select products_attributes_sets_id from products_attributes_sets_to_products where products_id =

 

[TEP STOP]

 

after editing an existing attribute-set. Is there a fix somewhere, which i might overseen? Another Problem: is it possible with AS (not AS PLUS, because i need multi-language) to do a correct sorting? (like in A->B->C and not C->B->A)

 

Greets,

Sandra

Share this post


Link to post
Share on other sites
Hi,

could someone please help me with the following problem? I am getting this error:

 

Attribute Sets changes were saved.1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

 

select products_attributes_sets_id from products_attributes_sets_to_products where products_id =

 

[TEP STOP]

 

after editing an existing attribute-set. Is there a fix somewhere, which i might overseen? Another Problem: is it possible with AS (not AS PLUS, because i need multi-language) to do a correct sorting? (like in A->B->C and not C->B->A)

 

Greets,

Sandra

Hello again Sandra

I'm afraid it looks like you have fallen foul of the register_globals issue (read this thread and you'll find lots about it) (Assuming you have your php settings set to register_globals off ). This was one of the reasons for moving to ASP.

I'm sorry I can't help you more at the moment (I am feeling your pain), but other priorities (with fees !!) keeping me busy -

regards

Chris

Share this post


Link to post
Share on other sites

Hi Chris,

well - register globals are switched on... (regarding to my .htaccess)

<IfModule mod_php4.c>

php_value session.use_trans_sid 0

php_value register_globals 1

</IfModule>

 

I (or better: my customer) have two problems with ASP:

1) no multi-lang-support,

2) no integration of existent attribute sets as it seems?

... :/

 

Greets,

Sandra

Share this post


Link to post
Share on other sites

Hi again,

 

well - inserting options to new products works, but not to old products. With old (like "existing" products) you have to do the following things:

1) edit product.

2) open "Add AS".

3) save (unmodified - either you really want to change something) AS

4) click on "edit this product"

5) click on "preview"

6) save the not-modified, but re-sorted (!) product, clicking finally on "refresh this product"....

 

SIGH.

 

Greets,

Sandra

Edited by owl666

Share this post


Link to post
Share on other sites
Hi again,

 

well - inserting options to new products works, but not to old products. With old (like "existing" products) you have to do the following things:

1) edit product.

2) open "Add AS".

3) save (unmodified - either you really want to change something) AS

4) click on "edit this product"

5) click on "preview"

6) save the not-modified, but re-sorted (!) product, clicking finally on "refresh this product"....

 

SIGH.

 

Greets,

Sandra

 

Are we talking ASP or AS here?

 

C.

Share this post


Link to post
Share on other sites
AS

 

Well, the reason I rewrote it is these types of issues cropping up all the time - sorry I can't help.

If I could throw you an olive branch it would be to say that I will be looking at languages in the near future for ASP - it should not be to difficult because the design will easily accomodate it.

 

C.

Share this post


Link to post
Share on other sites

I ran into a problem with the attributes not getting saved when I would use the Attributes Set Edit to assign sets to my products. I had to edit the products_attributes_sets_edit.php file and change:

 

$asRowCount

 

to

 

$_POST['asRowCount']

 

Hope this helps someone out!!!

 

Chad

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×