Jump to content
Sign in to follow this  
stevenjm

Yasu sef urls problem

Recommended Posts

Tried the yasu sef url's mod and had trouble with page titles not displaying properly for the product_info.php pages.

ie.

<title><?php echo $product_info_values['products_name'];?> - Sydney Australia</title>

 

only change on actual product_info.php is first include for app top changed to "include_once" instead of "include"

 

works without the mod but fails with the mod . blank - sydney australia

 

any ideas?

 

also noticed with mod installed I'm getting session id in url of index page?

 

love to hear any suggestions as it seems a mod with great potential for what I want.

 

I like the look of the nimmit contrib but want to be able to use gzip.

Edited by stevenjm

Share this post


Link to post
Share on other sites

Hi, not sure if this is the same problem; my product.info pages are all showing the correct titles and meta tags, but my index and category pages are not, they are showing "UK jewellery". This really confuses me, as the header tags controller script is still in my index.php script, and the default title in this is a much longer title - "UK jewellery" is a phrase that is being picked up, but I dont know where from! Any ideas on which part of the yasu contrib is overwriting the header tags controller??

 

My index.php script looks like this: (first section only)

 

<?php

/*

  $Id: index.php,v 1.1 2003/06/11 17:37:59 hpdl Exp $

 

  osCommerce, Open Source E-Commerce Solutions

  http://www.oscommerce.com

 

  Copyright © 2003 osCommerce

 

  Released under the GNU General Public License

*/

 

  require_once('includes/application_top.php');

// the following cPath references come from application_top.php

  $category_depth = 'top';

  if (isset($cPath) && tep_not_null($cPath)) {

    $categories_products_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS_TO_CATEGORIES . " where categories_id = '" . (int)$current_category_id . "'");

    $cateqories_products = tep_db_fetch_array($categories_products_query);

    if ($cateqories_products['total'] > 0) {

      $category_depth = 'products'; // display products

    } else {

      $category_parent_query = tep_db_query("select count(*) as total from " . TABLE_CATEGORIES . " where parent_id = '" . (int)$current_category_id . "'");

      $category_parent = tep_db_fetch_array($category_parent_query);

      if ($category_parent['total'] > 0) {

        $category_depth = 'nested'; // navigate through the categories

      } else {

        $category_depth = 'products'; // category has no products, but display the 'no products' message

      }

    }

  }

 

  require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_DEFAULT1);

?>

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html <?php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

 

  <?php

// RJW Begin Meta Tags Code

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

  require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title>Online jewellery retailer, discount body jewellery. Unique silver jewellery</title>

<meta name="description" content="Jewellery retailer online, offering discount body jewellery in silver, gold and platinum. Unique silver jewellery, including diamond and wedding jewellery"><META name="keywords" content=?online jewellery retailer, jewellery retailer, jewellery retailer online, discount body jewellery, online discount body jewellery, discount body jewellery online, unique silver jewellery, unique silver jewellery online, silver body jewellery, silver jewellery retailer, gold jewellery retailer, platinum jewellery retailer, diamond jewellery retailer, discount diamond jewellery, wedding jewellery, discount wedding jewellery"><?php }

 

// RJW End Meta Tags Code

?>

<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">

 

btw, my index.php page is renamed as silvergold.php using .htaccess - this is another way of attacking the seo process, and works absolutely fine - this wouldn't affect the header tags would it??


Please note - if I have suggested a contrib above, it doesnt mean it will work! Most of the contribs are not ones I've used, but may be useful for your particular problem....

Have you tried a refined search? Chances are your problem has already been dealt with elsewhere on the forums.....

if (stumped == true) {

return(square_one($start_over)

} else {

$random_query = tep_fetch_answer($forum_query)

}

Share this post


Link to post
Share on other sites

I've got a crazy problem. after installing YASU contribution at http://www.karenelyse.com I noticed that some of the product images are not being displayed -- big X where the images are supposed to be within the catalog.

 

Now why would SOME of the images work and not others?

 

I have an auto thumbnailer contribution installed? Could this be interfering? I don't think so because SOME of the images still work while others don't. Confusing right?

 

Please help me out on this. Thank you.

Share this post


Link to post
Share on other sites

FIXED!!!! this CRAZY problem was solved by my sheer intellectual genius. I discovered the broken image links were to images with a capital ".JPG" extension and the working ones were ".jpg"

 

in the .htaccess file, there is some provision for file extensions allowed, and there is "gif" and "jgp" in there, so i just added "JPG" and "GIF" and now the whole thing works like a charm

Share this post


Link to post
Share on other sites

But now... how do I safely do this for an installation of oscommerce OUTSIDE of the "catalog" directory; one that resides in the root?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×