Jump to content
Sign in to follow this  
panzz

Links Manager v1.01, please help???

Recommended Posts

In Links Manager, in the admin, under "Options" what does "rating" mean (what numbers do you put in there and why)?

 

Also, is there a way to put the links in a chosen order (e.g., alphabetical) on a site?

 

Thanks.


Joe

 

Code? PHP? What's that? Maybe I'll have it figured out in about 5 years, goodness knows I'm trying!

Share this post


Link to post
Share on other sites

Hi,

 

That is pretty much for the google PR (page rank) of a site. It helps know basically how valuable the link is to you.

 

The link listing is already in alphabetical order, with numeric URL's listed 1st.

 

KJ


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites

Thanks for the explanation about the rating.

 

The link listing is alphabetical in admin, but not on my site. That's really what I'm looking for. A way to have links listed alphabetically on my site.


Joe

 

Code? PHP? What's that? Maybe I'll have it figured out in about 5 years, goodness knows I'm trying!

Share this post


Link to post
Share on other sites

Hi,

I don't know if you are the author of the contrib "Links Manager". I love this contrib, but I have a single question:

The links, which I mean the urls used to link to the added sites, was made up by a redirect, i.e. use the "goto" method. But this is a problem when I come to several links exchange service sites, e.g. www.linkmetro.com, many of these sites don't recognize the "goto" url. So, I just want to ask, can we change the url to a standard static url way?

Thanks.

Share this post


Link to post
Share on other sites
Thanks for the explanation about the rating.

 

The link listing is alphabetical in admin, but not on my site. That's really what I'm looking for. A way to have links listed alphabetically on my site.

They display sorted properly on my site. Does the sorting work when you click on a column heading?

 

Jack

Share this post


Link to post
Share on other sites
Hi,

I don't know if you are the author of the contrib "Links Manager". I love this contrib, but I have a single question:

The links, which I mean the urls used to link to the added sites, was made up by a redirect, i.e. use the "goto" method. But this is a problem when I come to several links exchange service sites, e.g. www.linkmetro.com, many of these sites don't recognize the "goto" url. So, I just want to ask, can we change the url to a standard static url way?

Thanks.

 

Just go into your admin > config > links

Get rid of the redirect for the links (anotherwords you won't use the click count, the URL's will point to the real URL's)

 

Click Count False

Spider Friendly Links True

 

-KJ


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites

Hi,

I just want to know, if the links manager contrib can work together with SEO URLs contrib? How can I convert the urls generated by links manage to the form of search engine friendly, i.e., without the "?" marks and show the links of the websites directly in the Title's urls instead use "goto"?

Share this post


Link to post
Share on other sites

To NerioDavid

 

turn on the search engine friendly url (still in development)

set it to true

 

and you will have seo friendly links pages urls

Share this post


Link to post
Share on other sites

many languages in the admin have the status have the status blank!

what can i do?

 

anyone knows?

 

In the admin on the left hand side under Links Manager there should be

Links

Links Categories

Links Contact

Select Links you should see the link, select edit and at the bottom of the section that has just opened you will see Options with Status as a pull down menu, select Approved and then click the button update, this will set the link as approved so that it will show up in the catalog

Share this post


Link to post
Share on other sites
To NerioDavid

 

turn on the search engine friendly url (still in development)

set it to true

 

and you will have seo friendly links pages urls

This doesn't work for the majority of the shops and should not be enabled.

 

Jack

Share this post


Link to post
Share on other sites
many languages in the admin have the status have the status blank!

what can i do?

 

anyone knows?

See the Update Changes in the Update Dosc directory. There are some databases changes that you may not have.

 

Jack

Share this post


Link to post
Share on other sites

Hello,

Talking about languages:

Is the french version available somewhere????

Even partially ?? I will complete it or have to translate all..

Is this the correct thread to pose aditional questions?

TIA

Hugo

Share this post


Link to post
Share on other sites

There's not one availabel that I know of. But all that is needed is for the english text files to be copied and translated. There is no additional install required.

 

Jack

Share this post


Link to post
Share on other sites

Hi

 

I have recently installed Links Manager 1.10 and have searched the forums for the answer to my question, but so far no luck.

 

The problem I have is basically, when I click on Link Manager in Admin, I get an error 500 page. Everything seems to be installed correctly and links diplays correctly except that when I click on links on the main page, it tells me that "there are no categories yet" or similar text. Also, if I try to add a link, where the field is to fill in the category, is only 1 character wide and blank. So, it seems as if I am having some sort of a database error or a file permissions error but I am not sure where exactly my problem lies.

 

I would be grateful for any guidance on this problem, does anyone have any ideas for a fix ?

 

cheers

 

Viper

Edited by Viper0409

Share this post


Link to post
Share on other sites
Did you create at least one category?

 

Jack

 

Hi Jack

 

I am not sure what you mean, but I don't have any options in Links Manager via my admin to create any categories or links. When I click on Links Manager in Admin, I get taken to the server error 500 so I cannot actually create any categories. Apart from not being able to access Links Manager in Admin, everything else seems ok. In Admin > Configuration > links, everything is fine but as I said above in Admin > Link Manager there are no options to set and it throws the error 500 page. Hope this helps clarify Jack, if you need any more info, Post here and I should be around the forums checking out other posts in other threads.

 

cheers

 

Viper

Share this post


Link to post
Share on other sites

OK, I misunderstood your post before. If the rest of admin is working, then there must be some setting on your server that is failing due to the code in Links Manager. So you will need to contact your host and ask them why it is failing.

 

Jack

Share this post


Link to post
Share on other sites
OK, I misunderstood your post before. If the rest of admin is working, then there must be some setting on your server that is failing due to the code in Links Manager. So you will need to contact your host and ask them why it is failing.

 

Jack

 

Hi Jack

 

Thanks for your reply, I will give my host a try, but doubt that they would be able to assist. On previous attempts for for their assistance (at least 7 times) for various unrelated matters, I was basically left to my own devices to solve the problem. They were of no assistance at all, and I will be changing over host's when my contract expires. One of my first questions to them was about protecting the admin folder via their cpanel, their response was "We do not provide support for osCommerce", so basically I had to work out my own way to do it. no thanks to them. Mind you, they do install osCommerce for their customers for a price, so I guess their reasons were financial.

 

Anyway, getting back to the point here, I am surprised that no-one has come across this problem yet, I suspect that it may be a database problem but I am not real sure how to go about tracking where the problem lies.

 

Any other ideas ? If anyone would like to take a shot at this I would be grateful. In the meantime, I will give my hosts another call (don't like my chances) and see if I can get even a snippet of info from them.

 

Cheers

 

Viper

Share this post


Link to post
Share on other sites

The 500 error can indicate a number of different things. It is a "catch-all" error that is displayed when some error occurs that doesn't have a specific error page. For example, it can be a security violation (or a perceived one) or a resource limit violation. But whatever it is, it is a problem only your host can resolve since the log of the failure is only available to them, in most cases. So they are the only ones that can help you. You could try removing parts of the code in Links Manager until the problem goes away to find the code causing the problem. But even if oyu found it, you would probabl still need your hosts support to fix it.

 

Jack

Share this post


Link to post
Share on other sites
The 500 error can indicate a number of different things. It is a "catch-all" error that is displayed when some error occurs that doesn't have a specific error page. For example, it can be a security violation (or a perceived one) or a resource limit violation. But whatever it is, it is a problem only your host can resolve since the log of the failure is only available to them, in most cases. So they are the only ones that can help you. You could try removing parts of the code in Links Manager until the problem goes away to find the code causing the problem. But even if oyu found it, you would probabl still need your hosts support to fix it.

 

Jack

 

Hi again Jack

Thank you for your detailed reply, I haven't had time to call my host yet but I will first thing in the morning and hopefully they can clarify things for me.

 

I will post here if I find out what the problem is, for the benefit of other members who may have similar problems.

 

regards

 

Viper

Share this post


Link to post
Share on other sites
Hi again Jack

Thank you for your detailed reply, I haven't had time to call my host yet but I will first thing in the morning and hopefully they can clarify things for me.

 

I will post here if I find out what the problem is, for the benefit of other members who may have similar problems.

 

regards

 

Viper

 

Hi again

 

This is an update, I emailed and called my host again, and got the standard response apart from a couple of clues.

 

This was their response and btw, they didn't return my call.

 

Hello

 

If you have installed additional add-on's onto the Oscommerce we do not support

this. But you need to make sure you have:

 

1) Uploaded in ASCII format and not in "Binary"

 

2) The permissions are set correctly to 755

 

3) and if those two are correct then there is an issue with the script itself.

 

Actually, my links manager files are all set by default to 644, so I will change them all to 755 and see if that makes a difference. Then I will check if my files were uploaded in ASCII format, but, how would I check that. Is there a way to find out ? I use WS FTP. I am pretty sure this auto detects which format to upload in.

 

If anyone has any clues please let me know.

 

Cheers

 

Viper

Share this post


Link to post
Share on other sites

Changing the permissions shouldn't have any effect since the files are not written to. Text files (html and php) should be uploaded in ascii and images in binary (in general). Open your ftp program and look at the options or preferences settings. Change them to auto mode and upload the files again. My guess is that the program is already set that way and it won't make any difference.

 

Jack

Share this post


Link to post
Share on other sites

Hi All and Merry Xmas

 

Back after a little Xmas break.

 

Jack, yep you are right. I changed permissions on all files and this made no difference, so I checked all my files and they were uploaded using WS FTP Pro, which uploads all files in binary, except files which are in a list which includes PHP file extensions. So I guess the problem is in the script according to the hosts reply, but I doubt that this is the case. I can see from other members who have posted in this thread that they have had some gliches but seemed to have overcome those problems.

 

I am still stuck with the same problem, and am seriously thinking of giving up unless I can get some help to trace the problem, Hosts don't seem at all interested, so I guess this forum is my only source of help.

 

Getting back to the problem, when I access my admin panel, and click Links Manager this is what I get.

 

The page cannot be displayed

There is a problem with the page you are trying to reach and it cannot be displayed.

 

--------------------------------------------------------------------------------

 

Please try the following:

 

Open the ***.**.***.** home page, and then look for links to the information you want.

Click the Refresh button, or try again later.

 

Click Search to look for information on the Internet.

You can also see a list of related sites.

 

 

HTTP 500 - Internal server error

Internet Explorer

 

I have checked, double checked and triple checked all my file additions and file edits, but still have the same error. I have changed the file permissions to 755 and still not good, so I changed them back to 644.

 

Any other suggestions from anyone ?

 

Cheers

 

Viper

Share this post


Link to post
Share on other sites

You could try another ftp program.

 

Since the problem only happens with Links Manager, make a copy of another file, say customers.php and name it links.php, replacing the real links.php. Does the page load correctly when you click on Links Manager in admin or do you still get the 500 error?

 

Try clicking into the url string and erasing everything after admin/, then type in link_categories.php and press enter. This should load a different page of Links Manager. Does it work?

 

By doing the above, you should be able to isolate the problem down to a file(s).

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×