Jump to content
Sign in to follow this  
panzz

Links Manager v1.01, please help???

Recommended Posts

Another quick couple of question.?

 

-How do I get rid of that goofy looking little box if I choose not to have a picturess for my category?

 

-Can't you have a category inside a category? etc?

 

S

 

Simply make the picture a fake one. So pick a very small image maybe even a 1x1pxl? (same for all is OK) then delete the picture off the images directory. It won't show any pic for those directories then.

 

Currently you can't have a "Sub" Category. It only supports 1 level (or Main Categories). I know this stinks but like I mentioned before, this Contrib never really took off, just a goood foundation was formed.

 

Good luck, KJ

Jack.. Glad to see your spooging in some work on this contrib. It is very welcomed!

Edited by Top_Speed

define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites
I uploaded an update that includes a search function for the shop side.

 

NOTE: I used version 1.01 to make the changes since the other uploads were not integrated into the contribution properly and I didn't want to risk redoing the work of those people and making things worse.  If you just want to update whatever version you have, I only changed the catalog/links.php and catalog/includes/languages/english/links.php files.

 

Jack

 

Hi Jack,

Nice (search box) addition! Thnx!! (It was many on my wish list for this contrib) Any chance for a modification to the search results? The links displayed are linked to the category but not the page of the category. Another words if your search came up for "XYZ link" it would bring up the "ABC link" page (same category, wrong page number is all).

 

I only played with catalog/links.php so far. I centered and dropped the text, image spacer (to save head room): My Links Category Page

 

Nice!!, Thx again for the input, time and effort.

--KJ


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites

Does anyone know if installing the new version. (http://www.oscommerce.com/community/contributions,1256) will correct my issue.

 

Is there any logs / screen shots i need to post?

 

To use this, you will either have to update your database with the included file, which will cause a loss of data, or add a new field into the database manually

 

What kind of data loss? Just loss of links or entire product database?

 

Thank you

Share this post


Link to post
Share on other sites
Hi Jack,

Nice (search box) addition! Thnx!! (It was many on my wish list for this contrib) Any chance for a modification to the search results? The links displayed are linked to the category but not the page of the category. Another words if your search came up for "XYZ link" it would bring up the "ABC link" page (same category, wrong page number is all).

--KJ

Ahh, I didn't think about that. It should be that difficult a change to make that work. I will include it on the next update if no one does it first.

 

Jack

Share this post


Link to post
Share on other sites
Does anyone know if installing the new version. (http://www.oscommerce.com/community/contributions,1256) will correct my issue. 

 

Is there any logs / screen shots i need to post?

What kind of data loss? Just loss of links or entire product database?

 

Thank you

If you are using version 1.01 then the new version won't help you any. It only contains the changes I mentioned. The data loss I mentioned was referring to the links you have entered. The rest of your database is not touched. Actually, you can't install the database changes without removing the current items from the database (contained in three tables). So the easiest way is to add the change manually, IMO.

 

Jack

Share this post


Link to post
Share on other sites

I'm sorry but not really. I get the link failure once in a while but I never looked into it. The failure is happening becuause Lnks Manager can't read the contents of the page. If it is happening for all links, then there is something wrong on your end. But if it just does it on some sites, tehn it is probably something on the page you are checking that is causing it. Try entering a link to your own site. Does it fail then?

 

As for the images, I don't use them so I can't give you an idea on that.

 

Jack

Share this post


Link to post
Share on other sites

Who's the main support guy for this contribution? Compared to my other osc contribs, this one seems to have the least amount of support.

 

I'll probably won't look into the link failure error since it happens for everysite I've tried. dynamic and static alike. I do need to have the pics working so I can display other sites logo's / link buttons.

Share this post


Link to post
Share on other sites

There is no one officially supporting it. The original author hasn't posted since last August. You could try contacting him directly.

 

If the link feature fails on every site, even your own, then the problem is most likely host related.

 

For the images, do you have them enabled in the admin settings. That is just for the catalog side so if it is not enabled, that would cause the problem.

 

Jack

Share this post


Link to post
Share on other sites

Does anyone have some suggestions as to how the link page lists the sites? Like to have the info in rows instead of narrow columns?

 

Cheers

Share this post


Link to post
Share on other sites
Does anyone have some suggestions as to how the link page lists the sites? Like to have the info in rows instead of narrow columns?

 

Cheers

 

As of now it was built with columns. I think mainly because it was easiest from the Admin side to "turn on" or "off" a column (to make visable on the shop side).

 

It would be nice to have the link title (over) the description instead of side by side keeping the picture (if enabled) to the left. Also for the anchor text part of it, the Title should also be the link, not the http:// so there are some tweaks that need to be done for sure. We'll have to see if we get enough input for that to happen.

 

(JACK) I'm going to mess with putting the search box on the actual links page(s) as well. The main links (category) as of now is the only place it shows.

 

--KJ


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites

The code I added for the search is sectioned off so it should just be a matter of copying it to the appriate place.

 

Jack

Share this post


Link to post
Share on other sites

I just uploaded a new version.

 

I did the following:

Added Search function to each link page

Added Sort function to display in admin

Added Categories button to reach link categories page from the individual link pages

 

KJ - This did not incorporate the change you made only because I did not notice that change until the work was completed.

 

Jack

Share this post


Link to post
Share on other sites

Hello,

I have been using Links Manager v1.01 for quite awhile.

 

I want the capability of adding to sort by status but I dont want to lose my whole database of links that already exist.

 

What do I need to change ?- I believe I need tomake a change in the database, but I cant find information on what needs to be changed. Has someone set up an sql file to just add whatever needs to be added?

 

Please help - I use the Links Manager all the time - it's a wonderful contribution.

Share this post


Link to post
Share on other sites
I just uploaded a new version.

 

I did the following:

Added Search function to each link page

Added Sort function to display in admin

Added Categories button to reach link categories page from the individual link pages

 

KJ - This did not incorporate the change you made only because I did not notice that change until the work was completed.

 

Jack

 

Hi Jack,

 

Your additions... cool! I won't post (in the Contrib) to the entire package with the visual html that I did (so we don't go back and forth stepping on each other). If you like the search in the "submit bar" like I have the html here: Links Page with Search box in submit bar we'll keep suite. But Checkout the link results (type in "oil") it resembles the osC theme I think a bit more closely using the same background color as the shops boxes.

 

___Any thoughts on putting a link count next to the Category name? (like the osC Categories box) I'm thinking a basic/altered copy of how that was performed?

 

___I guess we have a few db questions and they are indeed important for continued users with a established db (like me too!)

 

Good that we have a phper helping along this contrib, I think it's worth keeping your links page(s) inside your osC shop. Thanks Jack!

:thumbsup:


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites

The following should update the database so the new version can be used.

 

First - Go to admin->tools and backup the database. If the database is corrupted in some way, which it shouldn't be, this will allow you to easily recover from it.

 

In order for the following to display correctly, you need to know the existing group_id for Links Manager. So go into phpmyadmin, select your database and then click on the configuration_group table (left column). Then click on the Browse tab. On the resulting page, scroll down until you find Links as the title. Write down the configuration_group_id associated with it.

 

Then, select the SQL tab. In the box on that page, paste the following

INSERT INTO  configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Maximum Links to Display', 'MAX_LINKS_DISPLAY', '20', 'How many links should be displayed per page?', '18', '15', now())

Replace the 18 above with the number you wrote down above. Click Go and the update should be completed. Go to configuration in admin and verify the new entry is listed and works.

 

KJ - Yes, I was going to look at the category count next. I like your placement of the search bar better but I added a categories link to that bar so I'm not sure it will all fit. I will play around with it and include the other change you made for the appearance as well since it does look nicer I think.

 

Jack

Share this post


Link to post
Share on other sites
I will play around with it and include the other change you made for the appearance as well since it does look nicer I think.

 

We could make the search text as only "Find Link:"

and make the search box smaller? Then a Categories link or button could fit in between that and the Submit new link button. Testing on a 600x800 reso and then it would not overflow to another row. (I use a higher reso but I know we should create for 800x600 by default).

 

--KJ


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites

The following should update the database so the new version can be used.

 

First - Go to admin->tools and backup the database. If the database is corrupted in some way, which it shouldn't be, this will allow you to easily recover from it.

 

<snip>

 

I tried it on my test site and it worked beautifully ! Thank you !

Share this post


Link to post
Share on other sites

Just a quick question, is there any provisions to manualy insert a link without being reciprocal. ?

 

I was just going to post the db fix,for MAX_LINKS_DISPLAY

 

Jimmy

 

DVBHardware.ccom


I'm not a coder just a splicer.

Share this post


Link to post
Share on other sites

I just uploaded a new version.

 

- Added categories count

- Moved search to submit bar. Didn't have time to add the search image. Will add that at a later date.

 

Jack

Share this post


Link to post
Share on other sites
I just uploaded a new version.

 

I did the following:

Added Search function to each link page

Added Sort function to display in admin

Added Categories button to reach link categories page from the individual link pages

 

KJ - This did not incorporate the change you made only because I did not notice that change until the work was completed.

 

Jack

 

Jack, I just upgraded from Links Manager for osC_v1.02 to your newest version 1.05 on 05/19/05. I copied the files as provided in the zip file.

 

Upon entering my admin section and clicking on links manager these are the errors i received:

Errors ocurring in /admin/links.php?page=0&action=new

 

Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/ipocnug/public_html/catalog/admin/links.php on line 182

 

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/ipocnug/public_html/catalog/admin/links.php on line 182

 

Warning: reset() [function.reset]: Passed variable is not an array or object in /home/ipocnug/public_html/catalog/admin/includes/classes/object_info.php on line 17

 

Warning: Variable passed to each() is not an array or object in /home/ipocnug/public_html/catalog/admin/includes/classes/object_info.php on line 18

 

Errors occuring in /admin/links.php?links_status_list=All&search=

 

Warning: Division by zero in /home/ipocnug/public_html/catalog/admin/includes/classes/split_page_results.php on line 33

Warning: Division by zero in /home/ipocnug/public_html/catalog/admin/includes/classes/split_page_results.php on line 50

 

I reverted to my old version and had no problems. But each time i have tried to reinstall the new version these are the errors that show up

 

PhilPoxon

Edited by 241

Share this post


Link to post
Share on other sites

The location in the code for the first error relates to reading items from the database and the division by zero error occurs if the new max display field is not used. So my guess is that the database was not updated correctly. As mentioned earlier, the changes I made were based on version 1.01 so there may be something in the 1.02 version that is causing the problem. Although if you replaced all files, that should not be the case.

 

Jack

Share this post


Link to post
Share on other sites
The location in the code for the first error relates to reading items from the database and the division by zero error occurs if the new max display field is not used. So my guess is that the database was not updated correctly.  As mentioned earlier, the changes I made were based on version 1.01 so there may be something in the 1.02 version that is causing the problem. Although if you replaced all files, that should not be the case.

 

Jack

 

Jack, I used the database update suggested and that has fixed the problem on the main links manager page. The version I have installed (1.02) is based on version 1.01 for the catalog and has a new version of the admin added to it

 

When I installed your version (1.05) I replaced all files in the admin section with the new ones provided for you. I tried to run the database setup but it aborted because i already had installed the software.

 

PhilPoxon

Share this post


Link to post
Share on other sites
I just uploaded a new version.

 

- Added categories count

- Moved search to submit bar. Didn't have time to add the search image. Will add that at a later date.

 

Jack

 

Hi Jack,

Nice to see you got the link count!

 

Not sure on how yours aligns (with or without category pictures?) but I'm thinking this is how the alignment should be with the picture on top, link below the count right after?? It might usable to some to have the image selectable in admin also. I know I like the categoriy pics but some in this post have asked how to remove them (just a thought).

 

l-cat_MISC_go-cart_friends.jpg

Arts (24)

 

Thanks for all your time spent, it's appreciated by all!!

KJ


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites

I have added a new version. Since all of this should have been posted in the support thread for the contribution, I have posted the link there and will continue any support issues from that thread.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×