Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
jpomerenke

Help!! Authorize.net problems

Recommended Posts

Ok so i use authorize.net for my payment gateway. I have the AVS system set up to minimize fradulant transactions. Now ironically when i was putting a test order through with my own card i accidently put in the worng address so my card was declined. But here is my problem and i cant seem to find any other forum post that deals with it. Instead of OScommerce telling the customer your card was declined and possibly the reason why it just brings you back to the page were you would reenter CC info. Now as a customer i would just think that the stores shopping cart system is screwed up and my card was fine. Now my question is....is there a mod or some way to fix this. At the least have it say your card was declined because your billing addy didnt match up with your address on your credit card?

Thanks

Joey

Share this post


Link to post
Share on other sites

That is already built into OSC. If you look in checkout_payment.php you should see a section which starts with:

if (isset($HTTP_GET_VARS['payment_error']) && is_object(${$HTTP_GET_VARS['payment_error']}) && ($error = ${$HTTP_GET_VARS['payment_error']}->get_error())) {

This then goes on to display the returned error message to the customer.

 

Have you installed any contributions which may have changed this? Are you using the stock Authorize.net payment module or a Authorize.net contribution?


I'd rather be flying!

Share this post


Link to post
Share on other sites
Is the AVS error built in it?  Im using the stock authorize.net and i also have that code in there. 

Any other suggestions?

 

Joey,

 

I am having the same problem. I get the error message displayed if it is a local error such as a credit card number being entered that does not pass the check-sum test, but I am not having any authorize.net errors displayed.

 

Were you able to resolve your problem, and if so, how?

 

Thanks.

 

Alan

Share this post


Link to post
Share on other sites
Guest
Joey,

 

I am having the same problem. I get the error message displayed if it is a local error such as a credit card number being entered that does not pass the check-sum test, but I am not having any authorize.net errors displayed.

 

Were you able to resolve your problem, and if so, how?

 

Thanks.

 

Alan

Why is everyone so tight-lipped about authorize.net? No one answers questions regarding this contrib.

I don't get it! :huh:

Share this post


Link to post
Share on other sites
Guest

I see the need for the exact same thing...if a customer enters a credit card number wrong (or the address wrong like was previously mentioned)...it just brings them back to the enter cc # page....but without an error message telling them anything was wrong. They would have no idea what to fix or that their order was processed or not.

Share this post


Link to post
Share on other sites

double check your payment screen, when it comes back after an error. I took me forever to see this, but on mine the error from authnet shows up as one little line at the very top of the screen, before the actual page starts.


Toward Continued Success - - > Carol Hawkey - - > KidsLearnToSew.com - - > Wyoming, USA

Mods Installed - - > Authnet AIM2 - Bundled Products 1.4 - Fancier Invoice 6.1 - Email_HTML_Order_Link_Fixed - Header Tags Controller - Login aLa Amazon - JustOneAttribute - Article Manager - SPPC w/PB - spiders.txt - Dangling Carrot/Olive - Printable Catalog - CCGV(trad)

Planned Mods - - > Purchase Without Account - USPS Label - Ultimate SEO

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×