Jump to content
hozone

[contribution] Total B2B

Recommended Posts

erm...i didnt do a through check...i get this error mesage on my prdt info.

 

Fatal error: Call to undefined function: tep_xppp_getproductprice() in /home/estrella/public_html/product_info.php on line 78

 

help pls?


You live, you learn. :)

Share this post


Link to post
Share on other sites
I've just installed the script and its running well and is really useful! :) however, just a suggestion, i think it'll be good if it allows customers to enter a discount code when they check out..instead of just categorizing into groups...:)

One downside to letting the customer enter a code is that codes could be shared 'downstream' to other users. Using the database makes sure that the user gets what the Admin wants to give.

Share this post


Link to post
Share on other sites
I've just installed the script and its running well and is really useful! :) however, just a suggestion, i think it'll be good if it allows customers to enter a discount code when they check out..instead of just categorizing into groups...:)

One downside to letting the customer enter a code is that codes could be shared 'downstream' to other users. Using the database makes sure that the user gets what the Admin wants to give.

the reason why i proposed the code thing is i think it'll be good to attach a discount code or something that is linked to a promotion, thus, upon receiving an order using the code, you'll know its from the particular promotion. just my 2 cents worth though. :)


You live, you learn. :)

Share this post


Link to post
Share on other sites

Hi, guys, sorry to ask this question but what does the "Price 1" under the product price mean??? ;) ;) ........plus i can't seem to adjust anything about price 1 ;)

 

thanks for explaining :P

Edited by markchiu

OS-commerce is great, but with other magical contributions, that is just so "COOL"!

Share this post


Link to post
Share on other sites

Bump


OS-commerce is great, but with other magical contributions, that is just so "COOL"!

Share this post


Link to post
Share on other sites

jogoto...I just had the problem, you did, and i took your modification, and it works too....really wonder why it happens.......perhpaps somewhere along this contribution that group by...... are not capital letters...and index.php is accidently being put the capital letters....... ;) :lol:

 

 

 

and never mind what about the price 1 problem...i just figured out that you could have more than 1 price of the same product :lol:


OS-commerce is great, but with other magical contributions, that is just so "COOL"!

Share this post


Link to post
Share on other sites
I installed the 1.1 version of B2B over a clean MS2 installation patched with multi stores 1.4.

 

I am running on a curious problem. First of all, all prices in the catalog show as 0. Regardless, I get this error in the "What's new" box:

 

Warning: Missing argument 3 for display_price() in E:\Miata\dividi\includes\classes\currencies.php on line 72

 

Line 72 is

 

 ? ?function display_price($products_id, $products_price, $products_tax, $quantity = 1) {

 

Any ideas?

@ mx5gr

 

I had the same problem, only difference is my prices were all 16 :D .

I wrote:

Problem solved, there are two lines of code in product info and listing were not marked as a change to the original code.

This only happens if you patch the files and taking only the marked parts. Taking the two files product_info.php and product_listing.php from the original installation files comparing to the contrib the change in product_info.php is

      $products_price = $currencies->display_price($product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id']));

replace with

      $products_price = $currencies->display_price($product_info['products_id'], $product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id']));

and

            $products_options_array[sizeof($products_options_array)-1]['text'] .= ' (' . $products_options['price_prefix'] . $currencies->display_price($products_options['options_values_price'], tep_get_tax_rate($product_info['products_tax_class_id'])) .') ';

with this

            $products_options_array[sizeof($products_options_array)-1]['text'] .= ' (' . $products_options['price_prefix'] . $currencies->display_price($product_info['products_id'], $products_options['options_values_price'], tep_get_tax_rate($product_info['products_tax_class_id'])) .') ';

 

In product_listing change

              $lc_text = ' ' . $currencies->display_price($listing['products_price'], tep_get_tax_rate($listing['products_tax_class_id'])) . ' ';

in

              $lc_text = ' ' . $currencies->display_price($listing['products_id'], $listing['products_price'], tep_get_tax_rate($listing['products_tax_class_id'])) . ' ';

 

It helped for me.

Share this post


Link to post
Share on other sites

Can I manipulate option prices with B2B? I have two options for each dvd on my store, one for purchase and one for rent. I want to be able to make the rent for premium members free (the price to show 0) and the purchase with 10% discount. Is it possible or is there another way to do it?

 

Any help would be greatly appreciated. And thanks for the great contribution! :)

 

Rufus

Share this post


Link to post
Share on other sites

I used a contribution to lost my products in columns nad with B2B the product_listing pages are blank and the right column is missing. If i go back to my old product_listing.php it works. Is there a way to get it to work with the columns?

Share this post


Link to post
Share on other sites

I have 71 products (about 4 pages) in one category after applying Total B2B v1.1 on a fresh MS2 I only get 1 page. In left column the count still says 71 products in the category but I only get about 18. Does anyone knows whats going on? I have applied other contribution after Total B2B and did not realize this problem until afterwards? Help :lol:

Share this post


Link to post
Share on other sites

I think the problem is, at the bottom of the list it is not displaying the page count (page 1 of ?) etc. It will only display the maximum value of "Search Result" set in admin. No option for next page etc. Where can this be fixed?

Share this post


Link to post
Share on other sites

@ Maj

 

see my posting:

Ok, problem solved:

 

There are four changes in catalog/index.php

 

GROUP BY p.products_id

 

added.

 

After changing to

 

group by p.products_id

 

(just small characters) it works.

Share this post


Link to post
Share on other sites
I think the problem is, at the bottom of the list it is not displaying the page count (page 1 of ?) etc. It will only display the maximum value of "Search Result" set in admin. No option for next page etc. Where can this be fixed?

where did you get this problem?


osCommerce Italia support: http://www.oscommerceitalia.com

Share this post


Link to post
Share on other sites
I think the problem is, at the bottom of the list it is not displaying the page count (page 1 of ?) etc. It will only display the maximum value of "Search Result" set in admin. No option for next page etc. Where can this be fixed?

where did you get this problem?

I get this problem in product listing; I applied Total B2B on a fresh MS2.2 It stopped displaying "Result Pages": Thanks to Wolfram Palmer, replacing group by clause with lower case DID THE TRICK but I do not understand why. I saw his posting in forum but I thought it would not apply in my case: apperently it did; Thanks Wolfram ;)

Share this post


Link to post
Share on other sites
@ Maj

 

see my posting:

Ok, problem solved:

 

There are four changes in catalog/index.php

 

GROUP BY p.products_id

 

added.

 

After changing to

 

group by p.products_id

 

(just small characters) it works.

next version will have thi s fix.

 

tks


osCommerce Italia support: http://www.oscommerceitalia.com

Share this post


Link to post
Share on other sites

Okay now I am done installing Total B2b. It looks great to me, but didn't work for me yet.

My first is question if I update the discount price for one of the customer when will the customer will see that price. I mean when he logins the price of each product will change to discount price or when he add the products to the cart. just wondering when customer will see that.

 

Secondly I did try to give discount by adding a new group called "special price" and put discount in that group as 8%. I also add the customer to that Special price group. Now the customer should see the price, when he logins or when he add the items to the cart, But it doesn't happen.

Can anyone let me know where I am doing wrong.

Do I have to change the option in Mystore i.e"Number of prices ..... .

 

Please let me know.

thanks

Sandeep

Share this post


Link to post
Share on other sites

Hozone,

I'm still using your Customer Group contrib and its working out perfectly with those fixes we hammered out a month or two ago.

 

About this one, did you notice any significant parse time increases upon installation? When I added CG I didn't notice any delays at all, but when I installed this one somehow on a new install it was showing a 3X increase in parse times...maybe I added it wrong and it was doing some unnecessary loops.

 

Just curious. I'd love to add it to a future wholesale-only website I'm thinking about partaking in.

 

P.S. Thanks for these wonderful contribs, keep up the great work.


I ♥ PHP/MYSQL/CSS

Share this post


Link to post
Share on other sites

After it is installed I get this:

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: NO) in /hsphere/local/home/fitnes1/xxx.com/shop/includes/functions/database.php on line 19
Unable to connect to database server!

Share this post


Link to post
Share on other sites
Hozone,

I'm still using your Customer Group contrib and its working out perfectly with those fixes we hammered out a month or two ago.

 

About this one, did you notice any significant parse time increases upon installation? When I added CG I didn't notice any delays at all, but when I installed this one somehow on a new install it was showing a 3X increase in parse times...maybe I added it wrong and it was doing some unnecessary loops.

 

Just curious. I'd love to add it to a future wholesale-only website I'm thinking about partaking in.

 

P.S. Thanks for these wonderful contribs, keep up the great work.

what do you mean when you said "parse time"?


osCommerce Italia support: http://www.oscommerceitalia.com

Share this post


Link to post
Share on other sites
After it is installed I get this:

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: NO) in /hsphere/local/home/fitnes1/xxx.com/shop/includes/functions/database.php on line 19
Unable to connect to database server!

you have to select right username and password for your database!


osCommerce Italia support: http://www.oscommerceitalia.com

Share this post


Link to post
Share on other sites
it asks for a server location but when the IP is added it gives a different error.

i suppose it is not a totalb2b problem.

maybe you have this problem even with a clean 2.2 ms2 ?


osCommerce Italia support: http://www.oscommerceitalia.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×