Jump to content
Sign in to follow this  
spoot

FedEx realtime: no 'Ground Service' option

Recommended Posts

Hi -

 

I'm using the Fedex_Direct_2.04 module. It's working well, giving me a list of quotes; but my client ships exclusively by FedEx Ground Service, and this option (though it's uncommented in the domestic_types array) doesn't show up in my shipping options.

 

Currently I've got 90 (home delivery) and 92 (ground service) uncommented; but only home delivery displays as an option on checkout.

 

Any ideas? Does FedEx not recognize 'Ground Service' anymore?

 

Thanks in advance for any help -

 

Michael

Share this post


Link to post
Share on other sites

The FedEx module checks if a 'company name' field is empty or if it has some data. If a company name exists in the address, it uses ground rates. If the company name field is empty, the module assumes the shipment is to a residential location and sets the residential flag when it sends the information to the FedEx server and 'Home Delivery' rates are used instead of ground.

 

Your client does know that Home Delivery is FedEx's guaranteed *ground* service to residential locations? Also, Residential area surcharge is about 30-40 cents less if you ship using HD instead of ground when you ship to residential. Also, if you ship using 'ground' service to a residential location, you can not claim late delivery.

 

If you want only ground service, you could probably see where the 'residential flag' is set (by checking the 'company name' field) when preparing the information to send to the server and always have it set to non residential

Edited by safoo

Share this post


Link to post
Share on other sites

This is an old post, but I had this same problem and wanted to post a solution that might help others.

 

Home Delivery is residential and the max weight is 70 lbs. Ground service is higher, but you have to pass in a company name since it is business based shipping.

 

Basically, if your product is greater than 70 pounds (lbs) and there is no company name in their user profile, then it will not use ground shipping at all. This left our customers ordering products over 70 lbs with only the air based options, which sent many running off to competitors.

 

To fix this, here's what I did:

 

open fedex1.php

 

At about line 52, you should see:

 

// class methods
   function quote($method = '') {
     global $shipping_weight, $shipping_num_boxes, $cart, $order;

 

Just under this, I inserted:

 

//added to account for ground shipping on orders greater than 70 lbs.  Home delivery cuts off at the 70 lb weight mark
//ground service requires a company name, so we just make it their first/last name.
  if ($shipping_weight > 70  && $order->delivery['company'] == '') {
    $order->delivery['company'] = $order->customer['firstname'] . ' ' . $order->customer['lastname'];
  }
// end ground shipping modify

 

Now, if my customer does not use a company name, and he orders something over 70 lbs, they will have the ground service option by making their first/last name the company name.

 

Hopefully this will help others that runs into the same problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×