Jump to content
Sign in to follow this  
241

NewsDesk v1.48 Support

Recommended Posts

There is an error in the script which has to do with the [Read More] function.

 

If you enable read more for sticky topics and not for normal topics, then it will appear for ALL topics. You cannot stop this until a new version is released...

Solution: Enable readmore for both normal and sticky topics.

This does not require a new release just for that, all you have to do is in either catalog/includes/modules/newsdesk_sticky.php change line # 79 from

$insert_readmore = '

to

$insert_readmore_s = '

and line # 158 form

' . $insert_readmore . '

to

' . $insert_readmore_s . '


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

hi again,

I am getting these errors in the admin section when i go to do anything in the edit part of article management.

 

Warning: main(includes/modules/newsdesk/html_editor/summary_bb.php): failed to open stream: No such file or directory in /usr/local/psa/home/vhosts//httpdocs/admin/newsdesk.php on line 551

 

Fatal error: main(): Failed opening required 'includes/modules/newsdesk/html_editor/summary_bb.php' (include_path='.:/usr/local/psa/apache/lib/php') in /usr/local/psa/home/vhosts/httpdocs/admin/newsdesk.php on line 551

Share this post


Link to post
Share on other sites
hi again,

            I am getting these errors in the admin section when i go to do anything in the edit part of article management.

 

Warning: main(includes/modules/newsdesk/html_editor/summary_bb.php): failed to open stream: No such file or directory in /usr/local/psa/home/vhosts//httpdocs/admin/newsdesk.php on line 551

 

Fatal error: main(): Failed opening required 'includes/modules/newsdesk/html_editor/summary_bb.php' (include_path='.:/usr/local/psa/apache/lib/php') in /usr/local/psa/home/vhosts/httpdocs/admin/newsdesk.php on line 551

 

 

Which version of newsdesk do you have installed and can you provide a link to the site


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

I have located a bug.... (dont know how to fix it)

Go to my site...

www.ipodxtras.com Then click on an article... Now in the breadcrumbs click on iPod Xtras...

 

There will be something odd showing up...

Share this post


Link to post
Share on other sites
I have located a bug.... (dont know how to fix it)

Go to my site...

www.ipodxtras.com  Then click on an article... Now in the breadcrumbs click on iPod Xtras...

 

There will be something odd showing up...

 

 

You have not found anything that has not already been dealt with and a fix posted here in the support, please look through the support before posting.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

So I found the section where you are supposed to change the code and i did that...

 

Now when trying to view an article I get this...

Fatal error: Call to undefined function: tep_array_filter() in /home/httpd/vhosts/ipodxtras.com/httpdocs/catalog/includes/functions/newsdesk_general.php on line 43

 

This is what my code looks like there...

// Parse and secure the newsPath parameter values
function newsdesk_parse_category_path($newsPath) {
// make sure the category IDs are integers
$newsPath_array = tep_array_filter(explode('_', $newsPath), 'is_numeric');

/* CHANGED TO ABOVE CODE
// Parse and secure the newsPath parameter values
function newsdesk_parse_category_path($newsPath) {
// make sure the category IDs are integers
$newsPath_array = array_map('tep_string_to_int', explode('_', $newsPath));
*/

 

As for the newsdesk info box....

 

It is still giving me the error having to do with illegal offset type in the newsdesk.php in inlcludes/boxes/

It has to do with code from 61 to 108 here is the code...

// -------------------------------------------------------------------------------------------------------------------------------------------------------------
function newsedsk_show_category($counter) {
// -------------------------------------------------------------------------------------------------------------------------------------------------------------
global $foo_newdesk, $categories_newsdesk_string, $id;

for ($a=0; $a<$foo_newdesk[$counter]['level']; $a++) {
$categories_newsdesk_string .= "  ";
}

$categories_newsdesk_string .= '<a href="';

if ($foo_newdesk[$counter]['parent'] == 0) {
$newsPath_new = 'newsPath=' . $counter;
} else {
$newsPath_new = 'newsPath=' . $foo_newdesk[$counter]['path'];
}

$categories_newsdesk_string .= tep_href_link(FILENAME_NEWSDESK_INDEX, $newsPath_new);
$categories_newsdesk_string .= '">';

if ( ($id) && (in_array($counter, $id)) ) {
$categories_newsdesk_string .= '<b>';
}

// display category name
$categories_newsdesk_string .= $foo_newdesk[$counter]['name'];

if ( ($id) && (in_array($counter, $id)) ) {
$categories_newsdesk_string .= '</b>';
}

if (newsedsk_box_has_category_subcategories($counter)) {
$categories_newsdesk_string .= '->';
}

$categories_newsdesk_string .= '</a>';

if (SHOW_COUNTS == 'true') {
$products_newsdesk_in_category = newsedsk_box_count_products_in_category($counter);
if ($products_newsdesk_in_category > 0) {
 $categories_newsdesk_string .= ' (' . $products_newsdesk_in_category . ')';
}
}

$categories_newsdesk_string .= '<br>';

if ($foo_newdesk[$counter]['next_id']) {
newsedsk_show_category($foo_newdesk[$counter]['next_id']);
}

}

 

I have the newsdesk box being used with STS here is the code for it so it can be used with STS...

//  BEGIN NewsDesk
  $sts_block_name = 'newsdeskbox';
  require(STS_START_CAPTURE);
  require(DIR_WS_BOXES . 'newsdesk.php');
  require(STS_STOP_CAPTURE);
  $template['newsdeskbox'] = strip_unwanted_tags($sts_block['newsdeskbox'], 'newsdeskbox');

 

Any help is much appreciated...

Share this post


Link to post
Share on other sites

You are using a snapshot verion and not the stable 2.2MS2 version of osCommerce, in the contributions area the download clearly states not for CVS versions and that this support thread

The support thread for 2.2MS2 versions not cvs versions is here:

 

I also do not support STS as it causes many issues with many contributions, furthermore cvs snapshots are really meant for developers, which infers a coding level able to resolve coding issues.

 

I have posted fixes for CVS and STS before and stated that they were one off never to be repeated supports.

 

Contributions are built and posted to meet the stable version releases of osCommerce for compatability.

 

CVS snapshots codes are not finalised and can change from one snapshot to the next, which would require constant changes to the contribution.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

I understand about STS, but I dont use a CVS version... I have downloaded the Milestone 2 version!

 

You are using a snapshot verion and not the stable 2.2MS2 version of osCommerce, in the contributions area the download clearly states not for CVS versions and that this support thread

I also do not support STS as it causes many issues with many contributions, furthermore cvs snapshots are really meant for developers, which infers a coding level able to resolve coding issues.

 

I have posted fixes for CVS and STS before and stated that they were one off never to be repeated supports.

 

Contributions are built and posted to meet the stable version releases of osCommerce for compatability.

 

CVS snapshots codes are not finalised and can change from one snapshot to the next, which would require constant changes to the contribution.

Share this post


Link to post
Share on other sites
So I found the section where you are supposed to change the code and i did that...

 

Now when trying to view an article I get this...

Fatal error: Call to undefined function: tep_array_filter() in /home/httpd/vhosts/ipodxtras.com/httpdocs/catalog/includes/functions/newsdesk_general.php on line 43

 

This is what my code looks like there...

// Parse and secure the newsPath parameter values
function newsdesk_parse_category_path($newsPath) {
// make sure the category IDs are integers
$newsPath_array = tep_array_filter(explode('_', $newsPath), 'is_numeric');

/* CHANGED TO ABOVE CODE
// Parse and secure the newsPath parameter values
function newsdesk_parse_category_path($newsPath) {
// make sure the category IDs are integers
$newsPath_array = array_map('tep_string_to_int', explode('_', $newsPath));
*/

I understand about STS, but I dont use a CVS version... I have downloaded the Milestone 2 version!

 

The codes that you have are not from my contribution, these codes are a fix for a cvs snapshot, so therefore you are either using a loaded version of oscommerce which has newsdesk installed or you are not using Newsdesk v 1.48.3

Edited by 241

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

I have what's probably a simple problem to fix, just not simple for me. :)

 

When the first page of my site loads the newsdesk doesn't show up in the info box (right column). When clicking on any other page or refreshing it does show up and shows on all subsequent pages.

 

I know somewheres it checks to see if there are any news articles, and if there isn't then it doesn't display the info box. Where does it check for this?

 

Thanks,

Mark

Share this post


Link to post
Share on other sites

Are you saying that the below is code for CVS?, because I changed this when I found it in a post on an earlier page... I Am having an isssue with the newsdesk when you click on a folder name... You told me it had already been solved so this is what i found...

Please advise...

// Parse and secure the newsPath parameter values
function newsdesk_parse_category_path($newsPath) {
// make sure the category IDs are integers
$newsPath_array = tep_array_filter(explode('_', $newsPath), 'is_numeric');

/* CHANGED TO ABOVE CODE
// Parse and secure the newsPath parameter values
function newsdesk_parse_category_path($newsPath) {
// make sure the category IDs are integers
$newsPath_array = array_map('tep_string_to_int', explode('_', $newsPath));
*/

Share this post


Link to post
Share on other sites
Are you saying that the below is code for CVS?, because I changed this when I found it in a post on an earlier page... I Am having an isssue with the newsdesk when you click on a folder name... You told me it had already been solved so this is what i found...

Please advise...

// Parse and secure the newsPath parameter values
function newsdesk_parse_category_path($newsPath) {
// make sure the category IDs are integers
$newsPath_array = tep_array_filter(explode('_', $newsPath), 'is_numeric');

/* CHANGED TO ABOVE CODE
// Parse and secure the newsPath parameter values
function newsdesk_parse_category_path($newsPath) {
// make sure the category IDs are integers
$newsPath_array = array_map('tep_string_to_int', explode('_', $newsPath));
*/

 

It is that code that lead me to believe that you were using a CVS version, that code should not have been changed the code that required changing is from post #78 The other issue of the foo is due to an array being called within an array and has been posted somewhere by me, however I cannot recall where.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

I mostly fixed the category issue, thanks so much... There is the drop down box where it says "Choose a Category" and then my first topic. If you select choose a category the url is "http://www.ipodxtras.com/catalog/newsdesk_index.php?newsPath="... Is there some way to fix this so that when you choose that option it will not automatically take you to this page which is an error?

 

And to your post above, are you saying the the News Box has a known issue, and that it isnt just me... That would be good news!

Share this post


Link to post
Share on other sites
I mostly fixed the category issue, thanks so much... There is the drop down box where it says "Choose a Category" and then my first topic.  If you select choose a category the url is "http://www.ipodxtras.com/catalog/newsdesk_index.php?newsPath="...  Is there some way to fix this so that when you choose that option it will not automatically take you to this page which is an error?

 

And to your post above,  are you saying the the News Box has a known issue, and that it isnt just me... That would be good news!

 

Please try and not miss interpret everything I write. There is no issue with the contributionas it was intended for 2.2ms2 the issue is with STS which I DO NOT SUPPORT


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Hi, guys! I installed this beautiful contribution at my Cigarettes store yesterday and like it very much :)

 

I have a question: how can I include php scripts in the news? I want to have links to products from my news. I tried including php code like follows:

\'<a href="\' . tep_href_link(FILENAME_PRODUCT_INFO, \'products_id=30\', \'NONSSL\') . \'">\'Marlboro

and few other variants, but this didn't work.

 

Is it possible at all?

Share this post


Link to post
Share on other sites

I noticed a small bug.. sorry if this has been already mentioned but I could not find.

 

When I had this symbol --> ' <-- that symbol in News Summary it caused this error when trying to duplicate the news article:

 

1064 - You have an error in your SQL syntax near 'e-Orders are right here in Lik Sangs Nintendo DS Update.')' at line 6

 

So in the word 'e-Orders caused the error. If I have the same word in them main news it does not cause an error.

 

Hop you understood :)

Share this post


Link to post
Share on other sites

is there a way that i can make the text that is displayed on the front page not bold nd larger?

 

and is there away to put the main body of the article on the front page?

thanks


"because it'll hurt more"- the greatest film of all time?

Share this post


Link to post
Share on other sites

Hiya all,

 

I have just installed Newsdesk 1.48.3 on osCommerce 2.2-MS2 and it is nearly doing everything i want it to (and more)

 

When i go to newsdesk_index.php the file runs but displays nothing but the standard framework, header, footer, info boxes etc. there is nothing in the body of the page.

 

I am not calling the file with any parameters. It does not throw any errors and i am not sure where to start debugging the system.

 

Apologies if this has been addressed somewhere else. I did have a look through this thread but could see anything relevant to this problem. If there is something i should look at please let me know

 

Thx

 

Toby


I ain't got time to bleed

Share this post


Link to post
Share on other sites
When i go to newsdesk_index.php the file runs but displays nothing but the standard framework, header, footer, info boxes etc. there is nothing in the body of the page.

 

You would need to provide a link in order to see what the issue is as if it is what I think then yes it has been addressed before


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×