Jump to content
Sign in to follow this  
241

NewsDesk v1.48 Support

Recommended Posts

what I see in the News categories box is this

 

Announcements (1)

Practical MIDI (1)


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

notset4life

 

what setting do you have in admin under configuration and images for Image required is it set to true or false


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

notset4life

 

The blank image place holders are there to remind you that you have no images with that particular article otherwise they would be filled with the images.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites
what I see in the News categories box is this

 

Announcements (1)

Practical MIDI (1)

It's there now, sometimes it just the links just dissapear ??

Share this post


Link to post
Share on other sites
what I see in the News categories box is this

 

Announcements (1)

Practical MIDI (1)

It's there now, sometimes it just the links just dissapear ??

I have been into your site a few times and see no issues with the newsdesk


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Thats good to hear Jimmy and thanks for the beta test, I believe that I gave your help a mention in one of the reviews.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites
Thats good to hear Jimmy and thanks for the beta test, I believe that I gave your help a mention in one of the reviews.

Hi,

 

I?ve some problems. I hope anybody can help me! jemand

 

First: This Demo: Look this Demo!

Click on "Read more..." Link, then please change the language, click on the british flag, it come into view a back button on the right site from continue Button. Click this: And all boxes not in order!

 

Second: When I take a information without a picture, why a blank image place! What I do, to use a text without a image. In admin-area, all images of "0", nevertheless a empty placeholder!

Thanx.....

Ric from Germany

Share this post


Link to post
Share on other sites
Thats good to hear Jimmy and thanks for the beta test, I believe that I gave your help a mention in one of the reviews.

Hi,

 

I?ve some problems. I hope anybody can help me! jemand

 

First: This Demo: Look this Demo!

Click on "Read more..." Link, then please change the language, click on the british flag, it come into view a back button on the right site from continue Button. Click this: And all boxes not in order!

 

Second: When I take a information without a picture, why a blank image place! What I do, to use a text without a image. In admin-area, all images of "0", nevertheless a empty placeholder!

Thanx.....

Ric from Germany

You have quoted my post to thank RI Downlink so I will use this opertunity for a history to date.

 

RI Downlink contacted me offline in regards to the Newsdesk, we worked away on some of the issues, resolving many.

RI Downlink was influenial in proposing how he saw the NewsDesk working and I would work on the codes to achieve the ends, RI Downlink was also influential in my releasing this update to the NewsDesk otherwise I would not have made a release. RI Downlink was not a beta tester in the true sense of a beta tester but did give ideas on what would be good as an improvement.

 

I posted requesting beta testers but got a very poor response from the community considering the amount of people whom whish to have the NewsDesk working properly, I got only one respondent, whom kindly offered their services as a beta tester. I accepted and asked them to work through the NewsDesk but they were mainly concentrating on testing the I.E.6 crash issue to which I had resolved but wanted further testing done.

 

The back button was added at the request of RI Downlink and was a last minute addition, which was only tested by myself.

 

The idea behind the back button was that where a category had more than one article the back button would show, allowing a return path to the category in order to read further articles from that category, this feature did not originaly exist and the continue button would take you all the way back whereby you had to go through the selection process again for each article. If a category had only one article or an article was in the top category the back button would not show thus the continue button would be all that was required as there was no point in going back to the category with the one article to which you had just read.

 

So the back button feature had not been fully tested, this would not normally have been an issue as a person normally would choose the language to browse in prior to browsing and would not normally change languages whilst browsing, so the issue did not show up under my very brief testing.

 

Now down to trying to resolve the issue.

 

I do not know if the issue can be resolved from the codes that I used or if a complete rewrite of the codes involved will be required.

 

I am not sure if the issue can be resolved by the use of an

}else if{

statement in the code so I will post the codes involved to see if a proper coder can take a look (laugh to themself) as to the codes I have used and then post a solution.

 

The file is the catalog/newsdesk_info.php and the two parts to the codes are this at the beginning of the file

// BOF Wolfen added code to retrieve backpath
$get_backpath = tep_get_all_get_params();
$get_backpath_back = tep_get_all_get_params(array('newdesk_id')); // for back button
$get_backpath = substr($get_backpath, 0, -15); //remove trailing &
if ($get_backpath_back != '') {
   $get_backpath_back = substr($get_backpath_back, 0, -15); //remove trailing &
} else {
   $get_backpath_back = $get_backpath;
}
// EOF Wolfen added code to retrieve backpath

and this code at the end of the file

<?php
// BOF Wolfen added code for button case
if ($get_backpath_back = $get_backpath) {
echo '<td align="right" class="main"><a href="' . tep_href_link(FILENAME_NEWSDESK_INDEX, $get_backpath) . '">' . tep_image_button('button_back.gif', IMAGE_BUTTON_BACK) . '</a>' . tep_draw_separator('pixel_trans.gif', '10', '1') . '<a href="' . tep_href_link(FILENAME_DEFAULT, '', 'NONSSL') . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a></td>';
} else {
echo '<td align="right" class="main"><a href="' . tep_href_link(FILENAME_DEFAULT, '', 'NONSSL') . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a></td>';
}
// EOF Wolfen added code for button case
?>

 

The issue of the blank image place. Check in your admin under configuration and under images check that the last line Image required is set to False as it should only be set to true when you are developing the site to help aid in location of image placement and missing images but this should be set to false when your site is up and running


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

I've just upgrade NewsDesk to latest version. However, when I click Article managment, it turns to a blackpage. Is there anything wrong?

Share this post


Link to post
Share on other sites

terencel

Do you mean a blank page.

Did you follow all the install instructions

Did you load the sql to the database


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites
terencel

Do you mean a blank page.

Did you follow all the install instructions

Did you load the sql to the database

All yes.

Share this post


Link to post
Share on other sites

terencel

 

It is normal when looking for support to give as much information as possible not as little as possible.

 

Is this a default install of oscommerce

What version are you running

Do you have other contributions installed mainly admin access with levels

Have you edited any of the files

Have you checked your file permissions

Have you checked that a file was not corrupt on upload

Have you checked that there are no whitespaces at the end or beginning of the newsdesk.php

Was this an update to an existing Newsdesk contribution or a fresh install of the contribution as nobody has reported having this issue with the install.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites
terencel

 

It is normal when looking for support to give as much information as possible not as little as possible.

 

Is this a default install of oscommerce

What version are you running

Do you have other contributions installed mainly admin access with levels

Have you edited any of the files

Have you checked your file permissions

Have you checked that a file was not corrupt on upload

Have you checked that there are no whitespaces at the end or beginning of the newsdesk.php

Was this an update to an existing Newsdesk contribution or a fresh install of the contribution as nobody has reported having this issue with the install.

1 It is default install

2 2.2 MS2

3 I think so

4-6 all done

 

It is a upgrade of pervious version.

Share this post


Link to post
Share on other sites

@ Steve,

 

Hi,

I?m new here in this forum (usually I use the german forum) but after adding the contrib newsdesk I got some trouble which I already got fixed after reading this thread over here.

It?a very nice contribution and looks to work pretty good. The reason at them moment why I?m posting here is that I?m using another contrib: sts templates and try to put the newsdesk in here.

 

Because I?m not good in php I do have trouble getting the content of the newsdesk overview (list of news) in a special window or content.

 

At the moment I find this only in the index. php.

 

Is anybody able to give a hint ?

 

sorry if this is not belonging to this threat, but I think you guys over here are very skilled in this ;-)

 

thanks for understanding

 

regards

byps

Share this post


Link to post
Share on other sites
This is the support for the update only

terencel

 

This is a complete replacement for all the previous Newsdesk, so did you replace all the previous Newsdesk, your issue is with a remnant of the previous Newsdesk.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Steve, did you workout the addition of the extra buttons in the admin top or right collum that I mentioned.


I'm not a coder just a splicer.

Share this post


Link to post
Share on other sites
This is the support for the update only

terencel

 

This is a complete replacement for all the previous Newsdesk, so did you replace all the previous Newsdesk, your issue is with a remnant of the previous Newsdesk.

I've already clear all the table use by NewsDesk and replace all the files and make approiate changes as stated in the install.txt

 

It is strange, only admin/newsdesk.php and admin/newsdesk_reviews.php return blank page.

Share this post


Link to post
Share on other sites
Steve, did you workout the addition of the extra buttons in the admin top or right collum that I mentioned.

Yes I did a very easy code change takes less than a minute.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Just wanted to say thanx for the contrib :)

 

I'm still tweaking away at it, and noticed that your display pages had the variable BOX_WIDTH_LEFT and BOX_WIDTH_RIGHT tweaks and had the cellpadding removed from the left and right columns. It was playing minor havok with my layout, and took me a while to find.

 

Thought I'd mention it for those who might have had similar concerns. Really easy to fix once you know where to look :o)

 

(amused by some of your coding comments as well!)

 

Thanx again

 

Dunx


Dunx

noidwerx

Share this post


Link to post
Share on other sites

noidwerx

 

Thanks it had been noted and removed for the next release which has also had minor mods to the admin side including additional buttons as requested by RI Downlink

 

The coding comments probably are not mine as I am far to boring for that :lol:

Edited by 241

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Cool cool...

 

hey, are you planning to have the ability to delete an image from a news article?

 

And the ability to name the URL would be handy.

 

Just some suggestions - keep up the good work!

 

Dunx


Dunx

noidwerx

Share this post


Link to post
Share on other sites

noidwerx

 

URL naming is allready in the next release.

I will look further into the image delete side.


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×