Jump to content
Sign in to follow this  
241

NewsDesk v1.48 Support

Recommended Posts

This is the support for the update only

 

This is an update to the existing contribution NewsDesk v1.4

A lot of bugs have been fixed and some language support added.

The languages being Dutch, English, French, German and Spanish.

Order listing has been initially set by Date.

 

The contribution is available here:

 

NewsDesk v1.48

***********************************

hi

i have this problem please help me!

in my store 12 language exist but in newsdesk.php some of those don,t work

Share this post


Link to post
Share on other sites

This may be another silly question but why is it that when I don't use a summary the main body of the article won't appear? It wouldn't be so bad if only I could get the summary NOT to display in bold ;)


For my contribution (to society) see my profile link.

--

my new charity store features: STSv4.5.2 and HTCv2.6.3 Bundle, Australian Post Shipping, Paymate, Category Trees Minimum Order Quantity, Enable/Disable Categories, Super Download Store, Paypal IPN, Free Dowloads, Anti-Robot Registration 2.6, Master Products, Lightbox for STS ... the rebuild continues...

Share this post


Link to post
Share on other sites
I have installed the Contab as per instruction and everything seem to be showing well in the Catalog side as does the NewsDesk Admin side but when i click the Article Management link in admin i get a blank page with the following error

Parse error: parse error, unexpected '{' in /home/xxxxx/public_html/catalog/admin/newsdesk.php on line 16

It is refering to a file that was provided so i can only assume its corect so this error shount be showing,

Has anyone any Ideas,

 

I am having the same problem and I also looked through this entire post for hours. Has anyone found a solution to this?

Share this post


Link to post
Share on other sites

I also am having an issue with the display of catalog/newsdesk_index.php

 

I already tried installing the last "fix" on the contributions page, but that didn't seem to change anything for me.

 

Here is a link to the page I'm having trouble with, it's still in development.

 

http://www.ebookfaerie.com/catalog/newsdes....php?newsPath=2

 

It's any page you go to from newsdesk_index.php but since you can't just go straight there I sent you to a path. Please help me with th is and my previous problem. Everything else is great for me other than these two things so far. Thanks!

Share this post


Link to post
Share on other sites
I am having the same problem and I also looked through this entire post for hours. Has anyone found a solution to this?

 

 

I am having exactly the same problem - everything installs and works fine until you want to write a news article! I'm wondering if you need to install some separate package for the WYSIWYG editor to work? Just a guess...

Share this post


Link to post
Share on other sites
I am having exactly the same problem - everything installs and works fine until you want to write a news article! I'm wondering if you need to install some separate package for the WYSIWYG editor to work? Just a guess...

 

 

Okay, I've managed to get it working - by replacing the updated newsdek.php file from Lupin3rd with the previous version from ddSHADOW, so it's something to do with that... I'll get back if I find out what it is.

Share this post


Link to post
Share on other sites
Okay, I've managed to get it working - by replacing the updated newsdek.php file from Lupin3rd with the previous version from ddSHADOW, so it's something to do with that... I'll get back if I find out what it is.

 

Bleh... when I said "working", I meant "sort of working" - at least you can see and edit the categories, but when you go to create a new news item it lets you enter the headline, but nothing else... you just get a blank in the Summary area :huh: . You can save it, but obviously it's a bit... ummm... empty.

Share this post


Link to post
Share on other sites
Bleh... when I said "working", I meant "sort of working" - at least you can see and edit the categories, but when you go to create a new news item it lets you enter the headline, but nothing else... you just get a blank in the Summary area :huh: . You can save it, but obviously it's a bit... ummm... empty.

 

 

 

Me again. Well, I've got it working - the newsdesk module was missing from the admin/includes/modules directory, as soon as I put it in it all started working. I thought I'd done the install correctly, but obviously not :-" . There is a bit of weird behaviour in the catagories view pages, but I reckon I can sort that out.

Share this post


Link to post
Share on other sites

Hi there, hopefully someone is still reading this thread!

 

I'm trying to get the date format changed on the newsdek_listing.php page, and it's bugging the heck out of me, because I can't seem to do it anywhere...

 

http://www.humdrumming.co.uk/newsdesk_index.php?newsPath=14

 

right now, it lists the news items by date (which is what I want), but formats the date to YYYY-MM-DD HH:MM:SS. I'd like this to show as DD/MM/YYYY, but can't find anywhere to control this by using tep_date_short or the like.

 

Can anyone help?

Share this post


Link to post
Share on other sites
Hi there, hopefully someone is still reading this thread!

 

I'm trying to get the date format changed on the newsdek_listing.php page, and it's bugging the heck out of me, because I can't seem to do it anywhere...

 

http://www.humdrumming.co.uk/newsdesk_index.php?newsPath=14

 

right now, it lists the news items by date (which is what I want), but formats the date to YYYY-MM-DD HH:MM:SS. I'd like this to show as DD/MM/YYYY, but can't find anywhere to control this by using tep_date_short or the like.

 

Can anyone help?

 

Hi - I think I'm the only other person alive on this thread. I'm not sure I can help you with this, as I've got the date display disabled on my site so I've not had to look at this yet. I think you need to be looking at the newsdesk_listing.php file, around lines 124-127. I can't be more specific - the code is particularly impenetrable, and I'm no php coder by any means!

 

I'm having trouble with changing the order that the news information is displayed on the same page you're having date problems with - at the moment it's summary - image - title, when I want it to be image - title - summary. I've mucked around with the code in newsdesk_listing all day and not got anywhere. How did you do it?

 

 

The guy who developed this module has also done loads of other stuff, and I guess he just doesn't have time to support this and the other bits he's done, I've not seen him in this thread for over a year. Good luck, anyway!

Share this post


Link to post
Share on other sites

Hi,

I've installed newsdesk and it's working really great on my localserver.

But whenever i upload it. I recieve following error.

Parse error: parse error, unexpected '{' in /usr/local/psa/home/vhosts/nexosports.com/httpdocs/ver3/admin/newsdesk.php(1) : eval()'d code on line 16

Can somebody please tell me what could be the reason ?

Thanks in Advance

Azi

Share this post


Link to post
Share on other sites

hello,

 

I have a problem, maybe anyone has already solve this.

I can't see the newsdesk_index.php, its blank, nothing appears.

I already instaled the fix there is on contribution page, but didn't solve.

 

my link is http://www.kubico.com/loja/newsdesk_index.php

 

Thanks in advance.


KUBICO from Portugal

Share this post


Link to post
Share on other sites
hello,

 

I have a problem, maybe anyone has already solve this.

I can't see the newsdesk_index.php, its blank, nothing appears.

I already instaled the fix there is on contribution page, but didn't solve.

 

my link is http://www.kubico.com/loja/newsdesk_index.php

 

Thanks in advance.

 

I solve my this problem with this post

http://forums.oscommerce.com/index.php?sho...c=92136&st=372#

Thanks to scanditan


KUBICO from Portugal

Share this post


Link to post
Share on other sites

Hi i just installed newsdesk and im getting two things, this error comes up on top of the pages:

 

<

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/httpd/vhosts/lancertuning.net/httpdocs/includes/configure.php:1) in /home/httpd/vhosts/lancertuning.net/httpdocs/includes/functions/sessions.php on line 67

 

and i cannot access the oscommerce admin, says 404 Not Found ... ???

 

Other than that it works as far as its on the page and looks / functions fine, other than not being able to access admin.

 

Thanks

 

*Edit* in case it helps the site is lancertuning.net

Edited by silens

Share this post


Link to post
Share on other sites

You may have a file corrupted, it's strange you have "<" on top of your page, try to upload again, your last changed files .

 

Sousa


KUBICO from Portugal

Share this post


Link to post
Share on other sites

Silens,

 

I found this on the bottom of your page:

  
Warning: main(): Unable to access /home/httpd/vhosts/lancertuning.net/httpdocs/twatch_include/api.php in /home/httpd/vhosts/lancertuning.net/httpdocs/includes/footer.php on line 19

Warning: main(/home/httpd/vhosts/lancertuning.net/httpdocs/twatch_include/api.php): failed to open stream: No such file or directory in /home/httpd/vhosts/lancertuning.net/httpdocs/includes/footer.php on line 19

Warning: main(): Unable to access /home/httpd/vhosts/lancertuning.net/httpdocs/twatch_include/api.php in /home/httpd/vhosts/lancertuning.net/httpdocs/includes/footer.php on line 19

Warning: main(/home/httpd/vhosts/lancertuning.net/httpdocs/twatch_include/api.php): failed to open stream: No such file or directory in /home/httpd/vhosts/lancertuning.net/httpdocs/includes/footer.php on line 19

Warning: main(): Failed opening '/home/httpd/vhosts/lancertuning.net/httpdocs/twatch_include/api.php' for inclusion (include_path='.:') in /home/httpd/vhosts/lancertuning.net/httpdocs/includes/footer.php on line 19

Fatal error: Call to undefined function: twatch_connect() in /home/httpd/vhosts/lancertuning.net/httpdocs/includes/footer.php on line 20

Warning: Unknown(): Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

 

Try to upload the file api.php.


KUBICO from Portugal

Share this post


Link to post
Share on other sites

How do I or Can I turn Newsdesk off? I'd like to turn it on and off while I play with the design of my site.

Edited by mpm

For my contribution (to society) see my profile link.

--

my new charity store features: STSv4.5.2 and HTCv2.6.3 Bundle, Australian Post Shipping, Paymate, Category Trees Minimum Order Quantity, Enable/Disable Categories, Super Download Store, Paypal IPN, Free Dowloads, Anti-Robot Registration 2.6, Master Products, Lightbox for STS ... the rebuild continues...

Share this post


Link to post
Share on other sites

Just a general thank you to the guys who wrote this! It's been a pleasure to install! I've so far only got it on Localhost, so no doubt still a few interesting hours ahead of me, but so far it's all looking very good. :D

 

Two things I found out whilst installing:

-> only the full package from ddshadow (Oct 2005) works properly. I haven't tested the SEO upload, but the other two are bugged. One doesn't even use PHP code I recognise, so god knows what coding language that's in.

-> to get this work properly with multi-language support I had to apply this fix:

Steve Bisset's fix for "too few arguments" on newsdesk_info.php

 

Shame the fix was missed in the last complete package but once you know what to do, it is easily applied.

 

all the best, Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
How do I or Can I turn Newsdesk off? I'd like to turn it on and off while I play with the design of my site.

I don't think you can turn on/off easily but if you want to hide the newsdesk from the shop, then you just need to delete / comment out the relevant entries in the /includes/column_right.php and /index.php. You will then have all the functions in admin, but it won't be viewable as customers will have no link to it.

 

PS: if newsletters have already been spidered, then above won't work 100% as the search engines will provide direct links. You could address this with a redirect command in .htaccess though.

 

all the best, Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites

It is possible to place my ?WYSIWYG WYSIWYG SPAW? to work in the NewsDesk.

 

With the current editor I have many problems with the HTML and the tables have serious errors.

 

 

Sorry my Inglish

 

Tks

Share this post


Link to post
Share on other sites
"There are no news articles in this category"

 

Oh, but there are!

 

ok. i've done my best to search through this forum, but still haven't found the answer to my problem. i've done a fresh install of the NewsDesk 1.48, into a fresh install of osC. everything is working fine, except for the News Categories, which work for the stock news articles included with NewsDesk, but don't seem to include the articles that i have added myself.

 

the crazy thing, is that the articles show up fine on my /catalog/index.php, like they should. i can click the "read more" and pull them up fine. AND, in the News Categories box, the little index showing how many articles there are in the category works and shows the right number, but it doesn't list them with i click on that category.

 

this is a previous post i found that seemed related, but desa80 never got a response as far as i could tell.

 

Hi everybody!

My problem is that when i click on my NEWS category : "newsdesk_index.php?newsdeskPath=4" no news are showing, but this text:

"There are no news articles in this category".

How to fix this?

any help will be appreciated.

Share this post


Link to post
Share on other sites

Hello how can i split results in admin pages.

 

In newdesk.php file.

 

 

Thanks,

 

Sousa


KUBICO from Portugal

Share this post


Link to post
Share on other sites

It is possible to place my ?WYSIWYG SPAW EDITOR? to work in the NewsDesk.

 

With the current editor I have many problems with the HTML and the tables have serious errors.

 

 

Sorry my Inglish

 

Tks

Share this post


Link to post
Share on other sites

Hello everyone,

 

I have a couple of issues with NewsDesk.

 

First of all, when I'm on catalog/newsdesk_index.php and select news category from the drop-down menu, it doesn't go anywhere and there is no Go button. So, how am I suppose to jump to my news category?

 

My second issue is with the HTC contrib. If I insert all meta tags in admin/HTC, they are not displayed on any News pages. There is just path to the page displayed in the browser, such as http://mystore.com/newsdesk_index.php instead of the defined meta tags.

 

In admin/NewsDesk, when I try to copy my News Item to the Top level or anywhere else by selecting Duplicate Article, I'm getting an SQL error:

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '? 3 images peuvent ?tre employ?es ! ! !')' at line 6

 

insert into newsdesk_description (newsdesk_id, language_id, newsdesk_article_name, newsdesk_article_description, newsdesk_article_url, newsdesk_article_url_name, newsdesk_image_text, newsdesk_image_text_two, newsdesk_image_text_three, newsdesk_article_viewed, newsdesk_article_shorttext) values ('5', '4', '3 images ! ! !', '3 images ! ! !La version 1.48.2 de NewsDesk a maintenant les possibilit?s pour employer 3 images plus des sous-titres.Yippe est la vie non grande ?', '', '', '', '', '', '0', 'MAINTENANT jusqu'? 3 images peuvent ?tre employ?es ! ! !')

 

[TEP STOP]

What's wrong?

 

When editing article in admin/newsdesk.php, there is an image 'move1.gif' missing from the editors panel, that's /admin/includes/modules/newsdesk/html_editor/editor_images/move1.gif. I looked in the previous releases for the image but couldn't find it. Does anybody have it and what is this option for?

 

When I insert my news article, it automatically displayed with the Date: Monday 10 March, 2003 instead of today's date. How can I change it?

 

On my newsdesk_index.php and newsdesk_info.php I have a little tiny dots (pixels) instead of, in my opinion, solid black lines around the table. On newsdesk_index.php there are two dots, one above and another one below the table. On newsdesk_info.php, one dot above and below the Reviews listing. Is there suppose to be a solid border for the table?

 

And, on my newsdesk_index.php I miss the NAVBAR_TITLE in the breadcrumb. It is defined in the language file indeed but just not shown on the page. In my newsdesk_index.php I have:

$breadcrumb->add($categories['categories_name'], tep_href_link(FILENAME_NEWSDESK_INDEX, 'newsPath=' . implode('_', array_slice($newsPath_array, 0, ($i+1)))));

What is the problem here? Any help would be greatly appreciated.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×