Jump to content

Archived

This topic is now archived and is closed to further replies.

schiznotty

SMTP Mail, Email Configuration Question

Recommended Posts

Has anyone actually got this working. I am going through everything now and testing various things of this store and if the email system doesnt work might as well not be using it. PLEASE SOMEONE MAKE A POSTING THAT WILL BE THE END ALL TO THIS AND WE CAN ALL GET ON OUR MARRY WAY.

Share this post


Link to post
Share on other sites

After searching, I found this site. It was a rough english discussion of the problem, but I found the solution near the bottom. Great job hashing it out.

 

Here is how they got this to work:

Edited the email.php, class.smtp.inc, and email.php per the instructions, but

 

replaced:

include (DIR_WS_INCLUDES. '/classes/class.smtp.inc');

 

with:

if (! class_exists ('smtp')) include (DIR_WS_INCLUDES. '/classes/class.smtp.inc');

 

---

 

I was getting a "Cannot redeclare class...on line 12" error, but this cleared things up. I recommend changing the double-quotes from their example to single-quotes if that is how the rest of your code looks. As for the other params in the files, use mail.yourserver.com for smtp server, www.yourdomain.com for HELO, useraccount@domain.com for most *nix mail account usernames. I had to configure this in all 3 files for it to work.

 

My 2 cents.

Share this post


Link to post
Share on other sites

Separate item of help for some users getting a relay-denied from their SMTP server:

 

Some mail servers deny sending if you do not specify a "from" address that is recognized as trusted. This solution has worked for some. It did not for me, but it is worth a shot if nothing else is working.

 

Edit the "from" part fo the email.php files:

$send_params['from']		= '';

 

could read

$send_params['from']		= 'youraccount@yourdomain.com';

 

or you might have to do

$send_params['from']		= '<youraccount@yourdomain.com>';

Share this post


Link to post
Share on other sites

Hey guys, I'm sorry I can't give you specific instructions on how to get this thing working. I don't use OS Commerce anymore and haven't for a while now but I'm happy to continue hosting the SMTP files link on Page 2. It sounds like there are a lot of people on here who have gotten it to work and can help so you're in good hands. Good luck to everyone!!!

Share this post


Link to post
Share on other sites

Hi,

I have a same problem with my email and tried to download smtp.zip it says page can not be displayed. i think the file has been moved.

could you please send it to may email: ashokone@yahoo.com

 

thanks in advance.

ashok

 

I GOT A FIX FOR MY PROBLEM!

 

Somebody in another osCOmmerce support forum provided me with a modification to the email.php files in osCommerce that have solved my problem.

 

I'll provide them here and hopefully be able to help someone else out there having the same problem I did. Download the Zip file and read the "readme" file carefully. It's all in there.

 

http://69.19.189.145/smtp.zip

 

Thanks,

 

SM

Share this post


Link to post
Share on other sites

I'm having a weard problem.

 

I can use the e-mail function through the admin panel and send e-mail to customers, but when customers register, they should recieve an e-mail.

 

They dont get that e-mail

 

Any suggestions about this?

Share this post


Link to post
Share on other sites

Does the contact us page work (i.e., does the store receive an email)?

 

What type of server are you hosted on? Windows or Linux?

 

What is your email transport configured as? SMTP or sendmail?

 

What is the email linefeed configured as?

 

Ben

Share this post


Link to post
Share on other sites
Does the contact us page work (i.e., does the store receive an email)?

 

What type of server are you hosted on? Windows or Linux?

 

What is your email transport configured as? SMTP or sendmail?

 

What is the email linefeed configured as?

 

Ben

 

Hey Ben,

 

Thanks for responding.

The store doesnt get an e-mail either. I'm using a windows server with xampp.

Transport is configured as SMTP. Linefeed as ''LF''

 

Roy

Share this post


Link to post
Share on other sites
Hey Ben,

 

Thanks for responding.

The store doesnt get an e-mail either. I'm using a windows server with xampp.

Transport is configured as SMTP. Linefeed as ''LF''

 

Roy

 

Update: I can send e-mail through the contact us page now. Only the account confirm email doesnt work.

Share this post


Link to post
Share on other sites
Update: I can send e-mail through the contact us page now. Only the account confirm email doesnt work.

 

Another update: I can send from Contact Us, but when i try to send in the admin panel, or the normal message after creating a account, my kerio mailserver says:

 

4.1.8 451 4.1.8 To send mail, first check your mail with a valid POP3 account' This prevents unauthorized spam relaying.

 

I googled for 2 hours but couldn't solve the problem.

 

Any suggestions guys?

Share this post


Link to post
Share on other sites
I GOT A FIX FOR MY PROBLEM!

 

Somebody in another osCOmmerce support forum provided me with a modification to the email.php files in osCommerce that have solved my problem.

 

I'll provide them here and hopefully be able to help someone else out there having the same problem I did. Download the Zip file and read the "readme" file carefully. It's all in there.

 

http://69.19.189.145/smtp.zip

 

Thanks,

 

SM

 

 

Could you please send me an address of that forum, coz on this one I can't get an answer to my question at all...

Share this post


Link to post
Share on other sites
Another update: I can send from Contact Us, but when i try to send in the admin panel, or the normal message after creating a account, my kerio mailserver says:

 

4.1.8 451 4.1.8 To send mail, first check your mail with a valid POP3 account' This prevents unauthorized spam relaying.

 

I googled for 2 hours but couldn't solve the problem.

 

Any suggestions guys?

Check with your hosting company. It may be that they require SMTP password authenication in order to send mail to a foreign domain (i.e., mail sent to the stores domain name are fine, but sending something to the customer won't work.)

 

If you need SMTP authenication, use this contribution.

 

Ben

Share this post


Link to post
Share on other sites

I also have the same problems:

 

the osCommerce CANNOT send email out, the SMTP.ZIP file that you guys discuss so far is still available?

 

if yes, please email to me, zhangwei9@hotmail.com :( :(

 

Thanks.

Share this post


Link to post
Share on other sites
I also have the same problems:

 

the osCommerce CANNOT send email out, the SMTP.ZIP file that you guys discuss so far is still available?

 

if yes, please email to me, zhangwei9@hotmail.com :( :(

 

Thanks.

The contribution I referenced in the previous post contains a implementation of SMTP which has been integrated into osCommerce. Use it.

 

Ben

Share this post


Link to post
Share on other sites

Thanks to everyone. You guys helped me a lot.

 

I see some guys still have a problems.

Here my description, how I did it, thanks to all information and .inc file in this topic.

Download smtp.zip on page 2 or here: http://72.18.246.145/files/smtp.zip (the link is working, I just downloaded this file today is 6.4.2008)

Go and read ReadMe.txt file!!!! MUST!!!!!

Just one comment: when you will edit .php and .inc files, check with host about SMTP server and !!!! PORT !!!, cause mine was different, not 25.

Another MUST to do: in both email.php change

 

include (DIR_WS_INCLUDES. '/classes/class.smtp.inc');

 

with:

 

if (! class_exists ('smtp')) include (DIR_WS_INCLUDES. '/classes/class.smtp.inc');

 

(thx to Swami)

 

 

When done with all editing in email.php and .inc files (under public folders and admin folders), go to admin side in your OScommerce, and in Configuration --> E-mail Options, change in E-Mail Transport Method from sendmail to smtp, and in E-Mail Linefeeds change to CRLF.

 

Again, this will work for servers running on Windows.

Worked fine for me.

 

Thank you again guys.

Share this post


Link to post
Share on other sites
Thanks to everyone. You guys helped me a lot.

 

I see some guys still have a problems.

Here my description, how I did it, thanks to all information and .inc file in this topic.

Download smtp.zip on page 2 or here: http://72.18.246.145/files/smtp.zip (the link is working, I just downloaded this file today is 6.4.2008)

Go and read ReadMe.txt file!!!! MUST!!!!!

Just one comment: when you will edit .php and .inc files, check with host about SMTP server and !!!! PORT !!!, cause mine was different, not 25.

Another MUST to do: in both email.php change

 

include (DIR_WS_INCLUDES. '/classes/class.smtp.inc');

 

with:

 

if (! class_exists ('smtp')) include (DIR_WS_INCLUDES. '/classes/class.smtp.inc');

 

(thx to Swami)

 

 

When done with all editing in email.php and .inc files (under public folders and admin folders), go to admin side in your OScommerce, and in Configuration --> E-mail Options, change in E-Mail Transport Method from sendmail to smtp, and in E-Mail Linefeeds change to CRLF.

 

Again, this will work for servers running on Windows.

Worked fine for me.

 

Thank you again guys.

 

 

I'm having the same problem:

 

I can send e-mails, the forgotten password works, it sends e-mail after order status modification but I receive NO emails if the contact us form is filled.

 

Could some one send me this smtp.zip file to arkantuspc@gmail.com or give me a working link?

 

thanks,

 

Paulo

Share this post


Link to post
Share on other sites
Hola, que tal,

espero me puedas ayudar con una tienda de oscommerse

ya instale la tienda, y estoy trabajando en windows, pero al momento de crear un nuevo usuario, me manda el siguiente error,

 

Warning: mail() has been disabled for security reasons in C:\Domains\mydominio.com\wwwroot\catalog\includes\classes\email.php on line 500

 

Warning: Cannot modify header information - headers already sent by (output started at C:\Domains\mudominio.com\wwwroot\catalog\includes\classes\email.php:500) in C:\Domains\mydominio.com\wwwroot\catalog\includes\functions\general.php on line 31

 

mi correo es : omargc@mail.com

 

ojala me puedas ayudar...

saludos

is there any way you can send me this file?

Share this post


Link to post
Share on other sites
Same here, I could use that file as well so if someone can email it to me that'd awsome. thanks

 

Hi I understand you frustration and could really use this file too.

 

Please could you email this to me at info@rhythmdancemusic.com.au. I would really appreciate it.

 

cheers

Charu

Share this post


Link to post
Share on other sites
Could you please send me an address of that forum, coz on this one I can't get an answer to my question at all...

 

Could you please post the link to this forum if you're not able to send the file. thanks

Share this post


Link to post
Share on other sites

Hi I spoke to my ISP about this and they said:

 

"Please note that our mail servers require SMTP authentication in order to send mail; your scripts will therefore need to use authentication and proper credentials. "

 

Any ideas where/how to set this up? I am very new to this so would appreciate the help. ++ still waiting on the file if anyone is kind enough to share :D

 

Thanks

Charu

Share this post


Link to post
Share on other sites
I found it. I'm not real sure what I did to get it to work, I just remember I used the example file in the zip to customize the class file to my smtp server and replaced the smtp class file in oscommerce. Good luck!

 

SMTP.ZIP

 

Hello

 

I have the same problem email doesn#t work (

 

please send this smtp file to me in irshadelettil@gmail.com

 

thanks a lot

Share this post


Link to post
Share on other sites
I'm having the same problem:

 

I can send e-mails, the forgotten password works, it sends e-mail after order status modification but I receive NO emails if the contact us form is filled.

 

Could some one send me this smtp.zip file to arkantuspc@gmail.com or give me a working link?

 

thanks,

 

Paulo

 

Hello

 

I have the same problem email doesnt work

 

please send this smtp file to me in irshadelettil@gmail.com

 

thanks..

Share this post


Link to post
Share on other sites

Hi all... if someone have problem with smtp mail..... please correct like this

 

Admin->Configuration->Mystore

 

Wrong

======

E-mail From : "admin" <irshadelettil@almorooj.com>

 

Corrected

=======

E-mail From : irshadelettil@almorooj.com

Share this post


Link to post
Share on other sites

×