Jump to content

Archived

This topic is now archived and is closed to further replies.

schiznotty

SMTP Mail, Email Configuration Question

Recommended Posts

I posted this question in the past but nobody was able to assist me. Hopefully someone out there can help out, it's driving me up the wall.

 

I am running osCommerce 2.2ms2, php 4.3.4 and mySQL 4.0.18 on a Windows system. I cannot get osCommerce to email out anything (either via an order or the Contact Us page) under any circumstance. I have tried several SMTP mail programs and numerous settings in both my php.ini and osCommerce admin with no success. I am currently running Mdaemon on the same server as my osCommerce site, so my php.ini file looks like this...

 

[mail function]

; For Win32 only.

SMTP = localhost (I also tried the IP Address of my mail server)

 

; For Win32 only.

sendmail_from = me@localhost.com

 

I also set the osCommerce setting "Sendmail" to "true" and told it to use "SMTP."

 

The most frustrating part for me is that I get NO email errors from osCommerce. I get an immediate successful notice from osCommerce, but the mail message never arrives at my SMTP server.

 

I know the SMTP server works for other php applications because I also have a phpBB2 running on the same system and it sends out emails with no problems. This leads me to believe that I have something configured incorrectly in osCommerce.

 

Please help! I'm going crazy!

 

Thanks,

 

SM

Share this post


Link to post
Share on other sites

Also, if nobody has any ideas about how to get the SMTP to work, I have the ability to setup a Linux box. Does anyone recommend a good mail program I can use for a Linux box that will work easily with osCommerce? Are there any special setup requirements to get it to work?

 

Thanks.

 

SM

Share this post


Link to post
Share on other sites
I also set the osCommerce setting "Sendmail" to "true" and told it to use "SMTP."

This is probably the confusion. In Admin -> Configuration -> E-mail Options, set E-mail Transport Method to SMPT (not sendmail). The other setting in that list, which I guess you were referring to, is Send E-Mails and it should be set true.

Share this post


Link to post
Share on other sites

Somebody recommended that I try an email_test.php file so I placed it in my web root directory, executed it and it appeared to go through but still no email. Maybe this is another clue as to what my problem is.

 

Thanks.

Share this post


Link to post
Share on other sites

I GOT A FIX FOR MY PROBLEM!

 

Somebody in another osCOmmerce support forum provided me with a modification to the email.php files in osCommerce that have solved my problem.

 

I'll provide them here and hopefully be able to help someone else out there having the same problem I did. Download the Zip file and read the "readme" file carefully. It's all in there.

 

http://69.19.189.145/smtp.zip

 

Thanks,

 

SM

Share this post


Link to post
Share on other sites

Yah, it works, no error or warning appears but, my clients receive no emails and during the ordering process i encounter this error

 

Fatal error: Cannot redeclare class smtp in C:\apache\htdocs\catalog\includes\classes\class.smtp.inc on line 12

 

what shoul i do?

Share this post


Link to post
Share on other sites
I GOT A FIX FOR MY PROBLEM!

 

Somebody in another osCOmmerce support forum provided me with a modification to the email.php files in osCommerce that have solved my problem.

 

I'll provide them here and hopefully be able to help someone else out there having the same problem I did.  Download the Zip file and read the "readme" file carefully.  It's all in there.

 

http://69.19.189.145/smtp.zip

 

Thanks,

 

SM

 

Hola, que tal,

espero me puedas ayudar con una tienda de oscommerse

ya instale la tienda, y estoy trabajando en windows, pero al momento de crear un nuevo usuario, me manda el siguiente error,

 

Warning: mail() has been disabled for security reasons in C:\Domains\mydominio.com\wwwroot\catalog\includes\classes\email.php on line 500

 

Warning: Cannot modify header information - headers already sent by (output started at C:\Domains\mudominio.com\wwwroot\catalog\includes\classes\email.php:500) in C:\Domains\mydominio.com\wwwroot\catalog\includes\functions\general.php on line 31

 

mi correo es : omargc@mail.com

 

ojala me puedas ayudar...

saludos

Share this post


Link to post
Share on other sites

I am having the same problem, and I tried to download the smtp.zip file, but it is no longer at this url. Can you please email me a copy to chronosseur@chronosseur.com, or post a new copy here?

 

Thanks,

 

ZG

 

I GOT A FIX FOR MY PROBLEM!

 

Somebody in another osCOmmerce support forum provided me with a modification to the email.php files in osCommerce that have solved my problem.

 

I'll provide them here and hopefully be able to help someone else out there having the same problem I did.  Download the Zip file and read the "readme" file carefully.  It's all in there.

 

http://69.19.189.145/smtp.zip

 

Thanks,

 

SM

Share this post


Link to post
Share on other sites

Most hosting companies ban any scripts called 'formmail' from operating on their servers. It's the first name that spammers/hackers look for. Should be okay if it's renamed though.

 

Vger

If I have formmail.cgi - how do I implement that with this?

Share this post


Link to post
Share on other sites

I could use this file also.. Could you send me a copy at billstickles@tampabay.rr.com

 

 

Thanks


"Every time I idiot proof something... The world comes out with a better idiot"

Share this post


Link to post
Share on other sites

Vger,

 

Thanks for the reply - however...Of course my host allows me to use formmail.cgi. It works fine on other applicaitons.

 

My question again is...how can to get email sent out using this and my cgi program to send out the email?

 

I need to get this working properly. Please advise.

Share this post


Link to post
Share on other sites
Hola, que tal,

espero me puedas ayudar con una tienda de oscommerse

ya instale la tienda, y estoy trabajando en windows, pero al momento de crear un nuevo usuario, me manda el siguiente error,

 

Warning: mail() has been disabled for security reasons in C:\Domains\mydominio.com\wwwroot\catalog\includes\classes\email.php on line 500

 

Warning: Cannot modify header information - headers already sent by (output started at C:\Domains\mudominio.com\wwwroot\catalog\includes\classes\email.php:500) in C:\Domains\mydominio.com\wwwroot\catalog\includes\functions\general.php on line 31

 

mi correo es :  omargc@mail.com 

 

ojala me puedas ayudar...

saludos

 

WHAT?! :D


Remember what the Bible says: He who is without sin, cast the first rock. And I shall smoketh it.

Share this post


Link to post
Share on other sites

for using windows with oscommerce, the smtp server doesnt like the alias:

 

No:

Customer Service <customerservice@domain.com>

Yes:

customerservice@domain.com

 

and the header error just seems to disappear


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

I also have the same problems:

 

the osCommerce CANNOT send email out, the SMTP.ZIP file that you guys discuss so far is still available?

 

if yes, please email to me, shawchyn@plato.com.my

 

Thanks.

Share this post


Link to post
Share on other sites

×