Jump to content
Sign in to follow this  
Drew

SECPay 2.2 error

Recommended Posts

Hi All.

 

I need some urgent help here.

 

I have 2 sites, both identicall in the sense they are selling tickets for 2 nightclubs.

 

Each has its own secpay account.

 

I followed the information here to het secapy working (dreaded digests) on the first account.

 

Now, after waiting 2 weeks for secapy to issue new passwords for the second account, I have logged in and created the digest and remote passwords which are the same a site1

 

BUT i still get the digest error.

 

Im using the exact same secpay.php file in /includes/modules/payment/ for both sites, and even if i put the secpay install ID of the working site in the not working site it still doesnt work!!!!

 

Any ideas, the site goes live after the weekend!!!

 

I just cant understand it, im ripping my hair out, both installs are exactly the same with the exception of the Secpay ID!


regards.

 

Mark

Share this post


Link to post
Share on other sites

OK, Ive now tried uninstalling the module and re-installing and trying to make a purchase with all the fields set to secpay and with the id field set to my ID and i still get an error.

 

Is this a problem with secpay themselves? Or am i going mad!!!!


regards.

 

Mark

Share this post


Link to post
Share on other sites
OK, Ive now tried uninstalling the module and re-installing and trying to make a purchase with all the fields set to secpay and with the id field set to my ID and i still get an error.

 

Is this a problem with secpay themselves? Or am i going mad!!!!

 

I had the same problem - two near identical sites, one worked and one didn't.

 

It turned out I had a space in the Store Name value for the site that wasn't working - SECPay doesn't like this!

 

Give it a check - good luck!

Share this post


Link to post
Share on other sites

ARRGHGGGGGHHHHGHGHHGHH!!

 

THANK YOU!

 

I remember reading about this some weeks ago! And it worked!


regards.

 

Mark

Share this post


Link to post
Share on other sites

Hi everyone,

 

I hope someone can help...

 

Im having the same problems as everyone else, Ive been trawling the forum all day and tried just about everything. :'(

At the moment Ive followed the instructions from Darbyweb to create the remote password and digest keys, and altered the code as Sonicthescrewdriver suggests, but I am still getting the error when I come to checkout with SECPay which says:

 

"Digests do not match : possible fraud attempt."

 

Can anyone help? Like many before me Im tearing my hair out, and obviously losing money too! Boo hoo!

 

Any help would be so greatly appreciated

 

Gem

Share this post


Link to post
Share on other sites
Hi everyone,

 

I hope someone can help...

 

Im having the same problems as everyone else, Ive been trawling the forum all day and tried just about everything.  :'(

At the moment Ive followed the instructions from Darbyweb to create the remote password and digest keys, and altered the code as Sonicthescrewdriver suggests, but I am still getting the error when I come to checkout with SECPay which says:

 

"Digests do not match : possible fraud attempt."

 

Can anyone help? Like many before me Im tearing my hair out, and obviously losing money too! Boo hoo!

 

Any help would be so greatly appreciated

 

Gem

 

What version of secpay.php are you using? look at the actual php file and about the third line down you should see something like this

 

$Id: secpay.php,v 1.32.2.7 2004/03/26 16:56:45 sparky Exp $

 

Regards

 

Nigel

Share this post


Link to post
Share on other sites

I actually wrote a bit more than what is said ubove but for some reason it hasnt come up!

I mentioned that I have tried the trick of putting an underscore where the spaces should be on my store name, and have remembered to uninstall the secpay module, make the changes and then reinstall. I played around with it for hours but still got nothing >_<

Share this post


Link to post
Share on other sites
I actually wrote a bit more than what is said ubove but for some reason it hasnt come up!

I mentioned that I have tried the trick of putting an underscore where the spaces should be on my store name, and have remembered to uninstall the secpay module, make the changes and then reinstall. I played around with it for hours but still got nothing  >_<

 

One more quick check - you don't have Password Protection on your store do you?

 

Just FYI, I actually didn't need to make the changes sonicthescrewdriver suggests, but just used go2pubs secpay.php as posted - this post

Share this post


Link to post
Share on other sites

Just a quick update guys:

 

I tested again this morning and everything seems to be working. Yay!

I had a tip form Keith at SECPay who said that the digest key shouldnt have any irregular characters within it (which it did), and suggested I use alllowercasewithnospacesbutaslongasyouwant.

 

Obviously thats not my password.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×