Jump to content
Sign in to follow this  
kamyau

UPS XML shipping module

Recommended Posts

Installed the UPS XML shipping module. Trying to configure the packaging... Error report fail to find htaccess.php. When I read the code from admin/packaging.php. At around line 59,

<?php

include(DIR_WS_CLASSES . 'htaccess.php');

 

Well can't find this file in the entire OSC2 or XMLUPS

 

Anybody has a clue...??

Share this post


Link to post
Share on other sites

I can't recall what led me to do so, but in my installation, that line is commented out. (You are correct - admin/classes/htaccess.php does not exist in the stock osC installation)


... if you want to REALLY see something that doesn't set up right out of the box without some tweaking,

try being a Foster Parent!

Share this post


Link to post
Share on other sites

Your help is appreciated

 

alright .. I commend out that line....

 

Run a checkout test ... and I have this error

 

Fatal error: Call to undefined function: curl_init() in c:\inetpub\wwwroot\osc\catalog\includes\modules\shipping\upsxml.php on line 590

 

anywhere u can find this function ???

 

By the way, are u running this module ?

 

 

Thanks

Share this post


Link to post
Share on other sites

That is a function in the PHP curl module. You must have curl installed in PHP on your server for the UPSXML to work.

 

Yes, I am running this mod


... if you want to REALLY see something that doesn't set up right out of the box without some tweaking,

try being a Foster Parent!

Share this post


Link to post
Share on other sites

tks.. I installed the curl extension to PHP...

 

I put in the UPS access key.. userid.. password.... .

 

I enable the log file upsxml.log

 

I have no response from UPS...

Share this post


Link to post
Share on other sites
tks..  I installed the curl extension to PHP...

 

I put in the UPS access key.. userid.. password.... .

 

I enable the log file upsxml.log

 

I have no response from UPS...

There seems to be a bug in older php curl versions. It does not work with 4.1, but it does with 4.3.4.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×