Jump to content
Sign in to follow this  
Darren2509

Not able to implement protx modules

Recommended Posts

Can anyone help? I have downloaded and installed the Protx modules from the site and am using the latest version of the osCommerce system (downloaded and installed 14 april 2004). I keep getting this error message in the Admin section:

 

Fatal error: Cannot redeclare class protx in /usr/wwws/users/larchet/catalog/includes/modules/payment/protx.php on line 13

 

Does anybody know how to eliminate this problem? I have searched all the forums and cannot find the solution.

 

any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

You should be using this module: Protx

 

Matti


Matti Ressler

 

We were all once expert at...... nothing

_____

Share this post


Link to post
Share on other sites

Thanks for the swift response Matti.

I downloaded and installed the version '16 Mar 2004 - Protx Form V 1.05' - thats what is causing the error.

 

Any suggestions? I'm sure its something I'm not doing properly

Share this post


Link to post
Share on other sites

Looks like you have uploaded the main module to the language directory by mistake ;)


Mark Evans

osCommerce Monkey & Lead Guitarist for "Sparky + the Monkeys" (Album on sale in all good record shops)

 

---------------------------------------

Software is like sex: It's better when it's free. (Linus Torvalds)

Share this post


Link to post
Share on other sites

Actually Matti, I have eliminated the error message. For some reason the system wouldnt recognise my payment modules if they were at a https:// address on the server (I am hosting with Pair, have you come across that problem before?).

 

My problem now is that, although there is no error message, the protx payment module will show up in the admin section (although all others do).

Share this post


Link to post
Share on other sites
Fatal error: Cannot redeclare class protx in /usr/wwws/users/larchet/catalog/includes/modules/payment/protx.php on line 13

 

The module contains the files named protx_form.php, and the above error shows that you were having problems in protx.php.

 

Have you changed the file names and the class names inside the files accordignly?

Share this post


Link to post
Share on other sites

BRILLIANT! Got it sorted, thanks very much.

 

I had protx.php and protx_form.php in the same directory - protx.php was in there from an older module and must have been causing a conflict.

 

It know works....pity the protx test server is down

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×