Jump to content

Archived

This topic is now archived and is closed to further replies.

Priest

Screwed by 2CheckOut!

Recommended Posts

One more question..

 

How does your PM2Checkout.php file look..

 

Can you post that Dave?

 

 

Thx,

 

 

Matthias

Share this post


Link to post
Share on other sites

Executive summary: 2Checkout WONT work :ph34r:

 

Below are the responses from 2checkout:

 

message by asantucci on Tue, 05/4/04 13:29

This issue should have been resolved. It it has not please let me know the exact variables that you are looking for. I have fixed the issues with XCart and other but for some reason every single person has problems with OSCommerce.

 

Please attempt it again. If it does not work provide me with a link to do a demo purchase on your account.

 

______________________________________

Thank you,

 

Tony

 

Then after insisting that there was a problem and that I have written payment modules I could not see any problem in the code... they insisted I set up a test account for them because they had no time to sign up for one, I get:

 

message by asantucci on Fri, 05/7/04 10:21

Okay I have done a test purchase. The main problem that I can see is the fact that when 2CO redirects back to your site you are looking for a cookie. That isn't going to work

becuase the buyer isn't actually direct back to your site. We fetch the page and then display it to the user.

 

______________________________________

Thank you,

 

Tony

Tech Support/Development

www.2Checkout.com

 

So I'm going to call them, but it is likely I am going to find some other module. The powers that be who have an "in" at 2checkout should contact them as well.


http://www.rayservers.com/

 

Secure Athlon 64 laptops, workstations and servers.

Linux/BSD/Windows

 

PGP: 0x12430522

Share this post


Link to post
Share on other sites

Hi Y'all

 

I used the workaround posted by dave123 successfully.

 

I just added the following to my open oscommerce ticket:

 

Hi Tony,

 

There is a workaround posted to the forums below:

http://forums.oscommerce.com/index.php?sho...ndpost&p=360933

 

I've managed to make it work, but had to disable x_response_code and hash checking in order to make it work.

 

Please come up with a solution to return to the oscommerce cart correctly.

 

Best regards,

 

---Venkat.

 

I disabled x_response_code and hash checking by commenting out the before_process() function in pm2checkout.php and replacing it with

    function before_process() {
     return false;
   }

 

So for now I can enable 2checkout, but will have to manually verify all orders.

 

:rolleyes:


http://www.rayservers.com/

 

Secure Athlon 64 laptops, workstations and servers.

Linux/BSD/Windows

 

PGP: 0x12430522

Share this post


Link to post
Share on other sites

Do you really think that 2CheckOut cares baout getting 2CO working with osCommerce? Maybe, but I don't believe it's a main priority. Instead, I think they expect OSC users to get it working with 2CO, not the other way around.

 

Good luck, though. 2CO are the ones who changed their code and now it doesn't work. They have lost me, at least, as a customer and I am happy with my new processor, as I get paid WEEKLY no matter how much I process, and all works just fine.

 

I would still like to see this fixed though, for everyone else still using 2CO.

 

-p-

Share this post


Link to post
Share on other sites

I added everthing according to the posts, with the addition of including a &demo=Y to the URL to keep it in test mode. Production the 2CO is blue, demo the 2CO logo is yellow. But no matter what, I can not get the credit card number and experation to be passed to the 2CO form. Anyone else have this problem? I wish I would have seen this thread before I signed up for 2CO Sunday night.

Share this post


Link to post
Share on other sites

2checkout is beat - i canned my account before the 30 day trial period was over. their amin interface is pathetic and their support team takes about 2 days to respond.

 

bail now and go else where.

Share this post


Link to post
Share on other sites
message by asantucci on Mon, 05/10/04 14:14

 

Date: Mon, 10 May 2004 14:14:03 -0400

 

Dear venkat@rayservers.com,

 

This is a message to advise you that we have recently worked on your ticket entitled

2checkout module in OScommerce

 

 

Our Response:

--------------------------------------------------------------------------------------

 

Venkat,

 

x_response_code is part of a result set that you only need if you are using our service as a gateway which we do not support therefore the parameter is not being passed back.  However, in an attempt to make this thing work I'm going to fake it to 1.

 

As for the has checking it is correct.

 

You might want to verify in the cart is computing the hash as follows without the spaces.

 

secretword vendornumber ordernumber total

 

______________________________________

Thank you,

 

Tony

Tech Support/Development

www.2Checkout.com

 

Here is where we are.

 

The setup with the redirect workaround works. And hash checking works now and the x_response_code is set to one.

 

I'll post the files to the contribs section.

 

Best of luck.


http://www.rayservers.com/

 

Secure Athlon 64 laptops, workstations and servers.

Linux/BSD/Windows

 

PGP: 0x12430522

Share this post


Link to post
Share on other sites
I added everthing according to the posts, with the addition of including a &demo=Y to the URL to keep it in test mode.  Production the 2CO is blue, demo the 2CO logo is yellow.  But no matter what, I can not get the credit card number and experation to be passed to the 2CO form.  Anyone else have this problem?  I wish I would have seen this thread before I signed up for 2CO Sunday night.

Ok the new version of 2CO is tricky with the demo mode, it doesnt give anything away like the old one i.e. YOU ARE IN DEMO MODE on the payment page, the only place it shows in the in the payment confirmation emails.

 

Also they have increased validation for the credit card processing in demo mode so now if you make up a false CC number e.g. 411111111111111 and put in expiry date you should be ok and it will process it in demo mode.

Share this post


Link to post
Share on other sites
Production the 2CO is blue, demo the 2CO logo is yellow.

I'm sorry?

 

I'm not in any demo-mode, but the logo is yellow..so what's this with these colors? :blink:

 

 

 

Greetz

Share this post


Link to post
Share on other sites

I will have to try it out again later. Is there a table of data that lists which payment processor is most popular for osCommerce stores for US/UK? Search didn't give me anything useful.

 

When I left the &demo=Y off of my "test" transaction, the logo was blue (blue box with white lettered 2CO in it). When I added the &demo=Y to the end of the "test" transaction URL, then the logo was yellow (yellow box with white lettered 2CO in it). So I assumed that prod=blue and its going through, and demo=yellow.

 

Maybe my cache was botched.

Share this post


Link to post
Share on other sites

hi guys,

 

I am using the default module (the one its came with the oscommerce) and its working fine so far. Do I need to upgrade to this module?

 

thanks in advance guys!

Share this post


Link to post
Share on other sites

I just setup the default Paypal and 2CO payment module in my os2. I found a problem that none of the item name and quantity show up inside each transaction. It just has the amount and shipping charge for PayPal transaction and total amount for 2Checkout transaction.

 

How and where can I know what my customers order?

 

I even login the customer account and find no records inside the My Orders page.

 

Can somebody give me some advises please?

 

Thank you.

Ted

Share this post


Link to post
Share on other sites

Everything is working fine. Thanks for the info.

 

I currently have a problem on the header and footer of the Look & Feel. I have submited a ticket to 2CO already. I wonder if there is anyone can also answer this question since I expect the tech support of 2CO is in a mess right now.

 

Question:

I have entered two valid url for the header and footer addresses inside LookandFeel configuration; however, none of them were show up.

When a customer confirmed order at my website and forwarded to 2CO page "https://www2.2checkout.com/2co/buyer/purchase", the header and footer show Broken vDeck logo of 2Co "https://www2.2checkout.com/vdeck_logo.gif" and "404 not found The requested resource could not be found."

Share this post


Link to post
Share on other sites

I have been working to 2CO.com to get this fixed. I have found the problem and documented it and sent it off to them I was told they would sit down with the programmers on monday and see if the can address the issue.

 

the proiblem is caused by the oscid not being returned which causes the problem of the user returning to a login page and the order not being logged to the database. when using the NEW 2CO.com severs.

 

Those of us still on the OLD servers will have the same problem if they turn the md5 hash stuff because it will not add the oscsid to the url.

 

both version sends them the correct return URL so we should not have to set one up on the 2CO.com account admin.

 

Note to correct the demo problem change the following:

 

tep_draw_hidden_field('x_test_request', ((MODULE_PAYMENT_2CHECKOUT_TESTMODE == 'Test') ? 'Y' : 'N')) .

 

to

 

tep_draw_hidden_field('demo', ((MODULE_PAYMENT_2CHECKOUT_TESTMODE == 'Test') ? 'Y' : 'N')) .

 

this will make the demo mode in the OSC admin work as it should.

 

One other note: if you have changed the OSC session id from osCsid to sid in the application_top.php this will cause nothing to work correctly because with 2CO.com sid is your account number and things get screwed up passing parm back and forth.

 

I will continue to post any updates I can.

Share this post


Link to post
Share on other sites

The hash checking for the new 2CO is broken again. It resulted in two (large) orders that did not register on the osc cart . :ph34r: So I have disabled it. The latest package that works for me is in contribs: http://www.oscommerce.com/community/contributions,904 - please test and let me know.


http://www.rayservers.com/

 

Secure Athlon 64 laptops, workstations and servers.

Linux/BSD/Windows

 

PGP: 0x12430522

Share this post


Link to post
Share on other sites

Thanks rayservers for providing the link to download the code. i tried it out as per instructions you included.

 

results:

the menu for adding card numbers has been removed which is great.

 

after success payment i am bounced back into log-in for the cart and my purchase is not recognized as being processed.

 

i deliver digital goods so this is no good. my customers get pretty upset when they do not get a link to download their products right away.

 

hopefully we can get this resolved soon. i'll be searching for another payment gateway very soon. i'm sorry i spent the 50 bucks last week.

Share this post


Link to post
Share on other sites

rayservers has officially given up on making 2checkout work. I recd orders from countries in the DENY list. The client had no access to a fax machine. The only option was to charge two small random amounts and have him access his card info and give this information to prove control over the credit card. 2CO was unwilling to do this. I'm sorry but the fraud prevention help leaves a lot to be desired, and the settings in *their* admin section do not work. Makes me look like a fool.

 

We will be integrating some other payment gateway. I'll let you know what happens.


http://www.rayservers.com/

 

Secure Athlon 64 laptops, workstations and servers.

Linux/BSD/Windows

 

PGP: 0x12430522

Share this post


Link to post
Share on other sites

i've been sending tickets to the tech support personal at 2CO for the past week without any help to speak of.

 

i'm interested in hearing of what other persons are using as a payment gateway to substitue. 2CO has held me up from opening my store.

 

thanks in advance for the feedbacks

 

i've tried 3 other shopping carts and they do not work with 2CO as well. they are:

 

cube cart

ecart

1shoppingcart

 

i'm sure there are many others as well.

Share this post


Link to post
Share on other sites

Are you on the old account system or the new account system?

 

Next I should here back from them today I know what the problem is and I have provided them the information they need to get it working.

 

the old account system works ok but you can't use the md5 hash stuff.

 

the new account system is not working at all the way it should this is because they are not adding the oscid to the return url... This causes the OSC system to see the URL as a none secure none user URL so it takes to the login screen and does not log the order into the database.

 

As soon as I get word back I will post the information I get from them.

Share this post


Link to post
Share on other sites

hello,

 

along with everyone else, i am extremely frustrated... thank you gizmo for your posting the code to fix the demo.

 

when i buy (either .01 in production or in demo) i do not get sent back to a login screen - but i do get "there has been an error processing your credit card" - making it look like my order was not processed. in reality, it was processed, and the client (me) was billed for the product.

 

is there anything that i can change so that the error is not getting thrown when the order does actually go through? should i send 2co a ticket for this?

 

also, because i'm still in the 30 day period with 2co, and if i can get my money back, can anyone suggest another company they are having good experiences with??? i am just opening a store and expect that sales will probably be very light to begin with and grow over a period of time. so, not having to pay unless i make a sale is very appealing...any suggestions would be great.

 

thank you,

eva

Share this post


Link to post
Share on other sites

it seems no one has any quick answers to the problem.

 

being new to the ecommerce world i wonder how many times payment gateways have done this to their customers? :blink:

Share this post


Link to post
Share on other sites

×