Jump to content

Archived

This topic is now archived and is closed to further replies.

redzonne

Changed hosting space and receiving a major error

Recommended Posts

I changed hosting accounts and now my cart or admin tool is erroring out with the following error:

 

1046 - No Database Selected

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

 

How can I fix this? :huh:

Share this post


Link to post
Share on other sites

If you created a new DB with the new host and then loaded your informtion into it then probably you have a new DB name and password.

 

Be sure to set up your new DB info in your configure.php files (catalog and admin).

 

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

  define('DB_SERVER_USERNAME', 'yourservername_osc1');

  define('DB_SERVER_PASSWORD', 'password');

  define('DB_DATABASE', 'mydatabase_osc1');

  define('USE_PCONNECT', 'false'); // use persisstent connections?

  define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

 

Peter

Share this post


Link to post
Share on other sites

Hi Peter

 

I'm in the same problem moving from highland_os7 to vsaucti_os1..

 

I changed the files as you suggested, the problem I have is..

 

How the heck do you know what the new database's password is:

 

on the old one it's a set of alphanumeric that I certainly didn't assign..

 

How do I know what vsaucti_os1's is as it's apparently not what I set it to, or how do I change it?

 

Thanks!


Regards,

 

Caroline

 

Contributions:

http://www.oscommerce.com/community/contributions,234 (Printable catalog modification - remove currency)

Share this post


Link to post
Share on other sites

This is the actual error I get:

 

Warning: mysql_connect(): Access denied for user: 'vsaucti_os1@localhost' (Using password: YES) in /home/vsaucti/public_html/shopping/includes/functions/database.php on line 19

Unable to connect to database server!


Regards,

 

Caroline

 

Contributions:

http://www.oscommerce.com/community/contributions,234 (Printable catalog modification - remove currency)

Share this post


Link to post
Share on other sites

Arrgh.. this is so frustrating..

 

I have the entire site ready to go at: http:www.highlandauctions.net/shopping, but when I moved everything over to the new domain, and setup the server I keep getting the error above even after altering the confire.php files.

 

Can anyone help? I sure would appreciate it, otehrwise I'll have to start from scratch..


Regards,

 

Caroline

 

Contributions:

http://www.oscommerce.com/community/contributions,234 (Printable catalog modification - remove currency)

Share this post


Link to post
Share on other sites

I had a very similar problem.

 

you have to edit the configure.php files at catalog/includes and admin/includes...but you also have to edit the one in catalog/includes/local


Contribs added:

AdminLogin-Catalog With Images-Credit Class/Gift Voucher-CoolMenu

EasyPopulate-LoginBox-Paypal Shopping Cart IPN-PDF Catalogs

Product Listing In Columns - Image Strip

--

...the young jedi said to his master "you want me to do WHAT?"

Share this post


Link to post
Share on other sites

×