Jump to content
Sign in to follow this  
defender39

Batch Order Center Update 1.1

Recommended Posts

Still nobody awnsered the question about the following error:

 

 

Warning: main(BATCH_PRINT_INCbatch_print_header.php): failed to open stream: No such file or directory in /home/.rambunctious/stardog/stardogshop/admin/batch_print.php on line 140

Warning: main(BATCH_PRINT_INCbatch_print_header.php): failed to open stream: No such file or directory in /home/.rambunctious/stardog/stardogshop/admin/batch_print.php on line 140

Fatal error: main(): Failed opening required 'BATCH_PRINT_INCbatch_print_header.php' (include_path='.:/usr/local/lib/php') in /home/.rambunctious/stardog/stardogshop/admin/batch_print.php on line 140

 

Please help us!

Share this post


Link to post
Share on other sites

Doesn't that just mean thart you didn't define BATCH_PRINT_INC ?

 

Check you have followed all the steps.

Share this post


Link to post
Share on other sites

Hi All

 

Got aproblem with batch print, works great except I cannot print anything.

 

Every time I press the print button either from the admin page or download the pdf and print nothing happens.

 

When I check the printer in control panel, it just says print error!

 

Any Ideas

 

Andy


Literally, Laterally Thinking! If you cannot get through it, go round it.

Share this post


Link to post
Share on other sites

If it display OK on your screen, maybe it is a problem with the latest version of Acrobat Reader. Their last two updates have been really c**p. I now have to print a sheet from another program immediately b4 printing the pages using Acrobat reader or else it all comes out in some illegible font!

Share this post


Link to post
Share on other sites

Hi David,

 

Thanks for that will also try printing thru IE as I prefer Firefox.

 

Cheers

 

Andy


Literally, Laterally Thinking! If you cannot get through it, go round it.

Share this post


Link to post
Share on other sites

We've used the basic/original version of this contribution for quite some time now (a year or so) with awesome success. Two days ago on one site, we start getting:

 

Program Message: 
There were no orders selected for export, try changing your order options.

 

When in fact there are indeed orders meeting the conditions. We've not altered the code and have not tweaked this site in ages. It just stopped returning results and everthing else is working fine. The same contribution on our other site is still working fine. I've double-checked and tested the files with back-ups and the same result.

 

Any ideas why all of a sudden, it's not returning positive results?

Share this post


Link to post
Share on other sites

Update to my post just above. I just learned that our host (pair.com) had just updated the database server to mysql version 4.1.14 on the very day that our batch_print started malfunctioning. Still checking to see how it could have affected things.

Share this post


Link to post
Share on other sites

Hey I installed it and now I'm going to Admin panel - tools - Batch Print Center

 

And it's telling me :

 

Access Denied  

No Right Permission Access 
Please contact your Webmaster to request 
more access or if you found any problem.

 

What should I do?

Share this post


Link to post
Share on other sites

The Clear Credit Card code is not working as I hoped. I wanted to use it to clear the values for orders with the status of shipped between given dates. I do not understand the php enough to decifer how this code is intended to work. Does it look at dates and invoice numbers and ignore status? If so, how can I get it to look at status? If I enter date and status it clears the numbers for all orders on a date regardless of status. It would be handy to have this feature.

 

Millie

Share this post


Link to post
Share on other sites
I have added the CVV mod to my cart and would like to see the CVV in this contribution, any done this or know how it can be done? Thanx!

 

Jaymz

 

 

In my template I found this code

		$pos = $pdf->ezText("<b>" . ENTRY_CC_EXP . "</b> " . $order->info['cc_expires'],GENERAL_FONT_SIZE);
}

}

 

and added this after.

 

$y = $pdf->ezText("<b>Security Code: </b>" . $order->info['cc_cvv']

 

Millie

Share this post


Link to post
Share on other sites

I added this contribution, and when I use the Letterhead portion, "my logos" are all distorted, Im wondering where to changed the resolution for this so that it looks proper?

 

thanks

Share this post


Link to post
Share on other sites
We've used the basic/original version of this contribution for quite some time now (a year or so) with awesome success. Two days ago on one site, we start getting:

 

Program Message: 
There were no orders selected for export, try changing your order options.

 

When in fact there are indeed orders meeting the conditions. We've not altered the code and have not tweaked this site in ages. It just stopped returning results and everthing else is working fine. The same contribution on our other site is still working fine. I've double-checked and tested the files with back-ups and the same result.

 

Any ideas why all of a sudden, it's not returning positive results?

Whatever happened with this? I am having the same problem. I know there are orders that match the criteria, but when I hit the 'send' button it tells me that no orders were selected. My date format is correct as 2006-01-01. Anybody know why this would happen???

Share this post


Link to post
Share on other sites
Whatever happened with this? I am having the same problem. I know there are orders that match the criteria, but when I hit the 'send' button it tells me that no orders were selected. My date format is correct as 2006-01-01. Anybody know why this would happen???

 

Can anyone put this into a standard SQL query for me to try on my database to see if it returns anything?

tep_db_query("select o.orders_id,h.comments,MIN(h.date_added) from " . TABLE_ORDERS . " o, " . TABLE_ORDERS_STATUS_HISTORY . " h where o.date_purchased between '" . tep_db_input($startdate) . "' and '" . tep_db_input($enddate) . "23:59:59'  and h.orders_id = o.orders_id" . $pull_w_status . $get_customer_comments . ' group by o.orders_id');

 

Jake

Edited by jake74

Share this post


Link to post
Share on other sites

Hi all,

 

I was wondering if I could get any help about the following:

 

I installed OSC for a friend who is a caterer, and he wants to print sticky labels (101.6 x 35.7 mm) wich should only include :

 

Company

First and last name

Product

Price (incl. VAT)

 

No more information is needed on the label.

 

One question about the labels:

He is using a dedicated matrix-labelprinter with continuous computer labels (you know, the ones with tractor pinholes). Is it possible to define continuous papertypes like these ?

 

Is someone willing to do this programming for a fee ? Please contact me, as I am really puzzled about how to get these labels programmed.

 

If someone is willing to get me started on how to define the labels, I'd really appreciate all the help !

 

Thanks in advance for your kind help,

 

Sx

Share this post


Link to post
Share on other sites
I installed OSC for a friend who is a caterer, and he wants to print sticky labels (101.6 x 35.7 mm) wich should only include :

 

Company

First and last name

Product

Price (incl. VAT)

 

No more information is needed on the label.

 

Anyone willing to help me with this ? I've been looking for a solution myself, and can't find it.

All help appreciated !

 

Sixten

Share this post


Link to post
Share on other sites

Assuming you have the right printer driver I see no reason why thus shouldn't work if you make a relatively simple modification of one of the existing invoice templates. I use the Dymo labelwriter with this contribution (just for the addresses). It should be just a question of moving a few fields around in the pdf (OK that takes some getting used to).

The only problem I can forsee is if the order contains a large number of products it will overflow onto the next label.

Share this post


Link to post
Share on other sites

This contribution seems like the best for me i found except that I need it to send an email each certain time (

 

Please enter the date you want extracted to PDF:

(enter date in YYYY-MM-DD format)

each time I select with the total orders by customer, lets say for example that send and email at the end of the month with the total added of the orders he made within that month

any ideas would be appreciated

jorgecastrot@yahoo.com

thanks

Share this post


Link to post
Share on other sites

This contribution seems like the best for me i found except that I need it to send an email each certain time (

 

Please enter the date you want extracted to PDF:

(enter date in YYYY-MM-DD format)

each time I select with the total orders by customer, lets say for example that send and email at the end of the month with the total added of the orders he made within that month

any ideas would be appreciated

jorgecastrot@yahoo.com

thanks

Share this post


Link to post
Share on other sites

Please can anyone help i have installed the batch print center and when i click on the batch print center option within admin i get this below and about 1000 any one know what this problem is hope someone can help thanks in advance

 

 

<results from batch print center within admin>

 

StartFontMetrics 4.1 Comment Copyright © 1985, 1987, 1989, 1990, 1997 Adobe Systems Incorporated. All Rights Reserved. Comment Creation Date: Thu May 1 12:38:23 1997 Comment UniqueID 43054 Comment VMusage 37069 48094 FontName Helvetica FullName Helvetica FamilyName Helvetica Weight Medium ItalicAngle 0 IsFixedPitch false CharacterSet ExtendedRoman FontBBox -166 -225 1000 931 UnderlinePosition -100 UnderlineThickness 50 Version 002.000 Notice Copyright © 1985, 1987, 1989, 1990, 1997 Adobe Systems Incorporated. All Rights Reserved.Helvetica is a trademark of Linotype-Hell AG and/or its subsidiaries. EncodingScheme AdobeStandardEncoding CapHeight 718 XHeight 523 Ascender 718 Descender -207 StdHW 76 StdVW 88 StartCharMetrics 315 C 32 ; WX 278 ; N space ; B 0 0 0 0 ; C 33 ; WX 278 ; N exclam ; B 90 0 187 718 ; C 34 ; WX 355 ; N quotedbl ; B 70 463 285 718 ; C 35 ; WX 556 ; N numbersign ; B 28 0 529 688 ; C 36 ; WX 556 ; N dollar ; B 32 -115 520 775 ; C 37 ; WX 889 ; N percent ; B 39 -19 850 703 ; C 38 ; WX 667 ; N ampersand ; B 44 -15 645 718 ; C 39 ; WX 222 ; N quoteright ; B 53 463 157 718 ; C 40 ; WX 333 ; N parenleft ; B 68 -207 299 733 ; C 41 ; WX 333 ; N parenright ; B 34 -207 265 733 ; C 42 ; WX 389 ; N asterisk ; B 39 431 349 718 ; C 43 ; WX 584 ; N plus ; B 39 0 545 505 ; C 44 ; WX 278 ; N comma ; B 87 -147 191 106 ; C 45 ; WX 333 ; N hyphen ; B 44 232 289 322 ; C 46 ; WX 278 ; N period ; B 87 0 191 106 ; C 47 ; WX 278 ; N slash ; B -17 -19 295 737 ; C 48 ; WX 556 ; N zero ; B 37 -19 519 703 ; C 49 ; WX 556 ; N one ; B 101 0 359 703 ; C 50 ; WX 556 ; N two ; B 26 0 507 703 ; C 51 ; WX 556 ; N three ; B 34 -19 522 703 ; C 52 ; WX 556 ; N four ; B 25 0 523 703 ; C 53 ; WX 556 ; N five ; B 32 -19 514 688 ; C 54 ; WX 556 ; N six ; B 38 -19 518 703 ; C 55 ; WX 556 ; N seven ; B 37 0 523 688 ; C 56 ; WX 556 ; N eight ;

 

 

<did not want to overload the forum with the 1000s of lines so this is not the full result>

Share this post


Link to post
Share on other sites

In terms of fixing the MySQL 4.1 issue (our host changed last Friday and knackered us up), I think the problem lies in the BETWEEN statement...

 

Our file is now working perfectly well with the query changed as follows:

 

$orders_query = tep_db_query("select o.orders_id, h.comments,MIN(h.date_added) from " . TABLE_ORDERS . " o, " . TABLE_ORDERS_STATUS_HISTORY . " h where o.date_purchased >= '" . tep_db_input($startdate) . "' and o.date_purchased <= '" . tep_db_input($enddate) . "' and h.orders_id = o.orders_id" . $pull_w_status . $get_customer_comments . ' group by o.orders_id');

 

 

Hope it helps anyone else who is stuck.

Share this post


Link to post
Share on other sites

Tnx Ian,

 

That is indeed the solution and cause. Our host also changed to the new MySQL. Which had the same effect as:

 

Program Message:

There were no orders selected for export, try changing your order options.

 

The new code works perfect.


Seize the Night!

 

Handy Contrib:

RSS News v0.8 Scrolls news from an xml file in a infobox.

Share this post


Link to post
Share on other sites
Assuming you have the right printer driver I see no reason why thus shouldn't work if you make a relatively simple modification of one of the existing invoice templates. I use the Dymo labelwriter with this contribution (just for the addresses). It should be just a question of moving a few fields around in the pdf (OK that takes some getting used to).

The only problem I can forsee is if the order contains a large number of products it will overflow onto the next label.

 

How did you define an continuous papertype ? The labels on the endless roll are 101.6 x 35.7 mm with 2 mm inbetween the labels.

 

I've been looking for an answer myself, but I'm really puzzled about it.

Share this post


Link to post
Share on other sites

There's no need to define a continuous paper type. It isn't continuous. There is one label per page. The Batch Print Centre contribution contains a template that works for the Dymo Labelwriter.

Share this post


Link to post
Share on other sites
Our file is now working perfectly well with the query changed as follows:

 

$orders_query = tep_db_query("select o.orders_id, h.comments,MIN(h.date_added) from " . TABLE_ORDERS . " o, " . TABLE_ORDERS_STATUS_HISTORY . " h where o.date_purchased >= '" . tep_db_input($startdate) . "' and o.date_purchased <= '" . tep_db_input($enddate) . "' and h.orders_id = o.orders_id" . $pull_w_status . $get_customer_comments . ' group by o.orders_id');

 

We are having the same problems and went from mysql 3.23.58 to 4.1.

 

I ran your fix and now the download link is showing up to download and when I download the batch_orders.pdf file the only thing in there is the store address. It tells me there are orders but they are not listed.

 

Anyone have a fix for the rest of this?

 

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×