Jump to content
Sign in to follow this  
group54

Paypal issue

Recommended Posts

When I click on the Paypal IPN links (either Transaction or Test) I am rerouted to the admin login. If I then re-login, it just refreshes back to the login page. I am using 2.2 with a few other contribs.

 

Any ideas??? I am set to go live in 2 weeks.

 

Thanks,

Phil

Share this post


Link to post
Share on other sites

Yes. I know b/c it was working before. Before what? I don't know. Because I have not changed anything functional wise or added any other mods. Has no one seen this happen before? If so, that is kinda scary.

Share this post


Link to post
Share on other sites

I would of answered you along time ago but you haven't bother to enlighten us as to which admin access contribution you are using, so whats the point in guessing. Also which PayPal IPN contrib are you using?

 

If your using Admin Access with Levels, then look in the administrators.php file and you will see a list of files associated to particular files from each menu box. You will need to update the list to include the new IPN file and any others.


"Any fool can know. The point is to understand." -- Albert Einstein

Share this post


Link to post
Share on other sites

Sorry - did not realize there was more than one version of each. I did not download them from here. I will get the details and post them here.

 

Thanks for the response.

Share this post


Link to post
Share on other sites

This is the code from my adminstrators.php. I don't see paypal ipn there... ??? Maybe I am not following you.

 

I still can't get this to work. It was working fine and then stopped. Strange too since I had not made any modifications or added any other contribs.

 

Any help would be great.

 

<!-- catalog //-->
         <tr>
           <td>
<?php
 $heading = array();
 $contents = array();

 $heading[] = array('text'  => BOX_HEADING_ADMINISTRATOR,
                    'link'  => tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('selected_box')) . 'selected_box=administrator'));

 if ($selected_box == 'administrator') {
   $contents[] = array('text'  => tep_admin_files_boxes(FILENAME_ADMIN_MEMBERS, BOX_ADMINISTRATOR_MEMBERS) .
                                  tep_admin_files_boxes(FILENAME_ADMIN_FILES, BOX_ADMINISTRATOR_BOXES));
 }

 $box = new box;
 echo $box->menuBox($heading, $contents);
?>
           </td>
         </tr>
<!-- catalog_eof //-->

Share this post


Link to post
Share on other sites

Ok - I have manually upgraded to 1.7 with the latest contrib hoping to alleviate that dang login issue. It is still there. Any suggestions? Must be some internal setup. Any suggestions where I can start looking? YUCK!

Share this post


Link to post
Share on other sites

BTW: I added the this call:

 

tep_admin_files_boxes(FILENAME_PAYPAL_IPN, BOX_CUSTOMERS_PAYPAL_IPN));

 

to adminstrators.php and nothing changed.

Share this post


Link to post
Share on other sites

Did I step on someone's toes??? Or is my problem just that rare? I am still trying to work it out. If you have any suggestions, I would appreciate it.

Share this post


Link to post
Share on other sites

Have a look in admin/includes/functions/administrators.php, scroll down and should see how the file names are associated to the main php file for each box, as an example there is or maybe was an ommission of the packingslip and invoice files

 

so to fix this:

insert

'invoice.php' => 'customers.php',

'packingslip.php' => 'customers.php',

 

just under orders.php

 

I think you're running Admin Access with Levels, which is what the above is in reference too.


"Any fool can know. The point is to understand." -- Albert Einstein

Share this post


Link to post
Share on other sites

Thanks for the reply. I looked in the directory you specified and I do not see administrators.php file there. Administrators.php is located in admin/includes/functions/boxes directory on my installation. And in that file I don't see a reference to orders.php

 

this is what is there:

<?php

$heading = array();

$contents = array();

 

$heading[] = array('text' => BOX_HEADING_ADMINISTRATOR,

'link' => tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('selected_box')) . 'selected_box=administrator'));

 

if ($selected_box == 'administrator') {

$contents[] = array('text' => tep_admin_files_boxes(FILENAME_ADMIN_MEMBERS, BOX_ADMINISTRATOR_MEMBERS) .

tep_admin_files_boxes(FILENAME_ADMIN_FILES, BOX_ADMINISTRATOR_BOXES) .

tep_admin_files_boxes(FILENAME_PAYPAL_IPN, BOX_CUSTOMERS_PAYPAL_IPN));

}

 

$box = new box;

echo $box->menuBox($heading, $contents);

?>

 

THANKS again for the reply!

Share this post


Link to post
Share on other sites

Did you remember to add the database define statements to

admin/includes/database_tables.php

catalog/includes/database_tables.php

and/or the file name defines in the two filenames.php (or where ever your version defines the files being used)

 

Also, if you can set your browser to show the status bar -- read what it says when you hover over the PayPal IPN Transactions link -- make sure there is no typo error and that the file was uploaded

 

I did have this problem on two sites each a different problem. I am pretty sure these were the problems.

Share this post


Link to post
Share on other sites

I am having the same problem in my admin panel. When I click on paypalipn test or paypal transactions I kicked to the login page. I have to close and reopen my browser to log back in.

 

All my files seem to be correct. Yesterday it worked fine on one of my sites and not on the other. Now I have the same problem on both sites but nothing has changed in my files or database.

 

The front end of the cart works fine, it forwards me to paypal, I make payment, it takes me back to the cart. In the back end the order is there. I get the email verifications for payment sent and payment recieved.

 

The only problem is in the back end on ipn test and txn.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×