Jump to content
Sign in to follow this  
defender39

Featured 1.5

Recommended Posts

Please, can you help me !!!

I installed products fertured 1.58 and take this error on catalog/admin/featured.php

 

Featured Products

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select p.products_id, pd.products_name, s.featured_id, s.featured_date_added, s.featured_last_modified, s.expires_date, s.date_status_change, s.status from products p, featured s, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = s.products_id order by pd.products_name limit -20, 20

 

[TEP STOP]

 

 

Yeah

I'm getting the same thing.

Also one like tis

 

1146 - Table 'gidgetge_p_os1.featured' doesn't exist

select count(*) as total from products p, featured s, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = s.products_id

[TEP STOP]

 

 

I just installed everything and followed the instructions.

A couple of things I am having trouble with are,

 

"Note: if you haven't previously installed the 'new products bug fix', bug report ID 1316, then you will also need to add this function."

 

I cant find this bug report. I will continue searching, but I believe it is part of my troubles.

The other is,

"Step 15:

Now you need to create the database table that will be holding the featured products. You need to run the featured_products_english.sql file's contents in your favourite sql interface (like phpmyadmin) to your database ."

 

I can not remember how to add this to my database. I now about going into the admin section and all that,

but am having trouble getting it into the SQL or wherever it goes.

 

This is a great contribution. One of the best I have been exposed to.

I would love to be able to use it.

In the meantime I will continue researching the answers.

If someone can help me, I would forever be in their debt.

 

Thanx for a great contrib!

Share this post


Link to post
Share on other sites
Yeah

I'm getting the same thing.

Also one like tis

 

1146 - Table 'gidgetge_p_os1.featured' doesn't exist

select count(*) as total from products p, featured s, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = s.products_id

[TEP STOP]

I just installed everything and followed the instructions.

A couple of things I am having trouble with are,

I cant find this bug report. I will continue searching, but I believe it is part of my troubles.

The other is,

I can not remember how to add this to my database. I now about going into the admin section and all that,

but am having trouble getting it into the SQL or wherever it goes.

 

This is a great contribution. One of the best I have been exposed to.

I would love to be able to use it.

In the meantime I will continue researching the answers.

If someone can help me, I would forever be in their debt.

 

Thanx for a great contrib!

 

Hi Gidget Gein,

 

The bug 1316 seems to be an old bug which was fixed in the latest osCommerce releases or updates. I would not worry about this.

 

Your problem is simply that you haven't imported the SQL file into your database. That's a necessary step, it won't work without it.

 

You can do this by using phpMyAdmin. Make sure there is not error message after you've imported it.

 

Don't forget (as always!) to make a backup of your batabase before playing in it!

 

Regards,

 

-Ben Martin

Share this post


Link to post
Share on other sites
Please, can you help me !!!

I installed products fertured 1.58 and take this error on catalog/admin/featured.php

 

Featured Products

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select p.products_id, pd.products_name, s.featured_id, s.featured_date_added, s.featured_last_modified, s.expires_date, s.date_status_change, s.status from products p, featured s, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = s.products_id order by pd.products_name limit -20, 20

 

[TEP STOP]

I HOPE THAT SOMEONE CAN HELP ME !!! THANKS IN ADVANCE

 

Hi lala,

 

Your error is the same than Gidget:

you haven't imported the SQL file into your database. That's a necessary step, it won't work without it.

 

You can do this by using phpMyAdmin. Make sure there is not error message after you've imported it.

 

Don't forget (as always!) to make a backup of your batabase before playing in it!

 

Regards,

 

-Ben Martin

Share this post


Link to post
Share on other sites
Please, can you help me !!!

I installed products fertured 1.58 and take this error on catalog/admin/featured.php

 

Featured Products

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select p.products_id, pd.products_name, s.featured_id, s.featured_date_added, s.featured_last_modified, s.expires_date, s.date_status_change, s.status from products p, featured s, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = s.products_id order by pd.products_name limit -20, 20

 

[TEP STOP]

I HOPE THAT SOMEONE CAN HELP ME !!! THANKS IN ADVANCE

 

Sorry lala, I was to quick to read your post. What I said was not your problem.

 

That's an old osCommerce bug you have. You'll simply need to edit 1 file to fix it. See this post:

http://forums.oscommerce.com/index.php?sho...mp;#entry697026

 

It seems that you have an older version of osCommerce, without the last (or last 2) updates. I'd suggest to update, it might as well save you a few future bugs.

 

Regards,

 

-Ben Martin

Share this post


Link to post
Share on other sites

I am using a template and have added this contrib.

 

On index.php whenever you click on add to cart image button it puts the wrong product in cart. How can I fix this error?

Share this post


Link to post
Share on other sites

Hi

 

I have installed this today and it works great but I have a slight prob. As a test I have added 11 featured products, limited the products to 9 in Admin and these are displayed on my main page. The prob comes in when I pick on the featured products hyperlink, the products are listed but all 11 are in the list.

 

I'd like to set all products as featured and just have the 9 products displayed on both pages.

 

Many thanks

 

ian

Share this post


Link to post
Share on other sites

After numerous problems, I finally got this to work - however, it put it in a little box at the top of the right column. I assume it would put it on the main page, replacing the "New Product for ...." section.

 

Is there any way to make it do that instead?

 

Thanks,

Joe

Share this post


Link to post
Share on other sites

im ready install :

featured-with-sts4.3.3.zip

 

but when akses in admin/category link to Featured product not shown??

ex:

Catalog

Categories/Products

Specials

Products Featured ======>> not shown

Products Expected

Products Attributes

Manufacturers

Reviews

 

and second problem is

when my akses to http://xxx.xom/admin/featured.php ===>>Access Denied

No Right Permission Access

Please contact your Web Administrator to request

more access or if you found any problem.

 

please help me

Share this post


Link to post
Share on other sites

I have installed latest version, and this is the error i recieve on catalog side:

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '&& language_id=4' at line 1

 

SELECT `products_description` FROM `products_description` WHERE products_id = && language_id=4

 

[TEP STOP]

Admin side works fine.

any help appreciated,

Thanks.

Share this post


Link to post
Share on other sites

Hi all, hope some new eyes can assist me with this issue. I install Featured Products 1.59, it is showing up on main/index page and does turn off "New Products for Month", but when I enter my Category page the Featured Products box does not show but the New Products for Month is showing. I do have some products listed in Feature Products that are also in the Category I have selected, if that makes a differance. Can anyone help, I have been looking for hours with a fine tooth comb..

Thanks in advance for any help,

Jeff

Share this post


Link to post
Share on other sites

Hi,

 

I was wondering if anybody can please help me? I want to make it so that when I create a new Featured Product, only the last 500 products are listed in the drop-down. I have tried using limit in just about every query there is, but I just can't get it working. Can anyone help?

Share this post


Link to post
Share on other sites

Anyone? I am using Featured Products 1.5.9, but cannot limit the queries for some reason.

 

$product_query = tep_db_query("select p.products_id, p.products_status, pd.products_name, s.expires_date from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_FEATURED . " s where p.products_status = 1 and p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' and p.products_id = s.products_id and s.featured_id = '" . $HTTP_GET_VARS['sID'] . "' order by pd.products_name");

$product = tep_db_fetch_array($product_query);

 

$sInfo = new objectInfo($product);

} else {

$sInfo = new objectInfo(array());

 

// create an array of featured products, which will be excluded from the pull down menu of products

// (when creating a new featured product)

$featured_array = array();

$featured_query = tep_db_query("select p.products_id, p.products_status from " . TABLE_PRODUCTS . " p, " . TABLE_FEATURED . " s where s.products_id = p.products_id OR p.products_status = '0'");

while ($featured = tep_db_fetch_array($featured_query)) {

$featured_array[] = $featured['products_id'];

}

}

 

$featured_query_raw = "select p.products_id, p.products_status, pd.products_name, s.featured_id, s.featured_date_added, s.featured_last_modified, s.expires_date, s.date_status_change, s.status from " . TABLE_PRODUCTS . " p, " . TABLE_FEATURED . " s, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' and p.products_id = s.products_id order by pd.products_name";

 

Adding limit doesn't seem to do much.

Share this post


Link to post
Share on other sites
I installed the last version and some files that were either not used or have somehow been broken from 1.3. So here is an extremely easy Featured replacement for you front page only. It also has an sql install that will give you admin control to turn it on or off. You can also designate the amount of products you wish to display from admin. Very easy and quick install. Simple to read instructions thanks to a previous contributor who gets named in the file.

 

http://www.oscommerce.com/community/contributions,651

 

any questions feel free to post them here for me to see

Great contribution.

I have one problem. The "New Products for (Month)" appears twice in the categories pages, but only in those that have subcategories. http://creativescrapbooksolutions.com/deluxe-pages-c-52.html

Any idea where I can fix this?

Everything else seems to work fine.

Thanks,

Carol Ann

Share this post


Link to post
Share on other sites

Hi,

 

Can someone help me to understand this error:

 

Warning: Cannot modify header information - headers already sent by (output started at /home/fastbo6/public_html/shop/admin/includes/languages/english.php:613) in /home/fastbo6/public_html/shop/admin/includes/functions/general.php on line 22

 

I installed version 4.3.4 released on 23 March 2007 - The error occurs any time I make a change in Admin panel. Refreshing the browser does not eliminate the error, but selecting the Back button on the browser takes me back to the page I was before, and the "change" was made.

 

I haven't installed the 'new products bug fix', but I am not sure if that is what is causing this problem.

 

Please help if you have any idea - :)

 

Thank you-

Erick

Share this post


Link to post
Share on other sites

Hi,

I'm using Oscommerce with MS2 and have been trying to install the Featured Products add-on.

However, there are certain parts of the instructions that lead to files that simply don't exist in my directory structure.

Having otherwise completed the installation - the system is not working. From the admin side I cannot access and edit the Featured Products list (in the catalog box). The home page of my website shows a blank where the box should be for the featured products. Can someone help me?

 

Here's the instructions I was unable to follow:

Step 3:

Add the following lines to /catalog/admin/includes/filenames.php: -- this file does not exist in this directory

 

define('FILENAME_FEATURED', 'featured.php');

define('FILENAME_FEATURED_PRODUCTS', 'featured_products.php');

 

Step 4:

Add the following line to /catalog/admin/includes/database_tables.php: -- this file does not exist in this directory

 

Step 5:

Edit the file /catalog/admin/includes/boxes/catalog.php - this file does not exist in any of my directories

 

 

Step 6:

Edit the file /catalog/admin/includes/languages/english.php:

Find: define('BOX_CATALOG_PRODUCTS_EXPECTED', 'Products Expected'); --- this line does not exist in this file on my system

Share this post


Link to post
Share on other sites

Hi,

I've got the problem solved now - don't worry!

Thanks!

Here's the instructions I was unable to follow:

Step 3:

Add the following lines to /catalog/admin/includes/filenames.php: -- this file does not exist in this directory

 

define('FILENAME_FEATURED', 'featured.php');

define('FILENAME_FEATURED_PRODUCTS', 'featured_products.php');

 

Step 4:

Add the following line to /catalog/admin/includes/database_tables.php: -- this file does not exist in this directory

 

Step 5:

Edit the file /catalog/admin/includes/boxes/catalog.php - this file does not exist in any of my directories

Step 6:

Edit the file /catalog/admin/includes/languages/english.php:

Find: define('BOX_CATALOG_PRODUCTS_EXPECTED', 'Products Expected'); --- this line does not exist in this file on my system

Share this post


Link to post
Share on other sites

Hi,

 

I'm trying to do something different with this conrtibution. I'm trying to add a seperater between each product, like the transparent ones from the oscommerce default, but these are visible. The idea looks like this here. The products are seperated by the dotted lines.

 

As you can see, I'm using another contribution for the products display, and I'd really like to make the Featured Products look the same, but every variation I use seems to either put the dotted lines through the second row or before the products, or it totally removes the products and just shows dotted lines.

 

Does anyone have an idea of where abouts on the featured.php page I can insert the code so the products are seperated by these dotted lines?

Share this post


Link to post
Share on other sites

Hi, thanks for the fantastic contribution. I have installed Featured Products 1.5.9 and it went completly smoothly and works perfectly...except that the featured products are located in the left column. I thought that the contribution was supposed to replace the New Products page?

 

Any help would be much appreciated.

Share this post


Link to post
Share on other sites

Hi everybody! :lol:

 

I installed this contribution on a heavily modified database and after a few tweaking I got it working just fine.

 

HOWEVER, very strange things happen on the admin side regarding product active/inactive OSC function: no matter the category, each time I try to set ANY product inactive by clicking on the red dot aside product description I get the following error

 

1054 - Unknown column 'products_featured' in 'field list'

 

update products set products_status = '0', products_featured = '0', products_last_modified = now() where products_id = '28'

 

[TEP STOP]

 

The funniest thing is that when I edit a product and set its status as "out of stock" I get the red dot displayed correctly and product disappears from the front store. :o

 

I spent TWO DAYS trying to figure out what is going on but could not get through: is there anybody who knows how to fix this issue? I am really going crazy :blink: with this and I would definitely appreciate any suggestions!

 

Thanks in advance

 

Mendoh

Share this post


Link to post
Share on other sites

hi!!

 

 

I get this in the index

 

Warning: include(includes/modules/FILENAME_FEATURED) [function.include]: failed to open stream: No such file or directory in /home/thewalld/public_html/compras/index.php on line 380

 

Warning: include(includes/modules/FILENAME_FEATURED) [function.include]: failed to open stream: No such file or directory in /home/thewalld/public_html/compras/index.php on line 380

 

Warning: include() [function.include]: Failed opening 'includes/modules/FILENAME_FEATURED' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/thewalld/public_html/compras/index.php on line 380

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×