Jump to content
Sign in to follow this  
snuff

VVC: working, but not properly

Recommended Posts

Hello Anybody and Everybody! I am stuck, need a lift.

I installed the VVC code mod and it works great in the create_account portion of my site.

My problem is that I want to use it also in the email (contact_us) and tell-a-friend sections.

I have NO worthwhile knowledge of PHP (except how to spell PHP) but I can follow good directions.

To this point I have the VVC "code box" and "code" appearing in my email page, so that far I have reached (pure luck), but it does not work properly. I type the code wrong and the email still goes fine and the "success" page arrives, it does not error out.

 

If someone could advise me of what/where I need to do, I'd appreciate it.

Site: t-nuts.com/catalog

running MS2 with some CVS 1/15/03

PHP 4.1.2 Zend 1.1.1

 

Thanks in advance

--Jeff


--Jeff

Of course I don't look busy! I did it right the first time!

Share this post


Link to post
Share on other sites

I'm having this same problem. I've installed the contribution to the contact and create account pages, however it doesn't work on either.

 

For the create account page it comes up with the "The security code you entered did not match the one displayed." message no matter if it's entered correctly or not. And like this guy, on the contact page it gets sent no matter what.

 

It looks like there's been no support for this contrib for quite awhile, but it would be great to have on my site. So if anyone has any ideas, suggestions, or possibly info on a similar contribution it would be appreciated.

Edited by jasper98

Share this post


Link to post
Share on other sites

I need help with this too. It seems to work on the Create Account and Tell A Friend pages, but on the Contact us Page I get the "The security code you entered did not match the one displayed." error regardless of whether the code was entered right or not, and the e-mail gets sent no matter what. I just want it to recognize the security code, and send them back to the form if they typed it wrong, only putting it through if it was typed correctly.


Unique handcrafted jewelry, accessories, toys, home decor, digital art and much more.

Share this post


Link to post
Share on other sites

Briana and Steve,

Are you still having the problem, if so what version did you install and what server components are you running (ie PHP version, etc)?

I have it working fine on my site and might be able to compare your files with mine to see where the problem might be if needed.


--Jeff

Of course I don't look busy! I did it right the first time!

Share this post


Link to post
Share on other sites

i added a german translation to the VVC contribution at

http://www.oscommerce.com/community/contri...,all/search,VVC

and i installed it on my server, it all runs fine.

 

i fixed the button-bug too.

 

 

i used the readme.txt file for install, (cause i already had some contributions installed) but if you have the standard installation of the oscommerce just copying the files should do the job too

Share this post


Link to post
Share on other sites

Hi All,

 

I've been using the VVC contrib for some time now, however have NEVER been able to get it to work with a modified contact_us page.

 

My contact_Us.php has extra dropdowns (a bastardised version of Super Contact_Us enhancement), and I can't seem to get the VVC code into the validation loop in order to work.

I've tried moving the code within the file, however no matter what I do VVC will not stop the email from being successfully sent.

 

Does anyone have any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×