Jump to content
Sign in to follow this  
paulm2003

BTSv1.2 Support

Recommended Posts

Hello Friends,

 

I installed the bts 1.3 in a new installation of oscommerce. The adminastration now shows the templates area, and i uploaded everithing.But when i chance the template in admin, nothing happens in the store.. anybody know what is happening... i believe that i made ebverithing correct...

 

Thanks,

 

Raphael

 

my store:

 

http://www.exoticgemsbrazil.com/store

Share this post


Link to post
Share on other sites
Hi everyone

 

I saw the 32-final demo

But cant seem to find it anywhere!

Can anybody help?

 

Thanks

I'm trying to look for 32-final template as well.

 

BTW: The zip files for BTS 1.31_1 and 1.31_1_1 is currupted.

Share this post


Link to post
Share on other sites
Hi everyone

 

I saw the 32-final demo

But cant seem to find it anywhere!

Can anybody help?

 

Thanks

I'm looking for 32-final template as well, anybody knows where I can get those?

 

BTW: The zip files for BTS 1.31_1 and 1.31_1_1 are currupted.

Share this post


Link to post
Share on other sites

Hi,

 

:blink: funny thing 'ere. Why are there no extra Sub-Categories for the Contribs? BTW: @ Brenden. Good job! I didn't understand all of it right now, but the installation was easy and well documented. ;)

 

Anyway, though I can't think of being the only one with that kind of problem, I didn't find a solution in this massive thread.

 

Here's my question:

 

Master Products changes a line ie to product_info.php

...
<!-- body_text //-->
<!-- Master Products //-->
   <td width="100%" valign="top"><?php  echo '<form name="buy_now_" method="post" action="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=add_slave', 'NONSSL') . '">'; ?><table border="0" width="100%" cellspacing="0" cellpadding="0">	
<?php
// Master Products EOF
 if ($product_check['total'] < 1) {
?>
     <tr>
       <td><?php new infoBox(array(array('text' => TEXT_PRODUCT_NOT_FOUND))); ?></td>
     </tr>
...

 

BTS dosn't output HTML in product_info.php anymore. Cause it's a template system. :) It get's it's HTML from template-file product_info.tpl.php.

...
   <?php echo tep_draw_form('cart_quantity', tep_href_link(FILENAME_PRODUCT_INFO, tep_get_all_get_params(array('action')) . 'action=add_product')); ?><table border="0" width="100%" cellspacing="0" cellpadding="0">
<?php
 if ($product_check['total'] < 1) {
?>
     <tr>
       <td><h1><?php new infoBox(array(array('text' => TEXT_PRODUCT_NOT_FOUND))); ?></h1></td>
     </tr>
...

 

How do I merge this? By now, Master Products shows all Slaves-Products at top level with it's Master-Products. Do I have to get rid of Master Products now, cause I use BTS? :ph34r: And what about Download Controller? Thanks for your help. I would appreciate some kind of tutorial as well.

 

Verob

 

OSCOMMERCE 2.2 MS2

BTS 1.31

newest Master Products

newest Download Controller


oscommerce 2.2 MS2

Share this post


Link to post
Share on other sites

Verob,

 

Do you have OSC 2.2 MS 2 working with BTS 1.3.1 AND Master Products 1.5.1(by Galen) or Master Products M2 1.1.5 ? I tried to get the contributions working together but no luck. How did you load the contributions i.e. Master Products first then BTS or BTS first? Do you have any tips or can you describe any helpful installation tips?

 

Is everything working correctly or are you still experiencing problems? Do you have a store where I can see the contributions in action?

 

Thanks

Share this post


Link to post
Share on other sites

Hi myoscommerce,

 

Verob,

 

Do you have OSC 2.2 MS 2 working with BTS 1.3.1 AND Master Products 1.5.1(by Galen) or Master Products M2 1.1.5 ? I tried to get the contributions working together but no luck. How did you load the contributions i.e. Master Products first then BTS or BTS first? Do you have any tips or can you describe any helpful installation tips?

 

I have oscommerce 2.2 MS 2 and installed "Master Products - MS2 v1. - Johnson?". After that I put Download Controller in it too. Then I installed the BTS 1.31! And I believe I said, that I have problems running it, didn't I?

 

Is everything working correctly or are you still experiencing problems? Do you have a store where I can see the contributions in action?

 

Thanks

As I said. It dosn't work. The problem occures, when I try to open a product with slaves in it. The table layout breaks.

 

By Verob


oscommerce 2.2 MS2

Share this post


Link to post
Share on other sites

This seems to be a very quiet thread. Anyone in 'ere? :-"

 

OK, I found out a funny thing and I'm not sure if it is my falt or if it is a bug in BTS. Whenever I put in another box into the main_page.tpl.php which includes a <form>-tag with a submit-Button, I'll get passed to the login page when I hit the button.

 

Course of all these files to check evan with the simple open and save-as way, I tried to just copy the search box and the tell a friend box. Same thing.

 

Then I moved the search box so that it is the first box on the left site. Same thing.

 

So, whenever I put my hands on search box or tell a friend box, it passes me to login page and not to search-result or tell a friend page.

 

What did I do wrong?


oscommerce 2.2 MS2

Share this post


Link to post
Share on other sites

I'm sure I'm being very dense :huh: , but for the life of me I can't seem to work out how to change the colours of the heading bars (the bits where it says "categories", "manufacturers") .

 

I can change every other bit of the template, just not that bit.

 

Any advice or points in the right direction would be great!

 

WARNING! I'm a newbie to PHP and the like, but I am learning (so please be gentle).

Share this post


Link to post
Share on other sites

Melissa,

 

Look in the templates/template_name/style.css file

 

where template_name is the name of your template.

 

Mark


Lifes a bitch, then you marry one, then you die!

Share this post


Link to post
Share on other sites
Melissa,

 

Look in the templates/template_name/style.css file

 

where template_name is the name of your template.

 

Mark

 

Hi Mark,

 

Thanks for that but I know it is somewhere in there I just don't know what they call it? I've edited all the lines with a colour on and I can alter the borders just not the background.....

I like the cool yellow effect that's already there, but I'd like to know how I can change it to something of my own :blush:

 

Thanks

Melissa

Share this post


Link to post
Share on other sites
Hi Mark,

 

Thanks for that but I know it is somewhere in there I just don't know what they call it? I've edited all the lines with a colour on and I can alter the borders just not the background.....

I like the cool yellow effect that's already there, but I'd like to know how I can change it to something of my own  :blush:

 

Thanks

Melissa

 

No Worries found the piccy I was after. At first I thought it was just a v.small black line, but on extremely closer inspection I found it was the yellow gradient .... DOH! How stupid am I ? :D

Share this post


Link to post
Share on other sites

Hello everyone,

 

I'm new here.

 

I've got oscommerce working well enough. I installed the BTSv1.31 and have a wee but hugely significant problem. None of my categories are showing up. :'(

 

Of course, everything is there in the admin, and my backup works fine using the standard install with a customized stylesheet.

 

I've tried looking through this site, and could find this problem mentioned. But since this is a bit of a firehose worth of info, perhaps I've missed it. Has anyone else had this problem before? And where might I find into on it?

 

Thanks hugely for any clues you can provide.

 

Lane

Share this post


Link to post
Share on other sites
Hello everyone,

 

I'm new here.

 

I've got oscommerce working well enough.  I installed the BTSv1.31 and have a wee but hugely significant problem.  None of my categories are showing up. :'(

 

Of course, everything is there in the admin, and my backup works fine using the standard install with a customized stylesheet.

 

I've tried looking through this site, and could find this problem mentioned. But since this is a bit of a firehose worth of info, perhaps I've missed it. Has anyone else had this problem before?  And where might I find into on it?

 

Thanks hugely for any clues you can provide.

 

Lane

ok, i like talking to myself. I've determined that the problem happens when the cache is enabled. In catalog/admin, Configuration > Cache > Use Cache set to true. Setting it to false makes it work properly again, I can now see my categories again.

 

This sounds like a bug, can anyone confirm this?

Share this post


Link to post
Share on other sites

:huh: Hi,

 

I'm new to this forum. I was trying out some samples with BTS and worked perfectly. The idea is fantastic. Now I would like develop my own template and deploy for BTS. Is there any documentation how to develop our own template for BTS? Or any instructions what files or convention of names are needed to develop templates for BTS?

 

Thank you very much for any of your advices!

 

Regards!

Jimmy

Share this post


Link to post
Share on other sites

Does anyone have a complete CSS template that works with BTSv1.31_1_2?

 

It looks like once upon a time there was a CSS template included in the contribution package, but it's not there now. Strange.... I've also looked under the Templates contribution area, but only found incomplete implementations there.

 

I am just about to begin plunging into learning how to build a new template to create a CSS base version for future use, but thought I would ask first to see if I could save a ton of time. Also, I'm wondering how much work it makes sense to put into this since milestone 3 is suppose to have its own tempate system. (same as BTS???)

 

Thanks in advanced for any help!!

Share this post


Link to post
Share on other sites
Does anyone have a complete CSS template that works with BTSv1.31_1_2?
Maybe it exists, but I don't think so. There was a main CSS template included once, that one is still available as a separate contribution http://www.oscommerce.com/community/contributions,2017 (but as said, it's just a main CSS template, certainly not a "full" CSS template)

Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

I want to know which is the template for the Featured Products displayed right after the Welcome Guest/Member text.

 

It's the table that has a three column layout with all the new products & stuff...

 

I altered the products_new.tpl.php file located at templates/themename/content to be a two column table rather than three layout because my site is desinged for two columns at this table, but nothing happened and the layout stayed as is (a 3 column table). Is this the file I need to alter or do I have to edit some core OSC code?


There's a diference between living & BEING ALIVE!

Share this post


Link to post
Share on other sites

I have a questions to ask:

 

Now, the Images folder is gone, correct?

How can I, say, add the contrib for the box shaddows into this without an images folder? Where would I PUT the images from here?

 

-Jyn

 

Uploaded an update for the CSS and OneTable template yesterday.

 

There was a problem a.o. writing reviews using these templates.

http://www.oscommerce.com/community/contributions,1263

 

The update also describes how to set the width of the text area fields, which can be usefull (depends on your template if you need it).

 

And just for the fun it also includes an "Automatic Templates Menu", automaticly creates links to template directories except for directories starting with and underscrore ("_"). So you can still have your secret template dir's too.


=======,+'^'+,===============================

Jyn Meyer

`+,.,+' Be Glad the world sucks- if it didn't we would all fall off.

===========================================

Share this post


Link to post
Share on other sites

Okay.. sorry, Im just trying to figure out if this is going to work for me...

 

HOW do I change the images again? Im not quite sure where the images are located for things such as the header, etc, so I can alter those...

 

 

-jyn

 

Hello Friends,

 

I installed the bts 1.3 in a new installation of oscommerce. The adminastration now shows the templates area, and i uploaded everithing.But when  i chance the template in admin, nothing happens in the store.. anybody know what is happening... i believe that i made ebverithing correct...

 

Thanks,

 

Raphael

 

my store:

 

http://www.exoticgemsbrazil.com/store


=======,+'^'+,===============================

Jyn Meyer

`+,.,+' Be Glad the world sucks- if it didn't we would all fall off.

===========================================

Share this post


Link to post
Share on other sites

Also, I was wondering if you could tell me how to alter the keywords? Ive been squinting at the code for a while but Im being turned around in circles (seems typical of PHP though *grin*).

 

-Jyn

 

Hello Friends,

 

I installed the bts 1.3 in a new installation of oscommerce. The adminastration now shows the templates area, and i uploaded everithing.But when? i chance the template in admin, nothing happens in the store.. anybody know what is happening... i believe that i made ebverithing correct...

 

Thanks,

 

Raphael

 

my store:

 

http://www.exoticgemsbrazil.com/store

Edited by JynMeyer

=======,+'^'+,===============================

Jyn Meyer

`+,.,+' Be Glad the world sucks- if it didn't we would all fall off.

===========================================

Share this post


Link to post
Share on other sites
Im not quite sure where the images are located for things such as the header, etc
:rolleyes:

 

here: http://www.exoticgemsbrazil.com/store/temp...2-final/images/ ?

and/or right click on image in browser and choose properties

and/or ake a look at the stylesheet

etc.

 

why do you quote irrelevant information?

Edited by PandA.nl

Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

How to ADD any modules to BTS ?

And how create a diffrent template for evry categories ?

like for 1(first) categories blu template with different header image (not logo)

and for 2(second) categories red template with another header and images ?

 

(sorry by my broken English ;-) )

Share this post


Link to post
Share on other sites
How to ADD any modules to BTS ?
no idea. Or do you mean pages?

 

And how create a diffrent template for evry categories ?
I think you can simply change the body tag in your main template to:

<body id="<?php echo 'category_' . $current_category_id; ?>">

and use the stylsheet to change to change the looks for each category (and achieve your goal without any extra templates)


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×