Jump to content
Sign in to follow this  
paulm2003

BTSv1.2 Support

Recommended Posts

MOVADO !

 

Can you tell me, how do you fix this bug (BTS 1.3 + Category Box Enhancement) ?

I have this problem too :(

 

Thank you !

Share this post


Link to post
Share on other sites

Is there an "updated download" one with all of the updates installed. i looked and couldnt find one. i dont want to have to install the old version and throw all the updates on.. this is for a new install. Thanks for the help!

Share this post


Link to post
Share on other sites

I'm using BTS1.3 with 32-final template.

 

I want to add multi-images for each products.

 

For some contributions, I tried..

 

1. 3 images http://www.oscommerce.com/community/contri...l/search,images

2. additional images

http://www.oscommerce.com/community/contri...l/search,images

3. Ultrapic

http://www.oscommerce.com/community/contri...l/search,images

 

The main problem is.. product_info.php

 

I'm not good at BTS structure. I touched product_info.tpl.php in 32-final's content dir.

Is that correct method?

Even I have done it, it cause an error.

 

Is there easy to install "multi-images contribution" for BTS system?

 

Thank you for your time.

 

Rayc

Edited by rayc

Share this post


Link to post
Share on other sites

The install worked great! Thanks for this very useful contrib.

However I ran the mysql statement 3 times by accident. How can I fix this as I know very little about mysql??

 

thank you!

Share this post


Link to post
Share on other sites

I do not know much about this contribution, thus my question.

 

Which one in contributions do I download? there are a few, as some just seem to be one file updated.

 

It sure would make it nice, that if there is an update, the whole package is included with that file listed that is updated.

 

Then people like me can just go get the latest and away we go!


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Hi all,

I have the BTS 1.3 installed and I worked very hard to customize my template and I feel very happy with it now. BTS + some CSS knowledge can do very powerful things. I encourage to use it.

 

Next step, is to work on OSC to make it "seach engine friendly". I read hundreds of threads, webs and I talked to sucessfull webadmins, and I also talked to promoting and SEO companies. This is a very tricky thing indeed. This is not the right place for conclusions, but one thing remains completely clear:

 

The HEADER TAGS CONTROLLER is a MUST HAVE contribution.

 

I heard many convincing testimonials. This contributions basically deals with different page titles for every product. Google seems to ignore the rest of the meta tags and pays only attention to the title. This contrib. also have and admin tool to customize the title on product basis.

 

The point is that I am having problems to make it work with BTS. The last step in the installation states:

 

Modify a line in all files ( approximately 35 files ) where there is a <TITLE> tag:

These files are located in /catalog. A search for <title><?php echo TITLE; ?></title> will locate all the files needing a change.

 

In each file of /catalog/ you will need to make the following modification:

 

Replace the existing line in all files that you want to use the Header Tags Controller:

 

Old Line:

<title><?php echo TITLE ?></title>

 

New Lines:

<?php

// BOF: WebMakers.com Changed: Header Tag Controller v1.0

// Replaced by header_tags.php

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

  require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

  <title><?php echo TITLE ?></title>

<?php

}

// EOF: WebMakers.com Changed: Header Tag Controller v1.0

?>

 

But I can not follow this step as the "old line" does not show up due to I have BTS and many files were replaced.

 

I did not find any thread dealing with BTS and HEADER TAGS CONTROLLER. I have found many threads about STS and this contribution, as STS strongly recommends to install it.

 

So my questions are:

?Does anybody know how to install HEADER TAGS along with BTS?

?It is possible to use an existing BTS template with STS?

 

Thanks in advance

JAS

Share this post


Link to post
Share on other sites
The HEADER TAGS CONTROLLER is a MUST HAVE contribution.

it is, but NOT if you have installed the BTS!!!

 

The BTS (all versions) already has it's own header tags controller, I have been using it for some months now and it works great just as it is, and google loves it. So you don't have to do anything about it at all, it works fine right after you've installed the BTS. And if you still think you really need to change the way it works, you can take a look at "includes/meta_tags.php" (as I posted earlyer in this same thread :rolleyes: )

 

Please look at your site, if you've installed the BTS the dynamic header tags are already there :blink:

 

Another note: don't worry too much about Talons recent updates, without the updates the BTS works just fine and you will sell just as much. I don't say Talon is wrong, but Talon just has a very sharp vision, and he corrects errors others would never even have noticed.

 

Great work Talon177!

(but maybe it's better to upload a full version again, people seem to get confused now)

Share this post


Link to post
Share on other sites

Hi, I'm new for BST 1.3,

I have a stupid question maybe:

 

how can working on a templates and now using a clodes templates for under construction time ?

 

Anothe question:

 

there are contribution there is IMPOSSIBLE to install in this BST

 

Than you all

Share this post


Link to post
Share on other sites

Hello all, I discovered osCommerce about a week ago and set it up on a testing server to get to know it. I am going through the contributions and trying to get to know them as well. BTS sounds like a great contribution. My question to the group is, has anyone been able to get PayPal_Shopping_Cart_IPN to work with BTS? So far I have not had any luck, but since I am a OSC newbie it may be operator error.

 

I will also post on the PayPal_Shopping_Cart_IPN support forum.

Edited by cool_fritz

Share this post


Link to post
Share on other sites

Ok, it was operator error. I now have BTS & PayPal_Shopping_Cart_IPN living in harmony. Can't wait to dig into BTS. Cheers.

Share this post


Link to post
Share on other sites

One simple question (not sure if it's been covered already, so sorry if it was) - Is there a fast simple way to get rid of the background images that show up in the center column upper right corner? (the table_background_et.gif images).

 

I don't want to replace them with transparent images (been there done that) I just want them to go away, period.

Share this post


Link to post
Share on other sites

I just installed BTS 1.3 with all the patches, everything is up to date, everything is working properly, i downloaded the 32-final add-on as well. Everything looks good except one thing. I don't see the customer information when they log in. What i mean is that once a user is loged in, the usual customer options are missing. If i switch templates the options are there but with 32-final there is no

View or change my Account information
View or change entries in my Address Book
View the orders i have made etc.
Is that supposed to be like that because of the template and if so how can i get those feautures back. Thank you for your time and consideration.

---------------------------

One OS to fool them all

One browser to find them

One email client to bring them all

And through security holes, blind them...

Share this post


Link to post
Share on other sites

k i figured that out. i was trying to

require 'account.php'

and i totally forgot that i didn't install the login box contribution which i don't really need. The fact is that in 32-final My account is missing anyways. All i did was just changed one of the links on top "Company History" and changed it to "My Account" and i pointed the link to account.php. That's about it.

 

laterz


---------------------------

One OS to fool them all

One browser to find them

One email client to bring them all

And through security holes, blind them...

Share this post


Link to post
Share on other sites

Is there a link manager contribution (such as http://www.oscommerce.com/community/contributions,1256) that will work with BTS v1.3?

 

I try to adept VJ's Links Manager for osC(MS2) v1.01 for BTS, but since I am not too familiar with how either BTS or the link manager works, i haven't gotten much success.. if anyone knows where I can find a link manager that is already made with a reciporal link checker, it would be great!

Share this post


Link to post
Share on other sites

Have a problem. This is what I get on my catalog page

 

Welcome Guest! Would you like to log yourself in? Or would you prefer to create an account?

 

 

[SIZE=1]Warning: main(includes/languages/english/FILENAME_DEFINE_MAINPAGE): failed to open stream: No such file or directory in /home/huskyzco/public_html/catalog/templates/content/index_default.tpl.php on line 36

 

Warning: main(includes/languages/english/FILENAME_DEFINE_MAINPAGE): failed to open stream: No such file or directory in /home/huskyzco/public_html/catalog/templates/content/index_default.tpl.php on line 36

 

Warning: main(): Failed opening 'includes/languages/english/FILENAME_DEFINE_MAINPAGE' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/huskyzco/public_html/catalog/templates/content/index_default.tpl.php on line 36

 

Warning: main(includes/modules/FILENAME_DEFAULT_SPECIALS): failed to open stream: No such file or directory in /home/huskyzco/public_html/catalog/templates/content/index_default.tpl.php on line 42

 

Warning: main(includes/modules/FILENAME_DEFAULT_SPECIALS): failed to open stream: No such file or directory in /home/huskyzco/public_html/catalog/templates/content/index_default.tpl.php on line 42

 

Warning: main(): Failed opening 'includes/modules/FILENAME_DEFAULT_SPECIALS' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/huskyzco/public_html/catalog/templates/content/index_default.tpl.php on line 42[/size]

 

I have checked the path, and where neccessary copied files to the path where index_default is looking, but it seems unable to find the files above. Ha a look in configure.php, but as I am not a coder, I am stumped.

 

Would love to use the BTS update, can anyone help? Perhaps some define code for the confi file?

 

Aaaargh

Share this post


Link to post
Share on other sites

You need

  define('FILENAME_DEFINE_MAINPAGE', 'define_mainpage.php');
 define('FILENAME_DEFAULT_SPECIALS', 'specials.php');

or something similar in includes/filenames.php (or includes/application_top.php if there is no includes/filenames.php). I'm not sure of the exact filenames that go in the second pair of quotes in each line.

 

Hth,

Matt


Always back up before making changes.

Share this post


Link to post
Share on other sites

ARGH!

 

Perhaps I am just missing something, or there isnt ANY kind of documentation for BTS (Basic Template Structure) regarding the configuration of each infobox on an individual basis. I've tried setting background colors for the shopping cart infobox, as an example...and it didnt work.

 

Oddly enough, the text color seems to work for that particular infobox, but I cant seem to reference a background color for the table content. Here is a snippet of the code:

 

/* example how to assign styles to one individual small infobox (delete if you don't like) */
table#shopping_cartBoxLT {
font-weight: bold;
color: #487DB4;
background-color: #487DB4;
}
table#whats_newBoxLT {
font-weight: bold;
color: #FFFFFF;
background-color: #FFFFFF;
}

 

You'll also notice that I tried to add a unique class for the whats_new infobox, but I'm not sure where else I should be referencing/creating the relevant whats_new box css reference.

 

Here's the site URL: http://www.ajewelryshop.com

 

Essentially, I'm trying to manipulate the unique background color, text, and header graphic for the whats_new infobox.

 

Anyone's help here would be greatly appreciated.

 

Thx,

 

-Codi


Carpe Carp: Seize the Fish.

Share this post


Link to post
Share on other sites

Ok...looks like I am figuring out how to modify the infoboxes, now. Anyone have a guess as to how someone might align the infobox to the center of the column?

 

Also, I'm still trying to figure out if there is a way to modify the center "New Products in..." box. Haven't a clue???

 

Thx,

 

-Codi


Carpe Carp: Seize the Fish.

Share this post


Link to post
Share on other sites

HAH. Already figured out how to align the infobox correctly with pixels.

 

I guess that just leaves me with the middle "new products" infobox question??!?


Carpe Carp: Seize the Fish.

Share this post


Link to post
Share on other sites

Does anyone know how to have 6 rows of products on the new products/index page? instead of the defualt 3.

 

Danny

Share this post


Link to post
Share on other sites

Hi

 

Another Newbie I'm afraid!

 

Having problems with the BTS install (done it 3 times now!!) and get the following error

 

Warning: main(templates/main_page.tpl.php): failed to open stream: No such file or directory in /hsphere/local/home/bikermar/sitebymark.co.uk/catalog/index.php on line 150

 

Warning: main(templates/main_page.tpl.php): failed to open stream: No such file or directory in /hsphere/local/home/bikermar/sitebymark.co.uk/catalog/index.php on line 150

 

Fatal error: main(): Failed opening required 'templates/main_page.tpl.php' (include_path='.:/usr/local/lib/php') in /hsphere/local/home/bikermar/sitebymark.co.uk/catalog/index.php on line 150

 

Anyone help??

Share this post


Link to post
Share on other sites
Warning: main(templates/main_page.tpl.php): failed to open stream: No such file or directory in

Looks like you've got a left over from an older BTS version (older than v1.2). You should first install osC2.2MS2 (really fresh install unless you know what you're doing) and then the latest BTS version only.

 

It's normal that templates/main_page.tpl.php does not exists in BTS1.3 (it's in a subdir of templates) that was only the case in older versions.

Edited by John-Doe

Share this post


Link to post
Share on other sites

I have just installed the bts system over a clean install of ms2

 

Sorry to be thick but how do i use it?

 

regards

 

mark


Regards

 

Mark A Reynolds

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×