Jump to content
Sign in to follow this  
sw45859

Custom Computer Creator v9 Support

Recommended Posts

hi,

 

ive just installed this contrib and have seen some working examples from the ccc forum (now inactive) and I just want to know if my admin should look like this:

i cant seem to figure out how to link my products to my drop down menu

 

i only seem to have 3 options in my admin

ccc config

ccc options

pending builds

 

???

Untitled-2.gif

 

Should I not have more options?

 

Thanks,

rushy

Share this post


Link to post
Share on other sites
hi,

 

ive just installed this contrib and have seen some working examples from the ccc forum (now inactive) and I just want to know if my admin should look like this:

i cant seem to figure out how to link my products to my drop down menu

 

i only seem to have 3 options in my admin

ccc config

ccc options

pending builds

 

???

 

Should I not have more options?

 

Thanks,

rushy

That's right, now you setup your builds under ccc options and add parts to the build. This is done by adding a category->subcategory->parts available method. First create a build(model) name. Then add category (ie Motherboard) then add parts for that category (ie MSI KM4AM-LV). Then when you go to http://www.yoursite/catalog/ccc.php you will see your model listed. Click it, and it will show your model. click it, and you will see the motherboard drop down selection box.

Share this post


Link to post
Share on other sites
That's right, now you setup your builds under ccc options and add parts to the build. This is done by adding a category->subcategory->parts available method. First create a build(model) name. Then add category (ie Motherboard) then add parts for that category (ie MSI KM4AM-LV).  Then when you go to http://www.yoursite/catalog/ccc.php you will see your model listed. Click it, and it will show your model. click it, and you will see the motherboard drop down selection box.

 

Thanks, mate, i can see what I'm doing now.

 

The only problem I have now is how to change the output of the build.php to actually fit into my page. It kicks itself out of alignment, even when I set the table to 732 px like the rest of my site and align it centre. for some reason the build.php kicks out to the left by about 100 pixels...

 

Also, has anyone successfully managed to change the look of this contribution for the customer end? And if anyone can give me pointers on where to start...?

Share this post


Link to post
Share on other sites

Rushy,

Mod the look from the ccc.php file around line 80 for the first screen around line 145-170 or so for the second screen. You can re table that stuff add an image or 2 to get a pretty good look. I added a couple of fields to the db for image files and called them as well as the text in the ccc.php, particularly ccc_fsb_description and ccc_systems_description. Take a look at www.snjcomputers.com/forum the "official CCC support forum" :thumbsup: Leandroc76 reformatted his build.php table to a pretty good look. FYI If you add a pic to the build.php page pulling from the ccc db it will be a broken link if the customer clicks edit from shopping cart page(because the build then becomes a product). You would need another array and an else to then pull the pic from the product_description table if you set up for the image to load into the product_description table. I hope this makes sense. Dig in, it does work but you need some skills its not for the faint of heart.

Share this post


Link to post
Share on other sites

hiya dootch,

 

im not skilled at all with php so this contrib is making hard work. Im learning as i go i must admit. One minute i think ive got it sussed the next something else goes tits up. Anyway, i managed to formet the page so that it integrates well with my site, the problem Im now having is that when the system has been selected and I click on 'continue' there is nothing in my cart. This didnt happen the other day so something ive recently changed has buggered it all up.

 

Just wondering if anyone has a fix for this issue before i roll back my files?

 

Thanks,

rushy

Share this post


Link to post
Share on other sites

Hi all,

 

I've installed this wonderful added on for oscommerce and spent so many hours to figure out how to use it. I would like to add a custom item just like any other regular item (products) where the user can browse through the categories menu and click on it.

 

I saw this guy has something that I want exactly like him. Can someone look at it and tell me if this guy use this mod and how do i do like him.

 

Here is the link:

 

http://www.allerc.com/product_info.php?cPa...roducts_id=1341

 

Thanks

Share this post


Link to post
Share on other sites
hiya dootch,

 

im not skilled at all with php so this contrib is making hard work.  Im learning as i go i must admit.  One minute i think ive got it sussed the next something else goes tits up.  Anyway, i managed to formet the page so that it integrates well with my site, the problem Im now having is that when the system has been selected and I click on 'continue' there is nothing in my cart.  This didnt happen the other day so something ive recently changed has buggered it all up. 

 

Just wondering if anyone has a fix for this issue before i roll back my files?

 

Thanks,

rushy

I had this same problem cause i was using CREloaded osc v6.51 with this contribution. The script tried sending the build before the header. I wrote some javascript to send it onclick rather than $_POST.

/catalog/custom_checkout.php

add to top

function popup($vMsg,$vDestination) {
echo("<html>\n");
echo("<head>\n");
echo("<title>System Message</title>\n");
echo("<meta http-equiv=\"Content-Type\" content=\"text/html;
charset=iso-8859-1\">\n");

echo("<script language=\"JavaScript\" type=\"text/JavaScript\">\n");
echo("alert('$vMsg');\n");
echo("window.location = ('$vDestination');\n");
echo("</script>\n");
echo("</head>\n");
echo("<body>\n");
echo("</body>\n");
echo("</html>\n");
exit;
}
around line 133
$header_url = tep_href_link(FILENAME_SHOPPING_CART, tep_get_all_get_params(array('action')).'action=buy_now&products_id='.$ccc_prod_id);
 if ($HTTP_GET_VARS['edit'] == '1'){
 //tep_redirect(tep_href_link(FILENAME_SHOPPING_CART, 'action=update_product'));
 popup('System has been added to cart.',$header_url);
 }else{

 popup('System has been added to cart.',$header_url);
 //echo '<a href="'.tep_href_link(FILENAME_SHOPPING_CART, 'action=buy_now&products_id='.$ccc_prod_id).'"><img src="'.DIR_WS_TEMPLATES . TEMPLATE_NAME.'/images/buttons/english/button_confirm.gif"></a>';
 //tep_draw_form('confirm_cart',$header_url .'action='.$header_url);

 }

Share this post


Link to post
Share on other sites

thx mate, i tried it and it seems to solve the problem! Ill just wait for the next one ;-) Although I must admit I'm kinda leaning towards Master Products 2 now with my custom pc builder sending users to the base build and then giving them the chance to add products to the build.

 

Seems to be a lot less buggy.

Share this post


Link to post
Share on other sites

Does anyone know, or have an idea, how to change so the prices in the red circles shows prices with "tax included" instead of "tax excluded" as it is now.

 

I have found out that the prices is written to the layers "pricing", "pricing3a" and "pricing4a" when selecting products in the dropdown box, and when making choises in the radio buttons.

 

I have looked, and tried to find a solution in "build.php" and "java.php" but simply not find any solutions so far.

 

I'm ripping my hair out over this one! Please help!!

 

include_tax.gif

 

/Christer

Share this post


Link to post
Share on other sites

Can someone please help me figure out how to display the product image on the ccc_more_info.php page?

Edited by kbell62

Share this post


Link to post
Share on other sites
i was told to move over to a new thread so i have done that, anyone who needs help with ccc9 please post here.

 

Does anyone know of a quick way (an mysql query) that will copy all of the products from the first system I created into all the other systems?

Share this post


Link to post
Share on other sites

I installed ccc 9.3 at: www.bigbangtech.com.

 

When I configure a system and checkout, it does not add the $100 build fee...

 

Also, in the Admin, I don't see any pending orders to build.

 

What am I missing here?

Share this post


Link to post
Share on other sites
I installed ccc 9.3 at: www.bigbangtech.com.

 

When I configure a system and checkout, it does not add the $100 build fee...

 

Also, in the Admin, I don't see any pending orders to build.

 

What am I missing here?

 

Fixed the build fee issue by turning it on in Admin LOL

 

But, I'm still not seeing pending builds in ccc admin, and in the regular orders section, if I try to update the build status to "building", nothing happens, and I get the "nothing to update" message...

Share this post


Link to post
Share on other sites

Hi guys,

 

I don't get any responses when asking for help in the support forum so I'm hoping that this thread still has some active people that know a thing or two about CCC9.3

 

I have a few questions so I'll use a list...

  1. Does anyone know how to use images instead of dropdown menus for attributes?
  2. How can I add extra radio button options? (eg: RAID? NO / STRIPE / MIRROR)
  3. How do I add checkbox options? (eg: ADD SOFTWARE? OPTION1 OPTION2 OPTION3)
  4. Can I add text options? (eg: What username would you like on administrator account?)
  5. Why does CCC add tax to build and warranty prices twice?
  6. Can the custom_checkout.php be skipped as it is redundant?
  7. Why do I get page expired if I use back button from custom_checkout.php?
  8. How do I insert linebreaks after components listed in order confirmation email?

Any help would be fantastic as these are the issues that I'm currently facing (I'm sure there will be many more..lol)

 

Carbon

Share this post


Link to post
Share on other sites
Hi guys,

 

I don't get any responses when asking for help in the support forum so I'm hoping that this thread still has some active people that know a thing or two about CCC9.3

 

We're dead, Jim!

Share this post


Link to post
Share on other sites

I configured some default parts for a system. But in my site, although it shows those default parts as choosen but sub total shown as 0.00!! If I change something in the drop down list of any parts, then it shows the price at sub total. If anyone knows the solution or have some suggestion, please help!

 

How can I change the price value i.e. 120.00 to 120,00?

 

Thanx

Share this post


Link to post
Share on other sites

I am having a very hard time installing CCC 9.3 I can't get the admin function to add components and am having a very hard time figuring out how to add components to the database.

 

Could someone give me a bit of an idea? like how to modify the ccc database and add components and new systems.

Share this post


Link to post
Share on other sites
I am having a very hard time installing CCC 9.3 I can't get the admin function to add components and am having a very hard time figuring out how to add components to the database.

 

Could someone give me a bit of an idea? like how to modify the ccc database and add components and new systems.

 

Hi Kate,

 

It's a common problem (there is NO documentation) so I'll give you the quick version.

 

First of all, using the normal OSCommerse "Catalog" section add a new product (eg: a graphics card), you may want to set up categories first (like "Components") but once you have created your product then go back to the "CCC Options" section. You need to set up at least one main category like "AMD Based systems" then at least one sub-category like "Value System" then by clicking on the little yellow folder icon on the left you can add sections (like Graphics) to your "AMD Based System > Value System".

 

Once you have made it this far down the tree you can then click the "Add Product" button which opens up a little browse type window showing all the products in your normal OSCommerse stock.

 

In this example you would browse to the Graphics card you added. You can then select things like "is it a required component or optional", "Does your Super-duper AMD system need a Graphics card too?". Once you've added one, the rest will be easy.

 

PS click the dimmed out light on the items entry to make it the default choice ;)

 

Anyhoo.. this should get you on your way.

 

Carbon

Share this post


Link to post
Share on other sites
Hi guys,

 

I don't get any responses when asking for help in the support forum so I'm hoping that this thread still has some active people that know a thing or two about CCC9.3

 

I have a few questions so I'll use a list...

 

Carbon

  1. Does anyone know how to use images instead of dropdown menus for attributes?
    Probably not....Tried coding radio buttons which didn't work well either
  2. How can I add extra radio button options? (eg: RAID? NO / STRIPE / MIRROR)
    Pretty hard to do the way the java, and script is written...more or less a templete for every component
  3. How do I add checkbox options? (eg: ADD SOFTWARE? OPTION1 OPTION2 OPTION3)
    Just create them in your admin. Put all available software in each option.
  4. Can I add text options? (eg: What username would you like on administrator account?)
    I would add these to custom_checkout.php
  5. Why does CCC add tax to build and warranty prices twice?
    Not sure on that
  6. Can the custom_checkout.php be skipped as it is redundant?
    The custom_checkout.php is needed b/c there are no product_ids since they are custom builds. The custom_checkout.php creates a product in the products table as Custom.
  7. Why do I get page expired if I use back button from custom_checkout.php?
    The script is coded to make you use the edit link in the shopping cart.
  8. How do I insert linebreaks after components listed in order confirmation email?
    It's been awhile since I edited this script, but I do remember parsing the text into a table when the build is added to the products_description table. I have yet parsed the html to mime html for the email sent to the customer.

Any help would be fantastic as these are the issues that I'm currently facing (I'm sure there will be many more..lol)

Share this post


Link to post
Share on other sites
  1. Does anyone know how to use images instead of dropdown menus for attributes?
    Probably not....Tried coding radio buttons which didn't work well either
     
     
  2. How can I add extra radio button options? (eg: RAID? NO / STRIPE / MIRROR)
    Pretty hard to do the way the java, and script is written...more or less a templete for every component
     
     
  3. How do I add checkbox options? (eg: ADD SOFTWARE? OPTION1 OPTION2 OPTION3)
    Just create them in your admin. Put all available software in each option.
     
     
  4. Can I add text options? (eg: What username would you like on administrator account?)
    I would add these to custom_checkout.php
     
     
  5. Why does CCC add tax to build and warranty prices twice?
    Not sure on that
     
     
  6. Can the custom_checkout.php be skipped as it is redundant?
    The custom_checkout.php is needed b/c there are no product_ids since they are custom builds. The custom_checkout.php creates a product in the products table as Custom.
     
     
  7. Why do I get page expired if I use back button from custom_checkout.php?
    The script is coded to make you use the edit link in the shopping cart.
     
     
  8. How do I insert linebreaks after components listed in order confirmation email?
    It's been awhile since I edited this script, but I do remember parsing the text into a table when the build is added to the products_description table. I have yet parsed the html to mime html for the email sent to the customer.

Any help would be fantastic as these are the issues that I'm currently facing (I'm sure there will be many more..lol)

 

 

Joe, I'd love to say "thanks, you're the man... can I buy you a beer?".... but I can't, you've got nothing ;)

 

Next.

 

Carbon

Edited by Carbon

Share this post


Link to post
Share on other sites

I tried this contrib but it didnt work out for me due to certain limitations, but I love the order total$ function. How hard would it be to extract that to be used with regular attributes?

Share this post


Link to post
Share on other sites

Hello to everything.

I have installed the contribution CCC 9.3 and me work all well until it arrives about to buy in (checkout_shipping.php), then in explorer it visualizes a white page.

 

somebody can help me

thank you

Share this post


Link to post
Share on other sites

I am having difficulties installing it onto my system.

 

I have tried it twice with these following errors:

 

Parse error: parse error, unexpected '<' in /home/brownie/public_html/catalog/includes/filenames.php on line 24

 

The main thing i need to ask is how do you enter database entries? Its just the last step in the 'readme' that i need help with.

 

Is there any other documentation with this config. Any help would be appreciated. You can instant message me on:

 

matty_the_man@hotmail.com or

 

mr.brownie@gmail.com for email.

 

Regards Matt

Share this post


Link to post
Share on other sites

Hi,

 

I'm manually updating my OSC installation as detailed here... hXXp://www.oscommerce.com/ext/update-20051113.html#_Toc119693706

 

The catalog/includes/classes/shopping_cart.php file needs updating but when you do CCC no longer transfers your custom computer to the shopping cart.

 

Does anyone have a fix for this?

 

Cheers

 

Carbon

Edited by Carbon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×