Jump to content
Sign in to follow this  
sw45859

Custom Computer Creator v9 Support

Recommended Posts

Hey, I get this error after a installation... I'm using STS4 also.

 

Warning: require(includes/languages/english/ccc.php) [function.require]: failed to open stream: No such file or directory in /public_html/shop/admin/ccc_config.php on line 15

Fatal error: require() [function.require]: Failed opening required 'includes/languages/english/ccc.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /public_html/shop/admin/ccc_config.php on line 15

 

All help appreciated!

Share this post


Link to post
Share on other sites

And another.

 

Warning: require(includes/languages/english/ccc.php) [function.require]: failed to open stream: No such file or directory in /public_html/shop/admin/pending.php on line 14

Fatal error: require() [function.require]: Failed opening required 'includes/languages/english/ccc.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /shop/admin/pending.php on line 14

Share this post


Link to post
Share on other sites
reply damit!

 

Hey There!

 

Both warnings are because there is no ccc.php language file present in the admin/includes/languages/english/ folder.

 

So, in the contribution's admin/includes/languages/English/ folder there are two language files: ccc.php & view_prod.php (note: for some reason the contribution's folder has a capital E in English, when it's actually lower case english)

 

You are missing at least the admin/includes/languages/english/ccc.php file. When you place this file in the english admin language folder both errors will be gone.

 

Regards,

 

JF

 

P.S. I'm not familiar with STS4, so it's possible that the language files have a different path, if so you would place the ccc9.3.1 contribution's admin/includes/languages/English/ccc.php file wherever the other language files are with the STS4 contribution.

Edited by JFrancis

Share this post


Link to post
Share on other sites

Hi Guys

 

Ive loaded Custom Computer Creator on to my Winodws server 2003 test rig. All I get when I go tot he home page is a blank white screen. If I log onto my admin page the left menu comes up but all the optins on the right are blank.

 

Any ideas?

 

Matt

Share this post


Link to post
Share on other sites

Hi All

 

i have a little problem after install CCC 9.3.1

Please give me advice how to change :

 

1. Price in another currency ( because my default is Rp. ) whenever i want to change the currencies, but the price not converted to currencies ( i had try to change at cataloq/includes/language/english.php set USD to IDR ) but nothing change.

 

2. How to define specified the LINKS in ccc.php so i can make thumbnail at index and direct links to AMD GAMERS PC at build.php example at http://www.digitalstormonline.com/gamingcomputers.asp

 

3. why there is not different at ccc.php ( Would You Like Pictures To Be Displayed? yes / no ) if i click no, there still display picture at build.php

 

Thanks before for All Authors and Support Dev Team special thanks to Carbon

 

I'm considered look forward and waiting for reply

Share this post


Link to post
Share on other sites

Well I took the leap to try to get the CCC scrips working.

 

I worked through most of the issues but I am stuck. On the main cart page I get

 

Error!

 

Unable to determine the page link!

 

Then If I refresh the page or try to open ccc.php I get this error

 

Fatal error: Call to a member function add_current_page() on a non-object in /home/redrockc/public_html/catalog/includes/application_top.php on line 312

 

I have tried a few workaronds for that error but non seem to work.

 

Any assistance would be appreciated or if anyone else can recomend another script for custom configurations.

 

Thanks,

 

David

Share this post


Link to post
Share on other sites

Hi people.

I have one question.

I want to have just one editable computer. Now customers have to push through two "useless" ccc.php pages.

Can i make the Custom Computer link go directly to build.php? It didnt work to just edit the link itself from ccc.php to build.cc.

 

Any help would be much appreciated.

 

Regards Morten

pcdeler.net

Edited by Mortenjan

Share this post


Link to post
Share on other sites
Can i make the Custom Computer link go directly to build.php? It didnt work to just edit the link itself from ccc.php to build.cc.

 

Hi,

 

If you go to the last link created in ccc.php (2nd useless ccc page!), and view the source, you will see that the link is within a form with hidden values, example:

		<table border="0" cellpadding="0" cellspacing="0" width="100%">
	<form action="http://your_website/catalog/build.php" name="a7" method="POST">
	   <input type="hidden" name="systype" value="3">
	   <input type="hidden" name="fsb" value="7">
	   <input type="hidden" name="pics" value="y">
	 <tr class="ccc" onclick="submit(a7)" onmouseover="rowOverEffect(this)" onmouseout="rowOutEffect(this)">
	  <td width="100%" align="center" valign="top">
	   <table border="0" cellpadding="0" cellspacing="0" width="100%">
		<tr>
		 <td align="center" style="font-size: 22pt;">
		  Business Computer
		 </td>
		</tr>
	   </table>
	  </td>
	 </tr>
	</table>
	</form>

Copy the code, including the specific hidden values (systype & 3, fsb & 7, pics & y), and place the copied code wherever you like (as long as it's not within another form).

 

Regards,

 

JF

Share this post


Link to post
Share on other sites
Hi,

 

If you go to the last link created in ccc.php (2nd useless ccc page!), and view the source, you will see that the link is within a form with hidden values, example:

		<table border="0" cellpadding="0" cellspacing="0" width="100%">
	<form action="http://your_website/catalog/build.php" name="a7" method="POST">
	   <input type="hidden" name="systype" value="3">
	   <input type="hidden" name="fsb" value="7">
	   <input type="hidden" name="pics" value="y">
	 <tr class="ccc" onclick="submit(a7)" onmouseover="rowOverEffect(this)" onmouseout="rowOutEffect(this)">
	  <td width="100%" align="center" valign="top">
	   <table border="0" cellpadding="0" cellspacing="0" width="100%">
		<tr>
		 <td align="center" style="font-size: 22pt;">
		  Business Computer
		 </td>
		</tr>
	   </table>
	  </td>
	 </tr>
	</table>
	</form>

Copy the code, including the specific hidden values (systype & 3, fsb & 7, pics & y), and place the copied code wherever you like (as long as it's not within another form).

 

Regards,

 

JF

 

 

Hi, thanks for the assistance!

Ive now copied the whole script and html code in "build.php" into my new page.

 

Works like a dream!

But now i got one problem. If i update the configurator with new products, the page wont update? Am i right? How can i solve this?

 

Thanks again for the help. Much appreciated.

Regards Morten

Share this post


Link to post
Share on other sites
If i update the configurator with new products, the page wont update? Am i right? How can i solve this?

Hi,

 

You'll have to repeat the process if you add another separate system configurator to your site.

 

You won't have to, if you are just updating the same system configurator (if you are just adding or removing products/components from your present system configurator setup).

 

G'Luck!

 

JF

Share this post


Link to post
Share on other sites
Hi,

 

You'll have to repeat the process if you add another separate system configurator to your site.

 

You won't have to, if you are just updating the same system configurator (if you are just adding or removing products/components from your present system configurator setup).

 

G'Luck!

 

JF

 

hm.. i tried to update the same system configurator.. doesnt work.

This is how it looks now: System configurator

 

(remember, i copied the hole script and html code directly from BUILD.php into my new page)

Thanks for the respons.

Regards Morten

Edited by Mortenjan

Share this post


Link to post
Share on other sites

Hey!

 

If you want to not have to redo it each time you modify, just use the example form from the earlier post, (replacing the 3 hidden values with your own) as your link to your configurator.

 

Regards,

 

JF

Share this post


Link to post
Share on other sites

Can i use that link in for example a box? So customers can push once to enter build.php?

 

As i see it now, you first have to make a custom page with that link, and from there enter build.php

 

Thanks

Regards Morten

Share this post


Link to post
Share on other sites

I've now pasted this code into my box:

 

      
<table border="0" cellpadding="0" cellspacing="4" style="border-collapse: collapse" bordercolor="#111111" width="100%">
       <form action="http://pcdeler.net/build.php" name="a7" method="POST">
        <tr class="ccc" onclick="submit(a7)" onmouseover="rowOverEffect(this)" onmouseout="rowOutEffect(this)">
         <td width="100%" align="center" class="main" valign="top"> 
          <input type="hidden" name="systype" value="6">
          <input type="hidden" name="fsb" value="7">
          <input type="hidden" name="pics" value="y">
         <font style="font-size: 11pt; font-family: Arial; ">PC konfigurasjon</font><br>

         <font style="font-size: 10px; font-family: Arial; "></font>
         </td>
        </tr>
        <tr>
         <td align="center"><img src="images/pixel_black.gif" border="0" alt="" width="50%" height="1"></td>
        </tr>
        </form>

 

But the link is not usable. The cursor changes, but nothing happends when pushing the link.

 

Any help is much appreciated.

Regards Morten

Share this post


Link to post
Share on other sites

Just a small question. It would be great to have a small scrollable information box about the selected products(Like the "more information" popup, just in the same page, in a box). Is this possible?

 

Regards Morten

Share this post


Link to post
Share on other sites

Ok I am in need of some help.

I have installed ccc and made the changes to my sql and now when i go to ccc Options in the admin panel i get.

 

1146 - Table 'mindyour_osc2.TABLE_CCC_SYSTEMS' doesn't exist

 

select c.*, cd.* from TABLE_CCC_SYSTEMS c, TABLE_CCC_SYSTEMS_DESCRIPTION cd where c.sys_id = cd.sys_id and cd.language_id = '1'order by sort_order asc

 

[TEP STOP]

 

anyone have an idea or a fix for this?

 

Thanks in advance Samsara

Share this post


Link to post
Share on other sites

Hi there, i need your help.

 

I´ve got my "custom computer creator" installed.

Everything works fine.

But if someone is ordering a "Custom Computer" my Stock don´t getting Subtract.

 

Well,...does anybody got an idea where the problem is or what php-files i have to check?

(sorry for my bad english)

 

Greetings from Germany

Jan

Share this post


Link to post
Share on other sites

Hi Guys,

 

It's been a while so I thought I'd drop by and let you know what I've managed to do with my CCC installation. The latest addition is the ability to let the customer tailor their Windows Desktop environment (Wallpaper, pointers etc).

 

Anyhoo, the interesting bit is that I came up with a unique spin on the old "Radio Button" problem (ie nobody can get the buggers to work). What I did was to create a wrapper that acts as a go-between the presentational code (nice image buttons) and the original <select> dropdown menu (which is then hidden).

 

If you're interested in taking a look, testing or commenting then read this article and follow the link...

 

Read the news article

Share this post


Link to post
Share on other sites

Hey guys great mod. Just wondering what other people have done with this mod to make it suit there needs. Im wanting to use this mod but change a few things one thing is send the items as there own product to the shopping cart not as a bundled product. Just wondering if anyone has had any luck with doing that?

Share this post


Link to post
Share on other sites
Hey guys great mod. Just wondering what other people have done with this mod to make it suit there needs. Im wanting to use this mod but change a few things one thing is send the items as there own product to the shopping cart not as a bundled product. Just wondering if anyone has had any luck with doing that?

 

Hi Glycerine (Cool handle btw),

 

I'm guessing that you dont have OSC (OSCommerce) or CCC (Custom Computer Configurator) installed as your question is a bit confusing. By default OSC is designed to sell individual items, so you could easily sell a single component or multiples. When you add the CCC modification it adds the ability to group products from within OSC and create a new product based on the customer's selections.

 

Hope that answers your question.

 

Carbon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×