Jump to content
Sign in to follow this  
sw45859

Custom Computer Creator v9 Support

Recommended Posts

I customised my site by installing a default OSC and getting it working, then adding CCC and checking that everything worked as intended. Only then did I begin to modify files.

That's the way I do.

But ccc is the most worst contribution to modify I have ever seen until now.

Unfortunately, my site is sooooo bespoke that it would be impossible to wrap it all up and offer it as a mod as I've almost changed every single file!

Is it? I thought you implemented these "help me to decide" button. I saw it one time in this thread and the users post was about his new implementations for ccc.

I think I can't offer my changes also but normaly I try to post the changes in the contribution threads (because I make a documentation on what I have changed) and sometimes when I did a lot I also upload the contribution (I make a manual for installation and include also the changed files so you can override the default oscommerce 2.2 rc1 files to see the changes).

Share this post


Link to post
Share on other sites

Sorry for the late answer, but I was in hospital from middle of november to middle of december (six weeks).

 

Grinse, try this instead...

 

echo "var _n" . $j . " = \"<img src='images/image_enlarge.gif' title='".TEXT_ENLARGE_IMAGE."' onclick=java script:ccc_popup(\'ccc_image.php?image=\"\n";

Perfect thanks!! But there are two small corrections needed: You can't seperate "javascript" and also you must specify the cursor type because if not there is the default one (and the user doesn't know that this is a link).

So here's the correct line (you must replace it in java.php):

echo "var _n" . $j . " = \"<img src='images/image_enlarge.gif' title='".TEXT_ENLARGE_IMAGE."' style='cursor:pointer' onclick=java script:ccc_popup(\'ccc_image.php?image=\"\n";

Now I have to implement the $language variable within java.php or another way to access the language specific directory, so the image can be language specific.

 

... by using the <input type="image"> it was acting like a submit button and posting the form.

Is it? I didn't know.

 

You searched people for testing your site? I wanna have a look on your ccc implementations - if still possible.

 

 

Edit:

Ok here's the final line with multilanguage support:

echo "var _n" . $j . " = \"<img src='" . DIR_WS_LANGUAGES . $language . "/images/buttons/image_enlarge.gif' title='".TEXT_ENLARGE_IMAGE."' style='cursor:pointer' onclick=java script:ccc_popup(\'ccc_image.php?image=\"\n";

Edited by Grinse

Share this post


Link to post
Share on other sites
You searched people for testing your site? I wanna have a look on your ccc implementations - if still possible.

 

Hi Grinse,

 

I'm currently working on the "Design a System" section (last out of three, Select, Customise and Design) which allows the user to specify ANY component they want and request a quote. I should have it done towards the end of this week.

 

If you want to have a look around just click here.

 

Cheers

 

Carbon

Share this post


Link to post
Share on other sites
Hi Grinse,

 

I'm currently working on the "Design a System" section (last out of three, Select, Customise and Design) which allows the user to specify ANY component they want and request a quote. I should have it done towards the end of this week.

 

If you want to have a look around just click here.

 

Cheers

 

Carbon

 

What the hell... great work. It was difficult to "find" ccc working because it's such customized!

Excelent work! Are you using STS for the theme? If, how did you manage the ccc_more_info.php to show the right way? Because if I activate sts and click on ccc_image.php or ccc_more_info.php I only get a new window (the php file selected) but it's showing me just the layout of the index.php from the selected template (no content, and the placeholder names left and right (in the way i selected them in my theme).

 

Also funy: when sts is active the selected components images are not showen. I have to select another option first to see an image.

 

screenshot1mu9.th.png

Share this post


Link to post
Share on other sites
What the hell... great work. It was difficult to "find" ccc working because it's such customized!

Excelent work! Are you using STS for the theme? If, how did you manage the ccc_more_info.php to show the right way? Because if I activate sts and click on ccc_image.php or ccc_more_info.php I only get a new window (the php file selected) but it's showing me just the layout of the index.php from the selected template (no content, and the placeholder names left and right (in the way i selected them in my theme).

 

Also funy: when sts is active the selected components images are not showen. I have to select another option first to see an image.

 

screenshot1mu9.th.png

 

Hi Grinse,

 

Thanks for the compliments.

 

I don't use any templates or themes and all coding is done by hand in NotePad2. I rewrote ccc_more_info.php because (IIRC) it only displays the description text entered into a catalog item and I wanted more, however it wouldn't work for someone else because it loads (and then includes) small files ascociated with each product that I use in the main part of the site (the showroom) which contain variables like product name, image, manufacturer, specs etc etc so instead of entering a description into my products (in OSC) I just enter the path to the relevant product file.

 

Carbon

Share this post


Link to post
Share on other sites

I have a problem:

 

At the moment i'm changing syntax so i could enable lightbox for images (and in the next step integrate more pics).

But my problem now it to convert a "onclick=javascript[...]" to "<a href'[...]".

 

The line that has to be changed is:

echo "var _p" . $j . " = \"<input type='button' value='".TEXT_ENLARGE_IMAGE."' onclick=java script:ccc_popup(\'ccc_image.php?image=\" + document.builds.new" . $j . ".options[document.builds.new" . $j . ".options.selectedIndex].getAttribute(\"model\") + '\')>'\n";

You'll find it in java.php but within these file its splitted (around line 143 - 146).

 

I tried first:

echo "var _p" . $j . " = \"<a href='' onclick=java script:ccc_popup(\'ccc_image.php?image=\" + document.builds.new" . $j . ".options[document.builds.new" . $j . ".options.selectedIndex].getAttribute(\"model\") + '\')>".TEXT_ENLARGE_IMAGE."</a>'\n";

The result: I get a new window with the image but I also get a white blank new window.

 

Second try was:

echo "var _p" . $j . " = \"<a href='\'ccc_image.php?image=\" + document.builds.new" . $j . ".options[document.builds.new" . $j . ".options.selectedIndex].getAttribute(\"model\") + '\'' target='_blank' >".TEXT_ENLARGE_IMAGE."</a>'\n";

But the result here: Something must be wrong because I don't even get a normal image with the click to enlarge button / text.

 

Does someone know what I should do to succeed?

Share this post


Link to post
Share on other sites

Hi Grinse,

 

Had a quick look and hashed this code up. It's untested so if it doesn't work let me know the error and I'll take a look...

 

echo "var _p" . $j . " = \"<a href='java script: ccc_popup(\'ccc_image.php?image=\" + document.builds.new" . $j . ".options[document.builds.new" . $j . ".options.selectedIndex].getAttribute(\"model\") + '\')>'" .TEXT_ENLARGE_IMAGE. "</a>\n";

 

Carbon

Share this post


Link to post
Share on other sites
Hi Grinse,

 

Had a quick look and hashed this code up. It's untested so if it doesn't work let me know the error and I'll take a look...

 

echo "var _p" . $j . " = \"<a href='java script: ccc_popup(\'ccc_image.php?image=\" + document.builds.new" . $j . ".options[document.builds.new" . $j . ".options.selectedIndex].getAttribute(\"model\") + '\')>'" .TEXT_ENLARGE_IMAGE. "</a>\n";

 

Carbon

 

Hi Carbon,

There's no error message, but it's not working. It's the same as it was with my second try: The "click to enlarge" field is not showing and the image also not aviable (just a red cross for a broken image link if you test it for example with ms internet explorer).

Share this post


Link to post
Share on other sites
Hi Carbon,

There's no error message, but it's not working. It's the same as it was with my second try: The "click to enlarge" field is not showing and the image also not aviable (just a red cross for a broken image link if you test it for example with ms internet explorer).

 

Hi Grinse,

 

Here's another go. Unfortunately because I don't use this feature (all my pics are big enough by default) and I have rewritten ccc_more_info.php I'm unable to test this code...

 

<?php 

echo "var_p" . $j . "='<a href=\"java script: ccc_popup(\'ccc_image.php?image=\" + document.builds.new" . $j . ".options[document.builds.new" . $j . ".options.selectedIndex].getAttribute(\"model\") + \"\')\">" . TEXT_ENLARGE_IMAGE . "</a>'\n";

?>

 

I've included the enclosing php tags just to emphasize that the code is php.

 

Fingers crossed ;)

 

Carbon

Share this post


Link to post
Share on other sites
Hi Grinse,

 

Here's another go. Unfortunately because I don't use this feature (all my pics are big enough by default) and I have rewritten ccc_more_info.php I'm unable to test this code...

 

<?php 

echo "var_p" . $j . "='<a href=\"java script: ccc_popup(\'ccc_image.php?image=\" + document.builds.new" . $j . ".options[document.builds.new" . $j . ".options.selectedIndex].getAttribute(\"model\") + \"\')\">" . TEXT_ENLARGE_IMAGE . "</a>'\n";

?>

 

I've included the enclosing php tags just to emphasize that the code is php.

 

Fingers crossed ;)

 

Carbon

 

The code is php but the tags are already there.

Share this post


Link to post
Share on other sites

Does anybody solved the problem with adding custom builds to db with a product_id and automatically added to new products page?

I don't want the customers to see the custom builds as new products. In admin interface, the default status it's set to 0 to prevent the custom computers from showing up in the store, but when set to 0 it prevents the computer from showing up in the cart.

 

I think this is the most important bug of this great contribution.

Share this post


Link to post
Share on other sites

While clicking submit on my last post, I'm thinking of someth: if it's not possible to resolve this bug, maybe there is a workaround for this:

 

1. Setting to inactive status automatically this products (custom builds) when added into the db with a product_id, therefore, the custom builds not appearing anymore in the new products module.

 

or

 

2. The custom builds that are inserted into the db are not belonging to any category and they are not appearing in admin catalog, so, we can write a code (or modify) in products_new.php to select only products that belongs to a category. Like that, the custom builds are not appearing anymore in the new products module.

 

I'm not a programmer, so, if it's someone who could help us in this matter, we don't mind. :D

Share this post


Link to post
Share on other sites

I'm not sure what you want?

 

If you don't want to add new created systems into the db this one's for you:

In includes/classes/shopping_cart:

Replace:

		if (($check_product !== false) && ($check_product['products_status'] == '1')) {

With:

		if (($check_product !== false)) {

 

It's mentioned somewhere here already.

Share this post


Link to post
Share on other sites

Maybe a stupid question: is CCC only usable for configurating Computers? I would like to use this system for other products that can be created. Is this possible?

Edited by edstasy

Share this post


Link to post
Share on other sites
Maybe a stupid question: is CCC only usable for configurating Computers? I would like to use this system for other products that can be created. Is this possible?

Of course its possible. CCC jsut createst a top-group (in the example data itel or amd computers). Within these topgroups subgroups (in the example for amd socket 939) and then group based items taken from your local store (in the example mainboard).

Share this post


Link to post
Share on other sites

Dependant Dropdowns, anyone?

 

I've been using the CCC for a while, and it seems like it is soooo close to being useful.

 

My main problem is that i sell over 80 custom systems, and i need more flexibility from CCC. Why do i have to manually enter the same categories for every fsb over and over again? It would be smarter to create the categories once and then select them from a drop down. Why have 80 different instances of the category, Motherboard?

 

Ideally, dependant dropdowns seem to be what i need. Each subsequent dropdown would narrow depending on the previous selection. I have many options that, if kept linear, would help create a custom system. Then i just add the rest of the options as one-ofs, independant of the dependant dropdowns.

 

Top Level: Choose your System Type (ie Rackmount, Walmount, Mini-PC, etc.)

Level 2: Choose your System Size (1U, 2U, 4U if applicable)

Level 3: Choose your Chassis (Narrowed from above choices)

Level 4: Choose your Mainboard (that works with the selected Chassis)

Level 5: Choose which version of Mainboard (each board has optional configs, CPUs, etc.)

 

Then they can freeform request Backplane, Memory, etc.

 

This would REALLY simplify things for the user. Of course, i have to make all the relationships, but it seems that the CCC touches on that, but you need to make a good tree structure for dependencies.

 

Has anybody considered this approach at all? It could also replace product attributes for complex products, and even give a stuctured alaternative to search for systems.

 

I know some PHP, and mySQL, and i've tinkered quite a bit with my base osCommerce build, but seems like i would need to look at AJAX for this.

 

Any suggestions?


I never miss...

Share this post


Link to post
Share on other sites

Hi there I've another problem with this contribution:

Sometimes the prices are rounded wrong. I only want to have 2 numbers after the comma but sometimes I get 15! I checked the two addons to correct these problem but that doesn't fix it.

Share this post


Link to post
Share on other sites

Hey I would like to install this contrib on my site. The one thing is that I have installed the fancier invoice and packing slip v6.1. I know a lot of the files that this contrib needs to modify have already been modified by the fancier invoice like the first 4. So where it says to change something, it doesnt even exist. I tried a different version of some pc creator and talk about confusing.. I installed it like it said to a "T" but it didnt work. I like this one better anyway. if anyone has any info that would help with installing this on a site moded with the facier invoice it will be greatly appreciated.

Share this post


Link to post
Share on other sites
Hey I would like to install this contrib on my site. The one thing is that I have installed the fancier invoice and packing slip v6.1. I know a lot of the files that this contrib needs to modify have already been modified by the fancier invoice like the first 4. So where it says to change something, it doesnt even exist. I tried a different version of some pc creator and talk about confusing.. I installed it like it said to a "T" but it didnt work. I like this one better anyway. if anyone has any info that would help with installing this on a site moded with the facier invoice it will be greatly appreciated.

 

Another question is are there product dependencies... for example you cant select and intel motherboard when an AMD processor is selected etc.

Share this post


Link to post
Share on other sites

OK I went through all the files, a lot of the stuff is in different places but at least it is there.

 

The only one that I can see that is completely different is the Catalog/Account_History_Info.php. Mine doesn't contain anything that the instructions say that it should because I have the fancier invoice and packing slip. If someone could help me with this one file and figuring it out I will be greatly appreciative.

 

(Another thing is I actually had to mod the fancier invoice to work on my site. I copied some files from the admin side to the catalog side because emails were not working etc. I think it was because of permissions but I would rather not allow permissions to the admin side. But if I can figure this one file out then the rest shouldnt be a problem for me. )

Share this post


Link to post
Share on other sites

Hi,

I have the problem from ccc 9.3.1. Computer creator work correctly but he does not send the order to the administrator modules and visible orders are not on the side shopping_cart.php.

Additionally as file product_info.php this will update he does not display me goods. The message "product not found" receives.

This is my configuration:

- oscommerce 2.2ms2,

- star products,

- featured product,

 

this site is Polish www.adi.pl

 

 

 

Best Regards

Robert

 

Sorry for my english

Share this post


Link to post
Share on other sites

I have a same question.

 

Which version of OSCommerce the CCC 9.3.1 works well on?

 

I have OSCommerce v2 Release Candidate 2 downloaded and installed, then I added CCC v9 on it. Everything shows over there but I could not add any built system into my shopping cart. Please help me. Thanks

Edited by iamthesuperman

Share this post


Link to post
Share on other sites

Never mind my problem, I just found out the fix from previous posts.

 

I had to do was to make"Default Status of Custom Computers" option in the admin as 1.

 

But I still have small problem with CCC, when I select No picture option on ccc.php the page refreshed but the selection was set up back to Yes. Any advices?

 

I have a same question.

 

Which version of OSCommerce the CCC 9.3.1 works well on?

 

I have OSCommerce v2 Release Candidate 2 downloaded and installed, then I added CCC v9 on it. Everything shows over there but I could not add any built system into my shopping cart. Please help me. Thanks

Share this post


Link to post
Share on other sites
OK I went through all the files, a lot of the stuff is in different places but at least it is there.

 

The only one that I can see that is completely different is the Catalog/Account_History_Info.php. Mine doesn't contain anything that the instructions say that it should because I have the fancier invoice and packing slip. If someone could help me with this one file and figuring it out I will be greatly appreciative.

 

(Another thing is I actually had to mod the fancier invoice to work on my site. I copied some files from the admin side to the catalog side because emails were not working etc. I think it was because of permissions but I would rather not allow permissions to the admin side. But if I can figure this one file out then the rest shouldnt be a problem for me. )

 

can anyone help me with this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×