Jump to content
Sign in to follow this  
sw45859

Custom Computer Creator v9 Support

Recommended Posts

ok an update if it helps anyone.......

 

<tr>
     <td class="pageHeading" align="right" valign="top"><table border="0" cellpadding="0" cellspacing="0">
      <tr>
       <td class="main" align="right"><b><font Size="3"><?php echo TEXT_SUBTOTAL;?></b></font><b><?php echo cur_symbol;?></b></td>
       <td class="main" align="left"><div id="Total_Top">0.00</div></td>
      </tr>

 

I had commented out the above code from build.php so that it didn't display the same buttons at the top as at the bottom.

This however meant that the Total_Top value could not be parsed.

 

Ok that isn't really an issue just looks untidy now :-|

 

The cart value is now being correctly taken to the checkout and stored correctly in the order confirmation.

The last issue is the customer build is still displaying on the front page ........

 

Anyone?

Cheers

Share this post


Link to post
Share on other sites
Anyone here thinking about giving the discount price for each component for the custom product? So when the customer done customize their system, the total price would be lower than if you buy each indvidual parts. I think that's one of the important purpose of the customize system. You let your customer choose what they want and at the same time saving money for buying a whole bundle of parts as one system. Can this be done easily for this mod?

 

Any thought?

 

 

Hi, I have given this some thought and am having that customized into my mod for my site as well as a quanity choice. I will share the code with you when I am finished. Before anyone started working on my cusomizations, the build details (or product description) would and still will not carry through to the shopping cart or orders......Any idea what may be causing that? Followed all inbtreuctions to a "t"...can't figure it out...

Share this post


Link to post
Share on other sites
Yes. I hope this simple solution works for you, it did for me.

 

In your admin section go to: Custom Computer->CCC Config->Default Status of Custom Computer->Make sure it is set to 1 (not 0)

 

I don't know why, but CCC is by default off. That should turn it on.

 

 

THANKS... that's exactly what I was looking for!!!!!

 

Best regards,

 

Ricardo Bergantino

Share this post


Link to post
Share on other sites

For some reason when a customer creates a "Custom Computer" using ccc.php and add it to the basket, it's also shown as it was a new product on the first page of my Store.

 

Is this normal???? How can I disable that??? I can't find where to delete those custom systems.

 

Please help...

 

 

Thanks

 

 

P.D.: www.panamaxp.com

Share this post


Link to post
Share on other sites

hey guys,

it's been a long time since i posted here or released a new version of CCC, one is coming in the near future.

 

in response to the bugs about a product not being added to the cart and why the default computer status is set to 0:

it's set to 0 to prevent the custom computers from showing up in the store, but when set to 0 it prevents the computer from showing up in the cart. this is an error on my part for not including the work-around for the shopping cart. well here it is:

 

CHECK ONLY IF PRODUCT IS NOT ADDING TO THE CART!!!!

if in /catalog/includes/classes/shopping_cart.php around line 100:

if (($check_product !== false) && ($check_product['products_status'] == '1')) {

replace with

//Custom Computer Creator Begin

if (($check_product !== false)) {

//Custom Computer Creator End

Share this post


Link to post
Share on other sites

Hello,

I'm hoping someone will be able to help with a little problem i have had upon completion of a successful install.

 

This is a great contribution Stephen by the way.

 

The only problem i have so far incurred in this contribution is from custom_checkout.php the table where the custom built computer description is written is completely white. This is a problem for me as the body background for my website is black with white text... So i can't read what is there without highlighting it and it looks completely alien to the design in my website...

 

I have tried editing a few things, swapping a few things and have spent alot of time analysing custom_checkout.php to see if there was something in there. I know i must be missing something but i can't find what exactly.

 

If you could help point me in the right direction, at least by telling me which file i should be studying i would appreciate it :)

 

Thanks for your time.

Share this post


Link to post
Share on other sites
Hello,

I'm hoping someone will be able to help with a little problem i have had upon completion of a successful install.

 

This is a great contribution Stephen by the way.

 

The only problem i have so far incurred in this contribution is from custom_checkout.php the table where the custom built computer description is written is completely white. This is a problem for me as the body background for my website is black with white text... So i can't read what is there without highlighting it and it looks completely alien to the design in my website...

 

I have tried editing a few things, swapping a few things and have spent alot of time analysing custom_checkout.php to see if there was something in there. I know i must be missing something but i can't find what exactly.

 

If you could help point me in the right direction, at least by telling me which file i should be studying i would appreciate it :)

 

Thanks for your time.

 

Hi Jcey,

 

If you open up an unedited copy of custom_checkout.php and go to line 155 you should find...

 

<td class="smallText"><?php echo $message; ?></td>

 

... all you need to do is define a new class in the stylesheet (or locally within the file) or you can specify style properties inline like...

 

<td class="smallText" style="color: #000000;"><?php echo $message; ?></td>

 

... to make the text black.

 

Hope this helps

 

Carbon

Share this post


Link to post
Share on other sites

Hi All,

 

First of all thank you so much for this brilliant contribution! I am fairly new to osCommerce and CCC so I'm just stumbling through. I do have fairly strong linux admin skills, pretty new to web stuff....

 

Our test site for the CCC is at http://www.epochlabs.com.au/catalog/ and I click up the top 'Custom Computer Creator' it gives me:

 

Alert:

'www.epochlabs.com.au has sent an incorrect or unexpected error. Error code -12236'

 

Hoping somebody has had this before (I couldn't find it in the post anywhere)

 

I have re-checked all of the modifications I did to install ccc everything looked hunky dorey, although maybe I did miss something. I don't want to flood the board with dumps of all the files I edited, but I can do this if need be.

 

Is there some more documentation I can read (other than what is included in this contrib)?

Can I find a more in depth description of what CCC can and can't do? and What is it intended for?

 

Thanks in advance for any help, anybody can provide,

 

Cheers!

 

Scott

Share this post


Link to post
Share on other sites
I have re-checked all of the modifications I did to install ccc everything looked hunky dorey, although maybe I did miss something. I don't want to flood the board with dumps of all the files I edited, but I can do this if need be.

 

So it turns out I did miss something. My partner and I had been messing around with the ssl certificate we use and while I was setting up CCC it was broken. We rolled back to working ssl setup and CCC started working.... Now all I have to do is work out how to tame the beast. :)

 

Is there some more documentation I can read (other than what is included in this contrib)?

Can I find a more in depth description of what CCC can and can't do? and What is it intended for?

 

I'd still like to know if there is some documentation on CCC (I still can't seem to find it), especially the way it use ssl and why?

 

Cheers again,

 

Scott

Share this post


Link to post
Share on other sites

Well I have installed ccc v9.2 and I dont understand

1. where does it suppose to view the computer builder on the website? Do I have to put a link to build.php or ccc.php in home page myself?

2. when i manually go to www.domain.com/ccc.php or build.php it comes up with the following error:

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in /var/www/virtual/domain.co.uk/htdocs/demo/includes/header.php:138) in /var/www/virtual/domain.co.uk/htdocs/demo/includes/boxes/categories.php on line 13

 

Please any help is appriciated,

 

Hoda

Share this post


Link to post
Share on other sites
i was told to move over to a new thread so i have done that, anyone who needs help with ccc9 please post here.

Hi

 

Can you send me some links to some sites that you may know are using your custom computer creator contribution.

 

Before we install I want to make sure that it is what we are looking for. If it is what we are looking for and we need some changes is this something that you will do for a charge?

 

Many Thanks

Share this post


Link to post
Share on other sites

Hi all,

 

I've installed CCC & for some reasons I have no options to add components to CCC.

 

It's a clean OSC install with very few template tweeks.

 

I've created a system but when I try to add components I get this "No Products In CCC"

 

There are no buttons or dropdowns in admin only there options:

 

Custom Computer

CCC Config

CCC Options

Pending Builds

 

I've double checked all code & it all seems fine - I've reinstalled admin/includes/functions/html_output.php with no success.

 

Any ideas?

 

Thanks

Share this post


Link to post
Share on other sites
Well I have installed ccc v9.2 and I dont understand

1. where does it suppose to view the computer builder on the website? Do I have to put a link to build.php or ccc.php in home page myself?

2. when i manually go to www.domain.com/ccc.php or build.php it comes up with the following error:

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in /var/www/virtual/domain.co.uk/htdocs/demo/includes/header.php:138) in /var/www/virtual/domain.co.uk/htdocs/demo/includes/boxes/categories.php on line 13

 

Please any help is appriciated,

 

Hoda

Go to the categories.php file and remove the "tep_show_category()" function and the error will stop. I am a professional programmer and I used to make functions multiple times and I had to look this error up every time. Now I can remember it.

 

LOL.

 

Arthur

 

http://www.zanscripts.net

Share this post


Link to post
Share on other sites

I have one error with this script. Whenever I submit the order through the custom checkout, it inserts the info to the database, but for some reason, it will not put it in the shopping cart:

http://www.zantagonox.com/index.php

 

I have SSL setup for it, so you will need to click the link at the top of the page, it is "Zantagonox Computer Configurator".

 

Any help would be nice.

 

Thanks,

Arthur

Share this post


Link to post
Share on other sites

Arthur:

 

Can you give me the link to the version of CCC you downloaded?

 

I have tried several with my CRE Loaded install, and I can get my customs into the cart, but my default images are screwy. Maybe we can help each other. There seems to be very little progress on this module lately.

 

Bullseye

 

here's a link to my work in progress:

http://www.customipc.com/ccc.php

 

I only have one custom under Rackmount...


I never miss...

Share this post


Link to post
Share on other sites

Arthur

 

 

I know this sounds crazy, but check in your admin tool to see if Default Status of Custom Computers is set to 1 instead of the default 0.

 

Other people in this topic have had that problem.

 

-bullseye


I never miss...

Share this post


Link to post
Share on other sites

Wow, that worked. I have been transfering our sites over to our new linux server, so the fix has been delayed. Thank you for the advice to do that.

Share this post


Link to post
Share on other sites

If a customer is logged in (which they will never do first), the cart works fine. Orders work fine, both normal and CCC.

 

If a customer puts items in their cart, then logs in as required at checkout, everything in the cart disappears!

 

I am using MySQL sessions, and Force Cookies is set to False. Around the same time that I was tinkering, my host, HostMonster, upgraded their cPanel and maybe PHP. So maybe that's related.

 

What I really need to know, is that when a customer checks out with items in cart, what happens between login.php, and shopping_cart.php where the items disappear?

 

Can someone show me where the session is stored in the DB? It seems to me that the session resets on login. And I know that I have Recreate Session set to false.

 

I just need to know what happens or is supposed to happen between those two pages. Thanks ahead!


I never miss...

Share this post


Link to post
Share on other sites
1. where does it suppose to view the computer builder on the website? Do I have to put a link to build.php or ccc.php in home page myself?

 

Does it not say in the install instructions that you add a link in the nav bar next to whats already there.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Hello,

 

That's a nice contribution if it works but I can't figure out what I'm doing wrong. In admin, the "Custom Computer" shows the list of components but they are all empty and I can not edit them. How can I get the items from the database in here? In the user area the components are messed up in different categories and other categories are empty! How can I fix this?

The shop can be found here: http://digizone.hu/build.php

Hoppefully someone allready had that kind of problem and knows what to do! Thanks!

Share this post


Link to post
Share on other sites

Hey, I've just installed this contrib but unfortunately the adminpanel doesn't show up. The page is just blank.

The url i was given was: /admin/ccc_config.php?selected_box=ccc&cID=1

 

Any ideas what is causing this?

Share this post


Link to post
Share on other sites

Hi,

Since my last post I have get it work but i still have two problems. One it seems to be caused by the language pack that i use in addition to english and occures when i try to add a product to the shopping cart:

Warning: Cannot modify header information - headers already sent by (output started at /usr/home/digiehu1/public_html/includes/languages/hungarian.php:1) in /usr/home/digiehu1/public_html/includes/functions/general.php on line 29

The second problem is that computers created with ccc v9 appear in the New products window in the index page and I'd would like to avoid that! Why they don't appear in admin under Pending builts so we can delete them? Anyone can help in resolving these problems? Thanks in advance!

 

Regards,

pietonul. :(

Share this post


Link to post
Share on other sites

Greetings,

 

Rather then a drop down of products, is anyone aware of a java method to horizontally scroll through the items, using previous and next buttons?

 

Thank you in advance.

Share this post


Link to post
Share on other sites

Hello there,

 

I've some problems with the Custom Computer Creator:

  1. Is there a way to display the product details directly and not via a button you first have to press (for example under or above the listbox)?
  2. Is it possible to use hardware / entrys for CCC that are not seperatly buyable in the shop (because I only want to sell whole systems)?
  3. With Version 9.3.1 you have to press at least 3 links before you can create a computer: Custom computer creator, the main title (in the preinstallation its AMD and Intel "what what") and than the system itself (in the preinstallation for example: AMD XP 3500). I want to disable the two links after Custom Computer Creator, so I only have to press the CCC link and than I can configure the system.
  4. I have seen a comercial version of CCC for xt:C where you have a summary of the system on top of the configuration page. I want to implement that also but how?
  5. Can I move the CCC link from the top right to the left to place it near the categories links of osCommerce?

Ok I know that's a lot of questions but I haven't found answers with the search option and I'm bloody new with the creator (and with oscommerce). So it would be wonderful if someone has some answers for me.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×