Jump to content
Sign in to follow this  
smitty1

Automated Auction Process

Recommended Posts

On your site, when you enter the information, then click "preview", do you see your item picture and information listed?


Keith

 

 

What the hell was I thinkin'?

Share this post


Link to post
Share on other sites

This happened to me when I first tried the contribution out. It turned out that the javascript didn't work for a Mac so I had to paste in the description etc from an editor.?Might be somewhere to start looking...

Share this post


Link to post
Share on other sites

I dont think that that is an issue because I am on an AMD XP Barton running XP. I am going to try a reinstall and see how that goes. Also, smitty, is there any way that I could try out what you have with 1.1. Maybe that will solve my problem =)). I will let you all know if that works.

 

thanks

Share this post


Link to post
Share on other sites

aceclimber

 

 

Hope you get it fixed cause its a great contribution.


Keith

 

 

What the hell was I thinkin'?

Share this post


Link to post
Share on other sites

OK now this is getting weird. I built a couple new auctions and they're not showing anything in the description field on ebay. The weird part is that I generated code from an auction that I have running and that is listed properly and it shows up with a blank description. How can the same code result in a good auction and one that doesn't work?


Keith

 

 

What the hell was I thinkin'?

Share this post


Link to post
Share on other sites

Here's the code for the auction that doesn't display correctly.

 

<table border="0" width="100%" cellspacing="0" cellpadding="0">
 <tr>
   <td>
    <script language="JavaScript" 
     type="text/JavaScript">
     if(navigator.appName == "Microsoft Internet Explorer") 
     {
     document.write("<object type='text/x-scriptlet' data='http://wvdropshipping.com/auction_product_info.php?cPath=9999&products_id=3845' width='750' height='100%'></object>")
     }
     else
     {
     document.write("<object type='text/html' data='http://wvdropshipping.com/auction_product_info.php?cPath=9999&products_id=3845' width='750' height='100%'></object>")
     }
     </script>
   </td>
 </tr>
</table>

 

 

If you just enter the URL in the browser, the information all displays.


Keith

 

 

What the hell was I thinkin'?

Share this post


Link to post
Share on other sites

I couldnt figure it out. Im just gfoing to wait until 1.1 comes out. In the mean time I ended up using auction blox's contrib.

Share this post


Link to post
Share on other sites

I have seen on this thread several people who say they cannot get their Current Auctions to update - I just installed the Automated Auction Process contrib and I can't get anything to update. Everything seems ok, but nothing out of the current aucitions. Has anyone figured out why?

 

Thanks,

 

Mike

Share this post


Link to post
Share on other sites

I can hardly wait for 1.1 to come out. The only problems I had with this mod were things I caused myself. Once I undid my "enhancements" it works great.


Keith

 

 

What the hell was I thinkin'?

Share this post


Link to post
Share on other sites

Hey guys,

 

I had this installed and I am trying to submit an auction on eBay, and when I insert the script into the Description field and try to preview it, I get this:

eBay_error.gif

 

Here is the code:

 

<TABLE cellSpacing=0 cellPadding=0 width="100%" border=0>
<TBODY>
<TR>
<TD>
<script language=JavaScript type=text/JavaScript>
     if(navigator.appName == "Microsoft Internet Explorer") 
     {
     document.write("<object type='text/x-scriptlet' data='/shopcart/auction_product_info.php?cPath=9999&products_id=173' width='100%' height='1300'></object>")
     }
     else
     {
     document.write("<object type='text/html' data=''/shopcart/auction_product_info.php?cPath=9999&products_id=173' width='100%' height='1300'></object>")
     }
     </SCRIPT>
</TD></TR></TBODY></TABLE>

 

Can someone please help?

 

What am I missing?

 

I can't wait to get this thing workin:)

 

Thanks All!

 

Shawn

Share this post


Link to post
Share on other sites

T-man it is the "link" ebay can not find. You may not have this properly set up in configure.php.

 

It should look like this:

<table border="0" width="100%" cellspacing="0" cellpadding="0">
 <tr>
   <td>
    <script language="JavaScript" 
     type="text/JavaScript">
     if(navigator.appName == "Microsoft Internet Explorer") 
     {
     document.write("<object type='text/x-scriptlet' data='http://www.smittys.pointclark.net/auction_demo/auction_product_info.php?cPath=9999&products_id=78' width='100%' height='1300'></object>")
     }
     else
     {
     document.write("<object type='text/html' data='http://www.smittys.pointclark.net/auction_demo/auction_product_info.php?cPath=9999&products_id=78' width='100%' height='1300'></object>")
     }
     </script>
   </td>
 </tr>
</table>

 

notice the http://www.smittys.pointclark.net/ this is not showing on yours because it needs to be set in configure.php.

 

Hope that helps.

B)


REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites

I think I found a big problem with this contribution. When I clicked on my "all products" link, the items I have on ebay were included and the price was $0.00 on all of them. I tried adding one to my cart and sure enough, I was able to proceed through checkout and purchase the item for a price of $0.00. I removed my all products paged till I can figure this out.


Keith

 

 

What the hell was I thinkin'?

Share this post


Link to post
Share on other sites

wvmlt,

What do you mean by "all products" link?? Is this another contrib installed?

 

What is the php code? I am sure we can change it so it chooses everything but the auction items.

 

:huh:


REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites

Thanks Smitty for the reply. I had my programmer go through and fix that problem. Apparently I have an older version (not ms2.2). Anyway we got that to work.

 

I do have a couple more questions. All my auctions have set shipping prices on them. I do not use weight at this time. When an auction closes and I go through the checkout process, the shipping cost does not come to my shopping cart. Is this feature suppose to work, or should I do this a different way? I could use weight if that is how it is suppose to work.

 

Also I noticed that when I purchased the item in eBay, and then went to checkout, the item that was in my shopping cart was listed as the item I got on ebay, but it was not the actual item (matching item) from my product list in my store. Should it be one of the actual items from my product list? Or just a new item that is not listed as an actual product?

 

Thanks again.

Shawn

Share this post


Link to post
Share on other sites
wvmlt,

What do you mean by "all products" link?? Is this another contrib installed?

 

What is the php code? I am sure we can change it so it chooses everything but the auction items.

 

:huh:

Yes it's another contribution that I had installed, it's called allprods or something like that. I just deleted it though. Great contribution. I think it makes my auctions look nicer without a lot of effort.

 

Here's the code

<?php 
/* 
 $Id: allprods.php,v 2.0 2004/01/13 20:28:47 UJP Co. Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2004 osCommerce

 Released under the GNU General Public License
 
*/ 

 require('includes/application_top.php'); 
 include(DIR_WS_LANGUAGES . $language . '/' . FILENAME_ALLPRODS); 

 $breadcrumb->add(HEADING_TITLE, tep_href_link(FILENAME_ALLPRODS, '', 'NONSSL')); 
?> 
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN"> 
<html <?php echo HTML_PARAMS; ?>> 
<head> 
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>"> 
<title><?php echo TITLE ?></title> 
<base href="<?php echo (getenv('HTTPS') == 'on' ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>"> 
<link rel="stylesheet" type="text/css" href="stylesheet.css">
</head> 
<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0"> 
<!-- header //--> 
<?php require(DIR_WS_INCLUDES . 'header.php'); ?> 
<!-- header_eof //--> 

<!-- body //--> 
<table border="0" width="100%" cellspacing="3" cellpadding="3"> 
 <tr> 
   <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2"> 
<!-- left_navigation //--> 
<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?> 
<!-- left_navigation_eof //--> 
   </table></td> 
<!-- body_text //--> 
   <td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">
     <tr>
       <td><table border="0" width="100%" cellspacing="0" cellpadding="0">
         <tr>
           <td class="pageHeading"><?php echo HEADING_TITLE; ?></td>
           <td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_products_new.gif', HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
         </tr>
       </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
     </tr>
     <tr>
       <td>
<?php
 // create column list
 $define_list = array('PRODUCT_LIST_MODEL' => PRODUCT_LIST_MODEL,
                      'PRODUCT_LIST_NAME' => PRODUCT_LIST_NAME,
                      'PRODUCT_LIST_MANUFACTURER' => PRODUCT_LIST_MANUFACTURER, 
                      'PRODUCT_LIST_PRICE' => PRODUCT_LIST_PRICE,
                      'PRODUCT_LIST_QUANTITY' => PRODUCT_LIST_QUANTITY,
                      'PRODUCT_LIST_WEIGHT' => PRODUCT_LIST_WEIGHT,
                      'PRODUCT_LIST_IMAGE' => PRODUCT_LIST_IMAGE,
                      'PRODUCT_LIST_BUY_NOW' => PRODUCT_LIST_BUY_NOW);
 asort($define_list);

 $column_list = array();
 reset($define_list);
 while (list($column, $value) = each($define_list)) {
   if ($value) $column_list[] = $column;
 }

 $select_column_list = '';

 for ($col=0, $n=sizeof($column_list); $col<$n; $col++) {
   if ( ($column_list[$col] == 'PRODUCT_LIST_BUY_NOW') || ($column_list[$col] == 'PRODUCT_LIST_NAME') || ($column_list[$col] == 'PRODUCT_LIST_PRICE') ) {
     continue;
   }
 }
 
 $listing_sql = "select p.products_id, pd.products_name, p.products_image, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, p.products_date_added, m.manufacturers_name from " . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id where p.products_status = '1' order by p.products_price, pd.products_name";
 include(DIR_WS_MODULES . FILENAME_PRODUCT_LISTING);
?>
       </td>
     </tr>
   </table></td>
<!-- body_text_eof //-->
   <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->
   </table></td>
 </tr>
</table>
<!-- body_eof //-->

<!-- footer //-->
<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>
<!-- footer_eof //-->
<br>
</body>
</html>
<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

Edited by wvmlt

Keith

 

 

What the hell was I thinkin'?

Share this post


Link to post
Share on other sites
I know it has been a while but it is almost done.

 

Any other suggestions? :huh:

I am always open to improvement :)

It would be nice to have an HTML editor where you add the description for your auction item.

 

htmleditor.gif


Keith

 

 

What the hell was I thinkin'?

Share this post


Link to post
Share on other sites

Good idea wvmlt, know where I could get one to add? Eithor javascript or php?

 

:unsure:


REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites

Smitty,

 

I've just installed AAP locally on Loaded 6 for testing. It all went smooth.

 

Just a question: in the new 1.1 version will I be able to choose the items to list on Ebay and send them with just a click as if I used turbolister ? Well actually it could be much better then TL because you will skip a passage, isn't it ?

 

Thanks


Outside links in signatures are not allowed!

Share this post


Link to post
Share on other sites

From what I've read, you will still generate the code to paste into ebays item description field or you can export a csv file to use with turbo lister. It'll make it easier to create auctions from inventory you have though because you don't have to enter in the item description......you just pick the item from a dropdown list and go.


Keith

 

 

What the hell was I thinkin'?

Share this post


Link to post
Share on other sites

Tomcat,

Unfortunatly, in 1.1 you won't be able to upload it directly to ebay. This would require the use of there API defeating the Open-Source concept ($$$). On the other hand you will be able to export it directly to your desktop as a cvs file designed for Turbo Lister. You would then open Turbo lister, import it and upload it from there.

 

Hope that helps.

:)


REDHAT'S OFF TO THE BEST E-COMMERCE SOLUTION AROUND!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×