Jump to content

Archived

This topic is now archived and is closed to further replies.

Kestas

OSC guru please - email problem

Recommended Posts

Hi all,

I have problem with emails, when I type national non-english characters in FROM: field only. Emails don't send, no php errors.

I have tested varied combination of emails headers on both Linux and windows servers, and found this "bug", when do not send emails only in from: field.

 

Symptoms:

1. When customer type his name with national character in contacts_us send email form;

2. When set "store name <shop@email.com>" in admin-configuration-my store "e-mail from" or "e-mail address", with national characters in "store name". There is no browser codding problem (when national characters replased with &xxx; if codding page on browser is wrong), because store name stored in database.

 

No problems with english characters. No problems with national characters in "customer name <his@email.com" when send emails from admin, no problems in subject field.

 

I use sendmail on windows and linux, same problem with smtp on windows, emails configured on MIME HTML.

 

Is very strange, because OSC is multilingual (standard spanish and german) and I don't found any post or bug report with it.

 

I can set "store name <store@email>" without national characters and it's OK, but customer can type his name with national characters and emails don't send.

 

Do any have this poblem? Is there soliution?


Kestas

Share this post


Link to post
Share on other sites

Oooops! :unsure: :unsure: :unsure:

 

Nobody has problems with emails with national characters in store name or customer name?

 

Is spanish and german also OK?

 

Please someone (non english) test it:

 

in contact_us send email form, FULL NAME field type name with national characters and send it to store owner

or

admin - configuration - my store - e-mail from set:

"store_name_with_national_char <store@email.com>" (without quotes)

and test sending emails to customers from admin.

 

Please report test results in this thread


Kestas

Share this post


Link to post
Share on other sites

Sorry for confusion,

 

Probably is problem with my ISP smtp mail server... :(

 

I found OSC demo on web with full functions in admin and tested it, it's OK.

 

Because I haven't smtp server, I need to change my ISP... :)


Kestas

Share this post


Link to post
Share on other sites

×