Jump to content


This topic is now archived and is closed to further replies.


Getting Logged Off

Recommended Posts

I just got to the stage where I am testing actually buying something and have now been logging in. I noticed that after posting a review or when I click on Home in my navigation bar, it acts like I am not logged in. It goes back to My Account in the Nav. bar and my shoppnig cart is then empty. I can log back in and my cart is still there. It probably happens in other combinations too.


Anyone know what is happening?Have not done any modification to login code or account management... <_<


Projects Director @ ozEworks.com

Share this post

Link to post
Share on other sites

Probably a cookie problem - post your catalog/includes/configure.php - leave out the database info.



Matti Ressler


We were all once expert at...... nothing


Share this post

Link to post
Share on other sites



Here it is - I could not see any marvellous but I am not sure I have my SSL stuff set up right yet ... My catalog directory is called "oscommerce".




osCommerce, Open Source E-Commerce Solutions



Copyright © 2003 osCommerce


Released under the GNU General Public License



// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://sequinflowers.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://sequinflowers.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'sequinflowers.com');

define('HTTPS_COOKIE_DOMAIN', 'sequinflowers.com');

define('HTTP_COOKIE_PATH', '/oscommerce/');

define('HTTPS_COOKIE_PATH', '/oscommerce/');

define('DIR_WS_HTTP_CATALOG', '/oscommerce/');

define('DIR_WS_HTTPS_CATALOG', '/oscommerce/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');


define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/sequinfl/public_html/oscommerce/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');




Projects Director @ ozEworks.com

Share this post

Link to post
Share on other sites

Around line 504 of includes/application_top.php, change

  $breadcrumb->add(HEADER_TITLE_TOP, HTTP_SERVER);

to (get rid of Top link)

//  $breadcrumb->add(HEADER_TITLE_TOP, HTTP_SERVER);

or to (make it include session ID)

  $breadcrumb->add(HEADER_TITLE_TOP, tep_href_link(FILENAME_DEFAULT));

I would guess that the reviews problem is similar. Have you installed any contributions that change the reviews page from which you are clicking on the malfunctioning link? Can you duplicate the problem at http://www.oscommerce.com/osCommerce22ms2/ ? If so, what exactly do you do?




Share this post

Link to post
Share on other sites



I will go see that breadcrumb code ...


I went to the site you said and I created an account. I got an error after it was created but it got created anyway (I found out when I tried to create it again).


I tried to buy something but got this message


1016 - Can't open file: 'customers_basket.MYI'. (errno: 145)


insert into customers_basket (customers_id, products_id, customers_basket_quantity, customers_basket_date_added) values ('7537', '3', '1', '20031222')




I think my account creation error was similar to this.



Is this related to my problem? Can't see how.



The only thing I changed that seems related is that I added the navigation to the footer bar. Your talking about breadcrumbs reminded me. I just copied code to do it. Can I have confused things having it in two places?



Do I have a firewall issue? I am running Zone Alarm Pro.


Off I go to look harder .... thanks!


Projects Director @ ozEworks.com

Share this post

Link to post
Share on other sites