Jump to content
Latest News: (loading..)
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

I keep on getting the following error. Any idea where I may have some permission issues? I have checked both the feeds folder and my text file and they have Read\Write\Execute with a numeric value of 777.

 

Warning: unlink(../feeds/adorablebaby_products.txt) [function.unlink]: Permission denied in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 216

 

Warning: fopen(../feeds/adorablebaby_products.txt) [function.fopen]: failed to open stream: Permission denied in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 348

 

Warning: fwrite(): supplied argument is not a valid stream resource in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 349

 

Warning: fclose(): supplied argument is not a valid stream resource in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 350

 

Warning: fopen(../feeds/adorablebaby_products.txt) [function.fopen]: failed to open stream: Permission denied in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 348

 

Warning: fwrite(): supplied argument is not a valid stream resource in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 349

 

Warning: fclose(): supplied argument is not a valid stream resource in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 350

 

Warning: fopen(../feeds/adorablebaby_products.txt) [function.fopen]: failed to open stream: Permission denied in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 348

 

Warning: fwrite(): supplied argument is not a valid stream resource in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 349

 

Warning: fclose(): supplied argument is not a valid stream resource in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 350

 

Warning: fopen(../feeds/adorablebaby_products.txt) [function.fopen]: failed to open stream: Permission denied in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 356

 

Warning: fwrite(): supplied argument is not a valid stream resource in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 357

 

Warning: fclose(): supplied argument is not a valid stream resource in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 358

File completed: adorablebaby_products.txt

 

Warning: chmod() [function.chmod]: Permission denied in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 360

Connected to uploads.google.com, for user adorablebaby

Uploaded ../feeds/adorablebaby_products.txt to uploads.google.com as adorablebaby_products.txt

 

 

Thanks!

Share this post


Link to post
Share on other sites

Updated, I had 22d4 now 22d5, still getting same error though.

You made a mistake with the update somehow since that function is no longer in Ultimate SEO so it can't be failing on it.

Share this post


Link to post
Share on other sites

I keep on getting the following error. Any idea where I may have some permission issues? I have checked both the feeds folder and my text file and they have Read\Write\Execute with a numeric value of 777.

 

Warning: unlink(../feeds/adorablebaby_products.txt) [function.unlink]: Permission denied in D:\Users\A\adorablebaby\shop.adorablebabyshop.com\admin\googlefeeder.php on line 216

 

It looks like it might be a file ownership problem so you'll need to ask your host to look at it.

Share this post


Link to post
Share on other sites

You made a mistake with the update somehow since that function is no longer in Ultimate SEO so it can't be failing on it.

 

Yes, I upgraded per instructions by replacing the seo.class.php file, but you are right, I didn't exactly notice but the error is a different one now...

 

Fatal error: Call to undefined function tep_not_null() in /hsphere/local/home/c148783/pureindollgence.com/oscommerce2/catalog/includes/classes/seo.class.php on line 1006

Share this post


Link to post
Share on other sites

Yes, I upgraded per instructions by replacing the seo.class.php file, but you are right, I didn't exactly notice but the error is a different one now...

 

Fatal error: Call to undefined function tep_not_null() in /hsphere/local/home/c148783/pureindollgence.com/oscommerce2/catalog/includes/classes/seo.class.php on line 1006

To find the answer to that, go to the bottom of the page, type in tep_not_null in the search box and click go.

Share this post


Link to post
Share on other sites

To find the answer to that, go to the bottom of the page, type in tep_not_null in the search box and click go.

 

Hello,

 

i have the same error:

 

Fatal error: Call to undefined function: tep_not_null() in /..../catalog/includes/classes/seo.class.php on line 1006

 

I can't find the answer. please help us.

 

chrissmith

Share this post


Link to post
Share on other sites

Hello,

 

i have the same error:

 

Fatal error: Call to undefined function: tep_not_null() in /..../catalog/includes/classes/seo.class.php on line 1006

 

I can't find the answer. please help us.

 

chrissmith

Here it is. You'll need to learn to use the forum and search on your own for answers or you'll find you waste a lot of time waiting.

Share this post


Link to post
Share on other sites

Here it is. You'll need to learn to use the forum and search on your own for answers or you'll find you waste a lot of time waiting.

 

thank you, but thats not the problem. i had found this topic but not the answer of my problem:

 

I had 22d4 now 22d5, still getting the new error: seo.class.php on line 1006

 

i am not a professional web designer. please help me. thanks

 

chrissmith

Share this post


Link to post
Share on other sites

thank you, but thats not the problem. i had found this topic but not the answer of my problem:

 

I had 22d4 now 22d5, still getting the new error: seo.class.php on line 1006

 

i am not a professional web designer. please help me. thanks

 

chrissmith

Your previous post said you were getting an error about tep_not_null. The link I provided will fix that. Now you are saying you have some other error, I think, but you don't say what the error is so I can't help.

Share this post


Link to post
Share on other sites

Your previous post said you were getting an error about tep_not_null. The link I provided will fix that. Now you are saying you have some other error, I think, but you don't say what the error is so I can't help.

 

That's the code in line 1006:

 

$return = (tep_not_null($cName) ? $cName . '-'. constant('PRODUCT_NAME_' . $pID) : constant('PRODUCT_NAME_' . $pID));

Share this post


Link to post
Share on other sites

Posting code that everyone has serves no purpose. Please post your actual error message.

Share this post


Link to post
Share on other sites

To find the answer to that, go to the bottom of the page, type in tep_not_null in the search box and click go.

 

I followed your suggestion and read through all the messages shown, but did not really see any clear cut answer to this problem other than suggested changes to the googlefeeder file which are already included in the version i installed.

Share this post


Link to post
Share on other sites

I followed your suggestion and read through all the messages shown, but did not really see any clear cut answer to this problem other than suggested changes to the googlefeeder file which are already included in the version i installed.

That code is not included in any of my versions and I don't support the versions written by someone else so I can't help you with that.

Share this post


Link to post
Share on other sites

That's the code in line 1006:

 

$return = (tep_not_null($cName) ? $cName . '-'. constant('PRODUCT_NAME_' . $pID) : constant('PRODUCT_NAME_' . $pID));

 

lordofcb had exactly the same error:

 

Jack_mcs, on 07 October 2009 - 08:34 AM, said:

You made a mistake with the update somehow since that function is no longer in Ultimate SEO so it can't be failing on it.

 

 

Yes, I upgraded per instructions by replacing the seo.class.php file, but you are right, I didn't exactly notice but the error is a different one now...

 

Fatal error: Call to undefined function tep_not_null() in /hsphere/local/home/c148783/pureindollgence.com/oscommerce2/catalog/includes/classes/seo.class.php on line 1006

 

i am from germany, my english is not so good. please help anyway ;)

Share this post


Link to post
Share on other sites

lordofcb had exactly the same error:

 

i am from germany, my english is not so good. please help anyway ;)

My googlefeeder.php file is 430 lines long so. I suppose you are referring to the Ultimae SEO file. The fix for that was mentioned - I even provided the link. If you don't want to apply it, I can't help you. If you do apply it, correctly, it will solve your problem.

Share this post


Link to post
Share on other sites

That code is not included in any of my versions and I don't support the versions written by someone else so I can't help you with that.

 

I am using the versions written by you. GoogleBase v2.3, and Ultimate_SEO_URLSv22d_5, I had already mentioned that previously.

As for your reference to an answer in that link, I can only assume you mean the one about adding a dummy tep_not_null function into the bottom of SEO.CLASS?

I am not sure about that though, in the message that followed that you said you already included the needed changed in the latest version, which is the 22d_5 version being the latest correct?

In any case, I tried adding in that extra tep_not_null funtion in, and it DID fix the googlefeeder issue, unfortunately though, the rest of my website crashed unable to run Ultimate SEO's anymore so I put my backup version od SEO.CLASS back on and all is working again (except Googlefeeder with SEO_ENABLED set to 'true', works ok with it set to FALSE though.

Share this post


Link to post
Share on other sites

OK, I'll try once more. Please read what I am saying, not what you think it should say.

 

- Restore your Ultimate SEO file to the original.

 

- Go to the link in this thread I posted and copy the tep_not_null function that is posted there.

 

- Open your googlefeeder.php file and paste it where indicated in that post.

 

- Stop - your'e done.

Share this post


Link to post
Share on other sites

OK, I'll try once more. Please read what I am saying, not what you think it should say.

 

- Restore your Ultimate SEO file to the original.

 

- Go to the link in this thread I posted and copy the tep_not_null function that is posted there.

 

- Open your googlefeeder.php file and paste it where indicated in that post.

 

- Stop - your'e done.

 

Well that finally worked, I think you could have saved yourself a few headaches by just pointing out the exact instructions earlier though. From the way I read that entry from your link, it sounded as though he was saying to add that tep_not_null function to your seo.class file, not to the googlefeeder file...

 

"I had exactly the same error as this when updating my seo.class.php file and I add this to the end of that file which resolved the error."

 

function tep_not_null($value) { if (is_array($value)) { if (sizeof($value) > 0) { return true; } else { return false; } } else { if (($value != '') && (strtolower($value) != 'null') && (strlen(trim($value)) > 0)) { return true; } else { return false; } } }

Share this post


Link to post
Share on other sites

Well that finally worked, I think you could have saved yourself a few headaches by just pointing out the exact instructions earlier though. From the way I read that entry from your link, it sounded as though he was saying to add that tep_not_null function to your seo.class file, not to the googlefeeder file...

 

Uh, you're welcome.

Share this post


Link to post
Share on other sites

I keep getting this error message on Google Feed - tried manually and auto feed for the past 2 days :(

 

.............

 

No items inserted - Processed on Oct 13, 2009 8:51 pm BST

 

Detected encoding: US-ASCII

Detected delimiter: Tab (\t)

Detected file format: Text

 

Feed Level Messages

Warning: Unsupported attribute: label - Warning

 

This attribute is no longer supported. Please replace the attribute with a relevant, supported attribute. Learn more

 

Item Errors - 774 items with errors 774 items affected 774

Invalid URL in attribute: link (774 errors)

 

...........

 

Tried to find the answer on Google forum but couldn't really sort it.

 

Can someone help me what I should look into?

 

Thank you!

Share this post


Link to post
Share on other sites

The invalid url error is the main problem. You have to click on one of those, find the line number the error is referring to (although it is all of them in this case) and look at your feed to determine the problem.

Share this post


Link to post
Share on other sites

Here we have also a posibility to do upload to specials sites like froogle.

So I want to use this script for doint this. And of course they want to have the

mentioned price including tax, also they want to know shipping/deliver cost even

till when the special price is available.

 

Regards

 

Purple

 

____

dossier surendettement

Share this post


Link to post
Share on other sites

Here we have also a posibility to do upload to specials sites like froogle.

So I want to use this script for doint this. And of course they want to have the

mentioned price including tax, also they want to know shipping/deliver cost even

till when the special price is available.

Did you have a question?

Share this post


Link to post
Share on other sites

Jack,

 

Thanks so much for supporting this contribution.

ive been reading the support thread and downloaded a bunch of versions of the google base contrib to try to figure out whats going on here.

 

It looks like the the changes from feb 12 by celextel -> july 15th 09 by you have changed the files from one root level file (/googlebase.php) to two admin files (/admin/googlefeeder.php & /admin/feeders.php).

 

it seems that the readme file, however, still dates from feb 06.

 

also, as per the instructions in the readme file, it asks the installer to add

 

    //Feeder Systems
    require(DIR_WS_BOXES . 'feeders.php');

 

to the left_column.php file, however, there is no feeders.php in the admin/includes/boxes folder.

 

now, for MY real problem, which i havent come across in the support forum yet (for these new files anyway);

 

after i configure my settings in /admin/googlefeeder.php, and then navigate there, i get

 

"Internal Server Error. Please contact a server administrator."

 

Any thoughts? I appreciate your time & support.

Thanks,

 

Lauren

Share this post


Link to post
Share on other sites

after i configure my settings in /admin/googlefeeder.php, and then navigate there, i get

 

"Internal Server Error. Please contact a server administrator."

It can be a large number of things. To isolate it, if there is an admin/error_log file, open that and see if there are any errors relating to this script. If not, then contact your host and ask them to see what the problem is. If they complain, saying it is a script problem, explain to them the script is widely used and only fails on their server. Hopefully, they will take a look at it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×