Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

The product type, as mentioned on the referenced google page above, is a category. From three pages back.

 

Jack

Share this post


Link to post
Share on other sites

hmmm....don't know how looked right over it, must have been one of the early morning snafoo's.

 

I do have a question though...

 

How/where does it pull the category from that it will be placed in? Can I set it to a custom category that would match what Google already has?

Share this post


Link to post
Share on other sites

It's whatever category it is in your shop. Code to be added to intercept that and change it to what you want but that might be confusing to the vistors since it wouldn't match and may even cause google to disallow it. If you want to have a different name, you should rename the actual category or move the product to a new one that matches it.

 

Jack

Share this post


Link to post
Share on other sites

$OutFile = "../feeds/your-outfile.txt"; //Replace "your-outfile" with the filename provided by Google

 

Where does Google assign this file name? I don't see it anywhere in the Webmaster Tools section. We've submitted maps in the past where we told it the file name, but I don't see where it assigns me a .txt file.

 

Any tips?

Share this post


Link to post
Share on other sites

I am by no means a pro, but if you go to Google Base, then go to data feeds, then hit create new data feed and you can name it whatever you want, like "store.txt". That is what I did and it worked. . .

 

I hope this helps (and I am right). . .

Share this post


Link to post
Share on other sites
I am by no means a pro, but if you go to Google Base, then go to data feeds, then hit create new data feed and you can name it whatever you want, like "store.txt". That is what I did and it worked. . .

 

I hope this helps (and I am right). . .

 

Kudos to you, jwalker. Thanks! I was searching in the wrong area (obviously).

Share this post


Link to post
Share on other sites
It's whatever category it is in your shop. Code to be added to intercept that and change it to what you want but that might be confusing to the vistors since it wouldn't match and may even cause google to disallow it. If you want to have a different name, you should rename the actual category or move the product to a new one that matches it.

 

Jack

Jack,

 

My categories in my store are more defined than the general categories that google has. Renaming/changing categories in my store would not be good for me. What are my options?

 

Blaine

Share this post


Link to post
Share on other sites

Google doesn't say you have to use what they suggest. If you use the department column title, they will accept the names you have.

 

Jack

Share this post


Link to post
Share on other sites

Installed and am generating the feed file which appears correct. I'm receiving this error though - which when I search on, it appears a lot people run into this when using it for a variety of purposes:

 

Fatal error: Call to undefined function: ftp_connect() in /mysitepath/admin/googlefeeder.php on line 378

 

According to phpinfo, the ftp is enabled. Any advice anyone can toss me?

Share this post


Link to post
Share on other sites

You'll need to ask your host about that one. It's a function in php and controlled by them.

 

Jack

Share this post


Link to post
Share on other sites

Hello

 

I think you guys were discussing this earlier, but when I go into Data Quality, it states all my products are "Missing Product Type Values", is this because my categories are different than Google, and do you think this will affect us negatively?

 

Secondly, about the "Missing recommended attribute: weight ", I was scanning through this Thread and it one post it stated a new version had fixed this, but I have the newest version but I a still receiving the error. Is that this big of a deal???

 

Thanks. . .

Share this post


Link to post
Share on other sites

For the product type, read the previous posts.

 

For the weight, enable that option in the settings.

 

Jack

Share this post


Link to post
Share on other sites

While talking with my host about ftp_connect, the mentioned (based on just looking at this one file) that $ftpservername was not declared which they thought was affecting ftp_connect. I got looking more at the line:

 

function ftp_file( $ftpservername, $ftpusername, $ftppassword, $ftpsourcefile, $ftpdirectory, $ftpdestinationfile )

 

and don't see where those are assigned values from the master config. Am I looking at that right? Am I missing a section where all of those are assigned the values from the master config? I don't seen anything in master config that relates to the FTP_DIRECTORy or FTP_DESTINATION_FILE either.

Share this post


Link to post
Share on other sites

I have just set this up. The script is now running after some problems. The problem that I am having si the file is sent to google ok but no products are inported. I get the email from google to say 0 out of 8 products installed. Here is a link to the txt file. outfile Is the script not creating it properly or what?

Share this post


Link to post
Share on other sites

You need to login to your googlebase account and see why the links were not accepted.

 

Jack

Share this post


Link to post
Share on other sites

I don't understand what you mean by "the Delimiter" but there are settings in the file of this contribution and settings in your googlebase account. You need to set them all correctly.

 

Jack

Share this post


Link to post
Share on other sites

It looks like Google has changed some rules around. 1 of which says not to include any shipping info in the title. Problem is I have "FREE SHIPPING" in all of my titles, and they are not inserting any of my items anymore. Is there a way to put in some extra code to strip out the phrase "FREE SHIPPING"?

Share this post


Link to post
Share on other sites

/feeds/wwhproducts.txt

 

Check whether the directory exist and is writable.

Also make sure the given file name is writable.

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites

I just wanted to thank Jack again. I have been up and running for about 10 days and have already noticed an increase in orders!!!

 

Thanks Again

 

Anthony

Share this post


Link to post
Share on other sites

I have managed to change the seperators. The problem that I am having is the google is not inporting any products. They are not giving an error code. Is there a way of adding products manualy? As at the moment I have not got that many and they will not be updated much.

Share this post


Link to post
Share on other sites
I have managed to change the seperators. The problem that I am having is the google is not inporting any products. They are not giving an error code. Is there a way of adding products manualy? As at the moment I have not got that many and they will not be updated much.

If you submit a feed and google accepts it but doesn't list the products, the problem is with google. You will need to talk to them to find out why they are refusing it.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×