Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

This worked - I am only getting the last category in the tree now for each product. However, if Google is allowing the full tree these days, I will revert it back to the original code.

 

I uninstalled the 1.25 version and installled the 1.21 version.

 

When I visit admin and click Feeder Systems in the menu, it opens to (in the main page):

"Google Base / Froogle: Google Base / Froogle" (with the last part being clickable)

 

When I click on the last 'Google Base / Froogle' it opens a new window which says "File completed: 'myfile' " and then I get nothing else.

 

I just noticed something else. When I click on the Feeder Systems in the menu, it opens a sub-menu below it which also says "Google Base / Froogle" which, when clicked, also opens a new window that only states that the 'file completed: myfile' - with nothing else.

 

PS - There is no file uploaded to GoogleBase.

 

 

There a line you need to uncomment to upload the file to Google. It's in the instructions. Step 7?


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Yes, that line is uncommented. :(

 

I've tried running this in IE and in Firefox, but get the same results (I tried it in FF because sometimes IE does wierd stuff).

Share this post


Link to post
Share on other sites
Yes, that line is uncommented. :(

 

I've tried running this in IE and in Firefox, but get the same results (I tried it in FF because sometimes IE does wierd stuff).

 

 

it's not browser related. it's a server side issue. it should throw at least an error message if the line is uncommented. check your php debug levels to make sure errors are thrown.

 

To be sure,

 

//ftp_file( $ftp_server, $ftp_user_name, $ftp_user_pass, $source_file, $ftp_directory, $destination_file);

 

is the line.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
There a line you need to uncomment to upload the file to Google. It's in the instructions. Step 7?

 

Thanks gor your reply. In actual fact the line you refer to is already uncommented in the contribution download package. I did get to the cause of the problem though. Many hosting companies disable the ftp_connect() function for security. A quick call to my host and the job's done! A tremendous contribution that'll save me hours every week - thanks FlyingMonkey

Share this post


Link to post
Share on other sites
check your php debug levels to make sure errors are thrown.

 

You lost me here, so I googled 'php debug'...should I have a program to debug php? Sorry for sounding like an idiot, but I'm new to this. :blink:

 

And it reminds me that another contrib I had installed (Paypal) was supposed to debug itself (during the testing stage) and send me e-mails with any errors...I never received any e-mails.

Share this post


Link to post
Share on other sites

I have two questions.

 

Should I be using version 1.21 or should I be using 1.20?

 

Also, in the googlefeeder.php file where you say to put the full path to the $OutFile - does it need the absolute path or just the http:// path?

 

Thanks!

Share this post


Link to post
Share on other sites

Trying to link my Google Base and Google Checkout accounts so I can offer Google Checkout via Google Shopping .... if that makes any sense at all...

 

The Google Base help section says I have to add a new area to my feed and have it say payment_options or something along those lines. Any idea on how to do this? Thanks!!

Share this post


Link to post
Share on other sites
I have two questions.

 

Should I be using version 1.21 or should I be using 1.20?

 

Also, in the googlefeeder.php file where you say to put the full path to the $OutFile - does it need the absolute path or just the http:// path?

 

Thanks!

 

1.21 should be fine. the $Outfile can either be the absolute or relative path of the file.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Im lost with this. I installed version 1.25 form the contrib page and i get these errors.

Warning: include(includes/languages/english/FILENAME_FEEDERS) [function.include]: failed to open stream: No such file or directory in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

Warning: include(includes/languages/english/FILENAME_FEEDERS) [function.include]: failed to open stream: No such file or directory in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

Warning: include() [function.include]: Failed opening 'includes/languages/english/FILENAME_FEEDERS' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

then i get other errors below that. can anyone help

Share this post


Link to post
Share on other sites
Im lost with this. I installed version 1.25 form the contrib page and i get these errors.

Warning: include(includes/languages/english/FILENAME_FEEDERS) [function.include]: failed to open stream: No such file or directory in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

Warning: include(includes/languages/english/FILENAME_FEEDERS) [function.include]: failed to open stream: No such file or directory in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

Warning: include() [function.include]: Failed opening 'includes/languages/english/FILENAME_FEEDERS' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

then i get other errors below that. can anyone help

 

you need to make sure that filename feeders is defined in catalog/admin/includes/filenames.php

ex...

define('FILENAME_FEEDERS', 'feeders.php');

Share this post


Link to post
Share on other sites

I must be doing something wrong.

 

According to Froogle the correct format is:

id title description link price brand condition image_link isbn mpn upc weight product_type quantity shipping tax

 

However this contribution (Google Base v1.25, olsonsp4c) is producing:

brand condition link title description expiration_date price image_link product_type id weight

 

Which is not acceptable and rejected by Google Base:

We didn't understand the header (first) row of your file. Please make sure you're using valid attribute names.

weight

 

We didn't understand the header (first) row of your file. Please make sure you're using valid attribute names.

product_type

 

We didn't understand the header (first) row of your file. Please make sure you're using valid attribute names.

condition

 

We didn't understand the header (first) row of your file. Please make sure you're using valid attribute names.

brand

 

Please let me know my error/s if you can help.

Edited by Dennisra

Share this post


Link to post
Share on other sites

I am getting this error when trying to upload to google:

 

File completed: ypg-froogle.txt

FTP open connection failed to uploads.google.com

 

Script timer: 3.037455 seconds.

Share this post


Link to post
Share on other sites

Using google base auto feeder 1.1

 

 

My feed failed - google gave the following message:

 

Errors:

Error Bad data Line #

We didn't understand your delimiter.

 

 

Also, if I look at the text file www.mydomain.com/textfil.txt in the browser, I get:

 

Parse error: syntax error, unexpected ';' in /xxxx url etc etc /public_html/googlebase.php on line 24

 

Any suggestions here?

 

Thanks

Edited by themilkman

Whats the point of a signature?

Share this post


Link to post
Share on other sites
Using google base auto feeder 1.1

 

 

My feed failed - google gave the following message:

 

Errors:

Error Bad data Line #

We didn't understand your delimiter.

 

 

Also, if I look at the text file www.mydomain.com/textfil.txt in the browser, I get:

 

Parse error: syntax error, unexpected ';' in /xxxx url etc etc /public_html/googlebase.php on line 24

 

Any suggestions here?

 

Thanks

 

 

On line 24 I had use the % sign for the tax - the output works now so am going to re-submit to google.

 

Thanks


Whats the point of a signature?

Share this post


Link to post
Share on other sites
On line 24 I had use the % sign for the tax - the output works now so am going to re-submit to google.

 

Thanks

 

 

 

Okay after re-submitting got the same error about the delimiter:

 

Errors:

Error Bad data Line #

We didn't understand your delimiter.

 

 

What to do about it?

 

Thanks


Whats the point of a signature?

Share this post


Link to post
Share on other sites
Okay after re-submitting got the same error about the delimiter:

 

Errors:

Error Bad data Line #

We didn't understand your delimiter.

 

 

What to do about it?

 

Thanks

 

 

Okay now I have set it from autodetect to tab /t

 

Will see if this works, thanks


Whats the point of a signature?

Share this post


Link to post
Share on other sites
Okay now I have set it from autodetect to tab /t

 

Will see if this works, thanks

 

 

Now I get:

 

Errors:

Error Bad data Line #

We did not understand the header (first) row of your file. Please make sure that you are using valid attribute names. help

 

We did not understand the header (first) row of your file. Please make sure that you are using valid attribute names. help <body>

2


Whats the point of a signature?

Share this post


Link to post
Share on other sites
I am getting this error when trying to upload to google:

 

File completed: ypg-froogle.txt

FTP open connection failed to uploads.google.com

 

Script timer: 3.037455 seconds.

Can anyone help me with this? I know the userid/password is correct, as I can login to uploads.google.com with no problem.

 

Thanks.

Share this post


Link to post
Share on other sites
Now I get:

 

Errors:

Error Bad data Line #

We did not understand the header (first) row of your file. Please make sure that you are using valid attribute names. help

 

We did not understand the header (first) row of your file. Please make sure that you are using valid attribute names. help <body>

2

 

Okay I took the output file and then copied the data into my own text file but deleted some columns and re-submitted manually and it took the data and it is live. This mean that all the columns being generated are not relevant for the Google category "Products". When my current feed expires in 2 days I will change the code to exclude some of the columns and try again........


Whats the point of a signature?

Share this post


Link to post
Share on other sites

My google base items expired... all of them... I tried to resubmit and it failed...

 

Reason: the feed is generating an expiration date for every item 2/12/09

 

how do I remove this tab in the code... I don't want an expiration date... lol

 

anyone that could help me with this - I would be grateful.

 

Thanks

Lonny

Edited by lowkey704

Yeah Yeah I am learning as I go... lol

Share this post


Link to post
Share on other sites
I am getting this error when trying to upload to google:

 

File completed: ypg-froogle.txt

FTP open connection failed to uploads.google.com

 

Script timer: 3.037455 seconds.

Can anyone please help me with this?

Share this post


Link to post
Share on other sites

Ok I have installed all the updates now... I still have this problem. I go through the steps... for whatever reason I can never make it upload to google through the submit button Warning: ftp_login() [function.ftp-login]: Login incorrect. in /var/www/vhosts/themancaveoutletstore.com/httpdocs/admin/googlefeeder.php on line 384

FTP connection has failed!

Attempted to connect to uploads.google.com for user nobodyspecial

 

Script timer: 4.692065 seconds.

 

line 384: $login_result = ftp_login($conn_id, $ftpusername, $ftppassword);

 

 

Anyways so I do it manually... click on data.txt - it opens a new page in my browser that shows me the file... I get to looking and sure enough 2009-12-02 is all over the place... I have 1,000 plus products... I can't just go through this file - copy and pasting...

 

My base items have expired... Boo!!! lol... so please someone - anyone... guide me to the light... tell me what I am not seeing or doing...

 

I stripped the EXP codes out of the admin and root googlefeeder.php file and they 2009-12-02 was still showing up...

 

I am lost...

 

Thank you,

 

Lonny


Yeah Yeah I am learning as I go... lol

Share this post


Link to post
Share on other sites

just eager to see if anyone has experience this problem. the expiration date is an expired date... ?? :unsure:


Yeah Yeah I am learning as I go... lol

Share this post


Link to post
Share on other sites

ok nevermind... somehow it corrected itself lol..

 

but i do have a question... how can I tell the code to remove the (") characters

 

for example... if I have a product description that says "play like the pros"

 

google see the pair of "" as something different... I have to manually go into the feed and remove them... I know there has to be a way to strip them from the feed as it's being generated.


Yeah Yeah I am learning as I go... lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×