Latest News: (loading..)
gottaloveit

Automatically send data feed to Froogle

3,578 posts in this topic

I just installed the 1.25 version by olsonsp4c. The file creates fine when tested, but when I click on the 'Send Feed' button in admin -> Tools -> GoogleBase Manager, nothing happens. I use IE7 and I notice that when the mouse hovers over the button, no url or file destination shows up in the bottom left of my IE screen. It appears there is no file/url associated with this button. I have double checked the install and everything is there.

 

Help me, olsonsp4c. You're my only hope. :lol:

Share this post


Link to post
Share on other sites
I get this error:

 

 

If I delete:

products_model AS prodModel,

 

all works fine.

 

Any ideas?

 

Try changing the line to

products.products_model AS prodModel,

 

Your database may have products_model in more than one table making it "ambiguous".

 

-Calvin

Edited by FlyingMonkey

Share this post


Link to post
Share on other sites
I just installed the 1.25 version by olsonsp4c. The file creates fine when tested, but when I click on the 'Send Feed' button in admin -> Tools -> GoogleBase Manager, nothing happens. I use IE7 and I notice that when the mouse hovers over the button, no url or file destination shows up in the bottom left of my IE screen. It appears there is no file/url associated with this button. I have double checked the install and everything is there.

 

Help me, olsonsp4c. You're my only hope. :lol:

 

 

It appears to be an issue in the language file. Give this a try and let me know if it worked. (I haven't installed 1.25 or tested the modification), so you'll be the first.

 

Replace /language/english/feeders.php with:

 

<?php
/* feeders.php v1.26 2009/01/06 */

define('HEADING_TITLE', 'GoogleBase Feeder System');
define('BODY_TEXT', 'Submit the ' . STORE_NAME . ' Google Base Feed <form method="link" action="' . tep_href_link(FILENAME_GOOGLE) . '"><input type="submit" value="Send Feed"></form>');

?>

 

The other option is always just to use really simple HTML, if the above doesn't work.

 

<?php
/* feeders.php v1.26 2009/01/06 */

define('HEADING_TITLE', 'GoogleBase Feeder System');
define('BODY_TEXT', 'Submit the ' . STORE_NAME . ' Google Base Feed <a href="' . tep_href_link(FILENAME_GOOGLE) . '">Send Feed</a>');

?>

 

 

-FlyingMonkey

Edited by FlyingMonkey

Share this post


Link to post
Share on other sites

Thanks FM!

 

That first set of code worked for me.

 

I hit the Send Feed button and it then showed me a screen which said 'File Completed: "myfeedfile.txt."

 

Is there supposed to be something more? I had assumed that this contrib would create the file and then also let me send it to Google somehow (after a little bit of editing, if needed). Is that what just happened (all in one click)?

 

More questions, by the way. :)

 

Is Google still picky about there only being one product_type? I want the file to contain the last category in the category tree if that is the case. I sell several types of jewelry - body piercing, stainless steel and traditional. If Google is still requiring only one product_type, I want the 'belly ring' product_type for my belly rings instead of 'jewelry, body jewelry, belly rings' or 'jewelry'. Someone posted earlier a fix that uses the top category alone, but I would like it to capture the bottom category.

 

Thanks for this great contrib, by the way!

Share this post


Link to post
Share on other sites
Try changing the line to
products.products_model AS prodModel,

 

Your database may have products_model in more than one table making it "ambiguous".

 

-Calvin

 

Thanks Calvin....That worked.

Jon

Share this post


Link to post
Share on other sites
Thanks FM!

 

That first set of code worked for me.

 

I hit the Send Feed button and it then showed me a screen which said 'File Completed: "myfeedfile.txt."

 

Is there supposed to be something more? I had assumed that this contrib would create the file and then also let me send it to Google somehow (after a little bit of editing, if needed). Is that what just happened (all in one click)?

 

Yes. Take a look at step 7 of the installation instructions. There should be something indicates it has been uploaded to Google.

 

 

More questions, by the way. :)

 

Is Google still picky about there only being one product_type? I want the file to contain the last category in the category tree if that is the case. I sell several types of jewelry - body piercing, stainless steel and traditional. If Google is still requiring only one product_type, I want the 'belly ring' product_type for my belly rings instead of 'jewelry, body jewelry, belly rings' or 'jewelry'. Someone posted earlier a fix that uses the top category alone, but I would like it to capture the bottom category.

 

Thanks for this great contrib, by the way!

 

 

hmm.... try replacing:

 

$catIndex[$row->prodCatID] . "\t" .

 

with:

 

$row->catName . "\t" .

 

Once again, I have not tested it. Let me know if it works. Google also now takes the full category tree. If I remember correctly... that should be the default behavior. It may be comma separated though right now.

Cheers,

 

-FlyingMonkey

Edited by FlyingMonkey

Share this post


Link to post
Share on other sites

This is a great add on my only complaint is that I had to disable the safe URLs to get google to accept the upload. Can you tell me now that google has uploaded the file is it safe to turn safe urls back on?

Share this post


Link to post
Share on other sites

My sincere apologies if this has been covered elsewhere - I've looked really hard!

I installed this excellent contribution this morning, following instructions carefully. I also encountered the inactive button problem, and used the code provided by Flying Monkey - perfect, thanks!

 

However, when I run googlefeeder.php I get the following message. I've tried disabling my firewall but it hasn't helped. Can anyone point me in the right direction please...?

 

Warning: ftp_connect() has been disabled for security reasons in /home/tooltrol/public_html/admin/googlefeeder.php on line 376

FTP open connection failed to uploads.google.com

Share this post


Link to post
Share on other sites
$row->catName . "\t" .

 

This worked - I am only getting the last category in the tree now for each product. However, if Google is allowing the full tree these days, I will revert it back to the original code.

 

I uninstalled the 1.25 version and installled the 1.21 version.

 

When I visit admin and click Feeder Systems in the menu, it opens to (in the main page):

"Google Base / Froogle: Google Base / Froogle" (with the last part being clickable)

 

When I click on the last 'Google Base / Froogle' it opens a new window which says "File completed: 'myfile' " and then I get nothing else.

 

I just noticed something else. When I click on the Feeder Systems in the menu, it opens a sub-menu below it which also says "Google Base / Froogle" which, when clicked, also opens a new window that only states that the 'file completed: myfile' - with nothing else.

 

PS - There is no file uploaded to GoogleBase.

Edited by vicster

Share this post


Link to post
Share on other sites
This worked - I am only getting the last category in the tree now for each product. However, if Google is allowing the full tree these days, I will revert it back to the original code.

 

I uninstalled the 1.25 version and installled the 1.21 version.

 

When I visit admin and click Feeder Systems in the menu, it opens to (in the main page):

"Google Base / Froogle: Google Base / Froogle" (with the last part being clickable)

 

When I click on the last 'Google Base / Froogle' it opens a new window which says "File completed: 'myfile' " and then I get nothing else.

 

I just noticed something else. When I click on the Feeder Systems in the menu, it opens a sub-menu below it which also says "Google Base / Froogle" which, when clicked, also opens a new window that only states that the 'file completed: myfile' - with nothing else.

 

PS - There is no file uploaded to GoogleBase.

 

 

There a line you need to uncomment to upload the file to Google. It's in the instructions. Step 7?

Share this post


Link to post
Share on other sites

Yes, that line is uncommented. :(

 

I've tried running this in IE and in Firefox, but get the same results (I tried it in FF because sometimes IE does wierd stuff).

Share this post


Link to post
Share on other sites
Yes, that line is uncommented. :(

 

I've tried running this in IE and in Firefox, but get the same results (I tried it in FF because sometimes IE does wierd stuff).

 

 

it's not browser related. it's a server side issue. it should throw at least an error message if the line is uncommented. check your php debug levels to make sure errors are thrown.

 

To be sure,

 

//ftp_file( $ftp_server, $ftp_user_name, $ftp_user_pass, $source_file, $ftp_directory, $destination_file);

 

is the line.

Share this post


Link to post
Share on other sites
There a line you need to uncomment to upload the file to Google. It's in the instructions. Step 7?

 

Thanks gor your reply. In actual fact the line you refer to is already uncommented in the contribution download package. I did get to the cause of the problem though. Many hosting companies disable the ftp_connect() function for security. A quick call to my host and the job's done! A tremendous contribution that'll save me hours every week - thanks FlyingMonkey

Share this post


Link to post
Share on other sites
check your php debug levels to make sure errors are thrown.

 

You lost me here, so I googled 'php debug'...should I have a program to debug php? Sorry for sounding like an idiot, but I'm new to this. :blink:

 

And it reminds me that another contrib I had installed (Paypal) was supposed to debug itself (during the testing stage) and send me e-mails with any errors...I never received any e-mails.

Share this post


Link to post
Share on other sites

I have two questions.

 

Should I be using version 1.21 or should I be using 1.20?

 

Also, in the googlefeeder.php file where you say to put the full path to the $OutFile - does it need the absolute path or just the http:// path?

 

Thanks!

Share this post


Link to post
Share on other sites

Trying to link my Google Base and Google Checkout accounts so I can offer Google Checkout via Google Shopping .... if that makes any sense at all...

 

The Google Base help section says I have to add a new area to my feed and have it say payment_options or something along those lines. Any idea on how to do this? Thanks!!

Share this post


Link to post
Share on other sites
I have two questions.

 

Should I be using version 1.21 or should I be using 1.20?

 

Also, in the googlefeeder.php file where you say to put the full path to the $OutFile - does it need the absolute path or just the http:// path?

 

Thanks!

 

1.21 should be fine. the $Outfile can either be the absolute or relative path of the file.

Share this post


Link to post
Share on other sites

Im lost with this. I installed version 1.25 form the contrib page and i get these errors.

Warning: include(includes/languages/english/FILENAME_FEEDERS) [function.include]: failed to open stream: No such file or directory in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

Warning: include(includes/languages/english/FILENAME_FEEDERS) [function.include]: failed to open stream: No such file or directory in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

Warning: include() [function.include]: Failed opening 'includes/languages/english/FILENAME_FEEDERS' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

then i get other errors below that. can anyone help

Share this post


Link to post
Share on other sites
Im lost with this. I installed version 1.25 form the contrib page and i get these errors.

Warning: include(includes/languages/english/FILENAME_FEEDERS) [function.include]: failed to open stream: No such file or directory in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

Warning: include(includes/languages/english/FILENAME_FEEDERS) [function.include]: failed to open stream: No such file or directory in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

Warning: include() [function.include]: Failed opening 'includes/languages/english/FILENAME_FEEDERS' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/lucky7t/public_html/restomusclecar.com/admin/googlefeeder.php on line 14

 

then i get other errors below that. can anyone help

 

you need to make sure that filename feeders is defined in catalog/admin/includes/filenames.php

ex...

define('FILENAME_FEEDERS', 'feeders.php');

Share this post


Link to post
Share on other sites

I must be doing something wrong.

 

According to Froogle the correct format is:

id title description link price brand condition image_link isbn mpn upc weight product_type quantity shipping tax

 

However this contribution (Google Base v1.25, olsonsp4c) is producing:

brand condition link title description expiration_date price image_link product_type id weight

 

Which is not acceptable and rejected by Google Base:

We didn't understand the header (first) row of your file. Please make sure you're using valid attribute names.

weight

 

We didn't understand the header (first) row of your file. Please make sure you're using valid attribute names.

product_type

 

We didn't understand the header (first) row of your file. Please make sure you're using valid attribute names.

condition

 

We didn't understand the header (first) row of your file. Please make sure you're using valid attribute names.

brand

 

Please let me know my error/s if you can help.

Edited by Dennisra

Share this post


Link to post
Share on other sites

I am getting this error when trying to upload to google:

 

File completed: ypg-froogle.txt

FTP open connection failed to uploads.google.com

 

Script timer: 3.037455 seconds.

Share this post


Link to post
Share on other sites

Using google base auto feeder 1.1

 

 

My feed failed - google gave the following message:

 

Errors:

Error Bad data Line #

We didn't understand your delimiter.

 

 

Also, if I look at the text file www.mydomain.com/textfil.txt in the browser, I get:

 

Parse error: syntax error, unexpected ';' in /xxxx url etc etc /public_html/googlebase.php on line 24

 

Any suggestions here?

 

Thanks

Edited by themilkman

Share this post


Link to post
Share on other sites
Using google base auto feeder 1.1

 

 

My feed failed - google gave the following message:

 

Errors:

Error Bad data Line #

We didn't understand your delimiter.

 

 

Also, if I look at the text file www.mydomain.com/textfil.txt in the browser, I get:

 

Parse error: syntax error, unexpected ';' in /xxxx url etc etc /public_html/googlebase.php on line 24

 

Any suggestions here?

 

Thanks

 

 

On line 24 I had use the % sign for the tax - the output works now so am going to re-submit to google.

 

Thanks

Share this post


Link to post
Share on other sites
On line 24 I had use the % sign for the tax - the output works now so am going to re-submit to google.

 

Thanks

 

 

 

Okay after re-submitting got the same error about the delimiter:

 

Errors:

Error Bad data Line #

We didn't understand your delimiter.

 

 

What to do about it?

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now