Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

i think commenting out
ftp_pasv ( $conn_id, true );

will help.. but im not so sure

That didn't work. Does anyone else have any ideas?

 

Thanks, Jason

Share this post


Link to post
Share on other sites

I am going crazy with this error.

 

Even went back to 1.03, it used to work fine.

 

File completed: xxxxxxxx.txt

Connected to uploads.google.com, for user xxxxx

 

Warning: ftp_put() [function.ftp-put]: PORT command successful. in /home/xxxx/public_html/admin/googlefeeder.php on line 363

uploads.google.com: FTP upload has failed!

 

Script timer: 94.597038 seconds.

 

Any idea?

Share this post


Link to post
Share on other sites

Hello,

 

Been using v1.20 on multiple sites and always working fine. I just installed it on another site and setup a google account. Ran the file and received a good load,

 

File completed: google.txt

Connected to uploads.google.com, for user tester

Uploaded /home/virtual/domain.com/var/www/html/temp/google.txt to uploads.google.com as google.txt

 

Script timer: 5.829862 seconds.

 

But for some reason the items are not showing in my google base account?? It has been 24hrs. Did something change at Google?

 

Thanks JR

Share this post


Link to post
Share on other sites

I have been struggling adding a GoogleFeeder to a client's site. I have a v 1.2 running on a different site on a different host just fine. On this site, I am continually running into this error:

 

FTP open connection failed to uploads.google.com

 

I checked and re-checked my FTP user/pwd, and everything seems to be OK. The script writes the .txt file fine, gives me the link after it runs etc. Just can't get this one to connect to Google. I saw a comment on commenting over the ftp_pasv ( $conn_id, true ) ; line, but it didn't seem to make a difference. It always seems to stall at the beginning of the "set up basic connection" segment.

 

Any suggestions? Could it be the host?

Edited by 200Megaton

Share this post


Link to post
Share on other sites

I've been trying to install (and make work) Google Base / Froogle Data Feeder v1.20 and am having problems...

 

When I try to test the file creation in a browser, I get:

 

File completed: filename.txt

 

Script timer: 41.191138 seconds.

 

filename.txt has a link to where I told it to put the file in the configuration step. When I go to the file, which is 777 and in a subdirectory (also 777) of a temp directory (also 777) under the catalog directory, the file is empty.

 

I tried adding content to the placeholder file. It doesn't overwrite the content even though it says, "File completed".

 

I have tried all sorts of stuff including taking the .htaccess file out of the admin path. Nothing seems to work.

 

I have seen several posting in this thread that had the same problem but I didn't see one that got an answer.

 

Can anyone out there please give me some suggestions?

 

 

Thanks in advance,

 

Tom

Share this post


Link to post
Share on other sites

When running the file I get A LOT of : (in apache server log)

 

PHP Notice: Undefined variable: _sid in [....path.....]includes/classes/seo.class.php

 

 

I am using the version by david for CHEMO URL (which apparently works ok)

 

Any thoughts ?

 

ps: [...path...] is the absolute path to my osc shop.

 

 

anyway: THANK YOU VERY MUCH FOR THIS CONTRIB ! may you live long and prosper !

Edited by GeorgeP

Share this post


Link to post
Share on other sites
I've been trying to install (and make work) Google Base / Froogle Data Feeder v1.20 and am having problems...

 

When I try to test the file creation in a browser, I get:

 

File completed: filename.txt

 

Script timer: 41.191138 seconds.

 

filename.txt has a link to where I told it to put the file in the configuration step. When I go to the file, which is 777 and in a subdirectory (also 777) of a temp directory (also 777) under the catalog directory, the file is empty.

 

I tried adding content to the placeholder file. It doesn't overwrite the content even though it says, "File completed".

 

I have tried all sorts of stuff including taking the .htaccess file out of the admin path. Nothing seems to work.

 

I have seen several posting in this thread that had the same problem but I didn't see one that got an answer.

 

Can anyone out there please give me some suggestions?

Thanks in advance,

 

Tom

 

Double check your database connection. At a minimum, even if the database connection is not set, it will write a line with the headers.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Hi,

I tried to install this contribution and I get

Warning: fopen(http://www.mysite.com/catalog/feeds/myfile.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /home2/xxxxxxx/public_html/catalog/admin/googlefeeder.php on line 321

 

Warning: fwrite(): supplied argument is not a valid stream resource in /home2/xxxxxx/public_html/catalog/admin/googlefeeder.php on line 322

 

Warning: fclose(): supplied argument is not a valid stream resource in /home2/xxxxxx/public_html/catalog/admin/googlefeeder.php on line 323

File completed: myfile.txt

 

Warning: chmod() [function.chmod]: No such file or directory in /home2/xxxxxx/public_html/catalog/admin/googlefeeder.php on line 325

 

Script timer: 0.955973 seconds.

 

I saw someone had the same problem and was told to check permissions. I have tried permissions at 777, 775 and 755.

Can anyone help?

Share this post


Link to post
Share on other sites
HTTP wrapper does not support writeable connections.

 

you might check with your isp. it looks as though the http wrapper's ability to open a writable http connection to a url has been disabled, causing the error on line 321. this failure is causing at least the next two errors. so resolving the first issue will likely resolve the rest.

Share this post


Link to post
Share on other sites
you might check with your isp. it looks as though the http wrapper's ability to open a writable http connection to a url has been disabled, causing the error on line 321. this failure is causing at least the next two errors. so resolving the first issue will likely resolve the rest.

Hi,

Thanks for your reply.

Just to make sure I understood. Do I have to ask my hosting company or my internet service provider or is it something I can do on my own?

 

Thanks in advance,

Alexandra

Share this post


Link to post
Share on other sites
Just to make sure I understood. Do I have to ask my hosting company or my internet service provider or is it something I can do on my own?

 

sorry for the confusion. i said isp but meant hosting company...the people hosting the web site.

Share this post


Link to post
Share on other sites
sorry for the confusion. i said isp but meant hosting company...the people hosting the web site.

Thank you. I have contacted them and waiting for a reply.

Share this post


Link to post
Share on other sites

Hi,

I got it to write the file but I can't get it to write the file with prices in USD. My default currency is euro. Also I can't get it to automatically upload so I sent the file manually.

 

I uncommented the line in step 7 a so it looks like this:

// close the FTP stream

ftp_close($conn_id);

 

return true;

}

 

 

//End FTP

 

 

When it says in step 7b to upload google feeder.php int catalog/admin is it ok to just save it when I uncomment the line because the file is already in catalog/admin or am I doing something wrong?

 

 

5) Upload googlefeeder.php into catalog/admin/

 

6) Make sure the file is being written properly.

a. To run the feeder point your internet browser to http://www.yourwebsite.com/admin/googlefeeder.php

b. Then point your browser to http://www.yourwebsite.com/feeds/your-outfile.txt to check the feed.

 

7) If the file is being written properly.

a) Uncomment the following line:

//ftp_file( $ftp_server, $ftp_user_name, $ftp_user_pass, $source_file, $ftp_directory, $destination_file);

b. Upload googlefeeder.php into catalog/admin/

 

 

 

This is what I have tried so I can get the prices in USD but it didn't work. I get them in euro.

//START Required Configuration

 

$OutFile = "/*****/l****/public_html/catalog/feeds/myfile.txt"; //"CHANGEME-full-path-to-file-with-777-dir-and-file-permissions-your-outfile.txt";

$destination_file = "myfile.txt"; //"CHANGEME-filename-to-upload-to-google.txt" ;

$source_file = $OutFile;

$catalogURL = 'http://www.mydomain.com/catalog/';

$imageURL = 'http://www.mydomain.com/catalog/images/';

$productURL = 'http://www.mydomain.com/catalog/product_info.php?currency=USD&products_id=';

$already_sent = array();

 

$home = "*****" ;

$user="*****";

$pass="*****";

$base="*****";

 

$ftp_server = "uploads.google.com" ;

$ftp_user_name = "myusername";

$ftp_user_pass = "mypassword";

$ftp_directory = ""; // leave blank

 

$convertCur = true; //default = false

$curType = "USD"; // Converts Currency to any defined currency (eg. USD, EUR, GBP)

if($convertCur)

{

$productURL = 'http://www.mydomain.com/catalog/product_info.php?currency=USD&products_id=';//where CURTYPE is your currency type (eg. USD, EUR, GBP)

}

 

$productCondition = "new"; //new, used, OR refurbished for ALL products.

 

I appreciate any help

Thank you

Share this post


Link to post
Share on other sites

This is the first error I'm getting:

 

Warning: ftp_connect() [function.ftp-connect]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /data/5/0/58/142/221631/user/225165/htdocs/shop/admin/googlefeeder.php on line 333

FTP open connection failed to

 

The file creates perfectly in this instance; I just wish that I could get it to upload to google so that I didn't have to manually do it all the time.

 

Then, whenever I try to play with the script (adding ftp:// instead of just uploads.google.com) I end up getting an Internal Server Error. I've been playing with this all morning and I'm really frustrated. I'm at the point where I've exhausted my ideas on what else to fiddle with to get it to work.

Share this post


Link to post
Share on other sites

Hello all!

 

I have tried to resolve this issue alone to no avail. Since Googlebase has changed a little (auto scheduling uploads etc) I am getting the following error about my upload to google base.

 

Errors:

Error Bad data Line #

We didn't understand the header (first) row of your file. Please make sure you're using valid attribute names. - help offer_id:

1

This attribute is no longer supported. Please use a supported attribute. - help category:

1

 

 

Has anyone had a similar problem yet?

 

Pete


Life Is Too Short,

Enjoy Your Coffee!

Pete

Share this post


Link to post
Share on other sites
Hello all!

 

I have tried to resolve this issue alone to no avail. Since Googlebase has changed a little (auto scheduling uploads etc) I am getting the following error about my upload to google base.

 

Errors:

Error Bad data Line #

We didn't understand the header (first) row of your file. Please make sure you're using valid attribute names. - help offer_id:

1

This attribute is no longer supported. Please use a supported attribute. - help category:

1

Has anyone had a similar problem yet?

 

Pete

 

Hi Pete,

 

Are you sure you are using a current and upto date version of the google base feeder.

 

These are the headers that are now used by google base:

 

brand

condition

link

title

description

expiration_date

price

image_link

product_type

id

 

I would suggest you use this contribution http://addons.oscommerce.com/info/4513

 

Aran

Share this post


Link to post
Share on other sites
Hi Pete,

 

Are you sure you are using a current and upto date version of the google base feeder.

 

These are the headers that are now used by google base:

I would suggest you use this contribution http://addons.oscommerce.com/info/4513

 

Aran

 

I already had it installed and I guess somewhere along the line I deleted the wrong bookmark to the new googlefeeder link! I was just using an old bookmark. DUH!!!! I guess I can still make a dumb mistake after 5 years!!!


Life Is Too Short,

Enjoy Your Coffee!

Pete

Share this post


Link to post
Share on other sites

Hello Peoples

 

Anyone know why I received this error msg from Froogle

 

 

File completed: replica-sunglasses.txt

 

Warning: ftp_login(): Login incorrect. in /usr/wwwroot/ddehek/newzealandnz/replica-sunglasses/admin/froogle.php on line 341

FTP connection has failed!

Attempted to connect to uploads.google.com for user newzealandnz

 

Script timer: 5.272128 seconds.

 

 

Cheers


Danny de Hek

Managing Director

 

New Zealand's Information Network

 

officecam.jpg

Share this post


Link to post
Share on other sites

Hello,

I have tried to use your contribution and have been successful in making the feed file without any issues.

But the problem is that my feed file has lot of HTML in the product description like quotes, tabs, tables, even extra spaces etc. With new rules from Google regarding the quoted attributes.... do you think your code can handle all this?

Please let me know ASAP.

Thanks,

Anisha.

Share this post


Link to post
Share on other sites
I've been trying to install (and make work) Google Base / Froogle Data Feeder v1.20 and am having problems...

 

When I try to test the file creation in a browser, I get:

 

File completed: filename.txt

 

Script timer: 41.191138 seconds.

 

filename.txt has a link to where I told it to put the file in the configuration step. When I go to the file, which is 777 and in a subdirectory (also 777) of a temp directory (also 777) under the catalog directory, the file is empty.

 

I tried adding content to the placeholder file. It doesn't overwrite the content even though it says, "File completed".

 

I have tried all sorts of stuff including taking the .htaccess file out of the admin path. Nothing seems to work.

 

I have seen several posting in this thread that had the same problem but I didn't see one that got an answer.

 

Can anyone out there please give me some suggestions?

 

 

Thanks in advance,

 

Tom

 

I am getting the same results as you did Tom what if any did you do to fix the issue?

 

My file xxx.txt does not create at all. I have read every post with no solution in site.

 

6) Make sure the file is being written properly.

a. To run the feeder point your internet browser to http://www.yourwebsite.com/admin/googlefeeder.php

b. Then point your browser to http://www.yourwebsite.com/feeds/your-outfile.txt to check the feed.

 

The file never get's created, I have checked the FTP login information and have even changed it again and again with no luck.

 

Does anyone have any suggestions?

Share this post


Link to post
Share on other sites

Is it possible to make this contribution add text to every product description.

 

I want every description to start with "IN STOCK" or something similar.

 

Any ideas on this? I presume it's permitted by Google?


Thanks for any help/comments.

 

Regards,

 

Lewis Hill

Share this post


Link to post
Share on other sites

Quick question:

I have Header Tags SEO contribution already installed and planning to install Ultimate SEO contribution also.

 

In description of Google Base / Froogle Data Feeder v1.03a for Ultimate SEO I read: "This will work with Ultimate SEO URLs 2.1d only - no other SEO contribution is supported.". Does it mean that it will not work if I will have both, Header Tags SEO and Ultimate SEO installed?

 

Thanks for help,

 

Mike


Computers777dotcom

Share this post


Link to post
Share on other sites

I'd llike to install that great contribution, but before doing that I'd like to know couple things:

 

I want to add UPC column to my products table and also make changes in Easy Populate to work with this field.

So, do EP and that contribution have aggreement for the name of that field?

And what changes I should make in that contribution to make it work after I will create that additional field?

 

Thanks for help,

 

Mike


Computers777dotcom

Share this post


Link to post
Share on other sites

I'm not sure if that thread is supported, but probably somebody can answer...

I got message "47 Naahh.. it will not work!" when I run googlefeeder.php

What can be a problem?

Thanks for any help.

 

Mike


Computers777dotcom

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×