Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

I receieved the following error after installation. I haven't gone further than step 6 yet because it doesn't appear to be working properly. here is the error message:

 

Warning: fopen(http://www.sitename.com/catalog/feeds/froogle.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /data/8/0/88/161/577324/user/589105/htdocs/catalog/admin/googlefeeder.php on line 321

 

Warning: fwrite(): supplied argument is not a valid stream resource in /data/8/0/88/161/577324/user/589105/htdocs/catalog/admin/googlefeeder.php on line 322

 

Warning: fclose(): supplied argument is not a valid stream resource in /data/8/0/88/161/577324/user/589105/htdocs/catalog/admin/googlefeeder.php on line 323

File completed: froogle.txt

 

Warning: chmod() [function.chmod]: No such file or directory in /data/8/0/88/161/577324/user/589105/htdocs/catalog/admin/googlefeeder.php on line 325

 

Script timer: 0.811788 seconds.

Share this post


Link to post
Share on other sites
I receieved the following error after installation. I haven't gone further than step 6 yet because it doesn't appear to be working properly. here is the error message:

 

Did you double check to ensure that your feeds folder is set to 777? Some host may not allow 777, try using 775 or 755.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

$OutFile = "http://www.motorheadextraordinaire.com/feeds/motor_feed.txt"; //"CHANGEME-full-path-to-file-with-777-dir-and-file-permissions-your-outfile.txt";
$destination_file = "motor_feed.txt"; //"CHANGEME-filename-to-upload-to-google.txt";
$source_file = $OutFile;
$catalogURL = 'http://www.motorheadextraordinaire.com/';
$imageURL = 'http://www.motorheadextraordinaire.com/images/';
$productURL = 'http://www.motorheadextraordinaire.com/product_info.php?products_id=';

$ftp_server = "uploads.google.com";
$ftp_user_name = "xxxxxxxxx";
$ftp_user_pass = "xxxx";

 

Ok we got his account and it still doesn't work. I get a totally blank white page.

 

The products url in the store looks like this:

http://www.motorheadextraordinaire.com/pro.../products_id/38

With each folder a different number so I don't know what to do here.

 

Thanks!

Share this post


Link to post
Share on other sites

$OutFile = "http://www.motorheadextraordinaire.com/feeds/motor_feed.txt"; //"CHANGEME-full-path-to-file-with-777-dir-and-file-permissions-your-outfile.txt";
$destination_file = "motor_feed.txt"; //"CHANGEME-filename-to-upload-to-google.txt";
$source_file = $OutFile;
$catalogURL = 'http://www.motorheadextraordinaire.com/';
$imageURL = 'http://www.motorheadextraordinaire.com/images/';
$productURL = 'http://www.motorheadextraordinaire.com/product_info.php?products_id=';

$ftp_server = "uploads.google.com";
$ftp_user_name = "xxxxxxxxx";
$ftp_user_pass = "xxxx";

 

Ok we got his account and it still doesn't work. I get a totally blank white page.

 

The products url in the store looks like this:

http://www.motorheadextraordinaire.com/pro.../products_id/38

With each folder a different number so I don't know what to do here.

 

Thanks!

Share this post


Link to post
Share on other sites
$OutFile = "http://www.motorheadextraordinaire.com/feeds/motor_feed.txt"; //"CHANGEME-full-path-to-file-with-777-dir-and-file-permissions-your-outfile.txt";
$destination_file = "motor_feed.txt"; //"CHANGEME-filename-to-upload-to-google.txt";
$source_file = $OutFile;
$catalogURL = 'http://www.motorheadextraordinaire.com/';
$imageURL = 'http://www.motorheadextraordinaire.com/images/';
$productURL = 'http://www.motorheadextraordinaire.com/product_info.php?products_id=';

$ftp_server = "uploads.google.com";
$ftp_user_name = "xxxxxxxxx";
$ftp_user_pass = "xxxx";

 

Ok we got his account and it still doesn't work. I get a totally blank white page.

 

The products url in the store looks like this:

http://www.motorheadextraordinaire.com/pro.../products_id/38

With each folder a different number so I don't know what to do here.

 

Thanks!

Sorry, but that's where I ran into the same problem and than gave up and decided to just do it manually. Hope someone else can help you. :(

Share this post


Link to post
Share on other sites
echo $output;

 

If you don't get any output, remove line 309 and insert that same line of code into line: 320.

 

This way you'll at least see if the feeder does anything. At a minimum you should get the headers for the file"brand\tcondition\tlink\ttitle\tdescription\texpiration_date\tprice\timage_link\tproduct_type\tid"; If you do get output, then it may be an issue with you hosting. Are any advance configurations enabled?

 

-Calvin


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Hi

 

I'm looking to install this contribution, I have Ultimate SEO and Separate Pricing per Customer installed currently. Couple of quick questions before I give it a go.

1. Do I need to change anything for UK use (Froogle.co.uk rather than.com)?

2. Does Google Base / Froogle Data Feeder v1.20 work with Ultimate SEO or do I need to use Google Base / Froogle Data Feeder v1.03b for Ultimate SEO?

 

Many thanks in advance.

Katie.

Share this post


Link to post
Share on other sites

Hi

 

I'm looking to install this contribution, I have Ultimate SEO and Separate Pricing per Customer installed currently. Couple of quick questions before I give it a go.

1. Do I need to change anything for UK use (Froogle.co.uk rather than.com)?

2. Does Google Base / Froogle Data Feeder v1.20 work with Ultimate SEO or do I need to use Google Base / Froogle Data Feeder v1.03b for Ultimate SEO?

 

Many thanks in advance.

Katie.

Share this post


Link to post
Share on other sites

Calvin,

 

When I inserted that line at line 309 I got a very long list of all products...this is the last line:

2007-04-05 1,496.50 http://www.motorheadextraordinaire.com/images/Custom® Series Portable With 2 Doors, 2 Drawers ss.JPG test - not for sale 103 File completed: motor_feed.txt

 

Script timer: 22.994957 seconds.

 

www.motorheadextraordinaire.com/admin/googlefeeder.php

 

When I clicked on that motor_feed.txt link at the very bottom I get a blank page???

 

It is my server for hosting and I have no advanced options enabled. The text file is 777 along with the feeds folder.

 

I don't know where else to look. The feeds folder is under the catalog folder.

 

Now, when I read this part again:

$OutFile = "../feeds/your-outfile.txt"; //Replace "your-outfile" with the filename provided by Google

$destination_file = "your-outfile.txt"; //"your-outfile" is provided by Google and is the same as above without the directory information

 

It says provided by Google. I just made a text file and put it in the feeds folder:

$OutFile = "http://www.motorheadextraordinaire.com/feeds/motor_feed.txt";

$destination_file = "../feeds/motor_feed.txt";

$source_file = $OutFile;

Edited by Melinda Odom

Share this post


Link to post
Share on other sites

I know this may sound strange but why do I not see install instructions?

Share this post


Link to post
Share on other sites

hmm hi... dont know why in the readme it says...

$imageURL = 'CHANGEME-http://www.yourwebsite.com/yourimagesdirectory/';

 

if my admin folder is http://www.yourwebsite.com/catalog/admin/

I have to change this http wrapper to

 

$imageURL = '../images/';

../ means I go one folder back out of admin and into /images/

maybe someone has the same problem...

 

my configuration looks like this now:

 

$OutFile = "../feeds/froogle.txt"; //"CHANGEME-full-path-to-file-with-777-dir-and-file-permissions-your-outfile.txt";
$destination_file = "froogle.txt";  //"CHANGEME-filename-to-upload-to-google.txt";
$source_file = $OutFile;
$catalogURL = '../';
$imageURL = '../images/';
$productURL = '../product_info.php?products_id=';
$already_sent = array();

 

its working with this configuration but the codes that are made include the wrong link....

Edited by MaNoLiA

Share this post


Link to post
Share on other sites

ok fixed the problem now... for

$productURL = '../product_info.php?products_id=';

use the full http:// address...

 

$productURL = 'http://www.yourwebsite.com/catalog/product_info.php?products_id=';

$imageURL = 'http://www.yourwebsite.com/catalog/images/';

 

I have a problem with the language... I have 3 languages... and there is a mix of english and spain :(

Edited by MaNoLiA

Share this post


Link to post
Share on other sites

Ok I added the language option for product title and description:

 

 

lines 119-140

WHERE products.products_id=products_description.products_id
AND products.products_id=products_to_categories.products_id
AND products_to_categories.categories_id=categories.categories_id
AND categories.categories_id=categories_description.categories_id
//add this:
AND products_description.language_id=2
// end
ORDER BY
products.products_id ASC
";


$catInfo = "
SELECT
//add this:
categories_description.language_id,
// end
categories.categories_id AS curCatID,
categories.parent_id AS parentCatID,
categories_description.categories_name AS catName
FROM
categories,
categories_description
WHERE categories.categories_id = categories_description.categories_id
//add this:
AND categories_description.language_id=2
// end
";

 

you should change this to a $language var that is editable by users in the next update? ;)

Share this post


Link to post
Share on other sites

grrrrr

still not working cause Strato disabled the ftp_connect function:

 

Call to undefined function: ftp_connect()

 

Someone got a solution for this?? :(

Share this post


Link to post
Share on other sites
Calvin,

 

When I inserted that line at line 309 I got a very long list of all products...this is the last line:

2007-04-05 1,496.50 http://www.motorheadextraordinaire.com/images/Custom® Series Portable With 2 Doors, 2 Drawers ss.JPG test - not for sale 103 File completed: motor_feed.txt

 

Script timer: 22.994957 seconds.

 

www.motorheadextraordinaire.com/admin/googlefeeder.php

 

When I clicked on that motor_feed.txt link at the very bottom I get a blank page???

 

It is my server for hosting and I have no advanced options enabled. The text file is 777 along with the feeds folder.

 

I don't know where else to look. The feeds folder is under the catalog folder.

 

Now, when I read this part again:

$OutFile = "../feeds/your-outfile.txt"; //Replace "your-outfile" with the filename provided by Google

$destination_file = "your-outfile.txt"; //"your-outfile" is provided by Google and is the same as above without the directory information

 

It says provided by Google. I just made a text file and put it in the feeds folder:

$OutFile = "http://www.motorheadextraordinaire.com/feeds/motor_feed.txt";

$destination_file = "../feeds/motor_feed.txt";

$source_file = $OutFile;

 

Check the feeds folder via your ftp for any files created and the date they were created.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Hello Guys,

 

I just have a small questions. hope you can make this clear for me.

I just installed the contribution and it seem to work fine.

 

when I'm done with upaloding the file to the FTP i get a message confirming the upload:

"Connected to uploads.google.com, for user <my user name>

Uploaded ../feeds/froogle.txt to uploads.google.com as froogle.txt"

 

The file is configured correctly in google as froogle.txt.

 

However, I did not get any confirmation from google for the uploaded file and when I log in to my google FTP folder i do not see the file there, even a moment after the upload.

 

My question is, should I see or get any confirmation from google for the file upload?

 

Thank you for your time,

 

Koby.

Share this post


Link to post
Share on other sites
Calvin,

 

The only file in the feeds folder is the motor_feed.txt file which is blank.

I believe you would have to have that file contain the information you want sent over to froogle. Again, not sure if thats what the purpose was of the contribution, but thats what I did. I first created the file using excel, saved as txt (text and tabs) and uploaded to server. My understanding was that this contribution made it simpler to send the file to froogle. If I'm wrong, please correct me. If not, than perhaps you should try that.

Share this post


Link to post
Share on other sites

I have a google account...where do i find the "filename provided by google"?

 

 

$OutFile = "../feeds/your-outfile.txt"; //Replace "your-outfile" with the filename provided by Google

Share this post


Link to post
Share on other sites

I'm having an issue. When I use the feeder, it says its uploaded correctly, but when I check my google base, there is nothing in it. Is there some sort of delay? I dont see why this is happening.

Share this post


Link to post
Share on other sites

Hi All,

 

It will be great if some one who is already using live froogle feed, please Make a document again with complete Installation guide, step by step Instruction, Because it look like this Topic started in 2004 with 89 pages on.

 

Thanks if someone comes up with some easy inStallation guide.

 

Thanks and regards..

zee

Edited by zeeshop

Share this post


Link to post
Share on other sites
I have a google account...where do i find the "filename provided by google"?

$OutFile = "../feeds/your-outfile.txt"; //Replace "your-outfile" with the filename provided by Google

 

 

Its the name of the file you want generated. When you register with google base you will specify your file name. Rename it to this. In my case I call it froogle-feed.txt

 

 

 

Can anyone help?

 

My items have also stopped appearing in googlebase. Google has said that I need to add a header line stating the attribute names. It would appear that at the moment this is not being added

 

Although if I manually upload my file it does show the items just not when I use the FTP side of things

Share this post


Link to post
Share on other sites
Calvin,

 

The only file in the feeds folder is the motor_feed.txt file which is blank.

 

The feeder is functioning correctly, but is not writing out the file. Check your feeder and server settings again.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
Hi All,

 

It will be great if some one who is already using live froogle feed, please Make a document again with complete Installation guide, step by step Instruction, Because it look like this Topic started in 2004 with 89 pages on.

 

Thanks if someone comes up with some easy inStallation guide.

 

Thanks and regards..

zee

 

It's part of the contribution package, a link is provided somewhere in the 89 pages to the contribution or you could just search for it in the contribution's area. ;)


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

I have already checked my settings and have removed this contribution.

 

It is not supported very well in my opinion with these vague answers and unclear install instructions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×