Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

hi,

 

i got an email from froogle saying that the images should be the big images and not the thumbnails. I tried changing the image-folder in froogle.php, but now it shows images as XXX.png, while the images are JPG-files (my thumbs are PNG). How do i correct that?

 

thanks!


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites

is theres a problem in froogle? I have been submitting my feeds for a week now and i keep getting this error

 

FTP connection has failed!

Attempted to connect to hedwig.google.com for user xxx

 

 

It used to work great before. Now I keep getting that error.

 

Thanks in advance.


Birds with same feathers, are same birds.

Share this post


Link to post
Share on other sites
is theres a problem in froogle? I have been submitting my feeds for a week now and i keep getting this error

 

FTP connection has failed!

Attempted to connect to hedwig.google.com for user xxx

It used to work great before. Now I keep getting that error.

 

Thanks in advance.

theres a new ftp server: uploads.google.com

 

but even with this one i also often get an FTP connection failed, so i mostly upload it by hand on the froogle site.


Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Share this post


Link to post
Share on other sites

Please read/search through this thread. Most of these answers have already been answered and most of the issues appear to be configuration. Please follow the directions again.

 

For the FTP connection fail: Double check your username/password in the Froogle Merchant Account.

 

pvtparts: I have never seen that before. what version of PHP are you running? the name/description goes through significantly more processing.

 

gr8sale: I do not find any occurence of "localhost" in your feed. There appears to be no issue.

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

I use this contribution:

Prices for Logged-In Users Only - Login view price 4.0

http://www.oscommerce.com/community/contri...ons,601/page,40

 

I received the following message from froogle. Is there any way around this while keeping Prices for Logged-In Users Only.

 

Thank you for submitting a bulk upload to Google Base. We've reviewed your bulk upload and need you to make changes. Your bulk upload has been disapproved due to the reason(s) listed below.

Issues:

- Price missing on item page

-----------------

Price missing on item page: Please make sure that the prices you include in your bulk upload also appear on your item pages. For example, the page you included for the item titled "1935 U.S. Mint Commemorative Year Set" does not include a price listing:

http://www.drabel.com/product_info.php?products_id=109

Please make sure that the product price is listed on your item pages, as this is one of Google Base's requirements for products.

After you've made the necessary change(s), please upload a new version of your bulk upload. We'll notify you if we need you to make any additional corrections. Otherwise, we'll send you an email to let you know that your bulk upload has been approved.

Sincerely,

The Google Team

Share this post


Link to post
Share on other sites
I use this contribution:

Prices for Logged-In Users Only - Login view price 4.0

http://www.oscommerce.com/community/contri...ons,601/page,40

 

I received the following message from froogle. Is there any way around this while keeping Prices for Logged-In Users Only.

 

Thank you for submitting a bulk upload to Google Base. We've reviewed your bulk upload and need you to make changes. Your bulk upload has been disapproved due to the reason(s) listed below.

Issues:

- Price missing on item page

-----------------

Price missing on item page: Please make sure that the prices you include in your bulk upload also appear on your item pages. For example, the page you included for the item titled "1935 U.S. Mint Commemorative Year Set" does not include a price listing:

http://www.drabel.com/product_info.php?products_id=109

Please make sure that the product price is listed on your item pages, as this is one of Google Base's requirements for products.

After you've made the necessary change(s), please upload a new version of your bulk upload. We'll notify you if we need you to make any additional corrections. Otherwise, we'll send you an email to let you know that your bulk upload has been approved.

Sincerely,

The Google Team

 

Dennisra

 

Looks like your google base feed does not contain any values for the price column. Have you manually checked your google-base feed text file? Is there any prices there?

If not, then just try disabling the "Price for Logged-in Users Only" contribution and then run the froogle and google-base feed. Once you have uploaded the feeds, you can turn on the "Price for Logged-in Users Only" contrib back on.

 

Looks like that contrib hides the price even from this script.

 

Hope this helps.

Share this post


Link to post
Share on other sites

Amit:

 

Thanks for the suggestion. That's what I thought at first also but the price is in the data feed. See below.

http://www.mysite.com/product_info.php?products_id=110 1936 U.S. Mint Commemorative Year Set Description: #776-778, 782-84. 5.25 http://www.mysite.com/0778.jpg Commemorative Year Sets 110

Edited by Dennisra

Share this post


Link to post
Share on other sites
Amit:

 

Thanks for the suggestion. That's what I thought at first also but the price is in the data feed. See below.

http://www.mysite.com/product_info.php?products_id=110 1936 U.S. Mint Commemorative Year Set Description: #776-778, 782-84. 5.25 http://www.mysite.com/0778.jpg Commemorative Year Sets 110

 

Dennisra, the problem isn't that the price isn't in your feed, it's that it isn't displayed (publically) on your site. That's what Froogle don't like, it's stated in their terms.

Share this post


Link to post
Share on other sites

Marc:

Thanks. I understand that. I was hoping there was some way around that but I guess not.

Dennis

Edited by Dennisra

Share this post


Link to post
Share on other sites
is theres a problem in froogle? I have been submitting my feeds for a week now and i keep getting this error

 

FTP connection has failed!

Attempted to connect to hedwig.google.com for user xxx

It used to work great before. Now I keep getting that error.

 

Thanks in advance.

 

It isn't hedwig.google.com any more it is uploads.google.com did you go to your account at google base and read about the changes?

 

Stephanie :blink:

Share this post


Link to post
Share on other sites
Thanks for that, I thought Id searched the thread properly..... :-)

 

I thought it may be MySQL v 5, Ive had a couple of other issues with it.

 

Ill let you know how I get on with the fix.

 

Sorry for the delay in replying, Yes the fix for MySQL 5 worked well,

 

Thanks,

Share this post


Link to post
Share on other sites

Just thought i'd add a couple of pointers, obvious though they may, regarding MySQL 5 users.

 

Check in your admin panel in TOOLS>SERVER INFORMATION for:

 

Configuration File (php.ini) Path

 

and note this to be the full path required in the step 1:

 

$OutFile = "../feeds/your-fr-outfile.txt"; //The filename to replace "your-fr-outfile" is provided by Froogle

 

righ up until the /admin

 

Example:

 

From This:

 

/websites/LinuxPackage03/fa/nc/yd/yourdomain.co.uk/public_html/catalog/admin/php.ini

 

To This:

 

/websites/LinuxPackage03/fa/nc/yd/yourdomain.co.uk/public_html/catalog/feeds/froogle.txt

 

ALSO:

 

Log into phpmyadmin and select your database.

 

Look at the top of the page and ensure that your Server or $home = "localhost" ; as required also in step 1 is named "localhost".

 

Mine for example was not localhost but mysql01.

 

These were the two problems i encountered and I hope they can resolve some issues for you guys also.

 

Many Thanks

D4

Edited by d4funky1

Share this post


Link to post
Share on other sites

I have the problem that since Google made the switch from 'Froogle' to 'Google base' they dont accept my feed.

 

I have over 800 Products in this feed and google say it is not utf-8 coded and they cant accept it.

 

here the email:

 

Hallo Patrick,

 

danke f?r Ihre R?ckmeldung und Ihr Feedback zu der Kodierung der

Bulk-Upload-Dateien. Es ist f?r uns jederzeit sehr hilfreich, Feedback von

unseren Nutzern zu erhalten. Wir hoffen, dass Sie uns weiterhin Ihre

Eindr?cke und Vorschl?ge mitteilen, da wir immer darum bem?ht sind,

Froogle und Google Base weiter zu verbessern.

 

Da wir keinen Einfluss auf Ihren Script haben, w?rden wir Ihnen empfehlen,

sich an Ihren Webmaster, Programmierer oder Shopsoftware-Anbieter zu

wenden, um sicherstellen zu k?nnen, dass der Script Dateien generiert, die

mit UTF-8 kodiert sind.

 

Lassen Sie uns gerne wissen, wenn Sie weitere Fragen haben.

 

Mit freundlichen Gr??en

 

Ihr Google-Team

 

They say i should told the problem to who has build the script and that it should be UTF-8 coded, i think it is a problem with german 'Umlaute' in product names and discriptions, they wont changed to utf-8.

 

I hope you can help me.

 

Patrick

Edited by Patrick_S

Captain: I thought you were going to upgrade this.

Trip: That is the upgrade.

Well, if you want, I can change the color.

Share this post


Link to post
Share on other sites
I changed this...

 

// charset for web pages and emails
define('CHARSET', 'iso-8859-1');

 

...to this...

 

// charset for web pages and emails
define('CHARSET', 'utf-8');

 

in both english.php files... I had to go through my products and replace the invalid characters, but it was a one-time edit, and the feed is now correct... :)

 

I tried this and it didn't work, I still get encoding errors on the same characters but I think the misinterpreted character is different (still not the right encoding but a different one none the less).

 

Any ideas ?

 

FlyingMonkey: Thanks for the contrib, good stuff. I'm sure you are aware that we are all eagerly awaiting a fix for the encoding problem (I sure am), we are wishing you good luck in vanquishing the problem :D

 

Cheers

Share this post


Link to post
Share on other sites

Hi All,

 

I was running this Contrib successfully until the GoogleBase changes.

I went through and made the necessary changes to admin/froogle.php and all is uploading without errors.

 

***Change

$ftp_server = "hedwig.google.com" ;

***to

$ftp_server = "uploads.google.com" ;

 

***Change

$output = "product_url t name t description t price t image_url t category t offer_id";

***to

$output = "link t title t description t price t image_link t label t id";

 

Remember to back up back up back up, just in case.

 

Have also added this to the Contrib @ http://www.oscommerce.com/community/contributions,3876

 

Hope this helps someone out there.

 

Regards, SHJ

Share this post


Link to post
Share on other sites

Hello,

 

at first great contribution.

 

my shop is in germany

i use SEO URLS

at the moment i use froogle v1.62.

 

The Problem i got my froogle.txt is complete in english not in german.

How to change language ?

 

thanks

and

bg

Michael

Share this post


Link to post
Share on other sites

Hey all,

 

Since the recent changes in Froogle I am having some small issues. My feed is being excepted with no problem, but everytime I upload it the google team notifies me that:

 

Missing attributes: We noticed that your items don't contain labels. We highly recommend you use the "label" attribute to include relevant keywords. The more relevant information you include for your items, the better we'll be able to match your items to users' queries.

 

Basically they want me to include product keywords for each item, I only have about 30000, LOL.

Does anybody know how to generate these maybe from categories tree and possibly from related products?

 

Any help is appreciated!

 

Thanks,

Steph

Share this post


Link to post
Share on other sites

I have a slightly modified verison of this great contrib. I added some values to turn off the ftp part of it and it also update currencies in the same script.

 

It has been working for a couple of weeks but it recently stopped and I reveived this error.

Warning: ftp_put(): php_connect_nonb() failed: No route to host (65) in /home/beachgla/public_html/catalog/update/index.php on line 571

Warning: ftp_put(): Entering Passive Mode (72,14,200,3,81,0) in /home/beachgla/public_html/catalog/update/index.php on line 571

This is the code around line 571:

ftp_pasv ( $conn_id, true );
// upload the file
$upload = ftp_put( $conn_id, $ftpdestinationfile, $ftpsourcefile, FTP_ASCII ); //Line 571
// check upload status
if (!$upload) {
echo "$ftpservername: FTP upload has failed!<BR>\n";


Eddie Schnell

Custom PC Builder

If you dare, take my advice. But make sure you back up TWICE before.

Share this post


Link to post
Share on other sites

I'm having the exact same issue also. Very frustrating......

 

I have a slightly modified verison of this great contrib. I added some values to turn off the ftp part of it and it also update currencies in the same script.

 

It has been working for a couple of weeks but it recently stopped and I reveived this error.

Warning: ftp_put(): php_connect_nonb() failed: No route to host (65) in /home/beachgla/public_html/catalog/update/index.php on line 571

Warning: ftp_put(): Entering Passive Mode (72,14,200,3,81,0) in /home/beachgla/public_html/catalog/update/index.php on line 571

This is the code around line 571:

ftp_pasv ( $conn_id, true );
// upload the file
$upload = ftp_put( $conn_id, $ftpdestinationfile, $ftpsourcefile, FTP_ASCII ); //Line 571
// check upload status
if (!$upload) {
echo "$ftpservername: FTP upload has failed!<BR>\n";

Share this post


Link to post
Share on other sites

Hello

 

When i was using froogle feed everything was fine, now that im using google base the store name is not coming up any more but the store owner name has replaced it.

 

I made no changes so i do not understand why this started to happen. :blink:

 

Kind regards

Share this post


Link to post
Share on other sites

This started happening to me after there was an update on my server. I called iPowerWeb, told them what the problem was, thay changed something, and it works like a charm. Problem is, they wont tell me what they did! >_<


Eddie Schnell

Custom PC Builder

If you dare, take my advice. But make sure you back up TWICE before.

Share this post


Link to post
Share on other sites

Hi,

 

Sorry if this has been suggested before, but this is now a very long thread :-)

 

Instead of defining the file and database variables separately in froogle.php why not:

 

1) At the top of the page add:

 

require('includes/application_top.php');

 

2) Change froogle.php to use constants from configure php

 

$home = DB_SERVER;

$user= DB_SERVER_USERNAME;

$pass= DB_SERVER_PASSWORD;

$base= DB_DATABASE;

 

3) Add to admin/includes/filenames.php

 

define('FILENAME_FROOGLE', 'froogle.php');

define('FILENAME_FROOGLE_OUT', '../feeds/your-fr-outfile.txt');

define('FILENAME_FROOGLE_DEST', 'your-fr-outfile.txt');

 

4) Change froogle.php to use above filenames:

 

$OutFile = FILENAME_FROOGLE_OUT;

$destination_file = FILENAME_FROOGLE_DEST;

 

-----------------------------------------------------------------

 

It does not make sense to add separate definintions for database constants, or depart from the osComm method of declaring file names, in my humble opinion :-)

 

For my own implementation I will add additional constants to configure.php to replace:

 

$ftp_server = "hedwig.google.com" ;

$ftp_user_name = "CHANGEME-froogle-username";

$ftp_user_pass = "CHANGEME-froogle-password";

Share this post


Link to post
Share on other sites
Hi,

 

Sorry if this has been suggested before, but this is now a very long thread :-)

 

Instead of defining the file and database variables separately in froogle.php why not:

 

1) At the top of the page add:

 

require('includes/application_top.php');

 

2) Change froogle.php to use constants from configure php

 

$home = DB_SERVER;

$user= DB_SERVER_USERNAME;

$pass= DB_SERVER_PASSWORD;

$base= DB_DATABASE;

 

3) Add to admin/includes/filenames.php

 

define('FILENAME_FROOGLE', 'froogle.php');

define('FILENAME_FROOGLE_OUT', '../feeds/your-fr-outfile.txt');

define('FILENAME_FROOGLE_DEST', 'your-fr-outfile.txt');

 

4) Change froogle.php to use above filenames:

 

$OutFile = FILENAME_FROOGLE_OUT;

$destination_file = FILENAME_FROOGLE_DEST;

 

-----------------------------------------------------------------

 

It does not make sense to add separate definintions for database constants, or depart from the osComm method of declaring file names, in my humble opinion :-)

 

For my own implementation I will add additional constants to configure.php to replace:

 

$ftp_server = "hedwig.google.com" ;

$ftp_user_name = "CHANGEME-froogle-username";

$ftp_user_pass = "CHANGEME-froogle-password";

 

 

Thought I may as well post my changes to configure.php:

 

At the end of the file I added

 

// define froogle parameters

define('FR_SERVER', 'hedwig.google.com');

define('FR_USERNAME', 'CHANGEME-froogle-username');

define('FR_PASSWORD', 'CHANGEME-froogle-password');

 

Then in froogle.php, assuming you already have added the line:

 

require('includes/application_top.php');

 

you can use:

 

$ftp_server = FR_SERVER;

$ftp_user_name = FR_USERNAME;

$ftp_user_pass = FR_PASSWORD;

Share this post


Link to post
Share on other sites

File completed:

 

Warning: ftp_login(): Login incorrect. in /home/woofwoof/public_html/english3/admin/froogle.php on line 325

FTP connection has failed!

Attempted to connect to uploads.google.com for user chongordon

 

Script timer: 3.425860 seconds.

 

 

 

 

 

Sorry, im newb in php. can u guys tell me whats my problem ?

THANKS!!!!!!!!!!!!!!!!!!!!!!!!!


Puppy Clothes by WoofWoofLand

Share this post


Link to post
Share on other sites
File completed:

 

Warning: ftp_login(): Login incorrect. in /home/woofwoof/public_html/english3/admin/froogle.php on line 325

FTP connection has failed!

Attempted to connect to uploads.google.com for user chongordon

 

Script timer: 3.425860 seconds.

Sorry, im newb in php. can u guys tell me whats my problem ?

THANKS!!!!!!!!!!!!!!!!!!!!!!!!!

The script is making the file, than sending it to Google.

Your script has made the file, but is having trouble logging into Google's FTP server. Make sure your login password is set correctly in the file.


Eddie Schnell

Custom PC Builder

If you dare, take my advice. But make sure you back up TWICE before.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×