Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

Calvin,

 

Some of my items on froogle are showing the sale prices, but then alot of them aren't. Any ideas on how I can fix this?

 

 

I struggled with this myself then doing some research I discovered that the specials without an expire date listed the full amount. So I made sure all my specials had an expiration date now the prices come out correctly.

Share this post


Link to post
Share on other sites
I struggled with this myself then doing some research I discovered that the specials without an expire date listed the full amount. So I made sure all my specials had an expiration date now the prices come out correctly.

 

which version are you running? There were some updates to the way specials were handled in the past. it currently enables specials if the specials status is enabled AND (if the date is newer than the current date OR no date is specified) as of probably the last couple of versions. maybe your specials were disabled? or the database maybe setup differently. which version of oSC are you using?

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
which version are you running? There were some updates to the way specials were handled in the past. it currently enables specials if the specials status is enabled AND (if the date is newer than the current date OR no date is specified) as of probably the last couple of versions. maybe your specials were disabled? or the database maybe setup differently. which version of oSC are you using?

 

Resolved as user error due to database swapping.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

I am using the latest version 1.62a

 

First off, thank you very much for that contribution, its easy to install and from what I can see generated file correctly, I uploaded to froogle, manually, and well lets see what happens :) I do have two questions:

 

1. I uncommented the FTP upload code but got the following errors (I replaced some real values by [...]):

File completed: froogle-outfile.txt
Connected to hedwig.google.com, for user [myUserName]

Warning: ftp_put() [function.ftp-put]: froogle-outfile.txt: Permission denied on server. (Overwrite) in D:\[full=path-to-catalog]\admin\froogle.php on line 344
hedwig.google.com: FTP upload has failed!

Script timer: 51.941484 seconds.
PHP Warning: ftp_put() [function.ftp-put]: froogle-outfile.txt: Permission denied on server. (Overwrite) in D:\[full=path-to-catalog]\admin\froogle.php on line 344

 

My configurations are:

 

$OutFile = "D:/[full=path-to-catalog]/feeds/froogle-outfile.txt";

$destination_file = "froogle-outfile.txt";

 

Are those errors from the ftp server?

 

2. In your readme file, part 9) For the Feeder System Admin Control Panel (Not Recommended: Optional)

There are instructions on adding feeder files, but I do not see those files in this distribution. Are those not available or am I missing something?

 

Thank you again,

Oleg

Share this post


Link to post
Share on other sites

1) your host does not allow ftp connections. try using a passive connection... there's instructions somewhere in this topic.

 

2) unforunately, i designed a system to incorporate all of the feeders into one... but it wasn't designed well enough so i threw it out the door. i keep planning on a new system, but haven't had the chance.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Too bad :(

I am looking for a shopzilla file format, same thing pretty much only different variables in different order, do you have any ideas, is there an exporter maybe that lets you select which fields to export.

 

FYI, shopzilla asks for (in that order, * cannot be empty):

 

*Category (shozilla related)

Manufacturer

*Title

Description

*Link

Image

*SKU

QTY

Condition

Ship Weight

Ship cost

Bid

Promotion Description

Ohter

*Price

 

Thanks,

Oleg

Share this post


Link to post
Share on other sites
can anyone give me an idea how to change the output url's from:

http://www.yourwebsite.com/product_info.php?products_id=0

 

to

http://www.yourwebsite.com/product/product...uct_detail.html

 

rewrite rule from my htaccess:

RewriteRule ^/?(product)/([^/]*)\.html$ product_info.php?products_id=$2&%{QUERY_STRING} [NC]

 

it shouldn't be hard at all... i have to prepare for an interview and finish up a couple projects. but i'll try to take a look at it next week.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Today, I installed FroogleDataFeeder v162a but receive this error:

 

Warning: fopen(http://***/feeds/***.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /***/admin/froogle.php on line 292

 

Warning: fwrite(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 293

 

Warning: fclose(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 294

 

Warning: fopen(http://***/feeds/***.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /**/admin/froogle.php on line 292

 

Warning: fwrite(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 293

 

Warning: fclose(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 294

 

Warning: fopen(http://***/feeds/***.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /***/admin/froogle.php on line 292

 

Warning: fwrite(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 293

 

Warning: fclose(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 294

 

Warning: fopen(http://***/feeds/***.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /***/admin/froogle.php on line 292

 

Warning: fwrite(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 293

 

Warning: fclose(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 294

 

Warning: fopen(http://***/feeds/***.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /***/admin/froogle.php on line 301

 

Warning: fwrite(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 302

 

Warning: fclose(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 303

File completed: http://***/.txt

 

Warning: chmod() [function.chmod]: No such file or directory in /***/admin/froogle.php on line 305

 

I checked to ensure that allow_fopen() is on in the php.ini and it is for main and local.

 

It seems everyone has had success with this contribution. Can anyone help me with this error?

Share this post


Link to post
Share on other sites
Today, I installed FroogleDataFeeder v162a but receive this error:

 

Warning: fopen(http://***/feeds/***.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /***/admin/froogle.php on line 292

 

Warning: fwrite(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 293

 

Warning: fclose(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 294

 

Warning: fopen(http://***/feeds/***.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /**/admin/froogle.php on line 292

 

Warning: fwrite(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 293

 

Warning: fclose(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 294

 

Warning: fopen(http://***/feeds/***.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /***/admin/froogle.php on line 292

 

Warning: fwrite(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 293

 

Warning: fclose(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 294

 

Warning: fopen(http://***/feeds/***.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /***/admin/froogle.php on line 292

 

Warning: fwrite(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 293

 

Warning: fclose(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 294

 

Warning: fopen(http://***/feeds/***.txt) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /***/admin/froogle.php on line 301

 

Warning: fwrite(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 302

 

Warning: fclose(): supplied argument is not a valid stream resource in /***/admin/froogle.php on line 303

File completed: http://***/.txt

 

Warning: chmod() [function.chmod]: No such file or directory in /***/admin/froogle.php on line 305

 

I checked to ensure that allow_fopen() is on in the php.ini and it is for main and local.

 

It seems everyone has had success with this contribution. Can anyone help me with this error?

 

:blush: Is there anyone that can provide a clue as to what I should do to correct this error. I echoed $output and the data is there (which I manually uploaded the feed). The problem comes from the following code:

 

$loop_counter++;

if ($loop_counter>750) {

$fp = fopen( $OutFile , "a" );

$fout = fwrite( $fp , $output );

fclose( $fp );

$loop_counter = 0;

$output = "";

 

}

}

 

$fp = fopen( $OutFile , "a" );

$fout = fwrite( $fp , $output );

fclose( $fp );

echo "File completed: <a href=\"" . $OutFile . "\" target=\"_blank\">" . $destination_file . "</a><br>\n";

chmod($OutFile, 0777);

 

I would appreciate a clue to unlock the "make this work secret."

 

Thanks!

Share this post


Link to post
Share on other sites

Hi,

 

We have used the froogle feeder to upload to froogle but we understand it that the feeder does not delete old feeds and just apends to the text file. We used the 'w' command (overwirte) but it only then writes part of the output to the text file.

 

We then tried unlink but we cant get that working properly either.

 

1. Does the froogle.php file really apend to the initial feed?

 

2. How can we delete previous feed? Below is the code we are trying but we cant get it working with either way:

$return=@unlink($OutFile);
echo "Return values=".$FileExists;
var_dump($return);

 

 

if(file_exists($OutFile))
unlink($OutFile);

 

 

if(is_file($OutFile))
unlink($OutFile);

 

All help will be much appriciated.

Share this post


Link to post
Share on other sites

Hi,

 

When I install the first part of this contribution, not the admin part yet, I get this error msg:

 

Error when connecting itself to the data base

/end of error msg

 

My code for the first part that is editable, with the passwords blanked out is:

 

$OutFile = "../feeds/davikfroogle.txt"; //"CHANGEME-full-path-to-file-with-777-dir-and-file-permissions.fr-outfile.txt";

$destination_file = "davikfroogle.txt"; //"CHANGEME-filename-to-upload-to-froogle.txt" ;

$source_file = $OutFile;

$imageURL = 'http://www.amerintconcepts.com/davikwebstore/images/';

$productURL = 'http://www.amerintconcepts.com/davikwebstore/product_info.php?products_id=';

$already_sent = array();

 

$home = "localhost" ;

$user="vickivicki";

$pass="********";

$base="amerint_osc1";

 

$ftp_server = "hedwig.google.com" ;

$ftp_user_name = "davik@amerintconcepts.com";

$ftp_user_pass = "*********";

$ftp_directory = ""; // leave blank for froogle

 

$taxRate = 0; //default = 0 (e.g. for 17.5% tax use "$taxRate = 17.5;")

$taxCalc = ($taxRate/100) + 1; //Do not edit

$convertCur = false; //default = false

$curType = "USD"; // Converts Currency to any defined currency (eg. USD, EUR, GBP)

if($convertCur)

{

$productURL = "CHANGEME-http://www.yourwebsite.com/product_info.php?currency=" . $curType . "&products_id="; //where CURTYPE is your currency type (eg. USD, EUR, GBP)

}

 

//START Advance Optional Values

 

//(0=False 1=True) (optional_sec must be enabled to use any options)

$optional_sec = 1;

$instock = 1;

$shipping = 1;

$lowestShipping = "4.95"; //this is not binary.

$brand = 1;

$upc = 0; //Not supported by default osC

$manufacturer_id = 0; //Not supported by default osC

$product_type = 1;

$currency = 1;

$default_currency = "USD"; //this is not binary.

$feed_language = 1;

$default_feed_language = "en"; //this is not binary.

$ship_to = 1;

$default_ship_to = "ALL"; //this is not binary, not supported by default osC for individual products.

$ship_from = 1;

$default_ship_from = "USD"; //this is not binary, not supported by default osC for individual products.

 

//END of Advance Optional Values

 

Would anybody be able to help me figure out why it wont' work? I've looked at the ones posted to this thread and my code seems to be like everyone else's so I am not sure why it's not working.

 

Thanks in advance

Share this post


Link to post
Share on other sites

PassionSeed: CHMOD 777 the directory where the feed is placed.

OSNewIsh: It should overwrite the file every time. Try using the latest version.

chantal7: Something is wrong with your database settings, double check them.

 

 

Based on popular demand:

 

The Official "Unoffical" Support for SEO URL's

 

Notes: The following release is meant to be an example/help to support your own SEO URL's contributions. This particular code is based on Chemo's SEO URL's. Please do not PM me asking to configure it, specifically for your store. Please use this forum topic for assistance.

 

 

Add:

 

$catalogURL = 'http://www.yourstore.com/catalog/'; //URL to your osC Catalog

 

After:

$source_file = $OutFile;

 

Replace:

	$output .= $row->product_url . "\t" .

 

with

 

		$string = ereg_replace("[^a-zA-Z0-9 ]", "", $row->name);
	$string = ereg_replace('  ', ' ', strtolower($string));
	$string = ereg_replace(' ', '-', strtolower($string));

	$output .= $catalogURL . $string . "-p-" . $row->id . ".html\t" .

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

chantal7: Something is wrong with your database settings, double check them.

 

Hi Flyingmonkey,

 

I am assuming you mean this part:

 

$home = "localhost" ;

$user="vickivicki";

$pass="********";

$base="amerint_osc1";

 

?

 

The only thing that I haven't tried and double checked is the $home = "localhost" ; I wouldn't know what else to put there.

 

The user name, password, and database name are all correct.

 

I don't know what's wrong.

 

Any suggestions?

Share this post


Link to post
Share on other sites

Flyingmonkey,

 

I think I've fixed it and it's soooo weird. I added another user in my database and changed $user="vickivicki"; to the new user name and it worked. It won't work with the other user name that is also

the name of the database.

 

I do not understand why it'll work with the new one and not the old one but if it works, it works, I guess.

 

Thanks for your help.

Share this post


Link to post
Share on other sites

One more quick question:

 

How can I tell if it's uploading to froogle automatically?

 

I got the admin stuff put in right and when I click on that I go the the page with the link to my froogle.txt. I also started a cron job using this info:

 

0 4 * * 3 /usr/bin/php -q /home/<unix route to your file>/admin/froogle.php /end of code

 

but using my directory file structure.

 

I can't tell that it's ftp'ing to anywhere.

Share this post


Link to post
Share on other sites
Flyingmonkey,

 

I think I've fixed it and it's soooo weird. I added another user in my database and changed $user="vickivicki"; to the new user name and it worked. It won't work with the other user name that is also

the name of the database.

 

I do not understand why it'll work with the new one and not the old one but if it works, it works, I guess.

 

Thanks for your help.

 

that's odd, double check to see if data is created by the feeder.

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
PassionSeed: CHMOD 777 the directory where the feed is placed.

OSNewIsh: It should overwrite the file every time. Try using the latest version.

chantal7: Something is wrong with your database settings, double check them.

Based on popular demand:

 

The Official "Unoffical" Support for SEO URL's

 

Notes: The following release is meant to be an example/help to support your own SEO URL's contributions. This particular code is based on Chemo's SEO URL's. Please do not PM me asking to configure it, specifically for your store. Please use this forum topic for assistance.

Add:

 

$catalogURL = 'http://www.yourstore.com/catalog/'; //URL to your osC Catalog

 

After:

$source_file = $OutFile;

 

Replace:

	$output .= $row->product_url . "\t" .

 

with

 

		$string = ereg_replace("[^a-zA-Z0-9 ]", "", $row->name);
	$string = ereg_replace('  ', ' ', strtolower($string));
	$string = ereg_replace(' ', '-', strtolower($string));

	$output .= $catalogURL . $string . "-p-" . $row->id . ".html\t" .

 

 

:blink: Hi Flying Monkey,

 

The directory and file has been and are set to CHMOD 777. The fopen warnings still occur. Could it be a setup in my PHP Version 5.0.4 that's causing this problem. allow_url_fopen is on.

 

I would appreciate any insight you can provide in resolving this.

Share this post


Link to post
Share on other sites
that's odd, double check to see if data is created by the feeder.

Yes, the data is being created by the feeder. :)

 

Now I just need to know how I can be sure that it's uploading to froogle. When I clicked on the url that the froogle.php shows, the name of my froogle file, it goes on to the feed. I get no errors or anything about ftp so I am not sure if it's ftp'ing or not.

 

Thanks

Share this post


Link to post
Share on other sites

Just installed this and it's fantastic !!

 

However, I have one small requirement. I actually want to use this mainly for sending a datafeed to an affiliate network but the output needs to be in XML or CVS. I'm guessing the XML would be difficult, but what about a csv? Anyone know how to do this?

 

Paul

Share this post


Link to post
Share on other sites
Too bad :(

I am looking for a shopzilla file format, same thing pretty much only different variables in different order, do you have any ideas, is there an exporter maybe that lets you select which fields to export.

 

FYI, shopzilla asks for (in that order, * cannot be empty):

 

*Category (shozilla related)

Manufacturer

*Title

Description

*Link

Image

*SKU

QTY

Condition

Ship Weight

Ship cost

Bid

Promotion Description

Ohter

*Price

 

Thanks,

Oleg

 

i am looking for exact the same format, i will take a look at the code to see if i can make it.

 

and also does anybody has experience with shopping.com, how is system works? same as froogle, ftp upload?

 

Thanks

 

sean

Share this post


Link to post
Share on other sites
It sorts the items by product id in ascending order... and your saying that it's randomly leaving some out? what's the url to your store?

Hi,

 

I just checked my stuff at froogle and google base and they have things listed fine except if a person is doing a search for a certain cordless phone, it sends them to a different product id...to a totally different product like hat pins.

 

Any idea of what is wrong? where should I look?

 

Thanks

Share this post


Link to post
Share on other sites
can anyone give me an idea how to change the output url's from:

http://www.yourwebsite.com/product_info.php?products_id=0

 

to

http://www.yourwebsite.com/product/product...uct_detail.html

 

rewrite rule from my htaccess:

RewriteRule ^/?(product)/([^/]*)\.html$ product_info.php?products_id=$2&%{QUERY_STRING} [NC]

 

 

did you have a chance to take a look at this yet, flyingmonkey? :)

Share this post


Link to post
Share on other sites

if you look a couple post up, i left an example. there's too many seo contributions available to write one for everybody. so i felt a general example would be the best way.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
Hi,

 

I just checked my stuff at froogle and google base and they have things listed fine except if a person is doing a search for a certain cordless phone, it sends them to a different product id...to a totally different product like hat pins.

 

Any idea of what is wrong? where should I look?

 

Thanks

 

If you were using a previous offer_id, Froogle wants you to use the same one. Try contacting Google.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×