Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

I had this same problem. It ended up being a password problem. Change your password with froogle and in your config file and try again. If your current pass has special charachters remove them, etc (make it DIFFERENT)

 

Craig

Share this post


Link to post
Share on other sites
I had this same problem. It ended up being a password problem. Change your password with froogle and in your config file and try again. If your current pass has special charachters remove them, etc (make it DIFFERENT)

 

Craig

 

You're just talking about the FTP password, correct? makes sense, but just to make sure.

 

Man, Froogle says that this thing can take up to an hour for the change to take place... it's been over 2 hours and the new password isn't in place yet (been testing with an FTP program.)

 

Hopefully that will change soon and I can report some good news.

 

Thanks

 

Mike

Share this post


Link to post
Share on other sites

Yea I dont remember exactly how it all happened but I just remember changinf the ftp password and it finally working.

 

Keep trying!

Share this post


Link to post
Share on other sites

Just wondering if anyone has done a Price Grabber feeder yet? looked through the forums but didn't see any completed yet.


Stephanie Harris

Share this post


Link to post
Share on other sites
You're just talking about the FTP password, correct? makes sense, but just to make sure.

 

Man, Froogle says that this thing can take up to an hour for the change to take place... it's been over 2 hours and the new password isn't in place yet (been testing with an FTP program.)

 

Hopefully that will change soon and I can report some good news.

 

Thanks

 

Mike

 

 

Ok, successfully changed the password, tested it using just an ftp program to verify that the password was indeed changed... Yet I'm still getting this:

 

File completed: sdb-upload-to-froogle.txt

FTP open connection failed to hedwig.google.com

 

Script timer: 0.169960 seconds.

 

Anyone have any other ideas?

 

Thanks,

 

Mike

Share this post


Link to post
Share on other sites

It means that it was unable to connect to hedwig.google.com (just the basic connection) even without user/password. Your host may not allow FTP or you may have to set it into passive FTP mode. There's instructions in this topic somewhere... I can't remember exactly what it is.

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Ok .. after about 4 + hours of work I finally got this stupid thing to include the CORRECT prices if you are using Salemaker.

 

I also found a BUG or SOMETHING that CAUSED me to spend at LEAST 2 hours trying to figure out what the crap was going on. ... I will explain ...

 

Sigh .. I dont know if I have the energy. : ) .. Ok, so I figured out how to get the prices to display correctly if you are using salemaker. So I start playing with the code to get it right and ALL sorts of things go wrong. EVERYTIME I would run froogle.php ALL the prices in the ENTIRE catalog would go to $0!! I had to delete the cookies to get it back right. Then no matter how hard I tried I could not get the prices in the file to display correctly. If I used $currencies->display_price(whatever) the prices would be 0 in the file. After pulling my hair out I finally discovered that at the top of the file there was the following:

 

$default_currency = "0"; //this is not binary.

 

IF IT AINT BINARY WHY IS IT SET TO 0!!??

 

So I set it to USD and EVERYTHING is now fine!! GRRRRR

 

Anyway, here is what to do so that the prices will be right if using sale maker.

 

First of all I need to call application_top and didnt know how to call it from a directory above admin (../includes/application_top.php, etc) so I moved froogle.php to the root dir. If someone can tell me how to call application_top from within the admin dir then I can fix that too. Anyway, the first thing is add a call to application top to the beginning of the file. The find the following:

 

while( $row = mysql_fetch_object( $result ) )

{

 

and below, add:

 

if ($new_price = tep_get_products_special_price($row->id)) {

$row_price = $currencies->display_price($new_price);

} else {

$row_price = $currencies->display_price($row->price);

}

 

Find:

 

$row->price . "\t" .

 

Replace with:

 

$row_price . "\t" .

 

 

Thats it! It should now add the correct prices to your file. Don't forget to remove the last mod I created or set the value to "1" so you don't get wierd math.

 

Please give me feedback and let me know how it works for you. This works with Special prices too!

 

Let me know! Once I get it right I will make it a contribution.

 

Craig

 

 

 

maksum,

 

I kinda remember that they would only allow uploading every so often. Could be a time limit type thing too?

 

Email them if nothing else, they got right back with me once.

 

Craig

Share this post


Link to post
Share on other sites
Instructions should be in the readme and via Froogle: https://www.google.com/froogle/merchants/ad...structions.html

 

If you need additional assistance, please pm me.

 

 

thanx calvin I managed to accomplish this, but I got 1 more question to ask

 

I'm using Chemo's Ultimate SEO 2.x that changes URLs

 

from this:

http://domain/product_info.php?products_id=23

 

to somethin like this:

http://domain/productname-p-23.html

 

I want to use second type of URL in my froogle feed as well as in all other feeds (like yahoo, bizrate, mysimon etc.) also.

 

Can You Help ?

 

 

Dinesh

Edited by dinesh

Share this post


Link to post
Share on other sites
Ok .. after about 4 + hours of work I finally got this stupid thing to include the CORRECT prices if you are using Salemaker.

 

I also found a BUG or SOMETHING that CAUSED me to spend at LEAST 2 hours trying to figure out what the crap was going on. ... I will explain ...

 

Sigh .. I dont know if I have the energy. : ) .. Ok, so I figured out how to get the prices to display correctly if you are using salemaker. So I start playing with the code to get it right and ALL sorts of things go wrong. EVERYTIME I would run froogle.php ALL the prices in the ENTIRE catalog would go to $0!! I had to delete the cookies to get it back right. Then no matter how hard I tried I could not get the prices in the file to display correctly. If I used $currencies->display_price(whatever) the prices would be 0 in the file. After pulling my hair out I finally discovered that at the top of the file there was the following:

 

$default_currency = "0"; //this is not binary.

 

IF IT AINT BINARY WHY IS IT SET TO 0!!??

 

So I set it to USD and EVERYTHING is now fine!! GRRRRR

 

.....

 

The lastest Froogle Data Feeder 1.62a sets the $default_currency equal to "USD". Along with every Froogle Data Feeder released to the public to my knowledge (by me), including the first release with advance options. Where did you get the code? It may be outdated or an unofficial release.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

I have 1.62a! I downloaded it from contributions and did not change anything. Not sure how it got that way but it was that way. :-"

 

So what did you think about my mod? Have you or anyone else tried it?

 

Craig

Share this post


Link to post
Share on other sites

I just got the froogle contrib and changed the parameters on froogle.php. I created the feed dir and changed the perm to 777. I ran the contrib and everything looked good. However, I can't access the the final txt file. I can't download it, delete it, move it or change the perm. If I try anything it gives an error:

 

No such file or directory

 

But it clearly shows a file in ftp and cpanel. However, I can't access the file or the feed dir through a browser. Any advice on how to remove the file and prevent this from repeating would be great.

 

Thanks in advance.


Shade and Sweet Water

Chris Czerniak

Share this post


Link to post
Share on other sites

zboyblue: i can't really comment on it... i don't have salemaker (so, i can't test it). someone released something for this data feeder a while back for salemaker... but once again, i've never tested or endorsed it.

 

cczernia: try asking your host.

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
I just got the froogle contrib and changed the parameters on froogle.php. I created the feed dir and changed the perm to 777. I ran the contrib and everything looked good. However, I can't access the the final txt file. I can't download it, delete it, move it or change the perm. If I try anything it gives an error:

 

No such file or directory

 

But it clearly shows a file in ftp and cpanel. However, I can't access the file or the feed dir through a browser. Any advice on how to remove the file and prevent this from repeating would be great.

 

Thanks in advance.

 

I had this same exact problem and it drove me bonkers for at least a couple hours. Turns out I had inadvertantly added a trailing space after the .txt filename in froogle.php - once I removed that the file behaved normally. Now if I could just figure out why my .txt file only shows the headers and no data. Argh!

Share this post


Link to post
Share on other sites
I had this same exact problem and it drove me bonkers for at least a couple hours. Turns out I had inadvertantly added a trailing space after the .txt filename in froogle.php - once I removed that the file behaved normally. Now if I could just figure out why my .txt file only shows the headers and no data. Argh!

 

Double check your database settings.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
Double check your database settings.

 

I am pretty sure the db settings are correct. They are the same as the setting in my catalog/admin/includes/configure.php (password hidden)

 

configure.php

  define('DB_SERVER', 'localhost');
 define('DB_SERVER_USERNAME', 'root');
 define('DB_SERVER_PASSWORD', '********');
 define('DB_DATABASE', 'fitniskin')

 

froogle.php

$home = "localhost";
$user="root";
$pass="********";
$base="fitniskin";

 

And when I run froogle.php it seems to be just peachy till I click the link for the .txt file it generated and see that all I have is a list of headers and nothing else. I haven't messed with any of the advanced options yet. Figured I had to get the basics working first.

 

Any other ideas would be welcome. In the meantime I'll keep chipping away at this brick wall with my forehead.

 

Excellent contrib BTW, at least, I hope it will be if I can get it to work :blink:

Share this post


Link to post
Share on other sites

hmm, usually it's just the db settings. try deleting the file... let me know if it creates a new one.

 

anything abnormal? like incredibly large descriptions, etc? is osC provided by your host? i've seen the db settings hard coded else where.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

FM,

 

Yup, deleted that sucker several times and it generates the file again just nicely, except without data.

 

I don't think there is anything unusual about the data that would throw up any red flags. The descriptions are a paragraph at most but they do contain some basic html tags like bold and italic and such. I tried removing the html from the descriptions just to see but the result was the same.

 

osC is provided by my host, however I did not use their automated install routine. I wanted to do it myself to get a better feel as to how it all goes together and make it easier to figure things like this out down the road. The version I currently have installed is osCommerce 2.2 Milestone 2 downloaded from SourceForge about a month ago.

 

The only thing I can possibly think of is a conflict with other contributions. I have the following installed:

- Wolfen Featured Sets v1.00

- Purchase Without Account

- 'On the Fly' Auto Thumbnailer using GD Library

- USAePay Payment Module

 

I have the following for the image url due to the thumbnailer contrib:

$imageURL = 'http://www.fitniskin.com/catalog/product_thumb.php?img=images/';

 

Hmm, dunno.

Share this post


Link to post
Share on other sites
FM,

 

Yup, deleted that sucker several times and it generates the file again just nicely, except without data.

 

I don't think there is anything unusual about the data that would throw up any red flags. The descriptions are a paragraph at most but they do contain some basic html tags like bold and italic and such. I tried removing the html from the descriptions just to see but the result was the same.

 

osC is provided by my host, however I did not use their automated install routine. I wanted to do it myself to get a better feel as to how it all goes together and make it easier to figure things like this out down the road. The version I currently have installed is osCommerce 2.2 Milestone 2 downloaded from SourceForge about a month ago.

 

The only thing I can possibly think of is a conflict with other contributions. I have the following installed:

- Wolfen Featured Sets v1.00

- Purchase Without Account

- 'On the Fly' Auto Thumbnailer using GD Library

- USAePay Payment Module

 

I have the following for the image url due to the thumbnailer contrib:

$imageURL = 'http://www.fitniskin.com/catalog/product_thumb.php?img=images/';

 

Hmm, dunno.

 

everything seems normal... you get data even if you fill stuff out wrong. try adding this right before the

$loop_counter++:

 

echo $output; (it should spit out some stuff on your browser) if it doesn't i'm pretty sure it's your db connection which you'll need to triple check or check with your host.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
everything seems normal... you get data even if you fill stuff out wrong. try adding this right before the

$loop_counter++:

 

echo $output; (it should spit out some stuff on your browser) if it doesn't i'm pretty sure it's your db connection which you'll need to triple check or check with your host.

 

Following your instructions this is what I got:

 

product_url name description price image_url category offer_id File completed: smooth_fitniskin_com.txt

 

Script timer: 0.010501 seconds.

 

 

So not knowing if the above is a good or bad thing, I went ahead and triple checked the db settings. I checked them against not only the settings for osC itself but also for other php/mySQL connections that I am running for phpBB and such. They all match up. I tried a fresh install of the froogle.php and configured it just because. No luck.

 

Thank you for your diligence.

Share this post


Link to post
Share on other sites
If http://www.fitniskin.com/ is your site its not even in a directory like

http://www.fitniskin.com/catalog

so it looks like your image url is wrong to start ;)

 

DOH! My bad. You are absolutely correct. This particular install (fitniskin) is not in the /catalog directory at all rather it is in the base dir. I typed that in the post out of habit as I am in the process of helping another client who just installed osC on their server and it IS using a catalog subdir. <sigh> I wish it were that simple though. The image url I MEANT to post is

 

$imageURL = 'http://www.fitniskin.com/product_thumb.php?img=images/';

 

Not that it matters much because according to FlyingMonkey it should at least spit out something even if I did have the image url screwed up. But thank you for pointing that out :blush: I can use all the help I can get at this point...and another cup of coffee.

Share this post


Link to post
Share on other sites

if your tables are named differently... with a prefix it won't work either. you'll have to update the sql code accordingly. ex: if you have something like ocs_products instead of just products as a table.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
if your tables are named differently... with a prefix it won't work either. you'll have to update the sql code accordingly. ex: if you have something like ocs_products instead of just products as a table.

 

Nope. All the table names are as they should be. But, finally, I did find the problem. Turns out to be just a little bit of osc ignorance on my part. (shocking, I know)

 

You see, this particular store only has about 8 products total for now, and I saw no value in creating separate categories for them. So none of the products added were assigned to a category. The froogle.php script was looking for categories and the products within them and the solitary unused category folder I had was empty thereby generating an empty .txt file. Once I moved the products into my only category folder...all is well in froogleland.

 

So by my little trial and error episode, and some guidance from Calvin, my tip to future users of the Froogle Data Feeder is....

 

"If your product ain't in a Category it ain't gettin' Froogled."

 

Thanks again,

 

P

Share this post


Link to post
Share on other sites

Hi!

 

i only get products_id in my froogle i also need products_model how do i get that??

 

Thx in advance.

 

//

Patrik

Share this post


Link to post
Share on other sites

How do I change the offer_id output to be the model number? I have already sent a feed to Froogle using the model number as offer_id and I would like to update that feed not replace it.

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×