Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

I am the only one who have a problem with 0.00EUR Products and Froogle?

 

No one else have Only-Info-Products that are not to buy while stand for an Product-Option?

 

Patrick


Captain: I thought you were going to upgrade this.

Trip: That is the upgrade.

Well, if you want, I can change the color.

Share this post


Link to post
Share on other sites
I am the only one who have a problem with 0.00EUR Products and Froogle?

 

No one else have Only-Info-Products that are not to buy while stand for an Product-Option?

 

Patrick

 

froogle hasn't hassled... me with 0 dollar products.

 

but you can always insert a statement that says if price <= 0 , then don't write this particular line into the feed.

 

like this,

 

if ($row->price <= 0) continue;

 

under this line:

 

if (isset($already_sent[$row->id])) continue; // if we've sent this one, skip the rest of the while loop

 

 

I shouldn't... be on this forum right now. gotta study... like no other. so i might not be around, but it should at least give you an idea of what you need to do.

 

-calvin


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
froogle hasn't hassled... me with 0 dollar products.

 

but you can always insert a statement that says if price <= 0 , then don't write this particular line into the feed.

 

like this,

 

if ($row->price <= 0) continue;

 

under this line:

 

if (isset($already_sent[$row->id])) continue; // if we've sent this one, skip the rest of the while loop

I shouldn't... be on this forum right now. gotta study... like no other. so i might not be around, but it should at least give you an idea of what you need to do.

 

-calvin

 

Thank you very much fpor your help.

Now the script works fine for me!

 

Best Regards

Patrick


Captain: I thought you were going to upgrade this.

Trip: That is the upgrade.

Well, if you want, I can change the color.

Share this post


Link to post
Share on other sites

Can anyone give me an example of what to put for $OutFile and $destination_file. Not quite sure what I have to put in there for each one.

 

Thanks for the help!

Share this post


Link to post
Share on other sites
I have a few questions:

 

1. why in the listing of items for my store does the store name appear as my id instead of my store name = store:aromatherapy_4_u instead of Aromatherapy for You - how can I fix this?

 

2. in my descriptions some apostrophes have become question marks - how can this be corrected?

 

3. in some of my prduct titles the letter following an apostrophe has become capitalized (ie Nature'S) - how can I fix this?

 

4. some photos aren't showing up and they are larger then other ones that are showing

 

Thanks

 

Can anyone help me with these? I really want to have the store name show up correctly!!

 

My Webpage

Edited by dandelion

Share this post


Link to post
Share on other sites
Can anyone give me an example of what to put for $OutFile and $destination_file. Not quite sure what I have to put in there for each one.

 

Thanks for the help!

 

Hello,

 

here an example:

 

$OutFile = "../feeds/froogle.txt"; //"CHANGEME-full-path-to-file-with-777-dir-and-file-permissions.fr-outfile.txt";

$destination_file = "froogle.txt"; //"CHANGEME-filename-to-upload-to-froogle.txt" ;

 

But you have name it exactly like you name it in Froogle

 

Best Regards

Patrick


Captain: I thought you were going to upgrade this.

Trip: That is the upgrade.

Well, if you want, I can change the color.

Share this post


Link to post
Share on other sites
Can anyone help me with these? I really want to have the store name show up correctly!!

 

My Webpage

 

Hello,

 

you can change your store name in froogle!

 

Best Regards

Patrick


Captain: I thought you were going to upgrade this.

Trip: That is the upgrade.

Well, if you want, I can change the color.

Share this post


Link to post
Share on other sites

i've done (a few) searches inside this topic and didn't find much answers, but does this contribution work with seo urls? i'm using nimmit's sef urls.

Share this post


Link to post
Share on other sites
Hello,

 

you can change your store name in froogle!

 

Best Regards

Patrick

I've set the store name in Froogle but froogle is using my store id not my store name!

Share this post


Link to post
Share on other sites
i've done (a few) searches inside this topic and didn't find much answers, but does this contribution work with seo urls? i'm using nimmit's sef urls.

 

no, but it's fairly easy to change the output for the url's to match those of your seo contribution.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
I've set the store name in Froogle but froogle is using my store id not my store name!

 

Have you ever contact the Google-Team?

 

Yes, there are realy life man and woman (not only computers) who can help you when you have problems.

Sorry i have only the e-mail-adress from the german google-team, but i think you can find it anywhere at froogle.

 

 

Best Regards

Patrick


Captain: I thought you were going to upgrade this.

Trip: That is the upgrade.

Well, if you want, I can change the color.

Share this post


Link to post
Share on other sites

"Extra Tab" errors.

 

I have searched everywhere, and only find similar problems, no solutions. I guess the product titles/descriptions are not being cleaned properly before the feed is created in some cases, has anyone found the solution? :'(

Share this post


Link to post
Share on other sites

I am having the hardest time trying to get rid of the " and ' for " and ' in my descriptions. They show up randomly. How do I get rid of them? I have searched forums forever for an answer. The Froogle feed is critical because these impact the product descriptions and searches. Please point me in the right direction.


Laser labels, barcode labels, custom labels

Share this post


Link to post
Share on other sites
"Extra Tab" errors.

 

I have searched everywhere, and only find similar problems, no solutions. I guess the product titles/descriptions are not being cleaned properly before the feed is created in some cases, has anyone found the solution? :'(

 

I asked about this some time ago and got no response. I wouldn't have thought it would be difficult to stip it out. I'll have a go at the weekend and get back to you.

Share this post


Link to post
Share on other sites
I am having the hardest time trying to get rid of the " and ' for " and ' in my descriptions. They show up randomly. How do I get rid of them? I have searched forums forever for an answer. The Froogle feed is critical because these impact the product descriptions and searches. Please point me in the right direction.

 

I'm having apostrophe problems as well but mine show as 'S with a capital S in some product titles (not all) and sometimes a ? instead of an apostrophe in product descriptions. As was said above this affects searches - if I search children's it won't find my product.

 

Ruth

Edited by dandelion

Share this post


Link to post
Share on other sites

Has anyone managed to get this altered to work with Chemo`s Ultimate SEO Urls?

Theres a great RSS feed contrib which uses the SEO URLS and the code looks like...

 

tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $id);

 

I tried changing

$productURL = "mystore.com/product_info.php?"; //where CURTYPE is your currency type (eg. USD, EUR, GBP)

to...

$productURL = "tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $id) ; //where CURTYPE is your currency type (eg. USD, EUR, GBP)

But that didnt quite work...

Is there something ive missed?

Share this post


Link to post
Share on other sites

OK now this is very clunky but how about this for stripping the tabs from the froogle feed?

 

In froogle.php replace

 

	preg_replace($_strip_search, $_strip_replace, strip_tags( strtr($row->description, $_cleaner_array) ) ) . "\t" .

with

		preg_replace($_strip_search, $_strip_replace, ereg_replace("[ \t]+", " ", strip_tags( strtr($row->description, $_cleaner_array) ) ) ) . "\t" .

 

I really couldn't see why the original expression failed. I hope this will stimulate someone to come up with a more elegant way.

Share this post


Link to post
Share on other sites

All works fine but the output created has Products descriptions in English and the categories in Spanish, what can I do to have it all in english

 

Thanks

Share this post


Link to post
Share on other sites

If my product does not have an image, Froogle Data Feeder is just putting the path to my images as specified in froogle.php. Is there anyway to specifiy if no image exists for a product to use no_image.gif? My feed is getting rejected by Froogle for invalid images. If this is answered previously in this forum, please excuse me, I could not find it.

 

Thanks in advance.

Share this post


Link to post
Share on other sites
I asked about this some time ago and got no response. I wouldn't have thought it would be difficult to stip it out. I'll have a go at the weekend and get back to you.

 

 

I posted a fix on Feb 9, 2005. I know it's difficult to search sometimes, but if you use google. it tends to give better search results.

 

http://forums.oscommerce.com/index.php?sho...ic=71088&st=912

 

 

 

If my product does not have an image, Froogle Data Feeder is just putting the path to my images as specified in froogle.php. Is there anyway to specifiy if no image exists for a product to use no_image.gif? My feed is getting rejected by Froogle for invalid images. If this is answered previously in this forum, please excuse me, I could not find it.

 

Thanks in advance.

 

 

Here's a solution below:

 

if someone tries the untested solution below, please pm me and let me know how it went.

 

REPLACE:

CONCAT( '" . $imageURL . "' ,products.products_image) AS image_url,

 

WITH:

 

CONCAT( '" . $imageURL . "' ,IFNULL(products.products_image, 'no_image.gif')) AS image_url,

 

You would of course need to place an image named "no_image.gif" in your image folder (for it to work with Froogle). Please provide a link to your feed too.

 

If it works, i'll integrate it into an updated version of the contrib.

 

-calvin

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Hello calvin,

 

I'm glad you still around, My site has two languages English and Spanish, default is English, when the feed is created everything comes out in english but not the categories, how can I make it all english?

 

 

Thanks

Share this post


Link to post
Share on other sites

Anybody know how to include fields created thru "Product Extra Fields" contribution in froogle feed. I need to include fields like ISBN/Author etc. because froogle needs these if you are selling books.

 

Dinesh

Edited by dinesh

Share this post


Link to post
Share on other sites
Anybody know how to include fields created thru "Product Extra Fields" contribution in froogle feed. I need to include fields like ISBN/Author etc. because froogle needs these if you are selling books.

 

Dinesh

 

Instructions should be in the readme and via Froogle: https://www.google.com/froogle/merchants/ad...structions.html

 

If you need additional assistance, please pm me.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Unfortunitly this does not work. Sill leaves the defaut image folder destination with no image.

 

 

I posted a fix on Feb 9, 2005. I know it's difficult to search sometimes, but if you use google. it tends to give better search results.

 

http://forums.oscommerce.com/index.php?sho...ic=71088&st=912

Here's a solution below:

 

if someone tries the untested solution below, please pm me and let me know how it went.

 

REPLACE:

CONCAT( '" . $imageURL . "' ,products.products_image) AS image_url,

 

WITH:

 

CONCAT( '" . $imageURL . "' ,IFNULL(products.products_image, 'no_image.gif')) AS image_url,

 

You would of course need to place an image named "no_image.gif" in your image folder (for it to work with Froogle). Please provide a link to your feed too.

 

If it works, i'll integrate it into an updated version of the contrib.

 

-calvin

Share this post


Link to post
Share on other sites

According to the Froogle rules, if there is no image you should leave the field blank rather than insert a no_image.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×