Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

Hi, Mine is not putting out anything on to the feed txt file?

Anyone know why?

 

thanks :)

 

This may help but it is kind of a general observation too!

 

I could not get the txt file to generate IF the feeder directory, or whatever you use to temp'y hold the file before FTP, was located in a PASSWORD PROTECTED DIRECTORY....like my admin directory (or whatever you change the name of it to).

 

Try a different directory... hth!

 

Regards,

Siddall

Share this post


Link to post
Share on other sites
Hi, Mine is not putting out anything on to the feed txt file?

Anyone know why?

 

thanks :)

Is both your .txt file AND its directory chmod'ed to 777? Does the rest of the script seem to be running ok? Are you getting any errors???

 

A little more information, please...

Edited by chynathedragon

Stress is a luxury afforded to those of us that need it least.

Where lipstick is concerned, the important thing is not color, but to accept God's final word on where your lips end. --Jerry Seinfeld

If you pick up a starving dog, and make him prosperous, he will not bite you. This is the principal difference between a man and a dog. --Mark Twain

Share this post


Link to post
Share on other sites
no errors! just a blank feed, the files are dir are 777

 

 

Are you sure you ran the script? Try refreshing the page (the timer will change slighly each time). Some browsers may cache those pages, even when you return to them.

 

Also check your database settings, make sure it's the same one as your store. :-" Try deleting the file, it should automatically create one. If it's not, your other settings are incorrect.

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

I get "Feed contains some errors" from froogle. And there are no info about what kind of errors I have in the feeder .txt file. The items were processed successfully.

 

I use the SEO URL, but in the feeder file, it doesn't use them.

 

Do you also have this problem? How do I check the feeder .txt format.

By the way, When I install this mod, the froogle.php file seems has some typos.

Around line 165:

$_cleaner_array = array(">" => ">", "®" => "", "? => "", "™" => "", "? => "");

 

I changed it to:

$_cleaner_array = array(">" => ">", "®" => "", "?" => "", "™" => "", "?" => "");

Share this post


Link to post
Share on other sites

For new customers that just means they haven't approved your feed yet.

One thing that would be very useful would be to strip out tab charachters from the product description. I keep getting caught on that one.

Share this post


Link to post
Share on other sites

Can anyone help me figure out why I recieve the following when running the froogle.php ? I can not use 777 permission. According to my server admin: This setting is not allowed for scripts on our machines since we run Suexec. Due to security reasons scripts are not allowed to have write permissions for all. You can safely set the permissions to 775 or 755 and they should function properly as they will be run with your username. I have tried each of these on the feeds directory and the output file. I have the feeds directory under the admin directory. I tried putting it in the root as well. No luck yet.

 

 

Warning: fopen(http://www.allthingstrendy.com/catalog/admin/feeds/catalog_allthingstrendy.txt): failed to open stream: HTTP wrapper does not support writeable connections. in /home/myID/www/www/catalog/admin/froogle.php on line 301

 

Warning: fwrite(): supplied argument is not a valid stream resource in /home/myID/www/www/catalog/admin/froogle.php on line 302

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/myID/www/www/catalog/admin/froogle.php on line 303

File completed: catalog_allthingstrendy.txt

 

Warning: chmod(): No such file or directory in /home/myID/www/www/catalog/admin/froogle.php on line 305

Edited by AllThingsTrendy

Anthony David

AllThingsTrendy.com

Share this post


Link to post
Share on other sites

Everything works great in my website, exept for this froogle contribution, I get the following error when i run from the web browser:

 

SQL error Can't create/write to file 'c:\apachefriendsc:\apachefriends\xampp\tmp\#sql_870_0.MYI' (Errcode: 22)| sql = SELECT concat( 'http://sales.invalsa.com/product_info.php?products_id=' ,products.products_id) AS product_url, products_model AS prodModel, products_weight, manufacturers.manufacturers_name AS mfgName, manufacturers.manufacturers_id, products.products_id AS id, products_description.products_name AS name, products_description.products_description AS description, products.products_quantity AS quantity, products.products_status AS prodStatus, FORMAT( IFNULL(specials.specials_new_products_price, products.products_price) * 1,2) AS price, CONCAT( 'http://sales.invalsa.com/images/' ,products.products_image) AS image_url, products_to_categories.categories_id AS prodCatID, categories.parent_id AS catParentID, categories_description.categories_name AS catName FROM categories, categories_description, products, products_description, products_to_categories left join manufacturers on ( manufacturers.manufacturers_id = products.manufacturers_id ) left join specials on ( specials.products_id = products.products_id AND ( ( (specials.expires_date > CURRENT_DATE) OR (specials.expires_date = 0) ) AND ( specials.status = 1 ) ) ) WHERE products.products_id=products_description.products_id AND products.products_id=products_to_categories.products_id AND products_to_categories.categories_id=categories.categories_id AND categories.categories_id=categories_description.categories_id ORDER BY products.products_id ASC

 

 

Please helpppppp....................... :'(

Share this post


Link to post
Share on other sites
Are you sure you ran the script?? Try refreshing the page (the timer will change slighly each time).? Some browsers may cache those pages, even when you return to them.

 

? Also check your database settings, make sure it's the same one as your store.? :-"? Try deleting the file, it should automatically create one.? If it's not, your other settings are incorrect.

 

 

Hey, I had the same problem and I found out what was causing it. In the froogle.php file, for the $OutFile you can not use the full url ie: http://www.yoursite.com/feeds/text_file.txt I changed that to ../feeds/text_file.txt and now its working fine. :)

 

Just thought I'd post this for anyone with the same problem. :thumbsup:

 

/edit forgot to say thanks for coding this! awesome contrib. guys.

Edited by Sean416

Share this post


Link to post
Share on other sites

Thank you Sean!!!

 

That worked! Mucho kudos!

Edited by AllThingsTrendy

Anthony David

AllThingsTrendy.com

Share this post


Link to post
Share on other sites

okay, got it working, but now it wont upload to google!! any ideas? (its not saying that it cant, but the file is not appering at google)

Share this post


Link to post
Share on other sites

are you directly checking froogle ftp or the froogle online merchant area? if it's the merchant area for froogle, there's a considerable delay before anything shows up. try checking directly, especially if no errors are given.

 

otherwise, just read through the directions again and/or search/read through this topic; most likely your issue has been answered many times in the past. and it's a lot quicker doing a quick search than waiting for an answer.

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
please there is nothing in this thread?

Try going into your froogle account and manually uploading your froogle txt file there.


Stress is a luxury afforded to those of us that need it least.

Where lipstick is concerned, the important thing is not color, but to accept God's final word on where your lips end. --Jerry Seinfeld

If you pick up a starving dog, and make him prosperous, he will not bite you. This is the principal difference between a man and a dog. --Mark Twain

Share this post


Link to post
Share on other sites
Hey, I had the same problem and I found out what was causing it. In the froogle.php file, for the $OutFile you can not use the full url ie: http://www.yoursite.com/feeds/text_file.txt I changed that to ../feeds/text_file.txt and now its working fine. :)

 

Just thought I'd post this for anyone with the same problem.  :thumbsup:

 

/edit forgot to say thanks for coding this! awesome contrib. guys.

 

I don't understand it... I had it as /catalog/feeds/text_file.txt and it wouldn't work.

 

I changed it to ../feeds/textfile.txt (it's the same directory different syntax) and it workes fine.

 

Thanks for the heads up!

Share this post


Link to post
Share on other sites

My file is being generated ok, however I am receiving this error message:

 

File completed: xxxx.txt

Connected to hedwig.google.com, for user xxxx

 

Warning: ftp_put(): php_connect_nonb() failed: Connection timed out (110) in /home/xxxx/public_html/admin/froogle.php on line 343

 

Warning: ftp_put(): Entering Passive Mode (216,239,45,39,241,56) in /home/xxxx/public_html/admin/froogle.php on line 343

hedwig.google.com: FTP upload has failed!

 

Script timer: 46.463325 seconds.

 

Any ideas how I can fix this?

 

Thanks!

Paul

Edited by Paulie

Share this post


Link to post
Share on other sites
My file is being generated ok, however I am receiving this error message:

Any ideas how I can fix this?

 

Thanks!

Paul

try extending your timeout settings in php.ini (you may have to have your web host do this for you)

Most hosts assume php scripts run in less than 30 seconds, and set the php.ini accordingly. Yours is 46+ seconds (I assume you have alot of links). Try changing timeout settings to 60 or higher.


Stress is a luxury afforded to those of us that need it least.

Where lipstick is concerned, the important thing is not color, but to accept God's final word on where your lips end. --Jerry Seinfeld

If you pick up a starving dog, and make him prosperous, he will not bite you. This is the principal difference between a man and a dog. --Mark Twain

Share this post


Link to post
Share on other sites
try extending your timeout settings in php.ini (you may have to have your web host do this for you)

 

Thanks for your suggestion. I contacted my host and asked them to increase the PHP timeout settings to 60 seconds. After they confirmed that this was done, I tried it again but it still timed out. I then contacted support again and told them that this was happening when I use the Froogle Data Feeder, and they said that it looks like it's the FTP connection that is timing out, and to contact Froogle about it. This can't be possible, because I am able to connect via CuteFTP with no problems at all, so I seriously doubt the problem is with Froogle. Any other suggestions?

 

Thanks,

Paul

Edited by Paulie

Share this post


Link to post
Share on other sites

*Update*

 

My host pulled the server due to a technical problem (unrelated) and now that the site is back up, the Froogle Data Feeder is working without any timeout issues. Hey, I won't ask questions! ;)

 

Paul

Share this post


Link to post
Share on other sites
*Update*

 

My host pulled the server due to a technical problem (unrelated) and now that the site is back up, the Froogle Data Feeder is working without any timeout issues.  Hey, I won't ask questions!  ;)

 

Paul

Good to know. I never got around to posting yesterday that the errors you describe were on your server's end...but I'm happy the issue is resolved. :)


Stress is a luxury afforded to those of us that need it least.

Where lipstick is concerned, the important thing is not color, but to accept God's final word on where your lips end. --Jerry Seinfeld

If you pick up a starving dog, and make him prosperous, he will not bite you. This is the principal difference between a man and a dog. --Mark Twain

Share this post


Link to post
Share on other sites

Please help me out here. I've serched all over the thread and doc, and can't find an answer.

 

My froogle file is generating just fine, uploading, and only generated a few tab errors.

 

UNFORTUNATELY....all of my product urls are broken. I've checked my froogle.php, and all the configs are fine. But when the URL is generated to submit to Froogle, they post as

 

http://www.xxxxxxxxx.com/catalog/product_i...p?products_id=3 (wth xxxxxx being the name of my store)

 

It only goes to the product id, and does not add the &osCid for the product, resulting in broken links. (Which Froogle did not catch, by the way).

 

Images are showing fine, and all of my links inside my store are working just fine.

 

Can someone please advise me as to how to fix this?

 

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Hmmmm....

 

What have I learned today? Let's see. . .

 

Lesson 1

 

Don't panic.

 

Lesson 2.

 

MAKE SURE YOU HAVE YOUR FLIPPIN PATH IN FROOGLE.PHP CORRECT.

I forgot to add my /catalog/ when I changed the store name.

 

Lesson 3.

 

Admit in public that you are an IDIOT. A complete knee-biter.

 

Class dismissed.

 

:blush:

Share this post


Link to post
Share on other sites

Froogle Data Feeder v1.62

Released By: Calvin K

------------------------

 

Date: August 4, 2005

 

Description: Creates and automatically sends a data feed to Froogle, to provide product information and pictures. This Froogle Data Feeder, handles product duplicates, specials(if available), currency conversion, tax support, html descriptions, full category trees, and automatic upload. In addition, the Froogle Data Feeder supports advance feeds. With the advance feed option enabled and the "instock" field enabled, it will create a feed with all of the products. Without the advance feed option enabled, it will only submit in stock items.

 

Minor Bug Fix: Removes extra tabs from the product descriptions that may cause errors in the feed.

 

Note: This release does not include support variable taxation levels for products. Sorry for the delay.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×