Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

Have you by any chance uncommented the FTP part of the script? By default the script is commented out with a /* at the beginning of the FTP part and a */ and the end of the FTP part.

Share this post


Link to post
Share on other sites

That was it!!!!!! Fantastic! I can't believe it. You deserve a couple of medals and 30 days paid vacation.

 

Many thanks!

Share this post


Link to post
Share on other sites
.

I could have it send out an e-mail everytime the file is uploaded too, but it seems like it'd be more trouble than good. Lemme know, what you guys think.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
This is great! Took me 5 minutes to install and another minute for it to export 2,572 products! The only problem I can see for myself is that, while the html is stripped out of the descriptions (and I was worried about whether or not it would do that), the descriptions become 'run on'. (Example: 'DetailsFalling LeavesStrudwick192x321 stitches59 colorsIf you would') I can definitely work around this though :o)

quin:

 

here is the code that prevented my version from running all the text together when using html:

 

change this code:

 

preg_replace($_strip_search, $strip_replace, strip_tags( $row->name ) ) . "\t" .

preg_replace($_strip_search, $strip_replace, strip_tags( $row->description ) ) . "\t" .

 

 

to this code:

preg_replace($_strip_search, $strip_replace, html_entity_decode( $row->name ) ) . "\t" .

preg_replace($_strip_search, $strip_replace, html_entity_decode( $row->description ) ) . "\t" .

 

 

the function html_entity_decode changes any html values back into their proper characters

Share this post


Link to post
Share on other sites

Can someone tell me how long it takes for google to setup my froogle account? Also, why submit the feed only every 30 days, why not everyday?

 

Does anyone know if our feed is sent to froogle if this will trigger the googlebot to spider the site too?

 

Many thanks

Share this post


Link to post
Share on other sites

It took about a week to get my account set up, and then another week after I pushed an initial valid feed before it showed up on Froogle. No, this is not connected to the Googlebot spider.

 

You can submit every day if you want (but not more often than that.) But if you don't submit for 30 days, your stuff is removed from Froogle, so you want to keep it current. If your store changes frequently, then by all means update frequently.

 

I had a problem at first where they listed the store name in the results by the username rather than the "real" store name. I sent them mail and, after a while, they fixed it.

Share this post


Link to post
Share on other sites
It took about a week to get my account set up, and then another week after I pushed an initial valid feed before it showed up on Froogle. No, this is not connected to the Googlebot spider.

 

You can submit every day if you want (but not more often than that.) But if you don't submit for 30 days, your stuff is removed from Froogle, so you want to keep it current. If your store changes frequently, then by all means update frequently.

 

I had a problem at first where they listed the store name in the results by the username rather than the "real" store name. I sent them mail and, after a while, they fixed it.

thanks for the info.

 

mac

Share this post


Link to post
Share on other sites

Deleted by DaemonJ as requested by user.

Edited by Daemonj

its a plane a ufo no its aircar

Share this post


Link to post
Share on other sites

Mo: just from a quick glance your setup is wrong.

 

$OutFile = "/home/win1001/public_html/temp/";

$destination_file = "windows101.txt";

 

should be

 

$OutFile = "/home/win1001/public_html/temp/windows101.txt";

$destination_file = "windows101.txt";

 

In the future, it isn't necessary to post all of the code if there are only a few lines that you had to configure.

 

 

Anyways, a new version of this contribution is out.

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Hi

 

first off, what a great contrib - took all of 5 mins to install and run for the first time. Small question, just because I am the lazy bloke who looks for a shortcut in everything I do.....we are a UK store who has been given permission to list on Froogle as we offer sales in $US and ship to the US, but when prices are pulled from the site they are in ?GBP - is there a way to amend the froogle.php script to multiply the ?GBP by the figure I have set in my admin controls?

 

I can work around it by a simple 2 minute edit in Excel and then ftp it off to froogle, but just wondering if it could be done, then I can leave the froogle upload to itself to work happily away automatically without any interference from me..... B)


Please note - if I have suggested a contrib above, it doesnt mean it will work! Most of the contribs are not ones I've used, but may be useful for your particular problem....

Have you tried a refined search? Chances are your problem has already been dealt with elsewhere on the forums.....

if (stumped == true) {

return(square_one($start_over)

} else {

$random_query = tep_fetch_answer($forum_query)

}

Share this post


Link to post
Share on other sites

Hi guys, i just downloaded the latest version of this mod and i will be installing it shortly. i read the readme file and it said the feed is automatically submitted once a week...is there a way to change the code so it submits the feed more than once a week? say once a day(and time of day) since i change prices daily?

Share this post


Link to post
Share on other sites

Yes, you can change it to upload daily. As default, it is set to once a week to create less load on Froogle's servers and your own.

 

The cron job is setup as follows:

 

Minute Hour Day Month Weekday Command

 

e.g.

 

0 4 * * 3 /usr/bin/php -q /home/<unix route to your file>/admin/froogle.php

 

where,

 

The cron command is: /usr/bin/php -q /home/<unix route to your file>/admin/froogle.php

 

and the cron is scheduled to run at 04:00 (4:00 am) every third weekday (weekly).


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
Hi

 

first off, what a great contrib - took all of 5 mins to install and run for the first time. Small question, just because I am the lazy bloke who looks for a shortcut in everything I do.....we are a UK store who has been given permission to list on Froogle as we offer sales in $US and ship to the US, but when prices are pulled from the site they are in ?GBP - is there a way to amend the froogle.php script to multiply the ?GBP by the figure I have set in my admin controls?

 

I can work around it by a simple 2 minute edit in Excel and then ftp it off to froogle, but just wondering if it could be done, then I can leave the froogle upload to itself to work happily away automatically without any interference from me..... B)

I have the code completed, I just need to do some more testing and make it into a releasable format. I'll finish it tomorrow(friday)... since it's a bit past 5am here (CA, USA) and i have class at 10am. zzz... =)

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

I downloaded and installed the new code, but I did find a bug in it. It is only listing the first product as on sale, the rest of the products have the befor sale price.

Share this post


Link to post
Share on other sites
I downloaded and installed the new code, but I did find a bug in it. It is only listing the first product as on sale, the rest of the products have the befor sale price.

are you positive? it seems to be working on mine. can anyone else verify?


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Yeah, I am positive. I just double checked it. I just modified it a little bit ago after I posted that message by changing all of my:

 

$already_sent[$row->name] = 1;

 

to

 

$already_sent[$row->name] == 1;

 

I then manually removed all duplicate products from my database and it worked like it should.

 

Then I switched the $already_sent's back to one equal instead of two other than the if statement one, and I once again had the sale's price problem.

 

For now, I am just going to stick with the modifications I made since it works until someone else verifies the bug.

Share this post


Link to post
Share on other sites
Yeah, I am positive. I just double checked it. I just modified it a little bit ago after I posted that message by changing all of my:

 

$already_sent[$row->name] = 1;

 

to

 

$already_sent[$row->name] == 1;

 

I then manually removed all duplicate products from my database and it worked like it should.

 

Then I switched the $already_sent's back to one equal instead of two other than the if statement one, and I once again had the sale's price problem.

 

For now, I am just going to stick with the modifications I made since it works until someone else verifies the bug.

ok, i think i fixed the problem. I just released an update.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Just released 1.1.2, this fixes a bug that was introduced with 1.1.0 and is found through 1.1.1

 

Use 1.1.2


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Congrats man! Everything seems to be working right now. :D

 

I didn't even catch the description bug, glad you caught that one, even though I already uploaded my file to froogle several hours ago, oh well, I send them another one tomorrow. :D

Share this post


Link to post
Share on other sites

This is a great contribution! Took 5 minutes to install on all of my sites!

 

I have a contribution (sorry can't seem to find it online anymore) installed on one of my sites that uses the product attributes to determine price. Because price is determined by product option (weight) most of my products have a $0.00 price in the products table.

 

I tried to join the products_attributes table but my SQL ins't that good.

 

Any wayto pull the first price from the attributes table if the price in the products table = 0.00 ? Or even easier, just pull the first price form the products_attributes table for the first matching product_id ?

 

Thx!

Share this post


Link to post
Share on other sites

Ok I am having a minor problem with this feed... I can't seem to get it to connect to frrogle. I have ftp enabled in my php configure but it keeps telling me connection failed.. Any hint would be appreciated.

Share this post


Link to post
Share on other sites
Ok I am having a minor problem with this feed... I can't seem to get it to connect to frrogle. I have ftp enabled in my php configure but it keeps telling me connection failed.. Any hint would be appreciated.

Try connecting using to the froogle ftp using a standalone FTP client like cute ftp first. If you can't connect via, a standalone ftp client then something is wrong with your froogle account.

 

otherwise it could be...

 

if you get this error:

Warning: ftp_put(): Can't build data connection: Connection timed out. in /home/theartou/public_html/admin/froogle.php on line 154

FTP upload has failed! source: /home/theartou/public_html/froogle/theartoutlet.txt dest: theartoutlet.txt

 

then:

 

You can try getting around this by setting PHP to use Passive mode, which

makes the FTP client connection out to port 20 on the FTP server. A quick

look at the manual says that you should use ftp_pasv to make that happen.

 

so all you need to do in the code:

 

// login with username and password

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

 

// turn passive mode on

ftp_pasv($conn_id, true);

 

// upload the file

$upload = ftp_put($conn_id, $destination_file, $source_file, FTP_BINARY);


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Well FTP works fine with FTP Pro Simply states failed to connect. When I added your code I get the following error message.

 

FTP upload has FAILED! source: /home/users/web/b22/niknakshop/catalog/froogle/theniknakshop.txt dest: theniknakshop.txt

 

Please let me know in you need to see any of the code.

 

Thanks for the quick reply..

Share this post


Link to post
Share on other sites

i just visited your site. it seems like the file was never created. the directory needs to be CHMOD'd to 777.

 

http://theniknakshop.com/catalog/froogle/theniknakshop.txt

 

anyways, i gotta get some sleep it's nearly 3am and i have class at 8am. good luck!

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×