Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

1.5 beta will be delayed a bit. i have a 1500 word paper, a presentation, a 3k paper then i'm moving in the next week. hopefully, the public release will fall into the normal time frame. 1.5 shouldn't be that hard to beta test, since it "shouldn't" affect the generated feed file. so i could just do a comparision on the feeds, and if something is different... DOH!

 

v1.5 is designed mainly to improve performance, usability, reliability, and help move towards modulization in v2.0. (the code will be a bit leaner with more efficent SQL queries; admin panel; and support those "uber-sized" stores 10k+ in products)

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
most of the lines point to only a few errors. you asked for help. for us to help you, why not post just a few of the lines. i would suspect it is a configuration issue, as i just installed that version last night on a different customer site and it worked fine.

Sorry it took so long to respond. I went back thru my previous post and realized it's only referring to two lines, 112 and 230... So, here are those lines:

 

line 112:

  if($catIndex[$catTempPar[$curID]] != null)

 

line 230:

	if ($already_sent[$row->id] == 1) continue; // if we've sent this one, skip the rest of the while loop

Share this post


Link to post
Share on other sites

OK sorry - to ask but I did not find the answer - I migt have missed it - if so - sorrry.

 

I have installed the contribution and it is working fine for multiple stores.

 

Now for the cron....

 

Do I install it in the crontab file for root or somwhere else?

 

I installed it there using:

 

 02 10 * * 7 /usr/bin/php -q /home/username/admin/froogle.php

 

so it would run at 10:02 on sundays. I got an email saying:

No input file specified.

 

So then I got looking again and now wonder if I am supposed to have the path to the txt file or something (<unix route to your file>)????

 

Any help? When running the php page manually it works fine.

 

Thanks


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

Hi: this looks like a great contribution, which will help me get my store on froogle soon! I have followed the instructions and made the necessary changes. When I try to run froogle.php from the browser, I get following error:

 

The page you have requested requires your browser to support cookies.? Please enable cookie support in your browser, and try again? 

 

Funny thing is, the browser is enabled to accept all cookies!

 

Also, I created the feeds folder outside the catalog folder. Is that going to be a problem?

 

Help appreciated.

Share this post


Link to post
Share on other sites

as long as the folder location is in a location named and not in the admin and has 777 properties should be ok.

for cookies, add the site to your trusted sites, then you should have no problems


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
Hi: this looks like a great contribution, which will help me get my store on froogle soon! I have followed the instructions and made the necessary changes. When I try to run froogle.php from the browser, I get following error:

 

The page you have requested requires your browser to support cookies.? Please enable cookie support in your browser, and try again??

 

Funny thing is, the browser is enabled to accept all cookies!

 

Also, I created the feeds folder outside the catalog folder. Is that going to be a problem?

 

Help appreciated.

froogle.php shouldn't require any cookies.... it runs independent of osC. have you tried rebooting?


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

I have been following this thread and there's a lot of great info here.

I've installed the mod and pointed everything to the right folder/file, run the script and I get Script timer: 0.730189 seconds.

 

But my output file is empty. CHMOD is 777 on file.

 

Any ideas?


____________________________________

every day above ground is a good day.

Share this post


Link to post
Share on other sites

Forgot to include some of the code:

 

$OutFile = "../guyleida.txt"; //"CHANGEME-full-path-to-file-with-777-dir-and-file-permissions.fr-outfile.txt";
$destination_file = "guyleida.txt";  //"CHANGEME-filename-to-upload-to-froogle.txt";
$source_file = $OutFile;
$imageURL = 'http://www.scraftbookunlimited.com/images/';
$productURL = 'http://www.scraftbookunlimited.com/product_info.php?products_id=';
$already_sent = array();


____________________________________

every day above ground is a good day.

Share this post


Link to post
Share on other sites

your file may be 777 however the directory is probably 755, create a froogle directory, make that 777 and then change the outfile path

 

from the file itself:

 

//"CHANGEME-full-path-to-file-with-777-dir-and-file-permissions.fr-outfile.txt";

Edited by Mibble

John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

I figured it out, I didn't have the FULL path in there before the output.txt file.

 

Awesome contrib.

 

Thanks to all who are working on it.

 

I'll use my first Froogle purchase to paypal some donations to ya.


____________________________________

every day above ground is a good day.

Share this post


Link to post
Share on other sites

This question is more Froogle-specific than OSC specific but I thought I'd ask.

 

My Froogle feed was accepted yesterday morning and my products showed up last night. The pricing is correct, the name of the product is right, but only about 5% of the products have images.

 

"Image not available".

 

The .txt file is correct, all the paths to the images are there, and the Froogle link takes you to the correct page on my site that shows the product.

 

Does it maybe take a while for Froogle to populate all the images from my site?

I can't imaging it would take that long. Only about 1500 products.

Edited by Vger

____________________________________

every day above ground is a good day.

Share this post


Link to post
Share on other sites

Wow - this thread is getting long - hve I mentioned I hate the OSC forum search option?

 

Anyway - has anyone discussed the ability to get the Froogle Feed to not list items with a zero price?


osC Contributions I have published.

 

Note: Some I only provided minor changes, updates or additions!

Share this post


Link to post
Share on other sites

yup, that should work.

 

OR:

 AND products.products_price != 0

 

yours will prevent products with negative values too. just incase for some odd reason, u wanted to sell products for a negative amount. but not sell products for free. :P

 

yes, this thread is getting really long. i'm thinking of setting up a new one, with an FAQ when v2 is released. since most of the questions are repeated over and over.


Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites
This question is more Froogle-specific than OSC specific but I thought I'd ask.

 

My Froogle feed was accepted yesterday morning and my products showed up last night. The pricing is correct, the name of the product is right, but only about 5% of the products have images.

 

"Image not available".

 

The .txt file is correct, all the paths to the images are there, and the Froogle link takes you to the correct page on my site that shows the product.

 

Does it maybe take a while for Froogle to populate all the images from my site?

I can't imaging it would take that long. Only about 1500 products.

 

Link to my store on Froogle:

scraftbookunlimited

 

from a quick look, it's all of your images with spaces in the filename.

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

a general good rule of thumb for images on the internet is no spaces, all lowercase, and less than 21 characters.

 

the spaces sometimes are replaced by %20, which causes problems sometimes.

could you post part of your feed? or provide the URL (since it's not the default one) B)

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

can anyone else confirm the following statement? "images with a filename that have spaces do not load properly on froogle."

 

if this is true, i may have a general bug fix for everyone.

 

please check your froogle listings by searching froogle for "store:yourtextfilename" where yourtextfilename is replaced by the name of the text file you upload to froogle and the quotes are removed.

Edited by FlyingMonkey

Most likely your question has been answered, please do a search first.

Share this post


Link to post
Share on other sites

Froogle is Beta still.

They can fix "spaces issue" themselves. Though we shall notify them about it :)

 

mrguytx, try e-mailing them at feeds-support@google.com. This is exactly the address to ask about such issues and they do reply.

Share this post


Link to post
Share on other sites

I did email them.

 

They said to fix it by putting %20% in all the spaces, yeah right.

 

I'm currently testing new code from FlyingMonkey, but it's not golden yet....


____________________________________

every day above ground is a good day.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×