Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

19 hours ago, Jack_mcs said:

@PapancoIn the googlefeeder.php file, change the OPTIONS_ENABLED_GOOGLE_UTM setting  to 0 or 1, depending on if you are using that google option.. Then find this line


define('OPTIONS_GOOGLE_UTM', '?utm_source=GoogleBase1&utm_medium=BaseFeed1&utm_campaign=products'); //see http://www.google.com/support/googleanalytics/bin/answer.py?hl=en&answer=55578

and replace it with this


if (OPTIONS_ENABLED_GOOGLE_UTM == 0) {
   define('OPTIONS_GOOGLE_UTM', '?store={my_store_code}'); 
} else {
   define('OPTIONS_GOOGLE_UTM', '?store={my_store_code}&utm_source=GoogleBase1&utm_medium=BaseFeed1&utm_campaign=products'); //see http://www.google.com/support/googleanalytics/bin/answer.py?hl=en&answer=55578
}

As before, be sure to change the "my_store_cde" with yours.

@Jack_mcs thanks for the support: I did a test but with UTM == 0 the store code is not inserted in the URL. If I enable UTM on 1, the UTM URL is correctly entered but the store code is not inserted in the URL. what else can i try?

Share this post


Link to post
Share on other sites

@PapancoAs mentioned, this is untested so I must be missing something. I will actually test it here and post once I have it working. I will try to get to it this week.

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

  • Added a localfeed option.
  • Corrected code for php warnings.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×