Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

The error means you have the seo option enabled in the settings but don't have the Ultimate SEO V2.2d contribution installed. You either need to turn off that setting or install that contribution.

 

Cool. I think we are getting somewhere. Now I am getting this

 

Parse error: syntax error, unexpected ')' in /services4/webpages/util/g/c/gchase.myutilitydomain.com/niagarafallsgallery.com/public/catalog/admin/googlefeeder.php on line 13

 

my Line 13 is

 

define('FTP_ENABLED', (isset($_GET['noftp']) ? '0')); //set to 0 to disable

 

I don't see the error, do you?

Share this post


Link to post
Share on other sites

Cool. I think we are getting somewhere. Now I am getting this

 

Parse error: syntax error, unexpected ')' in /services4/webpages/util/g/c/gchase.myutilitydomain.com/niagarafallsgallery.com/public/catalog/admin/googlefeeder.php on line 13

 

my Line 13 is

 

define('FTP_ENABLED', (isset($_GET['noftp']) ? '0')); //set to 0 to disable

 

I don't see the error, do you?

The code in the contribution doesn't have any such coding problems so any errors you are seeing are from some change you made. Try using a clean file and make the changes one at a time.

Share this post


Link to post
Share on other sites

The code in the contribution doesn't have any such coding problems so any errors you are seeing are from some change you made. Try using a clean file and make the changes one at a time.

 

OK, I installed it 3 times. still getting error

 

 

Parse error: syntax error, unexpected ')' in /services4/webpages/util/g/c/gchase.myutilitydomain.com/niagarafallsgallery.com/public/catalog/admin/googlefeeder.php on line 13

 

Here are lines 1-13. Any ideas?

 

<?php

// Title: Google Base Data Feeder

// Last Update: 12/25/09 by Jack_mcs at oscommerce-solution.com

 

 

/*************** BEGIN MASTER SETTINGS ******************/

 

define('SEO_ENABLED','false'); //Change to 'false' to disable if Ultimate SEO URLs is not installed

define('FEEDNAME', 'nfgtext.txt'); //from your googlebase account

define('DOMAIN_NAME', 'niagarafallsgallery.com'); //your correct domain name (don't include www unless it is used)

define('FTP_USERNAME', 'ftpniagarafallsgallery'); //created from within your googlebase account

define('FTP_PASSWORD', 'XXXXXXXXXXX'); //created from within your googlebase account

define('FTP_ENABLED', (isset($_GET['noftp']) ? '0' )); //set to 0 to disable

Share this post


Link to post
Share on other sites

The code in the contribution doesn't have any such coding problems so any errors you are seeing are from some change you made. Try using a clean file and make the changes one at a time.

I just noticed that is you don't count the blank lines your line 13 would be

 

define('DEFAULT_LANGUAGE', 1);

 

And from there on all lines don't have ' ' quotes. Notice your line did't put '1' like in all the preceeding lines and all lines thereafter don't have quote.

 

Don't know here. Just something I noticed

Thanks for all your help

Greg

Share this post


Link to post
Share on other sites

I have the data feed installed and it is working properly and uploading properly. Google has just posted my items and they all have broken links. The data feed is creating the urls

 

niagarafallsgallery.com/product_info.php?products_id=29

 

They should have the /catalog directory after the .com to workright. Is should look like this

 

niagarafallsgallery.com/catalog/product_info.php?products_id=29

 

What would I do to fix this?

 

Thank you in advance.

Greg

Edited by niagarafallsgallery

Share this post


Link to post
Share on other sites

I have the data feed installed and it is working properly and uploading properly. Google has just posted my items and they all have broken links. The data feed is creating the urls

 

niagarafallsgallery.com/product_info.php?products_id=29

 

They should have the /catalog directory after the .com to workright. Is should look like this

 

niagarafallsgallery.com/catalog/product_info.php?products_id=29

 

What would I do to fix this?

Change the domain name setting.

Share this post


Link to post
Share on other sites

Hi Jack,

 

I read this link regarding upcoming changes to Google Product Search. What changes would be needed to accomodate the availability, Google product category and additional images attributes?

 

Thanks for the fantastic contribution!

 

Regards,

Joe

Share this post


Link to post
Share on other sites

Hi Jack,

 

I read this link regarding upcoming changes to Google Product Search. What changes would be needed to accomodate the availability, Google product category and additional images attributes?

 

Thanks for the fantastic contribution!

The availability and product category will require additional fields in the database unless those are fixed. For example, some shops are never out of stock for any of their products so a new database field is not needed. But if stock is an issue, then it will have to be added and populated. Adding the field can be easily done with my "Add More Fields" contribution. Populating it will be up to the shop owner, as with any such field. The same is true for the product category. That option doesn't apply to all shops and can be ignored. But if your shop needs it, then a new field will have to be added and populated. The additional images is optional. I haven't thought it through as to how to code it since there are a number of additional images type addons available and code will have to be added to handle the fields so that this contribution works with all of them.

 

If you want to edit the file yourself and you don't need the extra database fields, then there are two changes (column heading and column data) that needs to be changed. It is not difficult if you are familiar with making such edits but it isn't something I would go over in a support thread, due to time limits.

Share this post


Link to post
Share on other sites

Hi, I am trying to install this contribution on osc 2.3.1. In you instructions it is stated:

 

Upload all of the files in the catalog directory to the correct

location on your server. If you have a 2.3, or above, shop, then

delete the feeders.php file and rename the feeders_2.3_only.php to

feeders.php.

 

However, the zip contributions file downloaded form

http://addons.oscommerce.com/info/4513

does not include feeders_2.3_only.php file.

 

I appreciate any help around.

Thanks,

brec

Boca Raton E-Commerce LLC


Regards,

Walter

Boca Raton E-Commerce LLC

www.dealsproshop.com

Share this post


Link to post
Share on other sites

Hi, I am trying to install this contribution on osc 2.3.1. In you instructions it is stated:

 

Upload all of the files in the catalog directory to the correct

location on your server. If you have a 2.3, or above, shop, then

delete the feeders.php file and rename the feeders_2.3_only.php to

feeders.php.

 

However, the zip contributions file downloaded form

http://addons.oscommerce.com/info/4513

does not include feeders_2.3_only.php file.

There are a number of contributions that provide googlebase feeds. The one you reference is not this one. You need to decide on one and, if it doesn't work, as for help in its support thread.

Share this post


Link to post
Share on other sites

There are a number of contributions that provide googlebase feeds. The one you reference is not this one. You need to decide on one and, if it doesn't work, as for help in its support thread.

Thanks for your quick reply, but I am confuse. The contribution I am referring to (http://addons.oscommerce.com/info/4513) points to this thread:

 

http://forums.oscommerce.com/index.php?showtopic=71088&st=1633

 

Regards,

brec

Boca Raton E-Commerce LLC


Regards,

Walter

Boca Raton E-Commerce LLC

www.dealsproshop.com

Share this post


Link to post
Share on other sites

Thanks for your quick reply, but I am confuse. The contribution I am referring to (http://addons.oscommerce.com/info/4513) points to this thread:

 

http://forums.oscommerce.com/index.php?showtopic=71088&st=1633

 

Regards,

brec

Boca Raton E-Commerce LLC

I apologize. the mistake was mine. I looked at the name and replied incorrectly. Yes, that is this contribution. But you will notice the uploads are by different people. I only support my uploads. There are a lot of uploads in the contribution section, for many contributions, by people that never support them. If you use one of those, you are prety much on your own, unless that person decides to spport his work.

Share this post


Link to post
Share on other sites

Ive managed to get my products up onto google merchant, all seemed fine until i reaised that the prices showing on google shopping for my store where without UK VAT,

After searching this thread i found,

 

UK Store Feeds who need the VAT to be Correct in Google Feeds -

 

 

 

FIND

 

/*************** BEGIN MASTER SETTINGS ******************/

 

REPLACE WITH

 

/*************** BEGIN MASTER SETTINGS ******************/

$taxRate = 20.0; //default = 0 (e.g. for 20.0% tax use "$taxRate = 20.0;")

$taxCalc = ($taxRate/100) + 1; //Do not edit

 

FIND

 

FORMAT( IFNULL(specials.specials_new_products_price, products.products_price), 2) AS price,

 

REPLACE WITH

 

FORMAT( IFNULL(specials.specials_new_products_price, products.products_price) * " . $taxCalc . ",2) AS price,

 

MAKE SURE THIS IS SET TO 0 and not 1

define('OPTIONS_ENABLED_INCLUDE_TAX', 0);

 

Done. Simples. ;-)

 

 

 

This i have done! yet still when creating a new data feed, my prices are still without UK VAT,

 

 

Can any1 help?

Share this post


Link to post
Share on other sites

Jack, does the latest version (v 2.8 May 4th, 2011) take care of all the new requirements that Google is asking for by Sept 22 (I think that's the date).

 

Also, I saw in only v 2.8 it says to just replace the googlefeeder.php file to update the software. Would that apply to all updates, from previous versions?

Edited by ggrant3

Share this post


Link to post
Share on other sites

Jack, does the latest version (v 2.8 May 4th, 2011) take care of all the new requirements that Google is asking for by Sept 22 (I think that's the date).

 

Also, I saw in only v 2.8 it says to just replace the googlefeeder.php file to update the software. Would that apply to all updates, from previous versions?

I only support my versions so I can't say if the one you mention has all of the new fields. My last version doesn't have all of the new requirements but they are being added. I don't know that I will get them uploaded by that date since I do have a real job, :), but I will try.

Share this post


Link to post
Share on other sites

I only support my versions so I can't say if the one you mention has all of the new fields. My last version doesn't have all of the new requirements but they are being added. I don't know that I will get them uploaded by that date since I do have a real job, :), but I will try.

 

The versions I mentioned are yours.

 

No problem on the date, I *think* it is Sept 22nd, but going from memory so I may be off a little.

Edited by ggrant3

Share this post


Link to post
Share on other sites

The versions I mentioned are yours.

 

No problem on the date, I *think* it is Sept 22nd, but going from memory so I may be off a little.

If you are referring to the version of May 4th, then yes, that is mine. You mentioned that it said to just replace the one file. I assumed you meant that was what the upload said, which is a common tactic of many uploaders. I never upload anything but a full version but I'm guessing you were referring to the update file included in my version.

Share this post


Link to post
Share on other sites

If you are referring to the version of May 4th, then yes, that is mine. You mentioned that it said to just replace the one file. I assumed you meant that was what the upload said, which is a common tactic of many uploaders. I never upload anything but a full version but I'm guessing you were referring to the update file included in my version.

 

Yup, I was referring to the May 4th version.

 

In the description it says "- Correct mistakes in the last upload. Just replace the googlefeeder.php to update." So I was just curious if for that version (and perhaps the next updated version from you), if that is all we would have to do, just replace that file.

 

Instead of going through the full installation again.

Share this post


Link to post
Share on other sites

Yup, I was referring to the May 4th version.

 

In the description it says "- Correct mistakes in the last upload. Just replace the googlefeeder.php to update." So I was just curious if for that version (and perhaps the next updated version from you), if that is all we would have to do, just replace that file.

 

Instead of going through the full installation again.

For version 2.8 you have to replace all of the files and make an additional change to the english.php file.

Share this post


Link to post
Share on other sites

Hi Jack,

Thanks for this contribution. I’m using V2.8 with CRE, it works, but not with the SEO enabled. The output is the same like $productURL = 'http://' . DOMAIN_NAME . '/product_info.php?products_id=';

For the SEO I’m using Ultimate 2.2.2d-11

Any idea?

Share this post


Link to post
Share on other sites

Hi Jack,

Thanks for this contribution. I’m using V2.8 with CRE, it works, but not with the SEO enabled. The output is the same like $productURL = 'http://' . DOMAIN_NAME . '/product_info.php?products_id=';

For the SEO I’m using Ultimate 2.2.2d-11

Any idea?

It will run on CRE correctly since I have installed it into such shops myself. But I can't really say more than that since it is against forum policy to offer support for such shops.

Share this post


Link to post
Share on other sites

It will run on CRE correctly since I have installed it into such shops myself. But I can't really say more than that since it is against forum policy to offer support for such shops.

 

I was reading this topic and I have the same issue with the output in OSC V2.2. It will be useful if I can solve this.

Share this post


Link to post
Share on other sites

I was reading this topic and I have the same issue with the output in OSC V2.2. It will be useful if I can solve this.

I can't think of any reason it would fail on that version with Ultimate SEO V2.2d installed. No such problem has ever been reported. All I can suggest is you need to be sure that the seo option is enabled in the settings in the googlefeeder file.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×