Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

Hi,

I install the lastest version. I get the following warining information?

 

 

Item Warnings - 6915 items with warnings 6915 items affected

2289Missing recommended attribute: shipping weight (2289 warnings)While items missing recommended attributes will process successfully, we recommend including relevant attributes if they are available.

 

 

2289Missing recommended attribute: google product category (2289 warnings)While items missing recommended attributes will process successfully, we recommend including relevant attributes if they are available.

 

 

2289Missing recommended attribute: product type (2289 warnings)While items missing recommended attributes will process successfully, we recommend including relevant attributes if they are available.

 

 

 

 

 

would you please help to give some suggestion asap?

 

 

 

 

Thanks & Best Regards,

 

Sunrise

 

 

 

 

 

Share this post


Link to post
Share on other sites

Item Warnings - 6915 items with warnings 6915 items affected

2289Missing recommended attribute: shipping weight (2289 warnings)While items missing recommended attributes will process successfully, we recommend including relevant attributes if they are available.

 

2289Missing recommended attribute: google product category (2289 warnings)While items missing recommended attributes will process successfully, we recommend including relevant attributes if they are available.

 

2289Missing recommended attribute: product type (2289 warnings)While items missing recommended attributes will process successfully, we recommend including relevant attributes if they are available.

Those are warnings that should not stop the feed from being accepted, although I suspect that will change. For the first and last items, enable those settings in the googlefeeder.php file. For the middle one, if your product requires that attribute, then you will need to have that added at some point since it will be required. If your product doesn't require it, then you can ignore it. At least, this is what google says but they keep changing the rules so who knows.

Share this post


Link to post
Share on other sites
<br />Those are warnings that should not stop the feed from being accepted, although I suspect that will change. For the first and last items, enable those settings in the googlefeeder.php file. For the middle one, if your product requires that attribute, then you will need to have that added at some point since it will be required. If your product doesn't require it, then you can ignore it. At least, this is what google says but they keep changing the rules so who knows.<br />
<br /><br /><br />

 

 

Thank you very much!!!

Share this post


Link to post
Share on other sites

Can anyone help ? im only a rookie!

 

I am getting an error code when trying to prouce a data feed from within admin,

 

: SQL error Unknown column 'products.products_brand' in 'field list'| sql = SELECT concat( 'http://reefbathrooms.co.uk/product_info.php?products_id=' ,products.products_id) AS product_url, products_model AS prodModel, manufacturers.manufacturers_name AS mfgName, manufacturers.manufacturers_id, products.products_id AS id, products_description.products_name AS name, products_description.products_description AS description, products.products_quantity AS quantity, products.products_status AS prodStatus, products.products_weight AS prodWeight, products.products_brand as brand, FORMAT( IFNULL(specials.specials_new_products_price, products.products_price) * 1.19,2) AS price, CONCAT( 'http://reefbathrooms.co.uk/images/' ,products.products_image) AS image_url, products_to_categories.categories_id AS prodCatID, categories.parent_id AS catParentID, categories_description.categories_name AS catName FROM (categories, categories_description, products, products_description, products_to_categories) left join manufacturers on ( manufacturers.manufacturers_id = products.manufacturers_id ) left join specials on ( specials.products_id = products.products_id AND ( ( (specials.expires_date > CURRENT_DATE) OR (specials.expires_date is NULL) OR (specials.expires_date = 0) ) AND ( specials.status = 1 ) ) ) WHERE products.products_id=products_description.products_id AND products.products_id=products_to_categories.products_id AND products_to_categories.categories_id=categories.categories_id AND categories.categories_id=categories_description.categories_id AND categories_description.language_id = 1 AND products_description.language_id = 1 ORDER BY products.products_id ASC

 

i understand this is some problem with my database, although im unsure what i need to change or add,

 

can anyone show my some light! =)

 

thanks!

Share this post


Link to post
Share on other sites

Can anyone help ? im only a rookie!

 

I am getting an error code when trying to prouce a data feed from within admin,

 

: SQL error Unknown column 'products.products_brand'

It is failing because you have the brand option enabled but don't have a brand field in the database. See previous posts regarding this.

Share this post


Link to post
Share on other sites

Hi Calvin,

 

 

 

I have installed Googlefeeder v2.8 and when select >Tools > Box_Feeders_Google I get them message "Version Checker is not installed. See here for details" However, when I open "feeders.php" the code

 

 

 

/********************** BEGIN VERSION CHECKER *********************/

if (file_exists(DIR_WS_FUNCTIONS . 'version_checker.php'))

{

require(DIR_WS_LANGUAGES . $language . '/version_checker.php');

require(DIR_WS_FUNCTIONS . 'version_checker.php');

$contribPath = 'http://addons.oscommerce.com/info/4513';

$currentVersion = 'GoogleBase V 2.8';

$contribName = 'GoogleBase V';

$versionStatus = '';

}

/********************** END VERSION CHECKER *********************/

 

 

 

is already there. Which is what version checker says to do. When I click on the link "Text_feeders_Google" and look in the feeds folder there is no file.

 

1. Did I do something wrong?

2. Looks like my computer is trying to stop a pop-up when I click the like text_feeders_google?

 

Thanks

 

Gregory Chase

 

www.niagarafallsgallery.com

Share this post


Link to post
Share on other sites

I have installed Googlefeeder v2.8 and when select >Tools > Box_Feeders_Google I get them message "Version Checker is not installed. See here for details" However, when I open "feeders.php" the code

See the directions in the install file regarding the version checker.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

See the directions in the install file regarding the version checker.

 

 

Forgive me for being new to this. I added the code

 

<tr>

<td class="smallText" style="font-weight: bold; color: red;"><?php echo AnnounceVersion($contribPath, $currentVersion, $contribName); ?></td>

</tr>

 

into "feeders.php"

 

still didn't work. The file tells me to put it in the file I want to watch. Since I don't know what file to have the Version String in or even why I want to have the version string can you tell me the if that was the right file. Or should I put it in the Google or Bing .php feeders?

Thanks for you help

Share this post


Link to post
Share on other sites

Forgive me for being new to this. I added the code

 

See the directions in the install file regarding the version checker.

Share this post


Link to post
Share on other sites

See the directions in the install file regarding the version checker.

 

 

That really doesn't help.

Do I put that code in googlefeeder.php and bingfeeder.php? The instructions say to put the code in the file I want to keep track of? If should say the name of the file. Don't know what it means?

Sorry.

Share this post


Link to post
Share on other sites

That really doesn't help.

Do I put that code in googlefeeder.php and bingfeeder.php? The instructions say to put the code in the file I want to keep track of? If should say the name of the file. Don't know what it means?

Sorry.

That's because you are not following the instructions. They don't say anything about editing a file but you seem determined to edit something. Just follow the instructions.

Share this post


Link to post
Share on other sites

That's because you are not following the instructions. They don't say anything about editing a file but you seem determined to edit something. Just follow the instructions.

Here is instructions

 

INSTALLATION:

===============================================================================

1) Upload the contents of the catalog directory. These are new files so they

can be safely uploaded.

 

---------------------------------------------------------------------

2) In the contribution file that you want to keep track of, add the following

near the top of the file, after the require('includes/application_top.php');

statement.

 

/********************** BEGIN VERSION CHECKER *********************/

require(DIR_WS_LANGUAGES . $language . '/version_checker.php');

require(DIR_WS_FUNCTIONS . 'version_checker.php');

$contribPath = 'http://addons.oscommerce.com/info/4513';

$currentVersion = 'GoogleFeeder V 2.7';

$contribName = 'GoogleFeeder V';

/********************** END VERSION CHECKER *********************/

 

where

XXXX is the correct contribution ID number (find it by going to that page in

the addons section of oscommerce.

 

YYYY is the name of the contribution with the version number. For example,

Header Tags SEO V 3.1.8

 

ZZZZ is the name of the contribution minus the version number. For example,

Header Tags SEO V

 

NOTE: Since there isn't a naming standard for contributions and some people upload

versions with completely changed and incorrect names, the above is only a suggestion.

You have to choose the naming method that makes most sense. For example, the latest

version of STS, as of this writing, is named "Simple Template System (STS) 4.5.9."

But a version before that was named "Latest version of STS is 4.5.8." So there isn't

an easy way to match something like this. But if the names are consistent, which they

should be, then the above method will work fine.

 

3) Then place this code anywhere in that same file where you want the version string to appear:

 

<tr>

<td class="smallText" style="font-weight: bold; color: red;"><?php echo AnnounceVersion($contribPath, $currentVersion, $contribName); ?></td>

</tr>

 

===============================================================================

That completes the installation. Go to the page that contains the added code

and a message regarding the version should be displayed. The new version of

Header Tags (3.19, not yet released) uses this code and has additional code to

allow better control of checking and displaying the version, in case you want

additional ideas of how to use it.

 

===============================================================================

The support thread is located at:

http://forums.oscommerce.com/topic/349870-version-tracker/

 

 

Do you have some newer instructions that don't require editing?

Share this post


Link to post
Share on other sites

Apologies if this as been asked before, but I couldn't find it.

 

Getting some delimiter errors when uploading to Google and can't figure out why. Here's the basics of the error report:

 

 

5 of 924 items inserted

 

Too few column delimiters (884 errors)

 

Too many column delimiters (35 errors)

 

 

I'm getting some warnings also, but it's the errors that I'd like corrected.

 

Thanks for any help

Share this post


Link to post
Share on other sites

Here is instructions

 

Do you have some newer instructions that don't require editing?

No, there are not any newer instructions but I assumed since you were asking a question about the googlefeeder that you were looking in its instructions. Step 6 states

6) Download the Version Checker contribution located at:

http://forums.oscommerce.com/topic/349870-version-tracker/

and upload the files included in it.

Share this post


Link to post
Share on other sites

Apologies if this as been asked before, but I couldn't find it.

 

Getting some delimiter errors when uploading to Google and can't figure out why. Here's the basics of the error report:

 

 

5 of 924 items inserted

 

Too few column delimiters (884 errors)

 

Too many column delimiters (35 errors)

You need to click on the link that shows the details of the errors. They will reference specific line numbers in the feed to make fixing them easier.

Share this post


Link to post
Share on other sites

No, there are not any newer instructions but I assumed since you were asking a question about the googlefeeder that you were looking in its instructions. Step 6 states

 

Your right and the Googlefeeder requires VErsion Checker which needs to be edited. My issue is in the editing of Versionchecker which is needed to make Googlefeeder work. So, now we get to my problem right. All are installed but I get the error that says I need to install Versionchecker. Any ideas? I will email you my edited VErsionchecker file?

Greg

Share this post


Link to post
Share on other sites

Your right and the Googlefeeder requires VErsion Checker which needs to be edited. My issue is in the editing of Versionchecker which is needed to make Googlefeeder work. So, now we get to my problem right. All are installed but I get the error that says I need to install Versionchecker. Any ideas? I will email you my edited VErsionchecker file?

Greg

I don't know how else to state it. This contribution does not require the Version Checker contribution. If you want to use it though, you just need to do as the instructions state and upload the files. No editing required!

Share this post


Link to post
Share on other sites

I don't know how else to state it. This contribution does not require the Version Checker contribution. If you want to use it though, you just need to do as the instructions state and upload the files. No editing required!

 

OK,

I have gotten past all then installing and version checker problems. But I still have issues. When I Tools> Google Base> Create and Do Not Upload Googlebase Datafeed The program opens a new windows and then does nothing. No text no error? Any ideas. Do you thikn I edited the googlefeeder.php wrong. If so do you have an email I and email the googlefeeder.php to? I don't want to post it in the public.

Thank You

Share this post


Link to post
Share on other sites

OK,

I have gotten past all then installing and version checker problems. But I still have issues. When I Tools> Google Base> Create and Do Not Upload Googlebase Datafeed The program opens a new windows and then does nothing. No text no error? Any ideas. Do you thikn I edited the googlefeeder.php wrong. If so do you have an email I and email the googlefeeder.php to? I don't want to post it in the public.

Thank You

My guess is that you made a mistake in the edit of the googlefeeder.php file and an error is occurring. Your host probably has error reporting turned off so you wouldn't see the error. You should try redoing the file first and if it still fails, contact your host and ask them to see if it is causing an error.

Share this post


Link to post
Share on other sites

My guess is that you made a mistake in the edit of the googlefeeder.php file and an error is occurring. Your host probably has error reporting turned off so you wouldn't see the error. You should try redoing the file first and if it still fails, contact your host and ask them to see if it is causing an error.

 

Heres the wau I edited it. Do you see any problems?

 

/*************** BEGIN MASTER SETTINGS ******************/

 

define('SEO_ENABLED','true'); //Change to 'false' to disable if Ultimate SEO URLs is not installed

define('FEEDNAME', 'nfgfeed.txt'); //from your googlebase account

define('DOMAIN_NAME', 'niagarafallsgallery.com'); //your correct domain name (don't include www unless it is used)

define('FTP_USERNAME', 'ftpniagarafallsgallery'); //created from within your googlebase account

define('FTP_PASSWORD', 'XXXXXXXXXXXXXXXXXXXXXXXX'); //created from within your googlebase account

define('FTP_ENABLED', (isset($_GET['noftp']) ? '0')); //set to 0 to disable 1 to enable

define('CONVERT_CURRENCY', '0'); //set to 0 to disable - only needed if a feed in a difference currecny is required

define('CURRENCY_TYPE', 'USD'); //(eg. USD, EUR, GBP)

define('DEFAULT_LANGUAGE', 1); //Change this to the id of your language. BY default 1 is english

define('QUOTES_CATEGORY_NAME',''); //if the Quotes contribution is installed, enter the name of the quotes category here

 

define('OPTIONS_ENABLED', 1);

define('OPTIONS_ENABLED_AGE_RANGE', 0);

define('OPTIONS_ENABLED_ATTRIBUTES', 0);

define('OPTIONS_ENABLED_BRAND', 0);

define('OPTIONS_ENABLED_CONDITION', 1);

define('OPTIONS_ENABLED_CURRENCY', 0);

define('OPTIONS_ENABLED_EXPIRATION', 1);

define('OPTIONS_ENABLED_FEED_LANGUAGE', 0);

define('OPTIONS_ENABLED_FEED_QUANTITY', 0);

define('OPTIONS_ENABLED_GTIN', 0);

define('OPTIONS_ENABLED_GOOGLE_UTM', 0);

define('OPTIONS_ENABLED_ISBN', 0);

define('OPTIONS_ENABLED_MADE_IN', 0);

define('OPTIONS_ENABLED_MANUFACTURER', 0); //displays the manufacturer name

define('OPTIONS_ENABLED_PAYMENT_ACCEPTED', 0);

define('OPTIONS_ENABLED_PRODUCT_MODEL', 0); //displays the product model

define('OPTIONS_ENABLED_PRODUCT_TYPE', 0);

define('OPTIONS_ENABLED_SHIPPING', 0);

define('OPTIONS_ENABLED_INCLUDE_TAX', 0);

define('OPTIONS_ENABLED_UPC', 0);

define('OPTIONS_ENABLED_WEIGHT', 0);

 

//the following only matter if the matching option is enabled above.

define('OPTIONS_AGE_RANGE', '20-90 years');

define('OPTIONS_BRAND', '');

define('OPTIONS_CONDITION', 'New'); //possible entries are New, Refurbished, Used

define('OPTIONS_DEFAULT_CURRENCY', 'USD');

define('OPTIONS_DEFAULT_FEED_LANGUAGE', 'en');

define('OPTIONS_DEFAULT_GOOGLE_UTM', '?utm_source=GoogleBase1&utm_medium=BaseFeed1&utm_campaign=products'); //see http://www.google.com/support/googleanalytics/bin/answer.py?hl=en&answer=55578

define('OPTIONS_GTIN', '');

define('OPTIONS_ISBN', '');

define('OPTIONS_MADE_IN', 'US');

define('OPTIONS_MANUFACTURERS_NAME_IGNORE', ''); //list if comma separated manufacturer names to be skipped - e.g. Matrox,Fox

define('OPTIONS_PAYMENT_ACCEPTED_METHODS', ''); //Acceptable values: Cash, Check, GoogleCheckout, Visa, MasterCard, AmericanExpress, Discover, wiretransfer

define('OPTIONS_PRODUCT_TYPE', 'full'); //full means the full category path (i.e., hardware,printers), anything else, or blank, means just the products category (i.e., printers)

 

//the following is for the shipping override option - enter multiple values separated by a comma

//Format entries follow. A colon must be present for each field, whether it is entered or not.

// COUNTRY - OPTIONAL - If country isn't included, we'll assume the shipping price applies to the target country of the item. If region isn't included, the shipping price will apply across the entire country.

// REGION - OPTIONAL - blank for entire country, otherwise, us two-letter State (CA), full zip code (90210) or wildcard zip code (902*)

// SERVICE - OPTIONAL - The service class or delivery speed, i.e. ground

// PRICE - REQUIRED - Fixed shipping price (assumes the same currency as the price attribute)

define('OPTIONS_SHIPPING_STRING', 'US:FL:Ground:7.00'); //says charge tax to US for residents of Florida at 5% and don't apply tax to shipping

 

//the following is for the tax override option - enter multiple values separated by a comma

//Format entries follow. A colon must be present for each field, whether it is entered or not.

// COUNTRY - OPTIONAL - country the tax applies to - only US for now

// REGION - OPTIONAL - blank for entire country, otherwise, us two-letter State (CA), full zip code (90210) or wildcard zip code (902*)

// TAX - REQUIRED - default = 0 (e.g. for 5.76% tax use 5.76)

// SHIPPING - OPTIONAL - do you charge tax on shipping - choices are y or n

define('OPTIONS_TAX_STRING', 'US:FL:5.00:n'); //says charge tax to US for residents of Florida at 5% and don't apply tax to shipping

 

define('OPTIONS_UPC', '');

define('OPTIONS_WEIGHT_ACCEPTED_METHODS', 'lb'); //Valid units include lb, pound, oz, ounce, g, gram, kg, kilogram.

 

//the following allow skipping certain items

define('OPTIONS_IGNORE_PRODUCT_ZERO', 1); //0 = include products with qty of 0 in output, 1 = ignore products with qty of 0

 

/*************** END MASTER SETTINGS ******************/

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

No, I don't.

 

My Website provider is APLUS.NET Since I installed your Google feed and then two others GoogleData Feeds and none have worked and now I installed your again meticulously. I have to think this is a server issue. Have you heard anything about APLUS.NET hosting and OSCOMMERCE?

Share this post


Link to post
Share on other sites

No, I don't.

 

I just got this from provider after installing your feed. Any ideas?

 

Warning: include_once(../includes/classes/seo.class.php) [function.include-once]: failed to open stream: No such file or directory in /services4/webpages/util/g/c/gchase.myutilitydomain.com/niagarafallsgallery.com/public/catalog/admin/googlefeeder.php on line 101

 

Warning: include_once() [function.include]: Failed opening '../includes/classes/seo.class.php' for inclusion (include_path='.:/services/websoftware/zend.php5/pear') in /services4/webpages/util/g/c/gchase.myutilitydomain.com/niagarafallsgallery.com/public/catalog/admin/googlefeeder.php on line 101

 

Fatal error: Class 'SEO_URL' not found in /services4/webpages/util/g/c/gchase.myutilitydomain.com/niagarafallsgallery.com/public/catalog/admin/googlefeeder.php on line 102

Share this post


Link to post
Share on other sites

I just got this from provider after installing your feed. Any ideas?

 

Warning: include_once(../includes/classes/seo.class.php) [function.include-once]: failed to open stream: No such file or directory in /services4/webpages/util/g/c/gchase.myutilitydomain.com/niagarafallsgallery.com/public/catalog/admin/googlefeeder.php on line 101

The error means you have the seo option enabled in the settings but don't have the Ultimate SEO V2.2d contribution installed. You either need to turn off that setting or install that contribution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×