Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

I haven't released a 2.3 compatible version but instructions are in this thread.

 

Hi Jack,

 

Are those instructions also included in the install text file within the latest version of the contribution? It looks like they are.

 

Cheers,

Paul

Edited by Cyburg

Share this post


Link to post
Share on other sites

Are those instructions also included in the install text file within the latest version of the contribution? It looks like they are.

I added the 2.3 compatible code and instructions in version 2.7 but forgot to mention it in the history so I forgot about it. So versions from 2.7 can be used with 2.3. This refers to my versions. I don't support or check any other versions so can't say whether they are compatible or not.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

I am new to osCommerce. Can someone please display link to correct section to learn how to add modules? where do I add box_invoice.php file?

 

Thanks, Will-

Share this post


Link to post
Share on other sites

i am wondering if anyone can help me. i must have done something to something but i do not know what. i have tried to seng a data feed to google and it came up with this error.

 

: SQL error Unknown column 'products.products_brand' in 'field list'| sql = SELECT concat( 'http://www.vanity-flair-uk.com/product_info.php?products_id=' ,products.products_id) AS product_url, products_model AS prodModel, manufacturers.manufacturers_name AS mfgName, manufacturers.manufacturers_id, products.products_id AS id, products_description.products_name AS name, products_description.products_description AS description, products.products_quantity AS quantity, products.products_status AS prodStatus, products.products_weight AS prodWeight, products.products_brand as brand, FORMAT( IFNULL(specials.specials_new_products_price, products.products_price), 2) AS price, CONCAT( 'http://www.vanity-flair-uk.com/images/' ,products.products_image) AS image_url, products_to_categories.categories_id AS prodCatID, categories.parent_id AS catParentID, categories_description.categories_name AS catName FROM (categories, categories_description, products, products_description, products_to_categories) left join manufacturers on ( manufacturers.manufacturers_id = products.manufacturers_id ) left join specials on ( specials.products_id = products.products_id AND ( ( (specials.expires_date > CURRENT_DATE) OR (specials.expires_date is NULL) OR (specials.expires_date = 0) ) AND ( specials.status = 1 ) ) ) WHERE products.products_id=products_description.products_id AND products.products_id=products_to_categories.products_id AND products_to_categories.categories_id=categories.categories_id AND categories.categories_id=categories_description.categories_id AND categories_description.language_id = 1 AND products_description.language_id = 1 ORDER BY products.products_id ASC

 

i have not used this for a couple of weeks and as far as i knew everything was fine when i last used it.

 

could someone please help.

 

i will be very greatful

Share this post


Link to post
Share on other sites

i am wondering if anyone can help me. i must have done something to something but i do not know what. i have tried to seng a data feed to google and it came up with this error.

 

: SQL error Unknown column 'products.products_brand' in 'field list'| sql = SELECT concat( 'http://www.vanity-flair-uk.com/product_info.php?products_id=' ,products.products_id) AS product_url, products_model AS prodModel, manufacturers.manufacturers_name AS mfgName, manufacturers.manufacturers_id, products.products_id AS id, products_description.products_name AS name, products_description.products_description AS description, products.products_quantity AS quantity, products.products_status AS prodStatus, products.products_weight AS prodWeight, products.products_brand as brand, FORMAT( IFNULL(specials.specials_new_products_price, products.products_price), 2) AS price, CONCAT( 'http://www.vanity-flair-uk.com/images/' ,products.products_image) AS image_url, products_to_categories.categories_id AS prodCatID, categories.parent_id AS catParentID, categories_description.categories_name AS catName FROM (categories, categories_description, products, products_description, products_to_categories) left join manufacturers on ( manufacturers.manufacturers_id = products.manufacturers_id ) left join specials on ( specials.products_id = products.products_id AND ( ( (specials.expires_date > CURRENT_DATE) OR (specials.expires_date is NULL) OR (specials.expires_date = 0) ) AND ( specials.status = 1 ) ) ) WHERE products.products_id=products_description.products_id AND products.products_id=products_to_categories.products_id AND products_to_categories.categories_id=categories.categories_id AND categories.categories_id=categories_description.categories_id AND categories_description.language_id = 1 AND products_description.language_id = 1 ORDER BY products.products_id ASC

 

i have not used this for a couple of weeks and as far as i knew everything was fine when i last used it.

 

could someone please help.

 

i will be very greatful

 

sorry sorted it!!

Share this post


Link to post
Share on other sites

HI Jack

 

In one of my forum post, you mentioned that you are working on something to easily create extra field to work with your Feeder contribution without adding bunch of codes. I am wondering if you had time to finsih it yet? If you did finish it, where can I find this modifications?

 

Just a reminder in case you forgot where you mentioned it:

http://forums.oscommerce.com/topic/376182-help-needed-extra-product-fields-301-with-header-tag-seo/page__view__findpost__p__1587647

 

 

Hope to hear from you soon.

 

Thanks

Kai

Share this post


Link to post
Share on other sites

HI Jack

 

In one of my forum post, you mentioned that you are working on something to easily create extra field to work with your Feeder contribution without adding bunch of codes. I am wondering if you had time to finsih it yet? If you did finish it, where can I find this modifications?

 

Just a reminder in case you forgot where you mentioned it:

http://forums.oscommerce.com/topic/376182-help-needed-extra-product-fields-301-with-header-tag-seo/page__view__findpost__p__1587647

I expected it to be completed by now but real work got in the way. It is 96% completed though. It will be completed by this time next week, for sure, since I will have time to work on it due to the upcoming holiday.

Share this post


Link to post
Share on other sites

since I will have time to work on it due to the upcoming holiday.

 

 

Hi Jack

 

Thanks for your update and really appricate you are working on this little codes during your holiday.

 

I am wondering when you finish this and will it be a new contribution, or you are just going to merge it into your google feeder contribution as an update?

 

Just easier for me to keep a track.

 

Thanks

Kai

Share this post


Link to post
Share on other sites

I am wondering when you finish this and will it be a new contribution, or you are just going to merge it into your google feeder contribution as an update?

It's a completely separate contribution with no connection to this contribution.

Share this post


Link to post
Share on other sites

Jack,

 

As I sell many items with different brands is it possible for the feed to use the manufacturer field to populate this?

Share this post


Link to post
Share on other sites

Jack,

 

As I sell many items with different brands is it possible for the feed to use the manufacturer field to populate this?

To populate what?

Share this post


Link to post
Share on other sites

To populate what?

 

For the manufacturer field in oscommerce to populate the 'Brand' field in the google feed?

Share this post


Link to post
Share on other sites

For the manufacturer field in oscommerce to populate the 'Brand' field in the google feed?

Change this line

       $extraFields .= ' products_description.products_name as brand, ';

to this one

       $extraFields .= ' manufacturers.manufacturers_name as brand, ';

Share this post


Link to post
Share on other sites

I'm having an issue with the GoogleBase data feed. I installed the contribution. However, when I go to tools and run the datafeed, the txt document is coming out blank. It has the header titles but the product information is not populating. Does anyone know what may be causing this?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I'm having an issue with the GoogleBase data feed. I installed the contribution. However, when I go to tools and run the datafeed, the txt document is coming out blank. It has the header titles but the product information is not populating. Does anyone know what may be causing this?

 

Thanks in advance.

Maybe the quantity for all of your products is 0. If they are, then change the setting for that condition.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Experimental feed to bing.

 

Jack, there are several issues with this feed.

 

First after change the code, I finally got it past their validation.

Here is what ms/bing/microsoft ad center wants.

 

Everything is in lb at ms period. So the produce weight field sending LB must be turned off. Or just remove the lb if you are not going to add other option product fields. Hey I kid you not. Here is their response.

"All ShippingWeight values are invalid. Please use only numbers; all weights are expressed in pounds automatically."

I have not tackled the conversion for metric as this was absolutely absured.

 

the next issue is more interesting and I made a quick table to handle the change.

MS does not wants product stock attrib (prodstatus) to send 0,1. They want In Stock, Out of Stock, Pre-Order, and Back-Order.

Since in OS we oly have in stock and out of stock. I simply added before row>prodstatus statement a simple if it is a one, change to "In stock" , 0 "Out of stock". Fixed the problem

 

For ftp_file changed the server to: feeds.adcenter.microsoft.com

 

Then wait for about 6 weeks. MS apparently manually validates your data feed before giving approval for display. Then you play the game with support until they tell you you've validated.

 

Hope this helps.

 

Wylie

Share this post


Link to post
Share on other sites

Experimental feed to bing.

 

Jack, there are several issues with this feed.

 

Hope this helps.

 

Wylie

Thank you for posting the problems. I will change the code for this in the next release. Does a Bing feed still require payment? They did at one time and were talking about making it free but I've not paid any attention to it in some time.

Share this post


Link to post
Share on other sites

Thank you for posting the problems. I will change the code for this in the next release. Does a Bing feed still require payment? They did at one time and were talking about making it free but I've not paid any attention to it in some time.

 

Hi Jack, Credit card is required to be posted but not charged. MS is trying to get you to buy ad time and as soon as the card is entered, the next screen takes you to start a campaign. Just click out of it.

What I recommend for those that want to use bing but don't want the CC headache. Get a prepaid with a buck on it. Or use a credit card that allows for Shopsafe(safeshop). Shopsafe lets you create a card off your main card with a limited, time limit expire. Once you are validated it doesn't appear you need to update the card for ms ad for the feed to work. Great system!

Oh one more thing. MS actually calls the company/ card holder before activation and verifies you created the account.

Sometime in a far off galaxy as previous expressed, about 6 weeks, MS/Bing will let you know if your datafeed is validated or rejected by email. Until then, nothing goes on the site.

MS is rather slow...

Share this post


Link to post
Share on other sites

Thank you for posting that. I'm sure it will help others. Submitting a feed to Bing is probably a good idea since they are growing and becoming more popular.

Share this post


Link to post
Share on other sites

Jack, not sure if I'm a Johnny-come-lately on the subject, but I got a mail from Google this morning listing changes to feed specification. One of these is that shipping costs need to be included, can this contribution handle this already/plans to do so before I start chopping away at your code like the amateur I am?

Share this post


Link to post
Share on other sites

Jack, not sure if I'm a Johnny-come-lately on the subject, but I got a mail from Google this morning listing changes to feed specification. One of these is that shipping costs need to be included, can this contribution handle this already/plans to do so before I start chopping away at your code like the amateur I am?

Yes, they changed the rules yet again. Some of the changes are already coded into this addon, like shipping. While others, like variants, aren't. For shipping, you have the option of overriding that with a setting in your googlebase account. But that will only work if your shipping is the same for everything. If it varies, you will need to use the option in the settings. Instructions are included with how to set those up.

Share this post


Link to post
Share on other sites

Yes, they changed the rules yet again. Some of the changes are already coded into this addon, like shipping. While others, like variants, aren't. For shipping, you have the option of overriding that with a setting in your googlebase account. But that will only work if your shipping is the same for everything. If it varies, you will need to use the option in the settings. Instructions are included with how to set those up.

 

 

Hi Jack,

 

I see they have some redundant fields (quantity etc) now and some new requirements such as "Availability - in stock, out of stock etc"

 

Also how would you suggest setting up several shipping costs which are dependant on item weight and shipping location? (I use MGZMT Shipping contribution to handle this on the store).

 

and finally, I still have a problem mixing non vat and vat goods - I asked the question several months ago - but bit the bullet and added 20% vat to everything, I suppose unless you have any suggestions I would need to manually adjust the datafeed prior to submission?

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Hi Jack,

 

I see they have some redundant fields (quantity etc) now and some new requirements such as "Availability - in stock, out of stock etc"

 

Also how would you suggest setting up several shipping costs which are dependant on item weight and shipping location? (I use MGZMT Shipping contribution to handle this on the store).

 

and finally, I still have a problem mixing non vat and vat goods - I asked the question several months ago - but bit the bullet and added 20% vat to everything, I suppose unless you have any suggestions I would need to manually adjust the datafeed prior to submission?

 

Thanks

Yes, they seem determined to upset everyone. The feed code will have to be changed to handle the new options. I haven't started on it yet but I don't think it will be a simple change, especially involving the variants.

 

For the shipping, you can setup a shipping profile in your googlebase account if your carrier is listed there. Otherwise, you have to use the settings in the file to create the shipping profiles. They now require the shipping weight too so you will have to turn on that option. But it appears the code will need to changed to use the shipping modules to calculate shipping for each product.

 

This addon has never handled individual taxes, though it looks like that is going to have to be changed too. Google has different guidelines for different countries so coming up with a file that will work for all will be difficult, or at least time-consuming.

 

For now, the existing code should allow a shop to get their feed listed. The other items should be available in later versions.

Share this post


Link to post
Share on other sites

Thanks Jack, Will keep watchin this space....

 

I think the only firm requirement missing from V 2.8 is the "Availability" option

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Thanks Jack, Will keep watchin this space....

 

I think the only firm requirement missing from V 2.8 is the "Availability" option

The variants are not coded in either. I haven't gone over all of the others yet but hopefully those are the only ones.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×