Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

Read the instructions with that contribution or ask in its support thread.

 

There's nothing in the contribution instructions regarding invalid characters and they listed THIS thread as the support thread for the contribution, that's why I'm here.

 

I just checked and this appears to be your contribution so why are you pointing me somewhere else?

I've downloaded v2.5 & v2.6 and don't see anything about invalid characters in the instructions.

Edited by cgchris99

Share this post


Link to post
Share on other sites

There's nothing in the contribution instructions regarding invalid characters and they listed THIS thread as the support thread for the contribution, that's why I'm here.

 

I just checked and this appears to be your contribution so why are you pointing me somewhere else?

I've downloaded v2.5 & v2.6 and don't see anything about invalid characters in the instructions.

You asked for how to get that to work and I told you. If you refuse to try it...

Share this post


Link to post
Share on other sites

You asked for how to get that to work and I told you. If you refuse to try it...

 

I'm willing to try anything. Maybe I'm blind. Is the information only in a certain download? Have I downloaded the wrong version?

Or are you saying I have to change my descriptions in order to get it to work?

 

If I change the product titles and descriptions to Scope 1.5in and someone on google searches for Scope 1-1/2" then it will not find it right?

Share this post


Link to post
Share on other sites

I have some items that are free shipping and others that aren't, is there any way to make the feeder display free shipping while not displaying any shipping information for the paid shipping items? Currently I enter "0" in my shipping weight in order to get my website to show free shipping.

Share this post


Link to post
Share on other sites

I have some items that are free shipping and others that aren't, is there any way to make the feeder display free shipping while not displaying any shipping information for the paid shipping items? Currently I enter "0" in my shipping weight in order to get my website to show free shipping.

Google won't allow you to show free shipping.

Share this post


Link to post
Share on other sites

Jack thanks for this contribution. I had it before and when my site was hacked ,I deleted some files not realizing it belonged to the datafeed.

One question: when put Mydomain.com/admin/google.php in the browser, It updates the datafeed without being logged in. Is that OK? Or should I disable something for security? I hope i'm explaining this right.

Share this post


Link to post
Share on other sites

Jack thanks for this contribution. I had it before and when my site was hacked ,I deleted some files not realizing it belonged to the datafeed.

One question: when put Mydomain.com/admin/google.php in the browser, It updates the datafeed without being logged in. Is that OK? Or should I disable something for security? I hope i'm explaining this right.

No, you should not be able to access any part of your admin without logging in first. If you don't know how to fix that, you should post in the general forum for help since that is a major problem for your shop.

Share this post


Link to post
Share on other sites

I have this installed on one of my sites - but the issue I find is that it does not accurately match up with the google taxonomy.

 

It pulls the category descriptions from what we have listed on our site. If there was a way to control what the categories were to use the google taxonomy - that would greatly help with getting products listed in the correct place.

http://www.google.com/support/merchants/bin/answer.py?hl=en&answer=160081

 

Clothing & Accessories > Clothing Accessories > Aprons

 

any thoughts on this?

Share this post


Link to post
Share on other sites

I have this installed on one of my sites - but the issue I find is that it does not accurately match up with the google taxonomy.

 

It pulls the category descriptions from what we have listed on our site. If there was a way to control what the categories were to use the google taxonomy - that would greatly help with getting products listed in the correct place.

http://www.google.com/support/merchants/bin/answer.py?hl=en&answer=160081

 

Clothing & Accessories > Clothing Accessories > Aprons

 

any thoughts on this?

That is the product type column in the feed and is the category name. If your category names don't match the category you want on google, and I assume you wouldn't want to change them, there's nothing in the code that would allow you to adjust that. You could build a table of names in the feed and then replace teh category name that matches it on the fly.

Share this post


Link to post
Share on other sites

Is there any way to have the link output automatically generate a source tag like ?utm_source=google_products and add it to the feed? I would like to follow my Google Products campaign in Google Analytics.

 

I am using the FWR Media update for Ultimate SEO URLS 5 with this google feed contrib. I dont know if it will be any different for this update.

Edited by Tim Romero

Share this post


Link to post
Share on other sites

Is there any way to have the link output automatically generate a source tag like ?utm_source=google_products and add it to the feed? I would like to follow my Google Products campaign in Google Analytics.

 

I am using the FWR Media update for Ultimate SEO URLS 5 with this google feed contrib. I dont know if it will be any different for this update.

The links you submit have to be valid, existing, links on your site or google will not allow them so I don't think that will work. I would think google has some way of doing that internally though so you may want to ask them first.

Share this post


Link to post
Share on other sites

I'm sorry.. I read your forums all the time, but I think this is the first time, I"m actually posting a question...

 

I have Google Datafeed installed and for the longest time it was working correctly... However now it seems to be posting the wrong expiration date (8-11-10) and it's not including any newly added products. I have no idea what I did or what changed.. Can someone please help me? Thanx

Share this post


Link to post
Share on other sites

I'm sorry.. I read your forums all the time, but I think this is the first time, I"m actually posting a question...

 

I have Google Datafeed installed and for the longest time it was working correctly... However now it seems to be posting the wrong expiration date (8-11-10) and it's not including any newly added products. I have no idea what I did or what changed.. Can someone please help me? Thanx

No need to apologize for posting a question. That's what support threads are for. :)

 

Do you have my latest version installed? There was a change to the code at some point regarding that problem.

Share this post


Link to post
Share on other sites

Yes, thank you. I have the latest one installed. There is a time thing on there and it looks right, but even if I play with the number on the end (2505600), nothing changes. It always comes up with the date of 8-11-2010. It doesn't change with the day or anything. I'm sorry I don't know anything about this to even know where to look to fix it.

Share this post


Link to post
Share on other sites

Yes, thank you. I have the latest one installed. There is a time thing on there and it looks right, but even if I play with the number on the end (2505600), nothing changes. It always comes up with the date of 8-11-2010. It doesn't change with the day or anything. I'm sorry I don't know anything about this to even know where to look to fix it.

I seem to recall one or two others having this problem and it was due to the dates in their database having future or no dates, or something like that. You may want to check that (you can find the details in this thread).

Share this post


Link to post
Share on other sites

Hi guys,

just wanted to know something about the Cronjob.

The googlefeeder.php is in the admin folder which is protected by .htaccess. Will it still work if the Cronjob is setup, if not, what is the work around.

 

Any help is appreciated.

Thx,

 

TJ

Share this post


Link to post
Share on other sites

I did see that, but the date that appears on my web page is correct.

No,not on the web page - in the products. Each product has its own date field. Try creating a new product and run the script. Does that product show up with a different date?

Share this post


Link to post
Share on other sites

Hi guys,

just wanted to know something about the Cronjob.

The googlefeeder.php is in the admin folder which is protected by .htaccess. Will it still work if the Cronjob is setup, if not, what is the work around.

Yes.

Share this post


Link to post
Share on other sites

Yes.

Hi Jack,

 

You mean the command in the Cronjob will still work regardless of the protected folder its pointing to.

I just wanted to clarify.

 

Thnx

Share this post


Link to post
Share on other sites

Hi Jack,

 

You mean the command in the Cronjob will still work regardless of the protected folder its pointing to.

I just wanted to clarify.

 

Thnx

The .htaccess will only control access to it by the 'others' class of users. That is, the web service server which is and unprivileged user. Cron jobs are run as the owner (or however they are set, if you have access to that.)

 

The three number you often see when we tell you to set permissions to 647 (just for example.) The 6 is the permissions level for the owner of the file, the 4 is the level of permissions granted to the group that the user is a member of, and the 7 is the permission level for all others (often called 'world'.)

 

 

The .htaccess file will only control access by the 'others' class, of which the httpd server is a part of.

 

That's the best explanation I can give of it.


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

The .htaccess will only control access to it by the 'others' class of users. That is, the web service server which is and unprivileged user. Cron jobs are run as the owner (or however they are set, if you have access to that.)

 

The three number you often see when we tell you to set permissions to 647 (just for example.) The 6 is the permissions level for the owner of the file, the 4 is the level of permissions granted to the group that the user is a member of, and the 7 is the permission level for all others (often called 'world'.)

 

 

The .htaccess file will only control access by the 'others' class, of which the httpd server is a part of.

 

That's the best explanation I can give of it.

 

Thanks Mark,

 

Well done.

Share this post


Link to post
Share on other sites

Any new products that I add don't even show up on the data feed. Basically nothing I've added since 8-11-2010. By the way, Thanx for all the help... I really am clueless as to what the problem could be...

Share this post


Link to post
Share on other sites

Any new products that I add don't even show up on the data feed. Basically nothing I've added since 8-11-2010. By the way, Thanx for all the help... I really am clueless as to what the problem could be...

Are you running an update automatically some how? If not then you must run it manually.


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

I'm running it manually. I go in and under tools click on "google base"... Then I go through the steps and get a word document that I can then upload to Google. Except that it only gives me a partial list of my products. It doesn't include anything new. And the expiration date never changes from 8-11-2010. Someone earlier mentioned something about database dates or no dates or future dates? I don't know what that meant either. I'm sorry. I just have no idea how to fix this and don't really want to start over as I have around 500 products on my site along with a few other add-ons. Thank you for all your help...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×