Jump to content
gottaloveit

Automatically send data feed to Froogle

Recommended Posts

Hi there!!!

 

Great contribution!!!!

 

I've solved the thing with USU5 but now I've a problem with Kiss Meta Tags, it gives me this error:

 

Warning: KissMT could not find a valid base filename, please inform the developer. in /includes/modules/kiss_meta_tags/classes/kiss_meta_tags_class.php on line 141

 

Warning: KissMT::include_once(//includes/modules/kiss_meta_tags/modules/) [function.KissMT-include-once]: failed to open stream: No such file or directory in /includes/modules/kiss_meta_tags/classes/kiss_meta_tags_class.php on line 186

 

Warning: KissMT::include_once() [function.include]: Failed opening '//includes/modules/kiss_meta_tags/modules/' for inclusion (include_path='.:/usr/local/lib/php') in /includes/modules/kiss_meta_tags/classes/kiss_meta_tags_class.php on line 186

 

Fatal error: Class 'KissMT_Module' not found in /includes/modules/kiss_meta_tags/classes/kiss_meta_tags_class.php on line 187

 

 

anyone can help me?

 

Thanks!!!

 

Andrea

Share this post


Link to post
Share on other sites

I have installed Google base v2.5 and it works great. It does what it's suppose to do which is upload the product list. Yahoo and Biz-rate (shopzilla) are charging for memberships now so I didn't even bothered with them. The problem that I'm having is that whenever I upload my product list and I go to my Google base account, I get this error when checking the status of my feed,

 

Unsupported attribute: category - Warning

Missing required attribute: condition (314 errors)

Missing required attribute: description (1 error)

 

Does anyone have any idea on how to resolve this issue? If you know what the solution is, please be specific in giving me instructions on how to solve the problem.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I have installed Google base v2.5 and it works great. It does what it's suppose to do which is upload the product list. Yahoo and Biz-rate (shopzilla) are charging for memberships now so I didn't even bothered with them. The problem that I'm having is that whenever I upload my product list and I go to my Google base account, I get this error when checking the status of my feed,

 

Unsupported attribute: category - Warning

Missing required attribute: condition (314 errors)

Missing required attribute: description (1 error)

 

Does anyone have any idea on how to resolve this issue? If you know what the solution is, please be specific in giving me instructions on how to solve the problem.

 

Thanks in advance.

You have to look at your feed to see what the problem is. The script comes setup with the condition option set to on and new. If your feed isn't showing that, which one of the errors says it isn't, then you may have turned off or changed that setting.

Share this post


Link to post
Share on other sites

Hi there,

 

I am having trouble exporting my feed in different languages.

 

It seems no matter what number i put in the language id variable, it remains in English.

 

here's a snapshot of code:

 

  $Mod: 20100328 Google Base Auto Feeder 1.3 Geoffrey Walton $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// ########## BEGIN CONFIGURATION ###################

// START Main Configuration

// Change to 'true' to enable the use of SEO
 define('SEO_ENABLED','false');
// Change this to the id of your language.  By default 1 is english
 $languages_id = 2; 
// Change this to your unit of wt
 $WeightUnit = " Gms.";    
 $Separator="\t";						// Set to "\t" or "|" or "~" depending on your feed settings
//End Main Configuration

 

Currency conversion is working fine, and everything works fine in English, just trying to get German.

 

Any help appreciated, and keep up the great work, a very nice module indeed.

 

Cheers, Danny

 

p.s. just realised your up to 2.5. Sorry, will update

Edited by dharake

Share this post


Link to post
Share on other sites

I am having trouble exporting my feed in different languages.

 

It seems no matter what number i put in the language id variable, it remains in English.

There is missing code in all of the versions, even 2.5, having to do with languages. The fix is already in the next version but it is not ready to upload. To apply it yourself, find this code

AND categories.categories_id=categories_description.categories_id " . $quotes . "

and add this after it

AND categories_description.language_id = " . DEFAULT_LANGUAGE . "
AND products_description.language_id = " . DEFAULT_LANGUAGE . "

Then, a few lines down, find

function findCat($curID, $catTempPar, $catTempDes, $catIndex)

and place this above it

WHERE categories.categories_id = categories_description.categories_id " . $quotes . "
AND categories_description.language_id = " . DEFAULT_LANGUAGE . "";

Share this post


Link to post
Share on other sites

does anybody know what the solution to this problem is?

 

Unsupported attribute: category - Warning

Missing required attribute: condition (314 errors)

Missing required attribute: description (1 error)

 

I have google base v2.5 and this is the error that I'm getting whenever I check my google feeds.

I also found out that bizrate or shopzilla and yahoo are charging a monthly fee and that sucks.

Any other free feeds that you'd suggest Jack?

 

Thanks in advance.

 

Van

Share this post


Link to post
Share on other sites

does anybody know what the solution to this problem is?

 

Unsupported attribute: category - Warning

Missing required attribute: condition (314 errors)

Missing required attribute: description (1 error)

 

I have google base v2.5 and this is the error that I'm getting whenever I check my google feeds.

I also found out that bizrate or shopzilla and yahoo are charging a monthly fee and that sucks.

Any other free feeds that you'd suggest Jack?

You'd have to look at the feed to see what the problem is but you shouldn't be seeing the condition error since that is enabled automatically. But if you changed it in the settings, that would be the cause of it.

 

There are other free feeds but, as far as I know, google is the only one that doesn't require a link on your site to them. Some shops don't mind such links though so, if you don't, you may want to look at them. The only one I can think of at the moment is goshopping. com.

Share this post


Link to post
Share on other sites

I sell all three types of conditions on my site (new, used, and refurbished). Is there a way to assign a condition to each product and have the googlefeeder file pull the condition from that?

 

Thanks,

Blaine

Share this post


Link to post
Share on other sites

I sell all three types of conditions on my site (new, used, and refurbished). Is there a way to assign a condition to each product and have the googlefeeder file pull the condition from that?

Yes, but it is not a simple change. A new database field has to be added to the products table to hold the condition for each product and this script would have to be altered to use it.

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

 

- Removed extra space around \t that could cause errors with google

- Fixed typo (FFEED) in googlefeeder file (mentioned by Silver Bullet)

- Moved english feeders file to the correct location (mentioned by Steelworks)

- Added missing language identifier to sql code

- Added version number to title of feeders page

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

 

- Removed extra space around \t that could cause errors with google

- Fixed typo (FFEED) in googlefeeder file (mentioned by Silver Bullet)

- Moved english feeders file to the correct location (mentioned by Steelworks)

- Added missing language identifier to sql code

- Added version number to title of feeders page

 

The only file missing from the package is the googlefeeder.php file. Is there a place to get the latest, complete php file? The instructions seem easy to follow by the way, can't wait to try this out.


We must be the change we wish to see in the world.

------------------------------------------------------------

p.s. BACKUP!

Share this post


Link to post
Share on other sites

The only file missing from the package is the googlefeeder.php file. Is there a place to get the latest, complete php file? The instructions seem easy to follow by the way, can't wait to try this out.

I checked the contribution and the file is there.

Share this post


Link to post
Share on other sites

First off - excellent contribution.

Installation was a breeze and documentation very clear :)

 

I do have a question relating to the shipping values however.

I use weight based shipping in oscommerce, and noticed you'd mentioned the following in the googlefeeder.php comments:

Custom Code is required to provide the shipping cost per product.  ###needs to be an array for per product.

 

Have you any idea how I'd do this? I am familiar with basic PHP, but would probably [definitely!] end up breaking something here!

 

Any assistance would be appreciated :)

Mic

Share this post


Link to post
Share on other sites

First off - excellent contribution.

Installation was a breeze and documentation very clear :)

 

I do have a question relating to the shipping values however.

I use weight based shipping in oscommerce, and noticed you'd mentioned the following in the googlefeeder.php comments:

Custom Code is required to provide the shipping cost per product.  ###needs to be an array for per product.

 

Have you any idea how I'd do this? I am familiar with basic PHP, but would probably [definitely!] end up breaking something here!

 

Any assistance would be appreciated :)

Mic

It isn't a simple change and I'm not sure it is a good idea, or even if it would work. Every product would have to be calculated for all of the shipping methods. For a shop that offered UPS and USPS and had hundreds of products, that would result in many calls to each of those sites in a short span of time. They may see that as some kind of attack and ban your site. Not to mention that the script would probably timeout if there were a large number of products and the site was on a shared server. So nothing has been done with that code and there probably won't be.

Share this post


Link to post
Share on other sites

It isn't a simple change and I'm not sure it is a good idea, or even if it would work. Every product would have to be calculated for all of the shipping methods. For a shop that offered UPS and USPS and had hundreds of products, that would result in many calls to each of those sites in a short span of time. They may see that as some kind of attack and ban your site. Not to mention that the script would probably timeout if there were a large number of products and the site was on a shared server. So nothing has been done with that code and there probably won't be.

 

Hey Jack,

 

Thanks for getting back to me so quickly.

 

yeah the dynamic element seems to make this very complex.

What about if I was to add an extra db field for each product containing the actual shipping cost, then use this value to push through to the googlefeeder? would this work?

 

thanks,

mic

Share this post


Link to post
Share on other sites

Hey Jack,

 

Thanks for getting back to me so quickly.

 

yeah the dynamic element seems to make this very complex.

What about if I was to add an extra db field for each product containing the actual shipping cost, then use this value to push through to the googlefeeder? would this work?

 

thanks,

mic

Yes, you can do that. Though google doesn't have a field for shipping so a customer field would probably have to be used. The shipping field in the contribution is a holdover from an older version and I don't know what google would do with it if it were used since I've never seen a shop try it before.

Share this post


Link to post
Share on other sites

My outputfile is empty, the only text it shows is:

"link title description expiration_date price image_link product_type id currency manufacturer mpn product_type"

 

It takes: Script timer: 0.027707 seconds.

 

I tried some changes in googlefeeder.php but without any luck. I use SEO, and tried changing it. The file is 777.

 

Somehow the script isnt finding my products. Any ideas are welcome?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

My outputfile is empty, the only text it shows is:

"link title description expiration_date price image_link product_type id currency manufacturer mpn product_type"

 

It takes: Script timer: 0.027707 seconds.

 

I tried some changes in googlefeeder.php but without any luck. I use SEO, and tried changing it. The file is 777.

 

Somehow the script isnt finding my products. Any ideas are welcome?

 

Thanks in advance.

I can only guess that either your database is not setup correctly and/or your confiugre file isn't. If the rest of the shop is working correctly - you can see products - then that would seem not to be the case.

Share this post


Link to post
Share on other sites

I can only guess that either your database is not setup correctly and/or your confiugre file isn't. If the rest of the shop is working correctly - you can see products - then that would seem not to be the case.

 

Well everything has been working fine, but no Feed :( Also i got some other sitmap/feeds generators installed, but they work properly, so it must be something in this GBase package.

I hope to find out though.

Share this post


Link to post
Share on other sites

Ok, installed the Google Feeder contrib this morning. Now getting this error message when attempting to run it:

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/reddevil/public_html/office/googlefeeder.php on line 47

 

This is appearing in a new window with the url of: http://reddevildistributing.com/office/googlefeeder.php

 

We have changed our default installation from "Admin" to "Office" for security reasons. Is it possible that this is causing the issue?

 

Any help is greatly appreciated and thank you in advance.

 

Todd


T. Patterson

Share this post


Link to post
Share on other sites

I have product descriptions that have sizes in them. For example

 

5-1/2" extension

Clarifier #1 1/8"

etc

 

Google doesn't like this. How can we convert the / and the " to the &xx; values before it uploads?

 

Thanks for any ideas.

Share this post


Link to post
Share on other sites

I have product descriptions that have sizes in them. For example

 

5-1/2" extension

Clarifier #1 1/8"

etc

 

Google doesn't like this. How can we convert the / and the " to the &xx; values before it uploads?

Install Easy Populate and use the function to convert those.

Share this post


Link to post
Share on other sites

Convert them to what, ascii codes?

Read the instructions with that contribution or ask in its support thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×